Copyright
Copyright © 2008-2017 Intergraph® Corporation. All Rights Reserved. Intergraph is part of Hexagon.

Including software, file formats, and audiovisual displays; may be used pursuant to applicable software license agreement; contains confidential and proprietary information of Intergraph and/or third parties which is protected by copyright law, trade secret law, and international treaty, and may not be provided or otherwise made available without proper authorization from Intergraph Corporation.

Portions of the user interface copyright 2012-2016 Telerik AD

U.S. Government Restricted Rights Legend
Use, duplication, or disclosure by the government is subject to restrictions as set forth below. For civilian agencies: This was developed at private expense and is “restricted computer software” submitted with restricted rights in accordance with subparagraphs (a) through (d) of the Commercial Computer Software - Restricted Rights clause at 52.227-19 of the Federal Acquisition Regulations (“FAR”) and its successors, and is unpublished and all rights are reserved under the copyright laws of the United States. For units of the Department of Defense (“DoD”): This is “commercial computer software” as defined at DFARS 252.227-7014 and the rights of the Government are as specified at DFARS 227.7202-3.

Unpublished - rights reserved under the copyright laws of the United States.

Intergraph Corporation
305 Intergraph Way
Madison, AL 35758

Documentation

Other Documentation
Other Documentation shall mean, whether in electronic or printed form and delivered with software or on Intergraph Smart Support, SharePoint, or box.net, any documentation related to work processes, workflows, and best practices that is provided by Intergraph as guidance for using a software product.

Terms of Use
a. Use of a software product and Documentation is subject to the End User License Agreement ("EULA") delivered with the software product unless the Licensee has a valid signed license for this software product with Intergraph Corporation. If the Licensee has a valid signed license for this software product with Intergraph Corporation, the valid signed license shall take precedence and govern the use of this software product and Documentation. Subject to the terms contained within the applicable license agreement, Intergraph Corporation gives Licensee permission to print a reasonable number of copies of the Documentation as defined in the applicable license agreement and delivered with the software product for Licensee's internal, non-commercial use. The Documentation may not be printed for resale or redistribution.

b. For use of Documentation or Other Documentation where end user does not receive a EULA or does not have a valid license agreement with Intergraph, Intergraph grants the Licensee a non-exclusive license to use the Documentation or Other Documentation for Licensee’s internal non-commercial use. Intergraph Corporation gives Licensee permission to print a reasonable number of copies of Other Documentation for Licensee’s internal, non-commercial use. The Other Documentation may not be printed for resale or redistribution. This license contained in this subsection b) may be terminated at any time and for any reason by Intergraph Corporation by giving written notice to Licensee.

Disclaimer of Warranties
Except for any express warranties as may be stated in the EULA or separate license or separate terms and conditions, Intergraph Corporation disclaims any and all express or implied warranties including, but not limited to the implied warranties of merchantability and fitness for a particular purpose and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of such disclaimer. Intergraph believes the information in this publication is accurate as of its publication date.

The information and the software discussed in this document are subject to change without notice and are subject to applicable technical product descriptions. Intergraph Corporation is not responsible for any error that may appear in this document.

The software, Documentation and Other Documentation discussed in this document are furnished under a license and may be used or copied only in accordance with the terms of this license. THE USER OF THE SOFTWARE IS EXPECTED TO MAKE THE FINAL EVALUATION AS TO THE USEFULNESS OF THE SOFTWARE IN HIS OWN ENVIRONMENT.
Intergraph is not responsible for the accuracy of delivered data including, but not limited to, catalog, reference and symbol data. Users should verify for themselves that the data is accurate and suitable for their project work.

**Limitation of Damages**

IN NO EVENT WILL INTERGRAPH CORPORATION BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL INCIDENTAL, SPECIAL, OR PUNITIVE DAMAGES, INCLUDING BUT NOT LIMITED TO, LOSS OF USE OR PRODUCTION, LOSS OF REVENUE OR PROFIT, LOSS OF DATA, OR CLAIMS OF THIRD PARTIES, EVEN IF INTERGRAPH CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

UNDER NO CIRCUMSTANCES SHALL INTERGRAPH CORPORATION’S LIABILITY EXCEED THE AMOUNT THAT INTERGRAPH CORPORATION HAS BEEN PAID BY LICENSEEE UNDER THIS AGREEMENT AT THE TIME THE CLAIM IS MADE. EXCEPT WHERE PROHIBITED BY APPLICABLE LAW, NO CLAIM, REGARDLESS OF FORM, ARISING OUT OF OR IN CONNECTION WITH THE SUBJECT MATTER OF THIS DOCUMENT MAY BE BROUGHT BY LICENSEEE MORE THAN TWO (2) YEARS AFTER THE EVENT GIVING RISE TO THE CAUSE OF ACTION HAS OCCURRED.

IF UNDER THE LAW RULED APPLICABLE ANY PART OF THIS SECTION IS INVALID, THEN INTERGRAPH LIMITS ITS LIABILITY TO THE MAXIMUM EXTENT ALLOWED BY SAID LAW.

**Export Controls**

Intergraph Corporation’s software products and any third-party Software Products obtained from Intergraph Corporation, its subsidiaries, or distributors (including any Documentation, Other Documentation or technical data related to these products) are subject to the export control laws and regulations of the United States. Diversion contrary to U.S. law is prohibited. These Software Products, and the direct product thereof, must not be exported or re-exported, directly or indirectly (including via remote access) under the following circumstances:

a. To Cuba, Iran, North Korea, Sudan, or Syria, or any national of these countries.


c. To any entity when Licensee knows, or has reason to know, the end use of the Software Product is related to the design, development, production, or use of missiles, chemical, biological, or nuclear weapons, or other un-safeguarded or sensitive nuclear uses.

d. To any entity when Licensee knows, or has reason to know, that an illegal reshipment will take place.

Any questions regarding export or re-export of these Software Products should be addressed to Intergraph Corporation’s Export Compliance Department, Huntsville, Alabama 35894, USA.

**Trademarks**

Intergraph®, the Intergraph logo®, Intergraph Smart®, SmartPlant®, SmartMarine, SmartSketch®, SmartPlant Cloud®, Sapphire®, PDS®, FrameWorks®, I-Route, I-Export, ISOGEN®, SPOOLGEN, SupportManager®, SupportModeler®, TANK, PV-Elite, CADWorx®, CADWorx DraftPro®, GTSTRUDL®, and CAESAR II® are trademarks or registered trademarks of Intergraph Corporation or its affiliates, parents, subsidiaries. Microsoft and Windows are registered trademarks of Microsoft Corporation. MicroStation is a registered trademark of Bentley Systems, Inc. Other brands and product names are trademarks of their respective owners.
## Contents

**Preface** .......................................................................................................................................................... 8  
  Smart Construction documentation .............................................................................................................. 8

**Welcome to Smart Construction** .............................................................................................................. 10

**Smart Construction Installation and Setup** ............................................................................................ 11
  Internationalization ............................................................................................................................... 13
  Smart Construction internationalization .............................................................................................. 15
  Smart Construction architecture ............................................................................................................. 16
  Licensing ............................................................................................................................................... 17

**Smart Construction Hardware and Software Recommendations** ........................................................ 18
  Smart Construction server .................................................................................................................... 18
  Smart Construction client ...................................................................................................................... 19
  Smart Construction OnSite .................................................................................................................... 20
  Customization information ..................................................................................................................... 20
  Graphics card information ...................................................................................................................... 21

**Install and Configure SmartPlant License Manager** ............................................................................. 22
  Smart Construction licensing .................................................................................................................. 22

**Install and Configure SmartPlant Foundation** .................................................................................... 24

**Install and Configure SmartPlant Markup Plus** .................................................................................. 25
  Configure SmartPlant Markup Plus and printing for Smart Construction .............................................. 25
  Verify the Application Pool settings for the plant application pool ..................................................... 25
  Configure Permissions and Settings for Smart Construction Printing ............................................... 26
  Open SmartPlant Markup Plus from the plant application pool user .................................................... 27
  Open Microsoft Excel as the plant application pool user and the SPFRemoteServices user ............. 28
  Set the default printer ......................................................................................................................... 28

**Install and Set Up a Smart Construction Server** .................................................................................. 29
  Install prerequisite software .................................................................................................................. 29
  Install Smart Construction on the SmartPlant Foundation application server ................................... 29
  Configure Smart Construction in Server Manager ............................................................................... 30
    Create a new Smart Construction site in Server Manager ............................................................... 31
    Run database scripts for a Smart Construction site ........................................................................ 31

**Set Up and Configure Smart Construction Services** .......................................................................... 32
  Set your active scope in SmartPlant Foundation Desktop Client ....................................................... 32
  Using a custom plant breakdown structure (PBS) hierarchy with Smart Construction ....................... 33
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Smart Construction schema</td>
<td>34</td>
</tr>
<tr>
<td>Load the Plant Breakdown Structure schema</td>
<td>35</td>
</tr>
<tr>
<td>Load the work package enumerated list schema</td>
<td>36</td>
</tr>
<tr>
<td>Load Smart Construction domains</td>
<td>37</td>
</tr>
<tr>
<td>Load Smart Construction administrative files</td>
<td>37</td>
</tr>
<tr>
<td>Analyze documents on your Smart Construction site</td>
<td>38</td>
</tr>
<tr>
<td>Configure Smart Construction security</td>
<td>39</td>
</tr>
<tr>
<td>Create and manage role assignments</td>
<td>40</td>
</tr>
<tr>
<td>Create Smart Construction users</td>
<td>40</td>
</tr>
<tr>
<td>Configure access groups</td>
<td>41</td>
</tr>
<tr>
<td>Associate Smart Construction users with a construction responsibility</td>
<td>45</td>
</tr>
<tr>
<td>Configure vaults for snapshots and files</td>
<td>46</td>
</tr>
<tr>
<td>Configure a vault for files attached to configuration documents</td>
<td>46</td>
</tr>
<tr>
<td>Configure and update a materials system</td>
<td>46</td>
</tr>
<tr>
<td>Create a TNS entry for the SmartPlant Materials database</td>
<td>47</td>
</tr>
<tr>
<td>Configure a materials system with Smart Construction</td>
<td>47</td>
</tr>
<tr>
<td>Set up the SmartPlant Materials site API</td>
<td>48</td>
</tr>
<tr>
<td>Install SQL scripts for a SmartPlant Materials database</td>
<td>48</td>
</tr>
<tr>
<td>Verify the materials system is working</td>
<td>49</td>
</tr>
<tr>
<td>Set up a project forecast in a materials system</td>
<td>49</td>
</tr>
<tr>
<td>Attach materials template files to the materials system configuration document</td>
<td>49</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the template files</td>
<td>50</td>
</tr>
<tr>
<td>Specify which work steps consume materials</td>
<td>51</td>
</tr>
<tr>
<td>Enable the Material Request window and report in Smart Construction</td>
<td>52</td>
</tr>
<tr>
<td>Configure and enable the Material Request window</td>
<td>52</td>
</tr>
<tr>
<td>Enable the Material Request Form report</td>
<td>53</td>
</tr>
<tr>
<td>Reset IIS application pools and retrieve documents</td>
<td>54</td>
</tr>
<tr>
<td>Configure the rules of progress</td>
<td>54</td>
</tr>
<tr>
<td>Configure the rules of progress in the rules of progress configuration workbook</td>
<td>54</td>
</tr>
<tr>
<td>Attach the ROP Configuration workbook and XML files to the Rules of Progress configuration document</td>
<td>57</td>
</tr>
<tr>
<td>Configure mapped properties for a published document</td>
<td>58</td>
</tr>
<tr>
<td>Map properties and generate XML for a Smart Construction retrieve</td>
<td>59</td>
</tr>
<tr>
<td>Attach the SPCRetrieveMappings.xlsm and XML files to the Retrieve Mappings configuration document</td>
<td>60</td>
</tr>
<tr>
<td>Import project data into Smart Construction</td>
<td>60</td>
</tr>
<tr>
<td>Update security for services on the Import Project Data window</td>
<td>61</td>
</tr>
<tr>
<td>Importing your schedule into Smart Construction</td>
<td>61</td>
</tr>
<tr>
<td>Import project configuration data into Smart Construction</td>
<td>68</td>
</tr>
<tr>
<td>Manage template files for Smart Construction</td>
<td>80</td>
</tr>
<tr>
<td>Configure IIS to process large files</td>
<td>82</td>
</tr>
<tr>
<td>Configure a schedule system for schedule data import</td>
<td>83</td>
</tr>
<tr>
<td>Configuring a schedule system with Primavera P6 SDK</td>
<td>83</td>
</tr>
<tr>
<td>Configuring a schedule system with Primavera P6 Web Services</td>
<td>92</td>
</tr>
<tr>
<td>Turn on Smart Construction queues</td>
<td>100</td>
</tr>
<tr>
<td>Retrieve and refresh data in Smart Construction</td>
<td>100</td>
</tr>
<tr>
<td>Retrieve documents in Smart Construction</td>
<td>100</td>
</tr>
</tbody>
</table>
## Contents

### Install and Set Up Smart Construction on Workstations

- Install prerequisite software ...................................................... 105
- Install Smart Construction on a client workstation .................. 105
- Install SmartPlant Review and its modules on a client workstation .............................................................................. 106
- Automatically log on to Smart Construction ...................................... 106
- Start Smart Construction .................................................................. 107
- Log on to Smart Construction .......................................................... 107
- Remove Smart Construction from a client workstation ............... 108

### Set Up and Configure Smart Construction OnSite

- Register Smart Construction OnSite with the Authorization Server ................................................................. 110
- Configure users for Smart Construction OnSite .......................... 110
- Install SSL certificates on your mobile device .................................. 110
- Install Smart Construction OnSite on your Android device .......... 111
- Reinstalling Smart Construction OnSite ........................................ 111

### After You Install and Set Up Smart Construction

- Upgrading Smart Construction ..................................................... 113
- Smart Construction upgrade sequence ....................................... 113
- Prepare to upgrade to Smart Construction 2017 .......................... 113
  - Make backups ............................................................................... 114
  - Upgrade SmartPlant Foundation .................................................. 114
- Upgrade the Smart Construction server ....................................... 114
  - Verify prerequisite software is installed ..................................... 114
  - Upgrade Smart Construction on the SmartPlant Foundation application server .................................. 115
  - Configure Smart Construction in Server Manager .................... 116
  - Configure the Smart Construction server ................................ 116
- Upgrade Smart Construction client workstations ....................... 126
  - Verify prerequisite software is installed ..................................... 126
  - Upgrade Smart Construction on a client workstation ............... 126

### Configure Smart Construction for Citrix

- System requirements for Citrix servers ........................................ 128
- Install Citrix software ................................................................. 128
- Install and configure the software for Citrix ............................... 128
- Using Smart Construction with Citrix .......................................... 129

### Smart Construction Launch Parameters

- Smart Construction command line parameters .......................... 130

### Install Smart Construction in Silent Mode

- Manage Template Files for Smart Construction ......................... 134
  - Open a Smart Construction template file ................................. 135
  - Attach template files to configuration documents .................... 136
  - Check in and sign off a Smart Construction template file ......... 136
Preface

This guide provides details to install, set up, and configure Intergraph Smart™ Construction servers and client workstations. This document is recommended for users or administrators who are familiar with SmartPlant Foundation.

Smart Construction documentation

Smart Construction documentation is available as Help and as Adobe® PDF files. To view printable guides for Smart Construction, click Help > Printable Guides in the software.

Intergraph gives its customers permission to print as many copies of the delivered PDF files as they need for their non-commercial use. Do not print the PDF files for resale or redistribution.

Installation and setup guide

- Intergraph Smart Construction Installation and Setup Guide - Provides installation and setup instructions for Smart Construction administrators and users.

Administration and configuration guides

- Intergraph Smart Construction Administration and Configuration Guide - Provides information to help administrators manage and configure the Smart Construction server and client.
- Intergraph Smart Construction Rules of Progress Configuration Guide - Provides reference and configuration information for developers and system administrators to configure and set up the rules of progress for their construction project.

Programming guides

- Intergraph Smart Construction API and Programmer's Guide - Provides reference information for developers and administrators about APIs and customization.
- Intergraph Smart Construction Customization Guide - Provides customization information for Smart Construction system administrators and developers.

User's guides

- Intergraph Smart Construction User's Guide - Provides information and instructions to help users create and manage information in Smart Construction.
- Intergraph Smart Construction Getting Started Guide - Provides overview information to help users start working in Smart Construction.

Troubleshooting guide

- Intergraph Smart Construction Troubleshooting Guide - Provides troubleshooting information for Smart Construction users and administrators.
Customer Support

For the latest support information for this product, use a World Wide Web browser to connect to http://support.intergraph.com (http://support.intergraph.com). Also, you can submit any documentation comments or suggestions you might have on the Intergraph support site.
SECTION 1

Welcome to Smart Construction

Smart Construction is a tool that facilitates faster, more accurate construction execution. The software provides you with the ability to create work packages that are optimized for overall completion. You can view, navigate, and filter 3D models and 2D drawings; view materials information; view schedule information; and report completion based on rules of progress in a single environment.

**NOTE** For information about running SmartPlant Enterprise products remotely using Citrix®, see the *SmartPlant Enterprise Citrix Configuration Guide* delivered with SmartPlant Foundation.
SECTION 2

Smart Construction Installation and Setup

Smart Construction must be installed on a SmartPlant Foundation application server. Smart Construction uses SmartPlant Foundation to share engineering, construction, and design data among Intergraph SmartPlant Enterprise lifecycle engineering products and users.

Before installing Smart Construction, you must first install and configure SmartPlant Foundation. If you already have SmartPlant Foundation installed, you only need to install Smart Construction. For more information on SmartPlant Foundation installation, see the *SmartPlant Foundation Installation and Setup Guide* delivered with the SmartPlant Foundation software.

When you install and set up Smart Construction, you need to perform the following tasks:

- Install and set up the Smart Construction server on the SmartPlant Foundation application server. The server can be configured using SmartPlant Foundation Server Manager.
- Install and set up Smart Construction services including external services such as a materials system, schedule system, and rules of progress.
- Install and set up the Smart Construction client on a workstation.
- Install and set up Smart Construction OnSite, if you plan to use the Smart Construction OnSite mobile app for your site.
The following diagram illustrates the Smart Construction installation. Items in white are installed during Smart Construction installation.

**Smart Construction Installation and Setup Tasks**

The following is a high-level graphical overview of the tasks necessary to install and set up Smart Construction. See later sections of this guide for more details on these individual tasks.
Internationalization

Supporting internationalization in a homogeneous environment is one of the enhancements available in SmartPlant Enterprise. A homogeneous environment uses elements from only a single locale. For example, a German customer running on a German operating system using only German characters and German cultural conventions is a fully supported homogeneous environment configuration.

Homogeneous Environments

When starting a new project, use extra care during installation and configuration to ensure the proper creation and maintenance of homogeneous environments:

- All the computers (servers and clients) within an integrated SmartPlant Enterprise implementation must have the same regional settings, and no one should change the regional settings after the project has started.
- Do not cross the decimal locale boundary. This is the most common cause of numeric data corruption and calculation errors. Having users with different regional settings (such as with a period versus a comma for the decimal point) causes the software to interpret values unpredictably. For example, a pipe run with a pressure of 35.3 psi can be read by the software as 353 psi to the user with different regional settings. A cable length defined as 39 ft 11,21 inches has been interpreted as 121718910971323 meters when published to an XML file. These incorrect interpretations may be used in internal software calculations and can be impossible to backtrack or correct. Do not change the decimal point character to try to solve an issue. Doing so will only corrupt values in the database or in text files.
- Do not cross the character-set locale boundary. For example, the character set boundary between Western (Latin-based) and Eastern Europe (Cyrillic-based), or between Eastern Europe and Japan.
- Create Oracle databases using AL32UTF8 for the database character set and AL16UTF16 for the NLS character set.
- Never modify the NLS_LANG registry entry on an Oracle client. Doing so causes the character data not to convert to Unicode.
- Create Microsoft SQL Server databases with locale-specific collation settings and ensure that all databases have the same setting.

Heterogeneous Environments

In contrast, a heterogeneous environment using elements from different, or even multiple locales, is not supported. Many customers are currently operating in unsupported heterogeneous environments and are often not aware of that fact. Examples of heterogeneous environments:

- Entering or viewing Japanese data on an US/English operating system
- Using German Regional Settings (where the decimal point is a comma) on a US/English operating system
- Using databases with different character encodings such as CL8MSWIN1251 or JA16SJIS
- Using multiple languages in a project, especially when crossing language-group boundaries
- Using an English server with different local language clients
International / Bi-lingual Projects

International bi-lingual projects are possible; however, great care must be used when configuring these environments. Limitations exist and must be properly understood:

- Oracle and MS SQL Server databases can reside on any language operating system, as long as the databases have been created and configured with proper Unicode and collation settings.
- All SQL Server databases must have the same collation setting and reflect the master language. Text is stored, sorted, indexed, and presented based on the collation setting. You must determine which language will be used primarily to generate output (P&IDs, SLDs, reports, approval documents, and so forth.) If Russian and English text is entered, and Russian is the target locale, choose the collation based on the Cyrillic character set.
- All Microsoft operating systems (Japanese, Russian, German, and so forth) can enter English characters. The reverse, however, is not true in most cases.
- Keyboard-locale can be changed as long as a character-set and code-page boundary is not crossed. For example, English, German, French, and Spanish characters can all be used in the same project because the same Windows® code-page (1252) is used. However, Russian characters (code-page 1251) cannot be used in a US/English environment.
- You must decide which language operating system is the master for bi-lingual projects.

The following is an example of a Russian-based project:

Companies in the United States and the United Kingdom are working a project with a Russian company and the deliverables (drawings, reports, and so forth) must ultimately be provided in Russian. The companies in the U.S. and the U.K. are working the project using the master Russian operating systems (possibly using virtual Russian operating systems running on VMware Workstation). The U.S. and U.K. companies can install and use English Microsoft Office products on the Russian operating system because Office products are globally enabled. If a Russian interface exists for the SmartPlant Enterprise application, then Russian users can use the Russian interface while the English-speaking users continue to use the US/English interface. English-speaking engineers can enter English characters. Russian-speaking engineers can enter Russian characters.

However, because the Russian locale uses different decimal and character-set locales, everyone (English and Russian engineers) must use the Russian decimal symbol which is a comma. For customization purposes, databases can be modified to accommodate new Russian-specific requirements (fields, properties, and so forth.) Using filters, display sets, and other software features, bi-lingual projects can be further customized. Graphic data, reports, and so forth can be created in either or both languages.

⚠️ CAUTION Do not change regional settings to reflect a U.S. environment in order to resolve problems in a non-US/English homogeneous configuration. Doing this creates a heterogeneous configuration that will cause other possibly hidden problems that cannot be corrected. Everyone working on a project must use the same regional settings and character set throughout the life of the project.

Citrix XenApp Solutions for International Projects

Using Citrix XenApp Solutions, you can define environments that isolate users from having to interact with non-native language operating systems while improving data integrity and minimizing opportunities for data corruption. However, users must enter data using master locale conventions for the project (decimal separator and date conventions, for example). You
can create these environments using different combinations of languages, but some limitations exist. For example, you cannot use Russian and Chinese text together in a project. In addition, special language characters (the German ä and ß for example) cannot be used if the master locale is outside the western Latin-based languages (the master locale is Russian, Chinese, Japanese, or Korean, for example).

Questions and Assistance
Please contact your support representative for assistance and answers to your questions: see Intergraph Customer Support.

Smart Construction internationalization
Smart Construction supports heterogeneous environments. A heterogeneous environment uses elements from different (or multiple) locales. Examples of heterogeneous environments follow:

- Entering or viewing Japanese data on a U.S./English operating system and changing input language (keyboard) dynamically, at any point, within one box in the user interface.
- Using German Regional Settings (where a decimal is a comma) on a U.S./English operating system.
- Using multiple languages in a project (especially when crossing language-group boundaries).
- Changing the language of the user interface at any time, regardless of the system locale, by changing the regional settings.
- Having multiple users access the same client and switch to their preferred language.

**IMPORTANT** String properties, including but not limited to size (in some cases) and thickness, are not localized in Smart Construction.

A heterogeneous environment is flexible because it does not impose limitations on the use of languages or cultural conventions of a user.

**NOTE** The initial release of Smart Construction OnSite supports native language and culture for data with English - United States (en-US) labels, date and number formatting. Future releases will include a full heterogeneous user interface.

Configuration Requirements
You must take great care when configuring international and heterogeneous environments. The following configuration requirements exist for Smart Construction:

**Smart Construction Configuration Requirements**
- Close Smart Construction client before changing Regional Options (such as numeric values, date and time formats, and so forth).
- Close Smart Construction client before changing the user interface language.

**Database Creation Configuration Requirements**
- Create Oracle databases using AL32UTF8 for the database character set and AL16UTF16 for the NLS character set.
- Never modify the NLS_LANG registry entry on an Oracle client. Doing so prevents the character data from converting to Unicode.
- Create Microsoft SQL Server databases with locale-specific collation settings and ensure that all databases have the same setting.

**IMPORTANT** Customers using multi-byte languages, such as Chinese and Japanese, with Smart Construction need to contact Intergraph Customer Support (http://support.intergraph.com) during installation to acquire a database update in order to accommodate the full length of some properties.

Questions and Assistance
Please contact your support representative for assistance and answers to your questions at Intergraph Customer Support.

**Smart Construction architecture**

Smart Construction uses SmartPlant Foundation technology to help you better manage your construction project and the data associated with it. Through the interoperability of Smart Construction and SmartPlant Foundation, Smart Construction users are able to create construction work areas (CWAs), construction work packages (CWPs), and installation work packages (IWPs) that detail work to be executed with engineering, construction, and design data stored in a SmartPlant Foundation database. Users are also able to view, navigate, and filter 3D models and 2D drawings that were published to a SmartPlant Foundation database. Users can connect to IWP data on their mobile device through the Smart Construction OnSite mobile app.

As seen in the following diagram, Smart Construction is installed with SmartPlant Foundation.
Smart Construction uses SmartPlant Foundation to share engineering, construction, and design data among Intergraph SmartPlant Enterprise life cycle engineering products and users. SmartPlant Foundation provides a comprehensive electronic data storage, exchange, management, and integration system for Smart Construction. Data published to SmartPlant Foundation from Intergraph SmartPlant Enterprise life cycle engineering products, such as Intergraph Smart® 3D or Plant Design System (PDS®), can be accessed and viewed in Smart Construction. An open API provides direct integration with SmartPlant Materials and other non-Intergraph applications, such as project control, schedule systems, or external document systems. Smart Construction delivers Microsoft Excel workbook templates that administrators can use to create and edit project data and rules of progress for a Smart Construction site. Administrators can use the open API to configure an existing materials system and documents system.

**Licensing**

Smart Construction is licensed concurrently with SmartPlant Foundation. When you install and configure SmartPlant Foundation and its prerequisite software, you must also install SmartPlant License Manager on the Smart Construction server. Verify you have the proper license for your project configuration. For more information, see *Install and Configure SmartPlant License Manager* (on page 22).

For more information about licensing for SmartPlant Foundation, see the *SmartPlant Foundation Licensing Guide* or the *SmartPlant License Manager Installation and User's Guide* delivered with SmartPlant Foundation.
SECTION 3
Smart Construction Hardware and Software Recommendations

Before beginning an installation of Smart Construction, verify that your servers and client workstation computers meet the following hardware and software recommendations.

★ IMPORTANT These hardware and software recommendations include the minimum requirements for hardware setup. Please contact your Intergraph services implementation team for specific hardware recommendations for your project.

Smart Construction server

Smart Construction must be installed on a SmartPlant Foundation application server. Smart Construction server does not require any additional hardware. For more information on SmartPlant Foundation hardware and software recommendations, see the SmartPlant Foundation Installation and Setup Guide delivered with SmartPlant Foundation software.

The Smart Construction server is a 64-bit application.

★ IMPORTANT

- Customers using multi-byte languages, such as Chinese and Japanese, with Smart Construction need to contact Intergraph Customer Support (http://support.intergraph.com) during installation to acquire a database update in order to accommodate the full length of some properties.
- Refer to the PPM Compatibility Matrix on the Intergraph Smart Support Web site to install and use the correct SmartPlant product versions, schema, and adapters with Smart Construction. For more information, contact Intergraph Customer Support (http://support.intergraph.com).
- Customers must install and use the latest Smart 3D version, schema, and adapters. The properties available depend on the Smart 3D version. For more information, contact Customer Support (http://support.intergraph.com).

Hardware Recommendations

- DVD drive access, either locally or through a network connection for installation
- 1000 BaseT or higher network interface

Supported Operating Systems

- Microsoft Windows Server 2012 R2 Standard or Datacenter Edition (64-bit) with IIS

Software Prerequisites

- Microsoft Internet Explorer 11 (required for viewing the online documentation delivered with the software)
Smart Construction Hardware and Software Recommendations

- PDF reader, such as Adobe Reader 11 (required for viewing the Printable Guides and reports)
- SmartPlant Foundation 2016 HF4
- SmartPlant License Manager 2012
- SmartPlant Markup Plus 2016 HF3
- SAP Crystal Reports 2013 Runtime

Software Recommendations
- 64-bit OLEDB provider data connectivity components (for External data filters)

Smart Construction client

The Smart Construction client can be installed in a 32-bit or a 64-bit environment.

Minimum Hardware Recommendations
- 2 core high-end server processor
- 4 GB RAM
- 1 GB of free disk space for software installation
- DVD drive access, either locally or through a network connection for installation
- 100 BaseT network interface

Supported Operating Systems
- Windows 7 Professional or Enterprise Service Pack 1 (64-bit)
  - supported with UAC enabled and set to Level 3 (Default)
- Windows 8.1 Professional or Enterprise (64-bit)
- Windows 10 Professional or Enterprise (64-bit)
  - Windows 8.1 and Windows 10 are supported with UAC enabled and set to "Notify me only when apps try to make changes to my computer" (default)

Software Prerequisites
- Microsoft Internet Explorer 11 (required for viewing the online documentation delivered with the software)
- PDF reader, such as Adobe Reader 11 (required for viewing the Software License Agreement, Printable Guides, and reports)
- Microsoft .NET Framework 4.6
- SmartPlant Markup Plus 2016 HF3

Software Recommendations
- Microsoft Office Excel 2010 SP1 or 2013 (32-bit or 64-bit) (used for exporting reports and viewing attached files)
Smart Construction Hardware and Software Recommendations

- Microsoft Office Word 2010 SP1 or 2013 (32-bit or 64-bit) (used for exporting reports)
- SmartPlant Review 2014 R1 including the API Module and the Simulation and Visual Effects Module (used for animated component sequencing)
- Windows Media Player (used if recording and playing back an animation recording)

Smart Construction OnSite

Hardware Recommendations
- 2 GB RAM
- 16 GB storage
- WiFi-enabled

Supported Operating System
- Android 5.0 (Lollipop) or later

Customization information

To take advantage of the customization capabilities of Smart Construction, your workstation must have the following installed:
- Microsoft Visual Studio 2008 SDK Version 1.0 (for localization)
- Microsoft Visual Studio 2015 (for feature and reports customization)
- SAP Crystal Reports 2013 for Visual Studio (for reports customization)
Graphics card information

To take advantage of the performance enhancements available for viewing 3D models, your graphics card needs to have at least the minimum requirements listed below. Cards with less than the minimum requirements are supported; however, they might not be able to successfully use all the performance enhancements.

<table>
<thead>
<tr>
<th>Minimum</th>
<th>Recommended (for systems with large models)</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenGL 2.0</td>
<td>OpenGL 2.1 or later</td>
</tr>
<tr>
<td>128 MB RAM</td>
<td>512 or more MB RAM</td>
</tr>
</tbody>
</table>

Additional requirements and/or recommendations for cards include:

- In general, workstation-level graphics cards provide better overall performance with 3D model files than desktop graphics cards.
- The card must be manufactured within the last three years.
- Use updated drivers (at least within the last 6 months).

★ IMPORTANT Systems running Citrix and remote desktop applications currently do not support the hardware acceleration performance enhancements.
SECTION 4

Install and Configure SmartPlant License Manager

Before installing Smart Construction, you must set up licensing. You must install and configure SmartPlant License Manager and its prerequisite software on the Smart Construction server.

For more information about licensing for SmartPlant Foundation, see the SmartPlant Foundation Licensing Guide or the SmartPlant License Manager Installation and User’s Guide.

For more information on SmartPlant License Manager installation and use, see the SmartPlant License Manager Installation and User’s Guide delivered with the SmartPlant License Manager software.

Smart Construction licensing

The SmartPlant License Manager provides both client and server licensing through specified tags in the license files.

Foundation Single User (FSU) tag

The Foundation Single User (FSU) tag provides Smart Construction administrator licensing for SmartPlant Foundation Desktop Client. The FSU license is a named user license. You must add an entry to the SmartPlant Foundation License Manager perpet.dat file specifying the user account that is permitted to use the FSU license. The entry can be identified by SPF_single in the perpet.dat file. The file is located at [Drive]\SmartPlant Foundation [version] Server Files\LicenseServers\[License Site Name].

The following is an example of a perpet.dat file containing one perpetual license (assigned to the superuser account) and one FSU license (assigned to the spcadmin account):

```
# First define the group 'Perpetual'
GROUP SPF_perpetual superuser
# Define the group 'Single'
GROUP SPF_single spcadmin
# Then INCLUDE the group
INCLUDE  SPF_perpetual  GROUP SPF_perpetual
INCLUDE  SPF_single  GROUP SPF_single
```

One FSU license is included with your company’s purchase, and only one user can use the license at a time. If licenses for additional SmartPlant Foundation Desktop Client users are needed, you can purchase additional perpetual or daily tokens.

Smart Construction (SPC) tag

The Smart Construction (SPC) tag provides Smart Construction client licensing for Smart Construction.
Smart Construction OnSite (SCO) tag

The Smart Construction OnSite tag (SCO) provides client licensing for the Smart Construction OnSite mobile app. Smart Construction OnSite is licensed on a daily user maximum basis.

The active session is 12 hours from the most recent synchronization between the Smart Construction OnSite app and the Smart Construction server.

For more information about licensing for SmartPlant Foundation, see the *SmartPlant Foundation Licensing Guide* or the *SmartPlant License Manager Installation and User's Guide*.

For more information on SmartPlant License Manager installation and use, see the *SmartPlant License Manager Installation and User's Guide* delivered with the SmartPlant License Manager software.
SECTION 5

Install and Configure SmartPlant Foundation

Before installing Smart Construction, you must first install and configure SmartPlant Foundation and its prerequisite software.

You can install both Smart Construction and SmartPlant Foundation from their installation packages. If you already have SmartPlant Foundation installed, you only need to install Smart Construction. For more information on SmartPlant Foundation installation, see the SmartPlant Foundation Installation and Setup Guide delivered with the SmartPlant Foundation software.

**NOTES**

- If you are configuring a system with multiple sites, see the SmartPlant Foundation How to Configure Performance Guide, delivered with SmartPlant Foundation, in order to properly configure a site with optimal performance.

- For SmartPlant file formats, a printer named SmartPlant PDF Converter XXX (where XXX denotes the version number) is installed on the SmartPlant Foundation application server when SmartPlant Markup Plus is installed. This printer is used for PDF generation and should not be removed or used for any other purpose.

- If you are configuring a system with the Smart Construction OnSite mobile app, you must set up and configure SmartPlant Foundation API Services. Your authentication server must be set up to use SSL. For more information, see the SmartPlant Foundation How to Configure API Services guide.
Before installing Smart Construction, you must first install and configure SmartPlant Markup Plus and its prerequisite software, as described in the SmartPlant Markup Plus Installation and Setup Guide.

**NOTE** For SmartPlant file formats, a printer named SmartPlant PDF Converter XXX (where XXX denotes the version number) is installed on the SmartPlant Foundation application server when SmartPlant Markup Plus is installed. This printer is used for PDF generation and should not be removed or used for any other purpose.

For more information on SmartPlant Markup Plus installation, see the SmartPlant Markup Plus Installation and Setup Guide delivered with the SmartPlant Markup Plus software.

### Configure SmartPlant Markup Plus and printing for Smart Construction

After you install and configure SmartPlant Markup Plus, you must configure the software to work with Smart Construction.

**Verify the Application Pool settings for the plant application pool**

1. Click Start > Administrative Tools > Internet Information Services (IIS) Manager.
2. Expand the server name, and click Application Pools.
3. Select the application pool name.
4. Click Advanced Settings to display the Advanced Settings dialog box.
5. Verify the Enable 32-Bit Applications property is set to FALSE.
6. Verify the Load User Profile property is set to TRUE.
Configure Permissions and Settings for Smart Construction Printing

Smart Construction prints various file types through SmartPlant Markup Plus. Smart Construction administrators must configure some permissions and settings in order for Smart Construction to access SmartPlant Markup Plus.

**NOTE** Smart Construction server installation installs a printer named Smart Construction PDF Converter 550. This printer is used to attach drawings to reports and should not be removed or used for any other purpose.

**Remove SPFRemoteServices and SPFServer users from the Administrators group (Optional)**

This is an optional procedure.

1. Log on to the Smart Construction server.
2. Open **Administrative Tools > Computer Management**.
3. On the **Computer Management** window, browse to the **Groups** folder (click **Computer Management > System Tools > Local Users and Groups > Groups**).
4. Right-click the **Administrators** group and select **Properties**.
5. On the **Administrators Properties** dialog box, select the **SPFRemoteServices** user and click **Remove**.
6. Select the **SPFServer** user and click **Remove**.
7. Click **OK** on the **Administrators Properties** dialog box to save the settings and close the dialog box.
8. Close the **Computer Management** window.

**Add SPFUsers and enable Local Launch and Local Activation**

1. Log on to the Smart Construction server.
2. Open **Administrative Tools > Component Services**.
3. On the **Component Services** window, expand the **My Computers** node (click **Console Root > Component Services > Computers > My Computers**).
4. Right-click **My Computer** and select **Properties**.

5. On the **My Computer Properties** dialog box, select the **COM Security** tab.

6. On the **Launch and Activation Permissions** section of the **COM Security** tab, click **Edit Default**.

7. On the **Launch and Activation Permissions** dialog box, click **Add**.

8. Browse to your location and click **OK**, if applicable.

9. Type SPFUsers in the **Enter the object names to select** section of the **Select Users or Groups** dialog box.

10. Click **Check Names** to verify the correct group name.

11. Click **OK** to add the group and close the **Select Users and Groups** dialog box.

12. On the **Launch and Activation Permissions** dialog box, select **SPFUsers (<Computer Name>\SPFUsers)** in the **Group or user names** section.

13. Select the options to allow **Local Launch** and **Local Activation** in the **Permissions for SPFUsers** section of the **Launch and Activation Permissions** dialog box.

14. Click **OK** to set permissions and close the **Launch and Activation Permissions** dialog box.

15. Click **OK** or **Apply** on the **My Computer Properties** dialog box.

16. Close **Component Services**.

**Open SmartPlant Markup Plus from the plant application pool user**

1. Log on to the SmartPlant Foundation application server with the user name and password of the application pool user.

2. Open SmartPlant Markup Plus.

3. Exit SmartPlant Markup Plus.
Open Microsoft Excel as the plant application pool user and the SPFRemoteServices user

1. Log on to the SmartPlant Foundation application server with the user name and password of the application pool user.
2. Open Microsoft Excel and complete the application setup by providing the appropriate information in the dialog boxes.
3. Exit Microsoft Excel.
4. Log on to the SmartPlant Foundation application server with the user name and password of the SPFRemoteServices user.
5. Open Microsoft Excel and complete the application setup by providing the appropriate information in the dialog boxes.

Set the default printer

Smart Construction server installation installs a printer named Smart Construction PDF Converter 550. This printer is used to attach drawings to reports and should not be removed or used for any other purpose. Set this printer as the default printer for the SPFRemoteServices user account.
Install and Set Up a Smart Construction Server

After installing and configuring SmartPlant Foundation, you can install and set up your Smart Construction server on the SmartPlant Foundation application server.

Before you install Smart Construction on the SmartPlant Foundation application server, you must verify required software is installed on the server. After installing and configuring the required software, you can install Smart Construction software on the application server and then configure the Smart Construction server in SmartPlant Foundation Server Manager.

**NOTE** You can also install the software in silent mode, which requires no user interaction as the software installs. For more information, see Install Smart Construction in Silent Mode (on page 132).

**IMPORTANT** Customers using multi-byte languages, such as Chinese and Japanese, with Smart Construction need to contact Intergraph Customer Support (http://support.intergraph.com) during installation to acquire a database update in order to accommodate the full length of some properties.

Install prerequisite software

Before you install Smart Construction on the SmartPlant Foundation application server, verify the installation of the recommended software. Smart Construction server does not require any additional hardware. Smart Construction must be installed on a SmartPlant Foundation application server. For more information, see the Smart Construction Hardware and Software Recommendations (on page 18) or the SmartPlant Foundation hardware and software recommendations in the SmartPlant Foundation Installation and Setup Guide delivered with SmartPlant Foundation software.

Install Smart Construction on the SmartPlant Foundation application server

**IMPORTANT** Before you install Smart Construction, decide the installation location on the SmartPlant Foundation application server. By default, the software installs in the following location: C:\Program Files (x86)\SmartConstruction\2017.

**NOTE** You can install the software in silent mode, which requires no user interaction as the software installs. For more information, see Install Smart Construction in Silent Mode (on page 132).

1. From the product installation DVD, if the installation does not start automatically, double-click setup.exe.
2. In the Welcome window, click Start Setup.
3. In the Details and Features window, enter your Serial Number, User Name, and Company.

4. In the Select Features To Install section, select the features you want to install:
   - **All Features** - Installs all the items described below.
   - **Smart Construction Client** - Installs the Smart Construction Client, which provides client functionality on the local computer.
   - **Smart Construction Server** - Installs the Smart Construction Server component, which includes the software required to set up Smart Construction on the application server.

5. If you are installing Smart Construction Client, in the Smart Construction Server Host Information section, enter the following:
   - **Server Host** - Name of the SmartPlant Foundation application server.
   - **Server Name** - Name of the SmartPlant Foundation site on the server to which the client will connect.

   **NOTE** This section is enabled only when you have chosen to install Smart Construction Client as a feature.

6. In the Install Path section, enter the path where the software is to be installed.

7. Click Install.
   - **TIP** Required information is marked by a red star. The Install button is not enabled until all this information is provided.

8. In the License Agreement window, from the Country or Region list, select your country or region.

9. Carefully read the license agreement. When you are finished, select I agree to the license agreement and conditions.

10. Click Install.

11. Click Finish when the installation is complete.

   **NOTE** Smart Construction server installation installs a printer named Smart Construction PDF Converter 550. This printer is used to attach drawings to reports and should not be removed or used for any other purpose.

### Configure Smart Construction in Server Manager

Use SmartPlant Foundation Server Manager to configure the following server settings for your Smart Construction site:

- Install DLLs
- Update configuration XML files on a SmartPlant Foundation site
- Update database tables specific to Smart Construction

For more information about SmartPlant Foundation Server Manager, see the *SmartPlant Foundation Server Manager User’s Guide*. 
Create a new Smart Construction site in Server Manager

1. Start SmartPlant Foundation Server Manager. The **Smart Construction Sites** node displays in the tree view after installing Smart Construction on the SmartPlant Foundation application server.

2. Select the Smart Construction Sites node and click **New** on the Server Manager toolbar.

   ★ TIP You can also select the **Smart Construction Sites** node and click **Edit > New** or right-click the node and click **New**.

3. On the **New Smart Construction Site** dialog box, select a site to update from the list. Click **Create**. The site node is added under the Smart Construction Sites. All server DLLs are installed on the site and configuration XML files are updated.

4. Close SmartPlant Foundation Server Manager.

   ★ IMPORTANT After creating the new Smart Construction site, close SmartPlant Foundation Server Manager and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

   ★ TIP After installing the server DLLs and updating the configuration XML files, perform a backup of your SmartPlant Foundation database. For more information on backing up your database, see the **SmartPlant Enterprise Backup and Restore Guide**.

Run database scripts for a Smart Construction site

After you configure a Smart Construction site in Server Manager, you must run database scripts to update database tables specific to Smart Construction.

1. Select a Smart Construction site in the Smart Construction node.

2. Right-click the selected site and click **Tools > Smart Construction > Run Database Script** to open the **Run Smart Construction Database Script** dialog box.

   ★ TIP You can also click **Tools > Smart Construction > Run Database Script** on the **Menu** bar.

3. Run the database scripts. Select each script from the **Run Smart Construction Database Script** box and click **Run**.

   ★ IMPORTANT The database scripts must be run in the order indicated by the number preceding the file name.
SECTION 8

Set Up and Configure Smart Construction Services

Use SmartPlant Foundation Desktop Client to set up and configure Smart Construction services. The Smart Construction administrator must log on to SmartPlant Foundation Desktop Client as an administrator.

Administrators must perform the following tasks to set up and configure the Smart Construction services:

- Import and load schema, domains, and administrative files on the Smart Construction server
- Configure security on the Smart Construction server
- Configure a materials system on the Smart Construction server
- Configure a schedule system on the Smart Construction server
- Load data on the Smart Construction server

Set your active scope in SmartPlant Foundation Desktop Client

Before setting up and configuring Smart Construction services, you must set your SmartPlant Foundation Desktop Client active scope to your Smart Construction plant. Smart Construction supports plant-level configurations, not project-level.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click File > Set Active Scope to open the Set Active Scope dialog box.
   You can also set the active scope by clicking the text beside Selected Roles, Query Scope, or Create/Update Scope in the Desktop Client status bar.
3. In the Set Active Scope dialog box, select your scope.
   
   **NOTE** You can select one plant for your query and create scope. Smart Construction does not support multiple query scopes.
4. Click OK.
Using a custom plant breakdown structure (PBS) hierarchy with Smart Construction

If you plan to use a custom Plant Breakdown Structure (PBS) hierarchy with Smart Construction, you must customize the Smart Construction schema to reflect the custom PBS hierarchy. For more information, see Configuring a Custom Plant Breakdown Structure (PBS) for Smart Construction in the Intergraph Smart Construction Customization Guide.

After you customize the Smart Construction schema according to the custom PBS hierarchy, you can configure Smart Construction items to use the PBS structure. For more information, see Configure Smart Construction client features with a custom PBS in the Intergraph Smart Construction Customization Guide.

If you upgrade a project with a custom PBS, see Upgrade a Smart Construction project with a custom PBS (on page 123) for special upgrade requirements.

You can use the Smart Construction Custom PBS Utility tool to customize the Smart Construction schema according to the custom PBS hierarchy. The Smart Construction Custom PBS Utility tool generates two XML files that must be loaded into Smart Construction - 02_SPC_PBS_AuthoringSchema.xml must be loaded using the Import Schema Wizard, and 051-02-SPC_PBS_CustomSearchCriteriaData.xml must be loaded using the Loader.

Run the Smart Construction PBS Configuration Utility

1. Browse to the CustomPBS folder in the Smart Construction installation directory. For example, browse to [Drive]\Program Files (x86)\SmartConstruction\2017\Utilities\CustomPBS.
2. Double-click the SPCCustomPBSUtility.exe to open the tool.
3. Specify the location of the Smart Construction PBS authoring schema file in the SPC Authoring schema files (*.xml) box. For example, browse to [Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema\02_SPC_PBS_AuthoringSchema.xml.

   TIP Click to browse to the Smart Construction PBS authoring schema file.
4. Specify the location of the generated EF schema file in the Generated EF Schema file (*.xml) box. For more information on generated schema, see Creating an alternate plant breakdown structure (PBS) in the SmartPlant Foundation How to Configure the Authoring and Data Warehouse Guide.

   TIP Click to browse to the generated EF Schema file.
5. Select a PBS level in the Assign CWP/IWP to box to specify which type of PBS item is to be related to the CWP and IWP level in Smart Construction.
6. Select one or more PBS levels in the Search by PBS item box to create custom search criteria for drawings in the Drawings browser in Smart Construction.
7. Click Options > Prefix to open the Select a different prefix dialog box.
8. Type a value in the Prefix box and click OK. By default the prefix is SPF.
9. Click **Options > Output location** to open the **Select an output directory** dialog box.

10. Type a new location in the box or click **Browse** to select a new location. Click **OK**.

**NOTE** The default location is the **My Documents** folder.

11. Click **Generate** to generate the Smart Construction schema according to the custom PBS hierarchy.

### Copy the generated files into the installation folder

The two XML files, 02_SPC_PBS_AuthoringSchema.xml and 051-02-SPC_PBS_CustomSearchCriteriaData.xml, generated from the **Smart Construction Custom PBS Utility** tool are located in the **My Documents** folder of the user or the location selected in the **Output location** dialog box. Before configuring a custom PBS, you must copy the files into the installation location.

- Copy the 02_SPC_PBS_AuthoringSchema.xml file into the **001-Schema** folder. For example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema`, and copy the file.

- Copy the 02_SPC_PBS_AuthoringSchema.xml file into the **SPCAuthoring** folder, located in the **Customization** folder. For example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\Customization\Schema\SPCAuthoringSchema`.

- Copy the 051-02-SPC_PBS_CustomSearchCriteriaData.xml file into the **051-CustomSearchCriteria** folder. For example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\003-Admin\051-CustomSearchCriteria`, and copy the file.

### Import Smart Construction schema

Use the SmartPlant Foundation Schema Import Wizard to import schema files into your Smart Construction project. For more information on the Schema Import Wizard, see the **SmartPlant Foundation Desktop Client User’s Guide**.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.

2. Click **Administration > Schema Import Wizard** in the Desktop Client.

3. Browse to the schema location.

4. Select a compare context option.

**IMPORTANT** Intergraph recommends you select the **Compare content of selected files against all database items with a matching container ID** option to compare your schema for Smart Construction.

5. Select the schema file to import. Click **Browse** on the **Schema Import Wizard** window to browse to the Smart Construction installation location. Select 01_SPC_AuthoringSchema.xml in the **001-Schema** folder (For example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema`).

6. Select a **Compare Option**. This step is optional.
7. Click **Next**. The **Comparison Results** form displays. The totals (New, Updated, and Removed objects and relationships) are displayed at the bottom of the form.

8. Select schema objects to import into your Smart Construction project. Select the check box next to each object name and click **Next** to import them one by one. Or, click **Select All** to import all objects, and click **Next**.

9. Verify the correct schema objects were loaded into the Smart Construction site in the **Review Changes** window. Click **Finish**.

**IMPORTANT** After loading schema changes, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

---

### Load the Plant Breakdown Structure schema

After loading the Smart Construction schema, you must load the Plant Breakdown Structure (PBS) schema. If using a custom PBS, see *Configuring a Custom Plant Breakdown Structure (PBS) for Smart Construction* in the *Intergraph Smart Construction Customization Guide*.

Use the SmartPlant Foundation Schema Import Wizard to import the PBS schema files into your Smart Construction project. For more information on the Schema Import Wizard, see the *SmartPlant Foundation Desktop Client User's Guide*.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **Administration > Schema Import Wizard** in the Desktop Client.
3. Browse to the schema location.
4. Select a compare context option.

**IMPORTANT** Intergraph recommends you select the **Compare content of selected files against all database items with a matching container ID** option to compare your schema for Smart Construction.

5. Select the schema file to import. Click **Browse** on the **Schema Import Wizard** window to browse to the Smart Construction installation location. Select 02_SPC_PBS_AuthoringSchema.xml in the **001-Schema** folder (For example, browse to \[Drive]\:Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema).

6. Select a **Compare Option**. This step is optional.

7. Click **Next**. The **Comparison Results** form displays. The totals (New, Updated, and Removed objects and relationships) are displayed at the bottom of the form.

8. Select schema objects to import into your Smart Construction project. Select the check box next to each object name and click **Next** to import them one by one. Or, click **Select All** to import all objects, and click **Next**.

9. Verify the correct schema objects were loaded into the Smart Construction site in the **Review Changes** window. Click **Finish**.

**IMPORTANT** After loading schema changes, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.
Load the work package enumerated list schema

After loading the PBS schema, you can load the package enumerated list schema, which loads the enumerated lists for the delivered package disciplines, purposes, and statuses (related to CWAs, CWPs, and IWPs). If you choose to not load the delivered package enumerated list schema, you must configure your own disciplines, purposes, and statuses. For more information, see Configure Work Package Disciplines and Purposes and Configure IWP Status in the Intergraph Smart Construction Administration and Configuration Guide.

Use the SmartPlant Foundation Schema Import Wizard to import the IWP enumerated list schema into your Smart Construction project. For more information on the Schema Import Wizard, see the SmartPlant Foundation Desktop Client User’s Guide.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **Administration > Schema Import Wizard** in the Desktop Client.
3. Browse to the schema location.
4. Select a compare context option.
   - **IMPORTANT** Intergraph recommends you select the Compare content of selected files against all database items with a matching container ID option to compare your schema for Smart Construction.
5. Select the schema file to import. Click **Browse** on the Schema Import Wizard window to browse to the Smart Construction installation location. Select 03_SPC_PackageEnumSchema.xml in the 001-Schema folder (For example, browse to \\Drive\Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema).
6. Select a **Compare Option**. This step is optional.
7. Click **Next**. The Comparison Results form displays. The totals (New, Updated, and Removed objects and relationships) are displayed at the bottom of the form.
8. Select schema objects to import into your Smart Construction project. Select the check box next to each object name and click **Next** to import them one by one. Or, click **Select All** to import all objects, and click **Next**.
9. Verify the correct schema objects were loaded into the Smart Construction site in the Review Changes window. Click **Finish**.
   - **IMPORTANT** After loading schema changes, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.
Load Smart Construction domains

Use the SmartPlant Foundation Loader to load Smart Construction domains. The domains you load are used to segregate Smart Construction data in the SmartPlant Foundation database.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click File > Loader.
3. On the Loader dialog box, browse to the SPC_Domains.xml file in the 002-Domain folder located in the Smart Construction installation location. For example, navigate to [Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\002-Domain.
4. Select the SPC_Domains.xml file.
5. Select the Put objects in new items window option to view new objects in the New Items window (optional).
6. Select SPC_Domains.xml in the Selected Load Files list.
7. Click Process. Results of the load display in the Processed load files list.
8. Click Load Results to view load process details.
9. Click Close.

★ IMPORTANT After loading the Smart Construction domains, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

Load Smart Construction administrative files

Use the SmartPlant Foundation Loader to load administrative files such as a Smart Construction menu, methods, and forms. Intergraph recommends you select to load the 010 Load Model.xmlIdr load file, in order to load all administrative functionality. When you install Smart Construction for the first time, you must also load the files in the 004-Users folder to load the delivered Smart Construction users. You must load the files in the 005-ConfigDocuments folder to load the delivered configuration documents.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click File > Loader to open the Loader dialog box.
3. Browse to the administrative files in the LoadFiles folder in the Smart Construction installation location. For example, navigate to [Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles.
4. Select the 010 Load Model.xmlIdr load file.
5. If loading individual files, verify the files are in numerical order. The administrative files must be loaded in the order indicated by the number preceding the file name. Click Move Selected Item Up or Move Selected Item Down in the Selected load files window to put the files in a numerical order.
6. Click Process. Results of the load display in the Processed load files list.
7. Click Load Results to view load process details.
8. Repeat steps 1-7 with the files in the 004-Users folder and the 005-ConfigDocuments folder.

**NOTE** To view the Smart Construction-specific menu in SmartPlant Foundation Desktop Client, you must configure the Smart Construction Administrator role. See Configure the Smart Construction Administrator role (on page 38) for more information.

**Configure the Smart Construction Administrator role**

When you loaded the administrative files into your Smart Construction site, a new Smart Construction menu was created in the SmartPlant Foundation Desktop Client, which enables Smart Construction administrators to perform Smart Construction-specific tasks.

In order to view this menu in SmartPlant Foundation Desktop Client, you must update the security settings for the Smart Construction Administrator role configuration and set your active scope to the Smart Construction Administrator role.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Administration > Configuration Role Assignment to display the role assignment GUI.
3. Select your Smart Construction project from the Configurations list.
4. Select Smart Construction Administrator role from the Roles list.
5. Query for the users you want to assign to the role and select them.
6. Click the Role Assignments tab.
7. Select the role assignment for the user. Click OK to commit the changes to the database and exit the Configuration Role Assignment GUI.
8. Set your active scope to the Smart Construction Administrator role.
9. Click Smart Construction on the menu bar and verify that the newly configured users can view the Smart Construction menu in the SmartPlant Foundation Desktop Client.

**Analyze documents on your Smart Construction site**

If you are installing Smart Construction on a system where documents have previously been published to SmartPlant Foundation and you have a new installation of Smart Construction, you must run the Analyze existing documents option in the SmartPlant Desktop Client.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > Administration > Options.
3. In the Find Smart Construction Options dialog box, type SPC System Options and click OK.
4. In the search results, right-click SPC System Options and select Analyze existing documents.
Configure Smart Construction security

Smart Construction security uses the SmartPlant Foundation security model to control access to and operation of project data in Smart Construction. Smart Construction administrators must configure and manage security through user roles and access groups in SmartPlant Foundation Desktop Client.

The SmartPlant Foundation security model is a flexible mechanism to control role-based user access to data and the operations that can be performed on that data.

The security model is comprised of:

- Users
- Roles, domains, and access groups
- Configurations
- Role assignments

A user is assigned a role in a configuration. Roles are related to access groups, which control access to the different components of the system.

The security model controls user access to:

- Application modules
- Menus and toolbars
- Shortcut menu commands
- Relationship manipulation and navigation

The SmartPlant Foundation Desktop Client is used to configure the security model by creating and relating security objects. No additional schema modeling of classes, interfaces, or relationship definitions is required.

Once the security access model is designed, the various levels of access are modeled by creating access groups and relating them to roles. The access groups are related to the relevant methods, interfaces, and view definitions to which they have to grant access.

Smart Construction is delivered with several default roles, access groups, and configurable GUI items, which are loaded with the default Smart Construction administrative files. For information about Smart Construction default roles, see Create and manage role assignments (on page 40). For more information about delivered access groups, see Configure access groups (on page 41). For more information on Smart Construction users, see Create Smart Construction users (on page 40). For more information on configurable GUI items, see Update and configure items on the Smart Construction interface in the Smart Construction Administration and Configuration Guide.

To configure Smart Construction security, you must create users, configure roles of users, then assign or relate the new user to access groups using the SmartPlant Foundation Desktop Client.

The SmartPlant Foundation How to Configure the Security Model guide describes the configuration and components of the SmartPlant Foundation Security Model. You can access the guide by clicking Help > Printable Guides.
Create and manage role assignments

Smart Construction is delivered with three default roles: **Viewer**, **Planner**, and **Administrator**.

<table>
<thead>
<tr>
<th>Role</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart Construction Viewer</td>
<td>View-only access to Smart Construction data</td>
</tr>
<tr>
<td>Smart Construction Planner</td>
<td>Permissions to view, modify, and update data in Smart Construction</td>
</tr>
<tr>
<td>Smart Construction Administrator</td>
<td>Permissions to view, modify, and update data, as well as perform administrative tasks on the Smart Construction system. By default, all Smart Construction roles are managed by the Smart Construction Administrator role.</td>
</tr>
<tr>
<td>Planning Group A</td>
<td>Smart Construction delivers an example planning group role, which limits access to functionality to specific users.</td>
</tr>
</tbody>
</table>

The role assignment links a user to a role in a given configuration.

**IMPORTANT** By default, all Smart Construction roles are managed by the Smart Construction Administrator role. When you create a new Smart Construction role, set the role to be managed by the Smart Construction Administrator role.

For more information about role creation, assignments, and configuration, see *Role Configuration* and *User and Role Assignment Configuration* in the *SmartPlant Foundation How to Configure the Security Model* guide. For more information on planning groups, see *Create and configure planning groups in the Intergraph Smart Construction Administration and Configuration Guide*.

Create Smart Construction users

Smart Construction delivers three example users: **SPC Viewer**, **SPC Planner**, and **SPC Administrator**.

You can load the example Smart Construction users with the SmartPlant Foundation Desktop Client Loader. Browse to the **004-Users** folder located in the Smart Construction installation location. For example, navigate to `[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\004-Users`.

<table>
<thead>
<tr>
<th>User</th>
<th>Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPC Viewer</td>
<td>Smart Construction Viewer</td>
</tr>
<tr>
<td>SPC Planner</td>
<td>Smart Construction Planner</td>
</tr>
<tr>
<td>SPC Admin</td>
<td>Smart Construction Administrator</td>
</tr>
</tbody>
</table>

The role assignment links a user to a role in a given configuration.
In order to use Smart Construction OnSite, users must meet following requirements:

- A password must be set for the user, and it cannot be blank.
- The user must be assigned the SmartPlant Foundation Viewer role.
- The user must be assigned a construction responsibility.

For more information on associating Smart Construction users with their area of construction responsibility, see Associate Smart Construction users with a construction responsibility (on page 45).

**NOTE** You can load the users when you set up and configure your Smart Construction project. You do not need to reload the users during a Smart Construction upgrade.

For more information about role creation, assignments, and configuration, see User and Role Assignment Configuration in the SmartPlant Foundation How to Configure the Security Model guide. For more information on configuring users, see Create login users in the SmartPlant Foundation How to Configure the Security Model guide.

## Configure access groups

Access groups govern user access to Smart Construction commands and navigation and are modeled to represent different levels of functional access. For example, access groups can be used to configure security for reports, models, drawings, filters, selection rules, attached files on IWPs, and specific toolbar buttons in Smart Construction.

To grant user permissions to access a specific command or function, associate that user's roles to the appropriate access group.

The following access groups and roles are delivered in Smart Construction.

<table>
<thead>
<tr>
<th>Access Groups</th>
<th>Access Group Descriptions</th>
<th>Roles</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPC_ActualManHoursEdit</td>
<td>Makes the Actual Man Hours for the IWP editable on the Components window.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_AddComponentsWithNoSteps</td>
<td>Add components that have no remaining unplanned work steps.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_Admin</td>
<td>Includes all administrator functions, methods, and procedures.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_AdvancedQueryManager</td>
<td>Modify queries that they create as well as modify or delete other shared queries.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_AdvancedQueryShare</td>
<td>Share queries that they create as well as modify or delete other shared queries.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_AutoLoadSavedFilters</td>
<td>Save a filter view, so it can be automatically loaded when a model or drawing is opened.</td>
<td>None by default</td>
</tr>
<tr>
<td>SPC_BrowserItemView</td>
<td>View browser items.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
</tbody>
</table>
### Set Up and Configure Smart Construction Services

<table>
<thead>
<tr>
<th>Access Groups</th>
<th>Access Group Descriptions</th>
<th>Roles</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPC_ComponentRegistersView</td>
<td>View component register items.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_ConstructionResourcesManage</td>
<td>Find, create, update, delete construction resources.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_CWADeleteAll</td>
<td>Delete CWAs without related packages that anyone owns.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_CWADeleteOwned</td>
<td>Delete CWAs without related packages that they created.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_CWAUpdate</td>
<td>Create, update, and delete CWAs.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_CWADeleteAll</td>
<td>Delete CWPs without related packages that anyone owns.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_CWPDeleteOwned</td>
<td>Delete CWPs without related packages that they created.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_CWPUpdate</td>
<td>Create, update, and delete CWPs.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_DashboardView</td>
<td>Able to view the Dashboard.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_DashboardManager</td>
<td>Share views that they create. Users can modify or delete other shared views.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_DocumentsSourceView</td>
<td>Able to view document source items and to determine if files should be attached when adding components to an IWP.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_DocumentView</td>
<td>View documents.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_DrawingView</td>
<td>View drawings.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_Everyone</td>
<td>Gives access to functionality for all users. Every user must have access to this role.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_ExportViewerFilters</td>
<td>Export filters from the viewers to a Microsoft Excel file.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>Access Groups</td>
<td>Access Group Descriptions</td>
<td>Roles</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>SPC_FileUpdate</td>
<td>Determine if files attached to an IWP can be included in or excluded from reports.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_FindAllPackages</td>
<td>Search for All Packages in Work Packages browser windows. If the access group is not added, then All Packages does not show in browser. Also, allows users to acknowledge changes for all IWPs with engineering changes.</td>
<td>Viewer, Planner, Administrator</td>
</tr>
<tr>
<td>SPC_FindGroupPackages</td>
<td>Search for IWPs owned by anyone in the planning group or groups of users. Planning group name displays in browser search list.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_FIWPDdeleteAll</td>
<td>Delete IWPs that anyone owns.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_FIWPDdeleteOwned</td>
<td>Delete IWPs that they create.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_FIWPDupdate</td>
<td>Create, update, delete IWPs.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_HiddenItemView</td>
<td>View hidden Smart Construction items. Hides Smart Construction items, such as drawings and models, from users with this access group associated to a role.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_ImportProjectData</td>
<td>Import and update schedule and project data.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_ManageAllUsersFilters</td>
<td>Create, update, and delete saved filters that are marked available for all users.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_ManagePublicColorDefinitions</td>
<td>Change, modify, and update color definitions.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_MaterialAllowForecast</td>
<td>Perform a materials forecast.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_MaterialAllowReserve</td>
<td>Perform a materials reservation.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_MaterialUpdate</td>
<td>Create and update materials; Forecast and reserve materials.</td>
<td>Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_MaterialView</td>
<td>View Materials.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>Access Groups</td>
<td>Access Group Descriptions</td>
<td>Roles</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------</td>
<td>-------</td>
</tr>
<tr>
<td>SPC_MessageView</td>
<td>View messages.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_ModelView</td>
<td>View 3D models.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
<tr>
<td>SPC_OriginalDrawingView</td>
<td>Allows a user to view the original engineering drawing as well as its superseding fabrication drawing.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_OriginalSpoolView</td>
<td>Allows a user to view the original engineering spool as well as its superseding fabrication spool.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_PackageComponentsAndAssembliesForSamePurpose</td>
<td>Allow a spool or assembly and components of that spool or assembly to both be put in an IWP of the same purpose.</td>
<td>None by default</td>
</tr>
<tr>
<td>SPC_PackageMismatchedCWP</td>
<td>See and plan all CWP, regardless of planning group association.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_PackageReplacedEngineeringComponents</td>
<td>Allow an engineering component item which has been replaced by a fabricated component item to be planned in an IWP.</td>
<td>None by default</td>
</tr>
<tr>
<td>SPC_PlanAllCWP</td>
<td>See and plan all CWP, regardless of planning group association.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_ProjectConfigurationUpdate</td>
<td>Update project configuration data.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_Retrieve</td>
<td>Access the retrieve option.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_ROPUtility</td>
<td>Access the Rules of Progress Utility option.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_ScheduleUpdate</td>
<td>Update schedule; Import and export schedule information.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_UpdateAutoLoadedSavedFilter</td>
<td>Update a filter that has been applied from a filter view that is set to be automatically opened when a model or drawing is opened.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
</tbody>
</table>
### Access Groups

<table>
<thead>
<tr>
<th>Access Group</th>
<th>Access Group Descriptions</th>
<th>Roles</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPC_UpdateExternalSystemProperties</td>
<td>Update properties of an object imported from an external system.</td>
<td>Administrator</td>
</tr>
<tr>
<td>SPC_ViewAndPrint</td>
<td>Opens a drawing or document in SmartPlant Markup Plus for viewing or printing.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_WorkPackageScheduleUpdate</td>
<td>Update and save changes in the Work Package Schedule window.</td>
<td>Planner, Administrator</td>
</tr>
<tr>
<td>SPC_WPView</td>
<td>View IWPs, CWPs, and CWAs.</td>
<td>Viewer, Planner, Administrator, Planning Group A (Example)</td>
</tr>
</tbody>
</table>

**NOTE** By default, the **SPC_BrowserItemView** access group is associated to models and drawings after being retrieved into Smart Construction. You can edit access groups on models and drawings to fit your business needs.

To configure access groups, you need to log on to the SmartPlant Foundation Desktop Client as an administrator. For more information, see *Roles and Access Groups* in the *SmartPlant Foundation How to Configure the Security Model* guide.

### Associate Smart Construction users with a construction responsibility

Smart Construction delivers a set of construction responsibilities that can be associated with a Smart Construction user in the SmartPlant Foundation Desktop Client.

When a user's position of responsibility has been defined in the system, the user and their responsibility can be associated with an IWP. Users with a construction assignment can access IWPs in the Smart Construction OnSite app.

The following responsibilities are delivered:

- Foreman
- General Foreman
- Field Engineer

You can define a user's construction responsibility in SmartPlant Foundation Desktop Client when you create the user or by updating an existing user. You can then assign that user to an IWP in the **Details** window of an IWP in Smart Construction. For more information, see *Add user assignments to an IWP* in the *Intergraph Smart Construction User's Guide*.

Smart Construction delivers three example users with construction responsibilities associated with them. You can load the example Smart Construction users with the SmartPlant Foundation Desktop Client Loader. Browse to the **004-Users** folder located in the Smart Construction installation location. For example, navigate to `[Drive]:\Program Files (x86)\SmartConstruction\2017\LoadFiles\004-Users`.

For more information on creating Smart Construction users, see *Create Smart Construction users* (on page 40).
Configure vaults for snapshots and files

You can configure SmartPlant Foundation vaults to store Smart Construction IWP snapshot files and document files.

Using SmartPlant Foundation Desktop Client technology, you must configure a vault for a specific class of object by relating the vault to an interface definition of the object.

In order to configure a vault for IWP snapshots, you must configure the vault to the interface definition, ISPC_ModelShotFile.

In order to configure a vault for IWP files, you must configure the vault to the interface definition, ISPC_PackageFile.

For more information on forcing a class of object to a vault, see Force a Class of Object to a Vault in the SmartPlant Foundation Installation and Setup Guide.

Configure a vault for files attached to configuration documents

You can configure SmartPlant Foundation vaults to store Smart Construction files attached to configuration documents objects.

Using SmartPlant Foundation Desktop Client technology, create a vault that is related to the Open to All owning group.

★ IMPORTANT The configuration document object vault must be related to the Open to All owning group.

For more information, see Vault configuration in the SmartPlant Foundation How to Configure Document Management Guide.

For more information on using configuration document objects, see Configure the Rules of Progress (on page 54), Configure mapped properties for a published document (on page 58), and Import project data into Smart Construction (on page 60).

Configure and update a materials system

Smart Construction can be configured to integrate with a materials system. By default, Smart Construction has direct integration with SmartPlant Materials; however, an open API provides integration with other materials systems. See the Intergraph Smart Construction API and Programmer’s Guide for more information about integration through the API.

Intergraph recommends that the materials system is set up outside of the Smart Construction server. You must then configure the connection for integration between your materials system and Smart Construction. Once configured for integration, Smart Construction uses the materials system forecast data to filter 3D models and 2D drawings. The connection between Smart Construction and the materials system also allows users with the appropriate security privileges to run a forecast and reserve materials for IWP’s in Smart Construction. You can also specify which work steps will consume materials. For more information, see Specify which work steps consume materials (on page 51).
Create a TNS entry for the SmartPlant Materials database

1. In Windows Explorer, navigate to the Oracle Home folder.
2. Open the tnsnames.ora file found in the ADMIN folder.
3. Create a TNS entry that points to your SmartPlant Materials database.
   ★ IMPORTANT Consult your local Oracle Administrator for assistance.

Configure a materials system with Smart Construction

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > New > Administration > Materials System in the SmartPlant Foundation Desktop Client to open the New Materials System dialog box.
3. Define details for the materials system.
   ☞ NOTES
      ▪ An ENS definition automatically names the materials system with the Smart Construction plant name in SmartPlant Foundation.
      ▪ Smart Construction hides your password in SmartPlant Foundation Desktop Client.
4. Click Apply or Finish to create the new materials system.
   ★ IMPORTANT
      ▪ The data source is the name of the local TNS entry that points to the materials database.
      ▪ The user ID and password are the same user ID and password contained in the materials system with permissions to run forecasts and reservations.
      ▪ The project forecast name must be the same project forecast name used in your materials system.
      ▪ Your active scope must be set before configuring a materials system in Smart Construction. For more information, see Set your active scope in SmartPlant Foundation Desktop Client (on page 32).

Update materials system information in SmartPlant Foundation Desktop Client

After you configure a materials system in SmartPlant Foundation, you can update the materials system information as needed.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > Administration > Materials System to open the Find Materials System dialog box.
3. Type a name of a materials system in the Find Materials System dialog box. Click OK.
   ★ TIP You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. In the search results list, right-click the name of the materials system you want to update and select Update.
5. Edit the materials system information on the Update form.
6. Click Finish to save the changes and update the system.

Set up the SmartPlant Materials site API

★ IMPORTANT You must set up the Materials Site API for Smart Construction in SmartPlant Materials.

1. In SmartPlant Materials, navigate to the A.20.12 screen.
2. Click the Integrator tab.
3. Select the record with the Parameter ZI_SITEAPI.
4. Verify that the Value option for the record with Parameter ZI_SITEAPI contains the value Y.
5. If the Value option does not contain the value Y, then select the option and press F9 to bring up the list of values window.
6. Select Y Site API is Activated. Click OK.
7. Press F10 to store the record.
8. Navigate to the A.20.06.02 screen.
9. Press F8 to populate the form.
10. Scroll to your Materials User and your Project.
11. Verify that the Use for APIs option is selected, which means the Site API for SmartPlant Materials is enabled.

   If the Active option is not selected, select the option to enable the Site API for SmartPlant Materials.

For more information, see Using the Site API Guide delivered with SmartPlant Materials.

Install SQL scripts for a SmartPlant Materials database

Complete the following steps in each SmartPlant Materials database that you plan to interface with Smart Construction.

1. Log on to SQLPlus using the user name and password of your SmartPlant Materials database.
2. Using SQL Plus, browse to the Materials folder in the Smart Construction server installation location. For example, navigate to \[Drive]\Program Files (x86)\SmartConstruction\2017\SPCServer\Support\Materials.
3. Run file scripts located in the Materials folder.

★ IMPORTANT Select the scripts that correspond to your version of SmartPlant Materials.

   ▪ If you are installing a new SmartPlant Materials system, run the following scripts:

      ▪ m_api_site_spc_spec.sql
      ▪ m_api_site_spc_body.sql
- m_api_site_spc_Type.sql for version 7.0.3 or later
- If you already have a SmartPlant Materials system installed, run the following scripts:
  - del_spc_fah_results.sql
  - m_api_site_spc_spec.sql
  - m_api_site_spc_body.sql
  - m_api_site_spc_Type.sql for version 7.0.3 or later

For more information, see *Using the Site API Guide* delivered with SmartPlant Materials.

**Verify the materials system is working**

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click *Smart Construction > Find > Administration > Materials System* to open the *Find Materials System* dialog box.
3. Type a name of a materials system in the *Find Materials System* dialog box. Click *OK*.
   - **Tip** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. In the search results list, right-click the name of the materials system and select *Test Service*.
5. After reviewing either the success or failure message, click *OK*.

**Set up a project forecast in a materials system**

After you configure your materials system with Smart Construction, forecast information updates 3D model and 2D drawing filters.

You must frequently run project forecasts for all drawings in your project.

Intergraph suggests that you run a project forecast daily in order to update Smart Construction filters with the latest forecast information.

See SmartPlant Materials documentation or the documentation of your materials system for more information about setting up a project forecast.

**Attach materials template files to the materials system configuration document**

- **IMPORTANT**
  - You must attach the SP Material Mappings.xlsm workbook and XML file to the Material Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.
  - Set your *Create scope* in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click *Smart Construction > Find > Administration > Configuration Documents* to open the *Query for Configuration Documents* dialog box.
Set Up and Configure Smart Construction Services

2. Type your search criteria and click **Finish** to find the configuration documents.

3. In the search results, right-click the **Material Mappings** document and select Files > Attach File to open the Attach File dialog box.

4. Click **Add File** and browse to the **SP Material Mappings.xlsx** workbook and **SP Material Mappings.xml** file.
   
   The files are delivered by default to `[drive]:\Program Files (x86)\SmartConstruction\2017\Templates\Material Mappings`.

5. Click **Open**, and then click **OK** to add the files to the list.

6. Click **Finish**.

**Customizing the material mappings template**

You can customize the material mappings for your project by editing the tables in the mapping template.

⭐ **IMPORTANT** For information and assistance in customizing the material mapping template for your project, please contact Intergraph Customer Support (http://support.intergraph.com).

1. Open the **SP Material Mappings.xlsx** workbook. (Browse to the **Templates** folder in the installation location, or check out the Material Mappings configuration document from the SmartPlant Foundation Desktop Client.)

2. Enable the macro content for the workbook.

3. Edit the **SP Material Mappings.xlsx** file.

4. Save your changes in the workbook file.

5. Open the **Main** tab of the workbook, click **Generate SP Material Mapping** to generate the XML mapping to be used.

6. Verify the XML file is generated.

7. Attach the XML and materials mapping template to the Material Mappings configuration document, and check in and sign off the Material Mappings configuration document in the SmartPlant Foundation Desktop Client.

**Use the SmartPlant Foundation Desktop Client to manage the template files**

After they are attached to the **Material Mappings** configuration document, the SP Material Mappings.xlsx workbook and SP Material Mappings.xml file can be managed in the SmartPlant Foundation Desktop Client.

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the **SmartPlant Foundation Desktop Client User's Guide**.
Specify which work steps consume materials

You can specify which work step consumes material in the RoP Configuration workbook. Materials can be consumed by multiple work steps in IWPs with different purposes; however, materials cannot be consumed by multiple work steps in IWPs with the same purpose. For more information, see Configure the rules of progress in the rules of progress configuration workbook in the Intergraph Smart Construction Rules of Progress Configuration Guide.

Configure system setting

1. Click Smart Construction > Find > Administration > Options.
2. In the Find Smart Construction Options dialog box, type SPC System Options and click OK.
3. In the search results, right-click SPC System Options and select Update.
4. Select Allow work steps to consume materials? to enable the functionality to specify which work steps consume the materials.
5. Click Finish to save your changes.

For information on Smart Construction system settings, see Configure System Settings for Smart Construction in the Intergraph Smart Construction Administration and Configuration Guide.

Specify which work steps consume materials

In the RoP Configuration workbook, type [Consumes material] in the row below the work step name to specify which work step is to consume the materials.

**NOTE** You can also indicate that a manual work step consumes a material item on the Components tab of the Work Packages browser window by enabling the Consuming Material column and marking the check box for the work step.

Material consumption details

Once configured, the rules of progress generation manage changes to the consumption of materials.

<table>
<thead>
<tr>
<th>Action</th>
<th>A work step owns the material item</th>
<th>Another work step owns the material item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a work step</td>
<td>Create the material item and associate it with the work step.</td>
<td>Transfer ownership if both work steps are unplanned, or both steps are planned but not processed.</td>
</tr>
<tr>
<td>Delete a work step</td>
<td>Delete the material item.</td>
<td>The material item is not updated.</td>
</tr>
<tr>
<td>Update a work step</td>
<td>Create or remove the material item.</td>
<td>Transfer ownership if both work steps are unplanned, or both steps are planned but not processed.</td>
</tr>
</tbody>
</table>
### Set Up and Configure Smart Construction Services

<table>
<thead>
<tr>
<th>Action</th>
<th>A work step owns the material item</th>
<th>Another work step owns the material item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert a work step from a manually added work step to a configured work step</td>
<td>Create the material item and connect it to the work step.</td>
<td>Transfer ownership if the old work step owner is unplanned, or old work step owner is planned but not processed.</td>
</tr>
<tr>
<td>Convert work step from a configured work step to a manually created work step</td>
<td>Delete the material item.</td>
<td>The material item is not updated.</td>
</tr>
</tbody>
</table>

---

#### Enable the Material Request window and report in Smart Construction

You can enable the **Material Request** window and **Material Request Form** report in the Smart Construction client to help plan material requests. When the **Material Request** window is enabled, users can manually manage material requests, or material requests can be automatically populated based on components, component register items, and work steps added to IWP. Material requests can also be manually added, updated, and deleted in the **Material Request** window. When the **Material Request Form** report is enabled, users can print a list of material request items for an IWP.

#### Configure and enable the Material Request window

The **Material Request** window can be enabled by configuring access groups and a system setting in order for users to access the object in the Smart Construction client.

##### Configure access groups for the Material Request window

- **NOTE** Intergraph recommends associating the access group SPC_MaterialView to allow users to view the **Material Request** window.

1. Log on to SmartPlant Foundation Desktop Client.
2. Click **Smart Construction > Find > Administration > Work Package Toolbar Items** to open the **Find Work Package Toolbar Items** dialog box.
3. Type your search criteria in the **Find Work Package Toolbar Items** dialog box. **Tip** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. Right-click the name of the toolbar and select **Manage Access Groups**.
5. On the **Manage Access Groups** window, select an access group to add to the toolbar item.
6. Click **Relate Selected Item** to add the access group to the toolbar.

7. Click **OK** to save your changes.

For more information on managing access groups, see *SmartPlant Foundation How to Configure the Security Model*.

**Configure the system setting for the materials consumption**

1. Click **Smart Construction > Find > Administration > Options**.

2. In the **Find Smart Construction Options** dialog box, type **SPC System Options** and click **OK**.

3. In the search results, right-click **SPC System Options** and select **Update**.

4. Select **Allow work steps to consume materials?** to enable the functionality to specify which work steps consume the materials.

5. Click **Finish** to save your changes.

For information on Smart Construction system settings, see *Configure System Settings for Smart Construction* in the *Intergraph Smart Construction Administration and Configuration Guide*.

**Enable the Material Request Form report**

You can enable the **Material Request Form** report by enabling security for the report.

You must configure security for the report object in SmartPlant Foundation Desktop Client to enable delivered reports.

Relate the necessary access groups to the custom report object. The **SPC_ReportsView** or **SPC_Everyone** access groups can be used to configure the security for the report object. It is delivered with Smart Construction.

1. In the SmartPlant Foundation Desktop Client, click **Smart Construction > Find > Administration > Custom Reports**.

2. Type the name of the item you want to update in the **Find** dialog box. Click **OK**.

   **Tip** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.

3. Find the report object in the search results list.

4. Right-click the report option and select **Manage Access Groups**.

5. Configure the correct access group to allow users to use the report.

For more information, see the *SmartPlant Foundation How to Configure the Security Model* guide.

For information on enabling the Material Request Form report, see *Enable delivered reports* in the *Intergraph Smart Construction API and Programmer's Guide* or the *Intergraph Smart Construction Customization Guide*.  

---

*Intergraph Smart Construction Installation and Setup Guide*  

53
Set Up and Configure Smart Construction Services

Reset IIS application pools and retrieve documents

After enabling the Material Request window and report, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project’s site. For more information on resetting IIS application pools, see IIS documentation.

After recycling the IIS application pools, retrieve documents into Smart Construction. For more information, see Retrieve and refresh data in Smart Construction (on page 100).

Configure the rules of progress

Smart Construction provides the ability to automatically assign work steps, along with their man hours and rates, to components in IWP's. These work steps form the basis of determining the completion status of an IWP. Administrators can configure rules of progress data to generate and associate work steps with components.

By default, the Rules of Progress Service delivered with Smart Construction communicates with an XML file generated from a Microsoft Excel workbook that is delivered with the Smart Construction server installation.

The Smart Construction administrator can check out and modify the workbook, then generate a new XML file with rules of progress data for the Smart Construction site to fit the specific needs of an organization.

The rules of progress data in the generated XML file are associated with components during the Smart Construction retrieve. After a retrieve is started, the Smart Construction Rules of Progress queue generates and associates the rules of progress information with retrieved components. The Rules of Progress queue creates a separate scheduler task, SPC Process ROP Scheduler, to relate the scheduler to the Rules of Progress queue. The SPC Process ROP Scheduler task regularly polls the queue to process the rules of progress data for retrieved documents.

If you choose not to use the delivered workbook or XML configuration file or if you already have a rules of progress system, you can create your own version of the Rules of Progress Service. In order to do this, you must implement the IRulesOfProgress WCF Service Contract and create a rules of progress component as described in the Intergraph Smart Construction API and Programmer's Guide.

Configure the rules of progress in the rules of progress configuration workbook

The following is a detailed work process that explains how to populate the ROP Configuration.xlsm workbook with rules of progress data. The Rules of Progress is managed using a configuration template and XML files. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

★ IMPORTANT You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

➤ NOTE Intergraph recommends that you store and manage your rules of progress data in SmartPlant Foundation Desktop Client; however, you can configure rules of progress data locally from the web site folder on the Smart Construction server in order to test and validate the
data prior to storing and managing the configuration document in SmartPlant Foundation Desktop Client. For more information about testing and validating locally, see Test and validate rules of progress data locally in the Intergraph Smart Construction Administration and Configuration Guide.

**Edit and add rules of progress data for component classes**

1. Open the ROP Configuration.xlsm workbook. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

2. Select a rate table tab to open rate table worksheet.

Add a new worksheet to your workbook, if you want to add a new rate table to define work steps.

**IMPORTANT** If you add a new rate table tab to the ROP Configuration.xlsm workbook, you must copy the correct header and metadata to the new tab. Open a delivered tab, select rows 1 through 6 and columns A through F, copy and paste the data onto a new tab.

3. Define the component class definition type in the **Component Classes** row (starting in row 1, column B). Separate entries with commas for multiple class definitions.

These class definitions match class definitions of objects published to SmartPlant Foundation. In the following example, the class definitions include P3DPipe, P3DPipeRun, PDS_Dwg_Pipe, and PDS_Pwg_PipeRun. Any component mapped to these component class definitions use the values defined on the rate table worksheet.

<table>
<thead>
<tr>
<th>Component Classes</th>
<th>~P3DPipe,P3DPipeRun,P3DPipeWall, PDS_Dwg_Pipe, PDS_Pwg_PipeRun</th>
<th>Installation, Install, ConsumesMaterial</th>
<th>&lt;Rate Ratio&gt;</th>
</tr>
</thead>
</table>

4. Define the lookup values for the class definition. Lookup values are preceded with a tilde (~) and are property definition names.

In the following example, the lookup values include SPC_ComponentItem_Size, SPC_ComponentItem_Thickness, SPC_ComponentItem_Material, and unit of measure (UoM).

<table>
<thead>
<tr>
<th>Component Classes</th>
<th>~P3DPipe,P3DPipeRun,P3DPipeWall, PDS_Dwg_Pipe, PDS_Pwg_PipeRun</th>
<th>Installation, Install, ConsumesMaterial</th>
<th>&lt;Rate Ratio&gt;</th>
</tr>
</thead>
</table>

**NOTES**

- You can specify a range for lookup values that are scoped by double or a unit of measure (UoM) type in the schema. For example, you can specify a range for ~SPC_ComponentItem_Size and ~SPC_ComponentItem_Rating. If using a range, type ([Minimum value],[Maximum value]).

- You can specify a list of properties for string lookup values, such as ~SPC_ComponentItem_Thickness. If using a list of values, type {Property value | Property value}. The list can only be applied to one lookup value per row. Multiple values must be separated by the pipe (|) in braces; these values are treated as an OR.
value. For example, {XS | XXS} would match all lookup values with a thickness of XS or XXS.

- You can specify a UoM along with a lookup value that does not use a wildcard. Provide a value or range, add a tilde (~), and type the UoM display value, as displayed in SmartPlant Foundation. For example, you can search for a specific value, like 20~in, or a range of values, like (3-6)~m. If no matches are found using the value and the UoM, then the value is considered without the specified UoM. If no match is found using only the value, the rules of progress will attempt to match using wildcard values.

- If you specify a UoM for one lookup value, you must also specify UoMs for all other lookup values that support UoMs in the same row.

- The wildcard values * and ? can be used to define lookup values. If there is an exact match (all lookup columns match the values on the component exactly), the rules of progress uses that row. Otherwise, the rules of progress attempts a match on the rows that contain wildcards. If multiple rows that contain wildcards are a match, the rules of progress uses the first match.

- The wildcard values cannot be used to look up the ~UOM lookup value.

- You cannot use a wildcard value as a part of a range.

- The wildcard value * finds any string of values. And, the wildcard value ? finds one value.

- The ~UOM lookup value is required.

- If you type data in the ROP Configuration.xlsm workbook and decide to remove the data, right-click the cell in Excel and select Clear Contents.

5. In the purpose and work step column, define the IWP purpose in the first row below the component class definitions, the sequence number in the second row, and the work step name in the third row.

   **IMPORTANT**

   - The IWP purpose must be spelled exactly the same as the purpose defined in the FIWP purposes enumerated list. For more information, see Configure Work Package Disciplines and Purposes in the Intergraph Smart Construction Administration and Configuration Guide.

   - The work step name is limited to 100 characters or fewer.

   - The sequence number is optional. All purpose and work step columns in a rate table tab must have sequences defined, or Smart Construction defines the sequence of work steps.

In the following example, components with the Component Classes of P3DPipeRun, PDS_Dwg, and PDS_Dwg_PipeRun in an Installation IWP have the work step Install associated.

6. Type [Consumes material] in the row below the work step name to specify which work step is to consume the materials.
7. Designate a new work step rate basis for the given lookup row in the <Rate Basis> column, or designate a new work step rate basis in the fifth row of the purpose and work step column.

8. If you choose use the default rate basis, Smart Construction calculates the rate based on units of a component. For more information, see Designate work step rate basis in the Intergraph Smart Construction Rules of Progress Configuration Guide.

9. Define a rate for the new work step value in the purpose and work step column.

10. Save your changes in the workbook file.

Generate the XML file and retrieve documents

1. Open the Main tab of the workbook.

2. Click Generate configuration file to generate the XML mapping to be used during retrieve.

   **NOTE** After you generate the configuration file, Smart Construction informs you of any validation errors in the ROP Configuration.xlsm. Smart Construction highlights the tabs containing errors and, within those tabs, the cells containing errors.

3. Verify the XML file generated to the location you specified when you checked out the files.

   ★ **IMPORTANT** If generating rules of progress data for the first time, browse to the Templates\ROP Configuration folder in the installation location. For example, browse to [Drive]:\Program Files (x86)\SmartConstruction\2017\Templates\ROP Configuration to find the generated XML file.

4. Check in and sign off the workbook. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

   ★ **IMPORTANT** If generating rules of progress data for the first time, attach the ROP Configuration.xlsm workbook and XML file to the Rules of Progress configuration document in the SmartPlant Foundation Desktop Client. For more information, see Attach the ROP Configuration workbook and XML files to the Rules of Progress configuration document (on page 57).

5. Retrieve documents into Smart Construction. For more information, see Retrieve and refresh data in Smart Construction (on page 100).

6. Verify the correct work steps, rates, and values are associated with the correct type of component.

Attach the ROP Configuration workbook and XML files to the Rules of Progress configuration document

★ **IMPORTANT**

- After you generate rules of progress data for your project for the first time, you must attach the ROP Configuration workbook and XML file to the Rules of Progress configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Clients stores the document, allowing users with the proper permissions to check the document out and in with revisions.

- Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.
1. Click **Smart Construction > Find > Administration > Configuration Documents** to open the **Query for Configuration Documents** dialog box.

2. Type your search criteria and click **Finish** to find the configuration documents.

3. In the search results, right-click the **Rules of Progress** document and select **Files > Attach File** to open the **Attach File** dialog box.

4. Click **Add File** and browse to the ROP Configuration.xlsm workbook and XML files.

5. Click **Open**, and then click **OK** to add the files to the list.

6. Click **Finish**.

**NOTE** For more information on managing configuration files for Smart Construction, see *Manage Template Files for Smart Construction* (on page 134).

### Configure mapped properties for a published document

Mapping is required to retrieve documents into the Smart Construction domain. Mapping helps define properties and data that will be retrieved into Smart Construction from the publishing tool.

Tools, such as Smart 3D, can publish documents to the SmartPlant Foundation data warehouse. The data warehouse can be configured with a Smart Construction server and project. After tools publish to the data warehouse, documents can be retrieved into the Smart Construction domain.

Before you retrieve documents into Smart Construction, administrators can check out and edit the SPCRetrieveMappings.xlsm file to map properties and data related to the documents between the publishing tool and Smart Construction. After mapping properties in the SPCRetrieveMappings.xlsm workbook, administrators can then generate an XML file from the SPCRetrieveMappings.xlsm that is used to map properties during retrieve.

![Diagram of configuration process](image)

During a retrieve operation, Smart Construction gets the view files and data files associated with the published document that is being retrieved. The data files contain engineering data exposed by various 3D models and 2D drawings generated by the various Intergraph engineering tools. These data files contain the component list and relationships you see in the engineering tools, as well as Smart Construction.
Map properties and generate XML for a Smart Construction retrieve

Use the following work process to map properties and generate XML for a Smart Construction retrieve. Retrieve mapping is managed using a configuration template and XML files. For more information on managing configuration files for Smart Construction, see *Manage Template Files for Smart Construction* (on page 134).

➤ **IMPORTANT** You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see *Configure a vault for files attached to configuration documents* (on page 46).

### Map properties in the mapping workbook

1. Open the SPCRetrieveMappings.xlsm file. For more information on managing configuration files for Smart Construction, see *Manage Template Files for Smart Construction* (on page 134).
2. Edit the SPCRetrieveMappings.xlsm file.
3. Save your changes in the workbook file.

### Generate XML and retrieve documents

1. Open the **Main** tab of the workbook.
2. Click **Generate Retrieve Mapping** to generate the XML map file to be used during retrieve.
3. Verify that the XML file was generated to the location you specified when you checked out the files.
   
   ➤ **IMPORTANT** If generating the retrieve mapping data for the first time, browse to the Templates\Retrieve Mappings folder in the installation location. For example, browse to \[Drive]\Program Files (x86)\SmartConstruction\2017\Templates\Retrieve Mappings to find the generated XML file.
4. Check in and sign off the workbook. For more information on managing configuration files for Smart Construction, see *Manage Template Files for Smart Construction* (on page 134).
   
   ➤ **IMPORTANT** If generating retrieve mappings for your project for the first time, attach the SPCRetrieveMappings.xlsm workbook and XML file to the **Retrieve Mappings** configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions. For more information, see *Attach the SPCRetrieveMappings.xlsm and XML files to the Retrieve Mappings configuration document* (on page 60).
5. Retrieve documents into Smart Construction. For more information, see *Retrieve and refresh data in Smart Construction* (on page 100).

➤ **NOTE** For more information on the retrieve process after mapping the properties, see *Retrieve process after mapping properties* in the *Intergraph Smart Construction Customization Guide*. 
Attach the SPCRetrieveMappings.xlsm and XML files to the Retrieve Mappings configuration document

**IMPORTANT**

- If generating retrieve mappings for your project for the first time, attach the SPCRetrieveMappings.xlsm workbook and XML file to the Retrieve Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.

- Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the Retrieve Mappings document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the SPCRetrieveMappings.xlsm workbook and XML files.
5. Click Open, and then click OK to add the files to the list.
6. Click Finish.

**Import project data into Smart Construction**

You can use the Import Project Data window in the Smart Construction client to import project data, such as your schedule objects from Primavera P6 and project configuration objects, into your project. Using the Import Project Data window, you can select which CWPs and project configuration objects and relationships you want to create, edit, or remove in your project.

The Import Project Data window reads project data from template files in which you can specify data. The window can also directly integrate with your Primavera P6 schedule system. For more information on directly integrating with Primavera P6, see Configure a Schedule System for Schedule Data Import (on page 83).

Using the Import Project Data window, you can create, edit, and remove CWPs from your schedule system. You can create CWPs two different ways using the Import Project Data window in Smart Construction:

- You can export your schedule from your scheduling tool, then import it into Smart Construction. For information on importing your schedule from an exported schedule file, see Importing your schedule into Smart Construction (on page 61).

- Using the Import Project Data window, you can create, edit, and remove project configuration objects, such as contractors, contracts, CWPs, drawings, and planning groups and their relationships. For information on importing your project configuration data, see Import project configuration data into Smart Construction (on page 68).
Update security for services on the Import Project Data window

When configuring your project data in the Import Project Data window, update the security access for users for the services your project is using.

For example, if you plan to use only the Project Configuration service, you can remove access to the other listed services.

For more information, see Configure access groups (on page 41).

Importing your schedule into Smart Construction

You can export your schedule from your scheduling tool, and then import it into Smart Construction. Configuring your schedule with Smart Construction is a multi-step process, as seen in the following work process diagram.

**NOTE** You can also directly integrate with your scheduling tool. For more information, see Configure a Schedule System for Schedule Data Import (on page 83).

What do you want to do?

- Export your schedule from your scheduling software (on page 62)
- Configure your schedule mapping for import (on page 62)
- Import project data in Smart Construction (on page 66)
Export your schedule from your scheduling software

You must export your schedule from your scheduling software as an XML file in order to import it into Smart Construction.

For more information, consult the documentation delivered with your scheduling software.

Configure your schedule mapping for import

You must map properties from your scheduling file to properties in Smart Construction. The following is a detailed work process that explains how to configure your schedule mapping for import into Smart Construction.

★ IMPORTANT You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

1. Open the Primavera Schedule Mappings.xlsx workbook. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

2. Click the Primavera Schedule tab.

3. Edit values for your exported schedule.

NOTES

- If you enter data in the mapping workbook and later decide to remove the data, right-click the cell in Excel and select Clear Contents.
- For more information on how to edit the workbook, see Structure of the workbook (on page 63).
- If a Smart Construction property does not exist for the custom property, you must extend the Smart Construction schema to include the custom property. For more information, see Extend the Smart Construction Schema in the Intergraph Smart Construction Administration and Configuration Guide.

4. Click Save to save your changes in the workbook file.

5. Open the Main tab of the Primavera Schedule Mappings.xlsx workbook.

6. Click the Generate Primavera Schedule Mapping button to generate the Primavera Schedule Mappings.xml file.

7. Check in and sign off the Primavera Schedule Mappings.xlsx workbook and Primavera Schedule Mappings.xml file into the SmartPlant Foundation Desktop Client. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

★ IMPORTANT If you are generating the Primavera schedule mapping data for the first time, attach the Primavera Schedule Mappings.xlsx workbook and XML file to the Primavera Schedule Mapping configuration document in the SmartPlant Foundation Desktop Client. For more information, see Attach the Primavera Schedule Mappings workbook and XML files to the Primavera Schedule Mappings configuration document (on page 66).
**Primavera Schedule Mappings.xlsm details**

Use topics in the following section to learn more about the Primavera Schedule Mappings.xlsm workbook.

**Installation and location of the workbook**

When Smart Construction is installed on a server, the Primavera Schedule Mappings.xlsm workbook is delivered to the **Import Project Data Systems** folder in the **Templates** folder of the installation location (for example, browse to [Drive]:\Program Files (x86)\SmartConstruction\2017\Templates\Import Project Data Systems to find Primavera Schedule Mappings.xlsm).

**Structure of the workbook**

The Primavera Schedule Mappings.xlsm workbook contains two tabs. The **Main** tab generates an XML file and saves it in the location specified when the file is checked out. The **Primavera Schedule** tab contains data and properties that are to be imported into Smart Construction.

**Main tab**

The **Main** tab is located on the first sheet of the workbook. It contains the **Generate Primavera Schedule Mapping** button, which generates the XML file and saves it in the location specified when the file is checked out.

⚠️ **IMPORTANT** The **Generate Primavera Schedule Mapping** button should not be renamed or removed because it contains a macro. The code behind the button should not be modified or removed.

**Primavera Schedule tab**

The **Primavera Schedule** tab contains data and properties that are to be imported into Smart Construction.

⚠️ **IMPORTANT**

- Column names are fixed and cannot be modified.
- Columns can be moved to different locations on the same sheet.
- Do not add new columns. Smart Construction does not read or handle any newly added columns.

💡 **NOTE** For more information on configuring UDFs and mapping arguments, see **Configure a User-Defined Field (UDF) in your Smart Construction mapping** (on page 64) or **Mapping arguments for your Smart Construction project data** (on page 65).

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Identifies a P6 object type, which appears as a node in the exported Primavera PM – (XML) file (limited to WBS currently).</td>
</tr>
</tbody>
</table>
**Configure a User-Defined Field (UDF) in your Smart Construction mapping**

In Primavera P6, User-Defined fields (UDFs) are custom fields, created to track information specific to your project, WBS, or activities. To use these UDFs in your Smart Construction project, you must map the UDF from Primavera to data in Smart Construction.

You can create this mapping in the Primavera schedule mapping workbooks.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute</td>
<td>Identifies a field name for the specified Entity, which appears as a sub node in the exported Primavera PM – (XML) file for the specified Entity type. For example, the WBS contains Code, Name, SequenceNumber, and so on.</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the desired value from the Primavera WBS data.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Identifies a P6 object type, which appears as a node in the exported Primavera PM – (XML) file (limited to WBS currently).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Identifies the UDF to be mapped, using the syntax <code>UDF.[UDF title or name]</code>.</td>
</tr>
<tr>
<td></td>
<td>If the UDF is on an activity, use the syntax <code>ACTIVITY:UDF.[UDF title or name]</code>.</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
</tbody>
</table>
### Column Header Explanation

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the desired value from the Primavera WBS data. If you are mapping a one-to-one relationship between a UDF and a Smart Construction property, the Argument column is left blank.</td>
</tr>
</tbody>
</table>

For example, if you have a UDF named Discipline in your Primavera P6 system, you can map it like the following:

<table>
<thead>
<tr>
<th>Entity</th>
<th>Attribute</th>
<th>SPCInterface</th>
<th>SPCProperty</th>
<th>Argument</th>
</tr>
</thead>
<tbody>
<tr>
<td>WBS</td>
<td>#UDF:Discipline</td>
<td>#SPC_CWP</td>
<td>#CWP_Discipline</td>
<td></td>
</tr>
</tbody>
</table>

#### Mapping arguments for your Smart Construction project data

You can specify arguments for your project data in the Argument column of the Primavera mappings workbooks. You can map arguments in order to call an external mapping function, allowing you to personalize your project data.

The following list defines the default methods provided by the Project Data Mappings service:

- **BuildWBSPath()**—this method builds a WBS path based on the WBS hierarchy from the Primavera project data; the resulting value mirrors the value generated by the former Refresh Schedule command.
- **CalculateEarlyStartDate()**—this method calculates the early start date for WBS items transforming to CWPs.
- **CalculateEarlyFinishDate()**—this method calculates the early finish date for WBS items transforming to CWPs.
- **CalculateLateStartDate()**—this method calculates the late start date for WBS items transforming to CWPs.
- **CalculateLateFinishDate()**—this method calculates the late finish date for WBS items transforming to CWPs.
- **MinDate(Activity:DateField)**—this method calculates the earliest date from all Activities under a WBS item, using the date field specified.
- **MaxDate(Activity:DateField)**—this method calculates the latest date from all Activities under a WBS item, using the date field specified.
- **RollupValue(Activity:P6Field)**—this method calculates a sum from all Activities under a WBS item, using the numeric field specified.
Set Up and Configure Smart Construction Services

**Attach the Primavera Schedule Mappings workbook and XML files to the Primavera Schedule Mappings configuration document**

**IMPORTANT**

- After you generate schedule mapping data for your project for the first time, you must attach the Primavera Schedule Mappings.xlsm workbook and XML file to the Primavera Schedule Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.

- Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the Primavera Schedule Mappings document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the Primavera Schedule Mappings.xlsm workbook and Primavera Schedule Mappings.xml files.
5. Click Open, and then click OK to add the files to the list.
6. Click Finish.

**Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule Mappings.xlsm workbook**

After it is attached to the Primavera Schedule Mappings configuration document, the Primavera Schedule Mappings.xlsm workbook and Primavera Schedule.xml file can be managed in the SmartPlant Foundation Desktop Client. For more information, see Attach the Primavera Schedule Mappings workbook and XML files to the Primavera Schedule Mappings configuration document (on page 66).

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the SmartPlant Foundation Desktop Client User's Guide.

**Import project data in Smart Construction**

1. Log on to Smart Construction as an administrator.
2. Click Administration > Import Project Data.
3. In the Import Project Data window, select a system name in the System Name box.
4. Click Settings 📝.
5. Edit your project settings for the project data system, and then click OK.

**NOTES**
- Use the **Browse**dialog box to navigate to the Microsoft Excel workbook that contains the project data you want to load or the XML file that contains the Primavera schedule you want to load.
- Confirm the schedule settings for your schedule system.

6. Using the table in the **Import Project Data** window, select the objects from the file that you want to load into your Smart Construction database.

**TIPS**
- The grid displays the contents of the input source. If a Microsoft Excel workbook contains multiple sheets, each sheet appears in the window as a separate tab of the table.
- For each item found in the input source, the **Action** column indicates which process is needed to synchronize the data file with the database.
- Use the options in the **Quick Selection** pane for fast navigation and selection of your data.

7. Select the check boxes by the items to be added to the database, modified in the database, or removed from the database.

**NOTE** Select the check box in the **Name** column to apply all changes to the object. You can select individual check boxes for an object to apply specific changes to that object.

8. Click **Process**.

**NOTES**
- This process creates a new SmartPlant Foundation design document and attaches an XML file that includes the content of the selected data file. The document name is [System Name]_[Service Name]. This document cannot be checked out. It is managed by Smart Construction and exists in the CURRENT state.
- If your import project data file is large in size, you can configure IIS to process large file sizes. For more information, see **Configure IIS to process large files** (on page 82).
- For more information on the **Import project data** window, see **Learn more about the Import Project Data window** in the Intergraph Smart Construction User's Guide.
- If you remove a CWP from your project data but the CWP is associated with an IWP, the CWP cannot be deleted.
Set Up and Configure Smart Construction Services

Import project configuration data into Smart Construction

Smart Construction allows you to create, import, and edit project data. You can create and configure contracts, contractors, and CWPs, and you can import construction resources. Smart Construction delivers a Microsoft Excel workbook template administrators can use to create and edit project data for a Smart Construction site to fit the specific needs of an organization. You can import the data from the Microsoft Excel workbook into Smart Construction.

When importing project data into Smart Construction, objects for the data are created in SmartPlant Foundation. If you are importing contract, contractor, CWP data, or construction resources into Smart Construction, contract, contractor, CWP, and construction resource objects are created in SmartPlant Foundation.

You can configure and map project configuration objects, such as contractors and contract numbers, CWPs, drawings, commissioning systems, and planning groups. You can also use the workbook to create a construction resource hierarchy.

Configure project configuration mappings and relationships

Before configuring your project data, you can define and map how project configuration objects and relationships will be configured for your project. For more information on the delivered project configuration relationships and data, see Delivered project configuration objects and relationships (on page 70).

For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

★ IMPORTANT You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

1. Open the Project Configuration Mappings.xlsm workbook. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).
2. Edit values for your project configuration mapping data.

ENotes

- To map a new property, type the property definition in the SPCProperty column and the interface definition name in the SPCInterface column. Type the project configuration workbook tab name in the Entity column to which the property is to map. Type a tab heading name in the Attribute column. For example, to map a drawing's commissioning system property to the Drawing tab of the project configuration workbook, you would type the following -

<table>
<thead>
<tr>
<th>Entity</th>
<th>Attribute</th>
<th>SPCInterface</th>
<th>SPCProperty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawings</td>
<td>CommissioningSystem</td>
<td>ISPC_2DDrawing</td>
<td>SPC_2DDrawing_CommissioningSystem</td>
</tr>
</tbody>
</table>

- To configure a relationship between two objects, type a tab name in the Entity column, type an object name in the Attribute column, and type Rel in the Argument column. By default, you can only configure relationships that are delivered with Smart Construction.

3. Click Save to save your changes in the workbook file.
4. Open the Main tab.
5. Click **Generate Project Configuration Mapping** to generate the Project Configuration Mappings.xml file.

6. Check in and sign off the Project Configuration Mappings.xlsm workbook and XML file into the SmartPlant Foundation Desktop Client. For more information on managing configuration files for Smart Construction, see **Manage Template Files for Smart Construction** (on page 134).

**IMPORTANT** If mapping the project configuration data for the first time, attach the Project Configuration Mappings.xlsm workbook and XML file to the **Project Configuration Mappings** configuration document in the SmartPlant Foundation Desktop Client. For more information, see **Attach the Project Configuration Mappings.xlsm workbook and Project Configuration Mappings.xml file to the Project Configuration Mappings configuration document** (on page 71).

**Project Configuration Mappings.xlsm details**

Use topics in the following section to learn more about the Project Configuration Mappings.xlsm workbook.

**Installation and location of the workbook**

When Smart Construction is installed on a server, the Project Configuration Mappings.xlsm is delivered to the **Templates** folder of the installation location (for example, browse to [Drive]\Program Files (x86)\SmartConstruction\2017\Templates\Import Project Data Systems to find Project Configuration Mappings.xlsm).

**Structure of the workbook**

The Project Configuration Mappings.xlsm workbook contains two tabs, **Main** and **Project Configuration**.

**Main tab**

The **Main** tab is located on the first sheet of the workbook. It contains the **Generate Mapping** button, which generates the XML file and saves it in the current Project Configuration Mappings.xlsm file location when you check out the document.

**IMPORTANT** Do not rename or remove the **Generate Configuration File** button. Do not modify or remove the code behind the button.

**Project Configuration tab**

The following table lists the columns and their purpose for the **Project Configuration** tab of the Project Configuration Mappings.xlsm workbook.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Maps data to the tab name in the project configuration workbook.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Maps data to the column heading in the project configuration workbook.</td>
</tr>
<tr>
<td>Column Name</td>
<td>Purpose</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
<tr>
<td>Argument</td>
<td>Identifies a method and argument list to generate the desired value. You can specify rel to create a relationship between an entity and an attribute.</td>
</tr>
</tbody>
</table>

**Delivered project configuration objects and relationships**

If you use the delivered project configuration workbook and the Project Configuration Mappings.xlsx, the following objects can be created in SmartPlant Foundation Desktop Client and made available in Smart Construction.

- Contractors
- Contracts
- CWPs
- Construction Resources

Using the delivered Project Configuration Mappings.xlsx, the following relationships can be created between project configuration objects.
Set Up and Configure Smart Construction Services

Attach the Project Configuration Mappings.xlsxm workbook and Project Configuration Mappings.xml file to the Project Configuration Mappings configuration document

**IMPORTANT** Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the Project Configuration Mappings document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the Project Configuration Mappings.xlsxm workbook and XML file.
5. Click Open, and then click OK to add the files to the list.
6. Click Finish.

Use the SmartPlant Foundation Desktop Client to manage the Project Configuration mapping files

After it is attached to the Project Configuration Mappings configuration document, the Project Configuration Mappings.xlsxm workbook and XML file can be managed in the SmartPlant Foundation Desktop Client. For more information, see Attach the Project Configuration Mappings.xlsxm workbook and Project Configuration Mappings.xml file to the Project Configuration Mappings configuration document (on page 71).

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the SmartPlant Foundation Desktop Client User's Guide.

Configure and import project configuration data

The following is a detailed work process that explains how to configure your project configuration for import into Smart Construction. Project configuration is managed using a configuration template that is imported into Smart Construction. See Configure project configuration mappings and relationships (on page 68) for information on how to configure and map project configuration data.

For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

**IMPORTANT** Smart Construction delivers example project configuration data. Intergraph recommends that you copy the Project Configuration Sample.xlsx workbook and create a unique project configuration workbook specific to your business needs.

**NOTE** When you configure and import project configuration objects into Smart Construction, the objects are also created in SmartPlant Foundation Desktop Client. For more information, see Manage project configuration in SmartPlant Foundation (on page 76).
Configure project configuration data

1. Open the project configuration workbook. For more information on managing configuration files for Smart Construction, see *Manage Template Files for Smart Construction* (on page 134).

2. Edit values for your project configuration data. For more information on the structure of the workbook, see *Structure of the workbook* (on page 73).

   NOTE Drawings must be retrieved in your Smart Construction project in order to create project configuration objects and relationships for them.

3. Click **Save** to save your changes in the workbook file.

Import project configuration data

1. Log on to Smart Construction as an administrator.

2. Click **Administration > Import Project Data**.

3. In the **Import Project Data** window, select a system name in the **System Name** box.

4. Click **Settings**.

5. Edit your project settings for the project data system, and then click **OK**.

   NOTES
   - Use the **Browse** dialog box to navigate to the Microsoft Excel workbook that contains the project data you want to load or the XML file that contains the Primavera schedule you want to load.
   - Confirm the schedule settings for your schedule system.

6. Using the table in the **Import Project Data** window, select the objects from the file that you want to load into your Smart Construction database.

   TIPS
   - The grid displays the contents of the input source. If a Microsoft Excel workbook contains multiple sheets, each sheet appears in the window as a separate tab of the table.
   - For each item found in the input source, the **Action** column indicates which process is needed to synchronize the data file with the database.
   - Use the options in the **Quick Selection** pane for fast navigation and selection of your data.

7. Select the check boxes by the items to be added to the database, modified in the database, or removed from the database.

   NOTE Select the check box in the **Name** column to apply all changes to the object. You can select individual check boxes for an object to apply specific changes to that object.

8. Click **Process**.

   NOTES
   - This process creates a new SmartPlant Foundation design document and attaches an XML file that includes the content of the selected data file. The document name is [System Name]_[Service Name]. This document cannot be checked out. It is managed by Smart Construction and exists in the CURRENT state.
If your import project data file is large in size, you can configure IIS to process large file sizes. For more information, see *Configure IIS to process large files* (on page 82).

For more information on the **Import project data** window, see *Learn more about the Import Project Data window* in the *Intergraph Smart Construction User's Guide*.

The **Resources** tab in the Smart Construction **Import Project Data** dialog box is read-only. When you process the construction resource data in the **Import Project Data** dialog box, Smart Construction syncs the construction resources in the project configuration workbook and your system.

---

**Project configuration workbook details**

Use topics in the following section to learn more about the project configuration workbook.

**Installation and location of the workbook**

When Smart Construction is installed on a server, the Project Configuration Sample.xlsx is delivered to the **Templates** folder of the installation location (for example, browse to `{Drive}\Program Files (x86)\SmartConstruction\2017\Templates\Import Project Data Systems to find Project Configuration Sample.xlsx`).

Smart Construction delivers example project configuration data. Intergraph recommends that you copy the Project Configuration Sample.xlsx workbook and create a unique project configuration workbook specific to your business needs.

**Structure of the workbook**

The workbook contains five tabs, **Contractors**, **Contracts**, **CWPs**, **Drawings**, and **Resources**. Each tab defines different project data and relationships.

**Contractors tab**

The following table lists the columns and their purpose for the **Contractors** tab of the project configuration workbook.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contractor</td>
<td>Contractor name.</td>
</tr>
<tr>
<td>ContractorDescription</td>
<td>Description of the contractor.</td>
</tr>
<tr>
<td>PlanningGroup</td>
<td>Name of the planning group object from SmartPlant Foundation. For more information on planning groups, see <em>Create and configure planning groups</em> in the <em>Smart Construction Administration and Configuration Guide</em>.</td>
</tr>
<tr>
<td>Contract</td>
<td>Contract name or number.</td>
</tr>
</tbody>
</table>

**Contracts tab**

The following table lists the columns and their purpose for the **Contracts** tab of the project configuration workbook.
## Set Up and Configure Smart Construction Services

### Contract Details
- **Contract**: Contract name or number, as listed in the Contractors tab.
- **ContractDescription**: Description of the contract.

### CWPs tab
The following table lists the columns and their purpose for the **CWPs** tab of the project configuration workbook.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>CWP</td>
<td>CWP name or number.</td>
</tr>
<tr>
<td>CWPDescription</td>
<td>Description of the CWP.</td>
</tr>
<tr>
<td>CWPEWP</td>
<td>EWP of the CWP.</td>
</tr>
<tr>
<td>CWPArea</td>
<td>Design area for the CWP.</td>
</tr>
<tr>
<td>CWPDiscipline</td>
<td>Discipline for the CWP. Disciplines listed in this column must be spelled the same as those in the Construction discipline enumerated list. For more information, see Configure Work Package Disciplines and Purposes in the Smart Construction Administration and Configuration Guide.</td>
</tr>
<tr>
<td>WBSPath</td>
<td>Work breakdown structure for the CWP.</td>
</tr>
<tr>
<td></td>
<td>The WBSPath value is required if you plan to export your schedule data from Smart Construction and import it into Primavera P6.</td>
</tr>
<tr>
<td>PlannedStart</td>
<td>The planned start date for the CWP. If you are using Primavera P6, the value matches the start_date value.</td>
</tr>
<tr>
<td>PlannedFinish</td>
<td>The planned finish date for the CWP. If you are using Primavera P6, the value matches the end_date value.</td>
</tr>
<tr>
<td>ActualStart</td>
<td>The actual start date of the CWP. If you are using Primavera P6, the value matches the act_start_date value.</td>
</tr>
</tbody>
</table>
Set Up and Configure Smart Construction Services

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActualFinish</td>
<td>The actual finish date of the CWP.</td>
</tr>
<tr>
<td></td>
<td>If you are using Primavera P6, the value matches the act_end_date value.</td>
</tr>
<tr>
<td>EarlyStart</td>
<td>The earliest start date of the CWP.</td>
</tr>
<tr>
<td>EarlyFinish</td>
<td>The earliest finish date of the CWP.</td>
</tr>
<tr>
<td>LateStart</td>
<td>The latest start date of the CWP.</td>
</tr>
<tr>
<td>LateFinish</td>
<td>The latest finish date of the CWP.</td>
</tr>
<tr>
<td>BudgetedLabor</td>
<td>Amount of labor budgeted for the CWP in hours.</td>
</tr>
<tr>
<td></td>
<td>If you are using Primavera P6, the value matches the best_work_qty value.</td>
</tr>
</tbody>
</table>

**Drawings tab**

The following table lists the columns and their purpose for the Drawings tab of the project configuration workbook.

⚠️ **NOTE** Drawings must be retrieved in your Smart Construction project in order to create project configuration objects and relationships for them.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing</td>
<td>The drawing name must be spelled correctly and must match the name of</td>
</tr>
<tr>
<td></td>
<td>the drawing retrieved into Smart Construction. For more information,</td>
</tr>
<tr>
<td></td>
<td>see Getting Data into Smart Construction in the Smart Construction</td>
</tr>
<tr>
<td></td>
<td>Administration and Configuration Guide.</td>
</tr>
<tr>
<td>CWP</td>
<td>CWP name or number, as listed in the CWP tab.</td>
</tr>
<tr>
<td>CommissioningSystem</td>
<td>Relates a commissioning system to a drawing as a property.</td>
</tr>
</tbody>
</table>

**Resources tab**

You can define the construction resource hierarchy in the Resources tab of the project configuration workbook. The Resources tab in the Smart Construction Import Project Data dialog box is read-only. When you process the construction resource data in the Import Project Data dialog box, Smart Construction syncs the construction resources in the project configuration workbook and your system. You can define a new level of a hierarchy in each column and details about a construction resource in each row. The column number defines the hierarchy level of the construction resource. All resources belong to the Level 1 resource or
Set Up and Configure Smart Construction Services

top-level category above it, and a new resource structure is created when a new top-level category is created.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1</td>
<td>Defines Level 1 or top-level category of a construction resource hierarchy. Resources included under a top-level category resource are considered part of the hierarchy of the category, until a new category is defined.</td>
</tr>
<tr>
<td>Column [Number]</td>
<td>The column number defines the hierarchy level of a construction resource. A top-level category of a resource is defined in the column above and to the left of the resource in the list. And, other members of the hierarchy are defined in the columns below and to the right of it in the list.</td>
</tr>
</tbody>
</table>

Manage project configuration in SmartPlant Foundation

In addition to the project configuration import operation in Smart Construction, administrators can use SmartPlant Foundation to manage the ProjectConfiguration.xls workbook, as well as the project configuration objects and relationships.

Manually create project configuration objects in SmartPlant Foundation

If given the appropriate security privileges, an administrator can manually create project configuration objects, such as CWPs, contracts, contractors, and crews, in SmartPlant Foundation.

1. Log on the SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > New or Smart Construction > New > Administration and select a category of object to create.
3. Type a name and other details in the New dialog box.
4. Click Apply or Finish to create the object.

After you create an object, you can configure relationships for that object. For more information, see Configure relationships for project configuration objects (on page 77).

For more information on creating objects in the SmartPlant Foundation Desktop Client, see Create and Modify Objects in the SmartPlant Foundation Desktop Client User’s Guide.
Find project configuration objects in SmartPlant Foundation

1. Log on the SmartPlant Foundation Desktop Client as an administrator.

2. Click Smart Construction > Find or Smart Construction > Find > Administration and select a category of object to query.

3. Type the name of the object for which you want to search.
   
   TIP You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.

4. Click OK.

For more information on searching for objects in the SmartPlant Foundation Desktop Client, see Search for Objects in the SmartPlant Foundation Desktop User's Guide.

Configure relationships for project configuration objects

You can configure relationships among project configuration objects at any time for your project using the SmartPlant Foundation Desktop Client.

For example, if you manually create project configuration objects in the SmartPlant Foundation Desktop Client or you import CWPs from an external system such as Primavera P6, you can create relationships for those objects in the SmartPlant Foundation Desktop Client.

See the following topics to learn how to view, create, and terminate relationships.

View relationships for an object

1. Log on the SmartPlant Foundation Desktop Client as an administrator.

2. Find the objects for which you want to view relationships.
   
   a. Click Smart Construction > Find and select a category of object to query.

   b. Type the name of the object for which you want to search.

   c. Click OK.

3. Right-click an object in the search results and select Show All Relationships to view the object's relationships.

For more information, see View relationships in the SmartPlant Foundation Desktop Client User's Guide.

Create relationships among objects

You can create relationships among project configuration objects at any time.

1. Log on SmartPlant Foundation Desktop Client as an administrator.

2. Find the objects for which you want to create a relationship.
   
   a. Click Smart Construction > Find and select a category of object to query.

   b. Type the name of the object for which you want to search.

   c. Click OK.

3. Drag one object on to another to create a relationship.
For more information about manually creating relationships in SmartPlant Foundation, see Drag objects to create relationships in the SmartPlant Foundation Desktop Client User’s Guide.

**Cancel or terminate relationships among objects**

Canceling or terminating relationships among project configuration objects can be helpful to manage changes in the construction project.

1. Log on the SmartPlant Foundation Desktop Client as an administrator.
2. Find the objects for which you would like to cancel or terminate a relationship.
   a. Click Smart Construction > Find and select a category of object to query.
   b. Type the name of the object for which you want to search.
   c. Click OK.
3. Right-click an object in the search results and select Terminate Relationships to cancel relationships for the object.

For more information, see Terminate relationships in the SmartPlant Foundation Desktop Client User’s Guide.

**Update a Commissioning System property on a drawing**

You can update the commissioning system property to fit your business needs. The commissioning system property must be added to a drawing using the ProjectConfiguration.xls workbook.

1. Log on the SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > 2D Drawings.
3. Type the name of the object for which you want to search.
   - TIP You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. Click OK.
5. Right-click the drawing you want to update and select Update to open the Update dialog box.
6. Edit the Commissioning System box.
7. Click Finish to save your changes.

**View construction resources and constraints**

You can view Smart Construction resources and constraints in the SmartPlant Foundation Desktop Client.
Set Up and Configure Smart Construction Services

**Search for construction resources**
1. Log on to the SmartPlant Foundation Desktop Client as an administrator.
2. Click **Smart Construction > Find > Construction Resources**.
3. Type the name of the item in the **Find** dialog box. Click **OK**.
   📌 **TIP** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.

**View construction resource details**
1. Log on to the SmartPlant Foundation Desktop Client as an administrator.
2. Click **Smart Construction > Find > Construction Resources**.
3. Type the name of the item in the **Find** dialog box. Click **OK**.
   📌 **TIP** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. Select the construction resource from the search results.
5. Right-click the construction resource and select **Details** to open the **Details** window.

**View relationships among construction resource objects**
1. Log on to the SmartPlant Foundation Desktop Client as an administrator.
2. Find the objects for which you want to create a relationship.
   a. Click **Smart Construction > Find** and select a category of object to query.
   b. Type the name of the object for which you want to search.
   c. Click **OK**.
3. Right-click an object in the search results.
4. Select **Show All Relationships** to view all relationships for the object.
5. Select **Show Tree Node Child** to view if the object has any members below it in the resource structure.
6. Select **Show Tree Node Parent** to view the object's category.
7. Select **Show Work Package Constraint** to view if the resource was added to an IWP as a constraint.
Manage template files for Smart Construction

Smart Construction has many features that can be personalized and configured to fit your business and project needs using Microsoft Excel workbook template files.

Smart Construction features that use a template

The following Smart Construction features use template files:

- Rules of progress
- Importing your schedule in the **Import project data** window
- Importing your Primavera P6 schedule in the **Import project data** window
- Mapping project configuration data for the **Import project data** window
- Mapping retrieve properties
- Materials mapping

Template delivery location

The template files are delivered to the **Templates** folder in the Smart Construction installation directory (browse to \[Drive]\:\Program Files (x86)\SmartConstruction\2017\Templates).

How the templates work

Each template is a Microsoft Excel file that contains a macro. You configure your data as needed in the template workbook and save it. Then, you click the **Generate** button on the **Main** tab of the template. The **Generate** button starts the macro, generating an XML file. Smart Construction uses the generated XML file to configure data in your project.

Getting the newly configured data into Smart Construction varies per service and feature. For example, Smart Construction automatically pulls the mapping for project configuration and schedule data for the **Import project data** window. You must start a retrieve or refresh work steps in order to pull in the latest Rules of Progress data. And, you must start a retrieve to get the latest retrieve mappings.

How to manage the files

Intergraph recommends that you use the document management feature in the SmartPlant Foundation Desktop Client to manage these template files. The SmartPlant Foundation Desktop Client stores the configuration document, allowing users with the proper permissions to check the document out and in with revisions.

Each template (and XML file) has a corresponding configuration document in the SmartPlant Foundation Desktop Client (You can find these configuration documents by clicking **Smart Construction > Find > Administration > Configuration Documents**).

After you make changes to your template and generate the XML file, Intergraph recommends that you attach the Microsoft Excel file and the XML file to its configuration document in the SmartPlant Foundation Desktop Client. For more information, see **Attach template files to configuration documents** (on page 81).
Open a Smart Construction template file

Smart Construction template files are delivered in the Templates folder in the installation location. Intergraph recommends that you manage the files in the SmartPlant Foundation Desktop Client where you can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the SmartPlant Foundation Desktop Client User's Guide.

**IMPORTANT** You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

Opening the file for the first time

1. Browse to the Templates folder in the installation location. For example, browse to [Drive]:\Program Files (x86)\SmartConstruction\2017\Templates.
2. Open the folder for the template you want to view.

Opening the template file from SmartPlant Foundation Desktop Client

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
3. Type your search criteria and click Finish to find the configuration documents.
4. In the search results, right-click the configuration document that contains the template and select Edit > Check out.
5. Select a location for the file and click OK. For more information, see Check in and check out a document in the SmartPlant Foundation Desktop Client User's Guide.

Enable the macro content for the workbook

2. Select Enable this content on the Microsoft Office Security Options and click OK.

Attach template files to configuration documents

After you configure data in a template file for the first time, you must attach all necessary files (in some cases an Excel workbook and an XML file) to the appropriate configuration document in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the configuration document, allowing users with the proper permissions to check the document out and in with revisions.

**IMPORTANT** Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the configuration document and select **Files > Attach File** to open the **Attach File** dialog box.

4. Click **Add File** and browse to the necessary files.

5. Click **Open** and then click **OK** to add the files to the list.

6. Click **Finish**.

**Check in and sign off a Smart Construction template file**

After making your edits, save the template and generate any XML files, as required. You can then close, check in, and sign off the template file in SmartPlant Foundation Desktop Client.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.

2. Click **Smart Construction > Find > Administration > Configuration Documents** to open the **Query for Configuration Documents** dialog box.

3. Type your search criteria and click **Finish** to find the configuration documents.

4. In the search results, right-click a configuration document, and click **Edit > Check In**. Select the document and click **OK**.

5. Sign off the document in the SmartPlant Foundation Desktop Client. For more information, see **Sign off on a document** in the **SmartPlant Foundation Desktop Client User's Guide**.

**Configure IIS to process large files**

You can configure the **Maximum allowed content length (Bytes)** option in the IIS Manager to process large file sizes. This setting is helpful when your project data file is large.

1. Open **IIS Manager**.

2. Navigate to and select your Smart Construction site under the **Default Web Site** node.

3. Right-click **Request Filtering** under the **IIS** section and select **Open Feature**.

4. Right-click the **Hidden Segments** tab in the **Request Filtering** window and select **Edit Feature Settings**.

5. Change the value for the **Maximum allowed content length (Bytes)** box to the desired value.

6. Click **OK**.

**IMPORTANT** You must recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

**TIP** Consider adding 5 MB to your current input file size (input file size + 5 MB) as the value for the **Maximum allowed content length (Bytes)** box.
Configure a schedule system for schedule data import

Smart Construction can be configured to integrate directly with a schedule system through an open API. Once configured for integration, Smart Construction uses the schedule system to load Construction Work Packages (CWPs) into a project in the Import Project Data window.

You can use either one of the following as the source for your schedule system in Smart Construction:

- Primavera P6 Software Development Kit (SDK)
- Primavera P6 Web Services

To use either of these sources with Smart Construction, you must perform a set of configuration procedures before you can import schedule data into Smart Construction.

**NOTE** If using Primavera Web Services as the source for your schedule system, SSL and message encryption are not supported for communication with Smart Construction.

Configuring a schedule system with Primavera P6 SDK

Use the following steps to configure a schedule system that uses Primavera P6 Software Development Kit (SDK) as the schedule source.

What do you want to do?

- Set up the schedule system source (on page 84)
Set up and Configure Smart Construction Services

- Configure the Primavera SDK schedule system (on page 85)
- Verify the schedule system is working (on page 86)
- Configure schedule mapping for import (on page 86)
- Import schedule data into Smart Construction (on page 91)

---

Set up the schedule system source

The schedule system must be set up and configured before you begin to configure Smart Construction to use it as a source.

To use the Primavera P6 SDK, you must install the SDK on the Smart Construction server and change a web server application pool identity for your Smart Construction site in IIS.

Install Primavera P6 Software Development Kit (SDK) on the Smart Construction server

If you are using the Primavera P6 Software Development Kit (SDK) as a source for your schedule system, you must install the SDK on the Smart Construction server. The Primavera P6 SDK setup maps the ODBC Data Source name with the associated database name. Smart Construction is compatible with the Primavera P6 version 8.3 SDK.

![IMPORTANT](image)

- The Primavera P6 user must have the **View All Global Project Data via SDK** security setting selected in Primavera P6 if using the SDK as a data source.
- If you are using Primavera P6 Web Services as your scheduling system source, you do not need to install the SDK.

For detailed information about installing the Primavera P6 SDK, refer to your Primavera P6 documentation.

**NOTE** Primavera support for its SDK is limited. While the majority of implementations using the SDK are successful, issues might be encountered that Primavera does not support. It might be necessary to use an alternative data source as the integration method between Primavera and Smart Construction. For example, you can import your exported Primavera schedule (as an XML file) into Smart Construction.
Change the PrimaveraWCFServicePool user

If you are setting up the Primavera P6 SDK for versions 8.2 or 8.3 of the software, you must change user account that is configured as the identity of the PrimaveraWCFServicePool application pool. By default, the PrimaveraWCFServicePool application pool identity is configured as the local system account. You must change the identity to a user account that can access a local copy of the PrmBootStrap.xml file. Typically, the user who installs the Primavera P6 SDK on the Smart Construction server will find the PrmBootStrap.xml file delivered to the location [Drive]\Users\[User name]\AppData\Local\Oracle\Primavera P6\P6 Professional.

1. Open the Internet Information Services (IIS) Manager.
2. Browse to the Application Pools node.
3. Right-click the PrimaveraWCFServicePool application pool and select Advanced Settings to open the Advanced Settings dialog box.
4. Under Process Model, select the Identity property and specify the user account.
5. Click OK and close the Internet Information Services (IIS) Manager.

★ IMPORTANT After you change the PrimaveraWCFServicePool user, recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

Configure the Primavera SDK schedule system

To use the Primavera P6 Software Development Kit (SDK) as a schedule source, you must configure the connection information for that source using the SmartPlant Foundation Desktop Client.

For information on using the Primavera P6 SDK as your schedule source, see Install Primavera P6 Software Development Kit (SDK) on the Smart Construction server (on page 84).

★ IMPORTANT

- Your active scope must be set before configuring a schedule system in Smart Construction. For more information, see Set your active scope in SmartPlant Foundation Desktop Client (on page 32).
- The Primavera P6 user must have the View All Global Project Data via SDK security setting selected in Primavera P6 if using the SDK as a data source.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > New > Administration > Schedule System to open the New Schedule System form.

★ NOTE If the Schedule System object has already been created, click Smart Construction > Find > Administration > Schedule System to search for the schedule system object, and in the search results list, right-click the name of the schedule system and click Update.

3. Define the details for the Primavera SDK in the Primavera SDK Settings details section.

★ NOTES

- An ENS definition automatically names the schedule system with the name of the Smart Construction plant name in SmartPlant Foundation.
Set Up and Configure Smart Construction Services

- The **DSN** must match the system DSN in the ODBC for the Primavera P6 SDK.
- The **System login** and **System password** must match the login name and password for Primavera P6.
- If you are using Primavera P6 v7.0, type 0 in the **Schedule System Access Level** box.
- If you are using Primavera P6 v8.2 or 8.3, type -1 in the **Schedule System Access Level** box.
- Smart Construction hides your password in SmartPlant Foundation Desktop Client.

4. Click **Apply** or **Finish** to create or update the schedule system.

**Verify the schedule system is working**

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **Smart Construction > Find > Administration > Schedule System** to open the **Find Schedule System** dialog box.
3. Type a name of a schedule system in the **Find Schedule System** dialog box. Click **OK**.
   - **TIP** You can use wildcards to narrow search results. ? and _ find any single character. * and % find any string of characters.
4. In the search results list, right-click the name of the schedule system and click **Test SDK Service**.
5. After reviewing either the success or failure message, click **OK**.

**NOTE** The test attempts to connect to Primavera P6 using the connection information provided for the schedule system. If you receive an error message, you should review the connection information on the schedule system object. See **Configure the Primavera SDK schedule system** (on page 85) for more information.

**Configure schedule mapping for import**

You must map properties from your scheduling file to properties in Smart Construction. The following detailed work process explains how to configure your schedule mapping for import into Smart Construction.

**IMPORTANT** You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see **Configure a vault for files attached to configuration documents** (on page 46).

1. Open the Primavera Schedule SDK Mappings.xlsm workbook. For more information on managing configuration files for Smart Construction, see **Manage Template Files for Smart Construction** (on page 134).
2. Click the **Primavera Schedule SDK** tab.
3. Edit values for your schedule.

**NOTES**

- The Primavera P6 SDK documentation (p6_pro_sdk.chm) provides helpful information about which values to map to for the project-level and task-level WBS entries. The project-level entries can map to the PROJWBS table in the help file, and task-level entries can map to the TASK table in the help file.
The field name in Primavera P6 maps to properties in Smart Construction.

If you enter data in the mapping workbook and later decide to remove the data, right-click the cell in Excel and select **Clear Contents**.

For more information on how to edit the workbook, click **Structure of the workbook** (on page 87).

If a Smart Construction property does not exist for the custom property, you must extend the Smart Construction schema to include the custom property. For more information, see **Extend the Smart Construction Schema** in the *Intergraph Smart Construction Administration and Configuration Guide*.

4. Click **Save** to save your changes in the workbook file.

5. Open the **Main** tab of the Primavera Schedule SDK Mappings.xlsx workbook.

6. Click **Generate Primavera Schedule SDK Mapping** to generate the Primavera Schedule SDK Mappings.xml file.

7. Check in and sign off the Primavera Schedule SDK Mappings.xlsx workbook and Primavera Schedule SDK Mappings.xml file into the SmartPlant Foundation Desktop Client. For more information on managing configuration files for Smart Construction, see **Manage Template Files for Smart Construction** (on page 134).

**IMPORTANT** If you are generating the Primavera schedule mapping data for the first time, attach the Primavera Schedule SDK Mappings.xlsx workbook and XML file to the Primavera Schedule SDK Mappings configuration document in the SmartPlant Foundation Desktop Client. For more information, see **Attach the mappings workbook and XML files to the Primavera Schedule SDK Mappings configuration document** (on page 90).

### Primavera Schedule SDK Mappings.xlsx details

Use topics in the following section to learn more about the Primavera Schedule SDK Mappings.xlsx workbook.

#### Installation and location of the workbook

When Smart Construction is installed on a server, the Primavera Schedule SDK Mappings.xlsx is delivered to the **Import Project Data Systems** folder in the **Templates** folder of the installation location (for example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\Templates\Import Project Data Systems to find Primavera Schedule SDK Mappings.xlsx`).

#### Structure of the workbook

The Primavera Schedule SDK Mappings.xlsx workbook contains two tabs. The **Main** tab generates an XML file and saves it in the location specified when the file is checked out. The **Primavera Schedule SDK** tab contains data and properties that are to be imported into Smart Construction.

#### Main tab

The **Main** tab is located on the first sheet of the workbook. It contains the **Generate Primavera Schedule SDK Mapping** button, which generates the XML file and saves it in the location specified when the file is checked out.
**IMPORTANT** The Generate Primavera Schedule SDK Mapping button should not be renamed or removed because it contains a macro. The code behind the button should not be modified or removed.

**Primavera Schedule SDK tab**

The Primavera Schedule SDK tab contains data and properties that are to be imported into Smart Construction.

**IMPORTANT**
- Column names are fixed and cannot be modified.
- Columns can be moved to different locations on the same sheet.
- Do not add new columns. Smart Construction does not read or handle any newly added columns.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Identifies the table name. For example, the PROJWBS table in Primavera P6 (limited to WBS currently).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Identifies the Column name in the Project WBS. An attribute can also be a UDF.</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the requested value from the Primavera WBS data.</td>
</tr>
</tbody>
</table>

**NOTES**
- The Primavera P6 SDK documentation (p6_pro_sdk.chm) provides helpful information about which values to map to for the project-level and task-level WBS entries. The project-level entries can map to the PROJWBS table in the help file, and task-level entries can map to the TASK table in the help file.
- The field name in Primavera P6 maps to properties in Smart Construction.
- For more information on configuring UDFs and mapping arguments, see *Configure a User-Defined Field (UDF) in your Smart Construction mapping* (on page 64) or *Mapping arguments for your Smart Construction project data* (on page 65).
Configure a User-Defined Field (UDF) in your Smart Construction mapping

In Primavera P6, User-Defined fields (UDFs) are custom fields, created to track information specific to your project, WBS, or activities. To use these UDFs in your Smart Construction project, you must map the UDF from Primavera to data in Smart Construction.

You can create this mapping in the Primavera schedule mapping workbooks.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Identifies a P6 object type, which appears as a node in the exported Primavera PM – (XML) file (limited to WBS currently).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Identifies the UDF to be mapped, using the syntax UDF.[UDF title or name]. If the UDF is on an activity, use the syntax ACTIVITY:UDF.[UDF title or name].</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the desired value from the Primavera WBS data. If you are mapping a one-to-one relationship between a UDF and a Smart Construction property, the Argument column is left blank.</td>
</tr>
</tbody>
</table>

For example, if you have a UDF named Discipline in your Primavera P6 system, you can map it like the following:

<table>
<thead>
<tr>
<th>Entity</th>
<th>Attribute</th>
<th>SPCInterface</th>
<th>SPCProperty</th>
<th>Argument</th>
</tr>
</thead>
<tbody>
<tr>
<td>WBS</td>
<td>UDF:Discipline</td>
<td>ISPC_CWP</td>
<td>CWP_Discipline</td>
<td></td>
</tr>
</tbody>
</table>

Mapping arguments for your Smart Construction project data

You can specify arguments for your project data in the Argument column of the Primavera mappings workbooks. You can map arguments in order to call an external mapping function, allowing you to personalize your project data.

The following list defines the default methods provided by the Project Data Mappings service:

- BuildWBSPath()—this method builds a WBS path based on the WBS hierarchy from the Primavera project data; the resulting value mirrors the value generated by the former Refresh Schedule command.
- CalculateEarlyStartDate()—this method calculates the early start date for WBS items transforming to CWPs.
Set Up and Configure Smart Construction Services

- CalculateEarlyFinishDate()—this method calculates the early finish date for WBS items transforming to CWPs.
- CalculateLateStartDate()—this method calculates the late start date for WBS items transforming to CWPs.
- CalculateLateFinishDate()—this method calculates the late finish date for WBS items transforming to CWPs.
- MinDate(Activity:DateField)—this method calculates the earliest date from all Activities under a WBS item, using the date field specified.
- MaxDate(Activity:DateField)—this method calculates the latest date from all Activities under a WBS item, using the date field specified.
- RollupValue(Activity:P6Field)—this method calculates a sum from all Activities under a WBS item, using the numeric field specified.

Attach the mappings workbook and XML files to the Primavera Schedule SDK Mappings configuration document

★ IMPORTANT

- After you generate schedule mapping data for your project for the first time, you must attach the Primavera Schedule SDK Mappings.xlsx workbook and XML file to the Primavera Schedule SDK Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.
- Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the Primavera Schedule SDK Mappings document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the Primavera Schedule SDK Mappings.xlsx workbook and Primavera Schedule SDK Mappings.xml files.
5. Click Open, and then click OK to add the files to the list.
6. Click Finish.
Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule SDK Mappings.xlsm workbook

After it is attached to the Primavera Schedule SDK Mappings configuration document, the Primavera Schedule SDK Mappings.xlsm workbook and Primavera Schedule SDK Mappings.xml file can be managed in the SmartPlant Foundation Desktop Client. For more information, see Attach the mappings workbook and XML files to the Primavera Schedule SDK Mappings configuration document (on page 90).

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the SmartPlant Foundation Desktop Client User's Guide.

Import schedule data into Smart Construction

★ IMPORTANT In order to see a project data system in the Import Project Data window in Smart Construction, the access group SPC_ScheduleUpdate (or the access group assigned to the user who is allowed to use this feature) must be associated with the project data system object. For new sites created with version 2017 and later, in order to see the Primavera SDK and Primavera Web Services data sources, you need to associate them with the appropriate access group. For more information on access groups, see Configure access groups (on page 41).

1. Log on to Smart Construction as an administrator.
2. Click Administration > Import Project Data.
3. In the Import Project Data window, select a system name in the System Name box.
4. Click Settings.
5. Edit your project settings for the project data system, and then click OK.

NOTES

- Use the Browse dialog box to navigate to the Microsoft Excel workbook that contains the project data you want to load or the XML file that contains the Primavera schedule you want to load.
- Confirm the schedule settings for your schedule system.

6. Using the table in the Import Project Data window, select the objects from the file that you want to load into your Smart Construction database.

TIPS

- The grid displays the contents of the input source. If a Microsoft Excel workbook contains multiple sheets, each sheet appears in the window as a separate tab of the table.
- For each item found in the input source, the Action column indicates which process is needed to synchronize the data file with the database.
- Use the options in the Quick Selection pane for fast navigation and selection of your data.
7. Select the check boxes by the items to be added to the database, modified in the database, or removed from the database.

**NOTE** Select the check box in the Name column to apply all changes to the object. You can select individual check boxes for an object to apply specific changes to that object.

8. Click Process.

**NOTES**

- This process creates a new SmartPlant Foundation design document and attaches an XML file that includes the content of the selected data file. The document name is [System Name]_[Service Name]. This document cannot be checked out. It is managed by Smart Construction and exists in the CURRENT state.

- If your import project data file is large in size, you can configure IIS to process large file sizes. For more information, see Configure IIS to process large files (on page 82).

- For more information on the Import project data window, see Learn more about the Import Project Data window in the Intergraph Smart Construction User's Guide.

- If you remove a CWP from your project data but the CWP is associated with an IWP, the CWP cannot be deleted.

### Configuring a schedule system with Primavera P6 Web Services

Use the following steps to configure a schedule system that uses Primavera P6 Web Services as the schedule source.
Set Up and Configure Smart Construction Services

What do you want to do?
- **Set up the schedule system source** (on page 93)
- **Configure the Primavera Web Services schedule system** (on page 93)
- **Verify the schedule system is working** (on page 94)
- **Configure schedule mapping for import** (on page 94)
- **Import schedule data into Smart Construction** (on page 98)

---

**Set up the schedule system source**

The schedule system must be set up and configured before you begin to configure Smart Construction to use it as a source.

For guidance on setting up Primavera P6 Web Services, consult your Oracle documentation.

**NOTE** If using Primavera Web Services as the source for your schedule system, SSL and message encryption are not supported for communication with Smart Construction.

**Configure the Primavera Web Services schedule system**

To use Primavera P6 Web Services as your schedule source, you must configure the connection information for that source using the SmartPlant Foundation Desktop Client.

For information on implementing P6 Web Services, refer to your Primavera documentation.

**IMPORTANT** Your active scope must be set before configuring a schedule system in Smart Construction. For more information, see Set your active scope in SmartPlant Foundation Desktop Client (on page 32).

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **Smart Construction > New > Administration > Schedule System** to open the **New Schedule System** form.

   **NOTE** If the Schedule System object has already been created, click **Smart Construction > Find > Administration > Schedule System** to search for the schedule system object, and in the search results list, right-click the name of the schedule system and click **Update**.

3. If using Primavera Web Services, complete the **Primavera Web Service Settings details** section.

   **NOTE** The P6 Web Services Host requires both the host name and TCP port number of the Primavera Web Services host. For example, P6host:8800.

4. Click **Apply** or **Finish** to create or update the schedule system.
Verify the schedule system is working

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > Administration > Schedule System to open the Find Schedule System dialog box.
3. Type a name of a schedule system in the Find Schedule System dialog box. Click OK.
4. In the search results list, right-click the name of the schedule system and click Test Web Service.
5. After reviewing either the success or failure message, click OK.

**NOTE** The test attempts to connect to Primavera P6 using the connection information provided for the schedule system. If you receive an error message, you should review the connection information on the schedule system object. See Configure the Primavera SDK schedule system (on page 85) for more information.

Configure schedule mapping for import

You must map properties from your scheduling file to properties in Smart Construction. The following detailed work process explains how to configure your schedule mapping for import into Smart Construction.

**IMPORTANT** You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

1. Open the Primavera Schedule Web Mappings.xlsm workbook. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).
2. Click the Primavera Schedule Web tab.
3. Edit values for your schedule.
4. Click Save to save your changes in the workbook file.

**NOTES**
- The field name in Primavera P6 maps to properties in Smart Construction.
- If you enter data in the mapping workbook and later decide to remove the data, right-click the cell in Excel and select Clear Contents.
- For more information on how to edit the workbook, see Structure of the workbook (on page 63) in the Intergraph Smart Construction Administration and Configuration Guide.
- If a Smart Construction property does not exist for the custom property, you must extend the Smart Construction schema to include the custom property. For more information, see Extend the Smart Construction Schema in the Intergraph Smart Construction Administration and Configuration Guide.

5. Open the Main tab of the Primavera Schedule Web Mappings.xlsm workbook.
6. Click Generate Primavera Schedule Web Mapping to generate the Primavera Schedule Web Mappings.xml file.
7. Check in and sign off the Primavera Schedule Web Mappings.xlsm workbook and Primavera Schedule Web Mappings.xml file into the SmartPlant Foundation Desktop Client. For more information on managing configuration files for Smart Construction, see Manage Template Files for Smart Construction (on page 134).

**IMPORTANT** If you are generating the Primavera schedule mapping data for the first time, attach the Primavera Schedule Web Mappings.xlsm workbook and XML file to the Primavera Schedule Web Mappings configuration document in the SmartPlant Foundation Desktop Client. see Attach the mappings workbook and XML files to the Primavera Schedule SDK Mappings configuration document (on page 90).

**Primavera Schedule Web Mappings.xlsm details**

Use topics in the following section to learn more about the Primavera Schedule Web Mappings.xlsm workbook.

**Installation and location of the workbook**

When Smart Construction is installed on a server, the Primavera Schedule Web Mappings.xlsm is delivered to the Import Project Data Systems folder in the Templates folder of the installation location (for example, browse to [Drive]:\Program Files (x86)\SmartConstruction\2017\Templates\Import Project Data Systems to find Primavera Schedule Web Mappings.xlsm).

**Structure of the workbook**

The Primavera Schedule Web Mappings.xlsm workbook contains two tabs. The Main tab generates an XML file and saves it in the location specified when the file is checked out. The Primavera Schedule Web tab contains data and properties that are to be imported into Smart Construction.

**Main tab**

The Main tab is located on the first sheet of the workbook. It contains the Generate Primavera Schedule Web Mapping button, which generates the XML file and saves it in the location specified when the file is checked out.

**IMPORTANT** The Generate Primavera Schedule Web Mapping button should not be renamed or removed because it contains a macro. The code behind the button should not be modified or removed.

**Primavera Schedule Web tab**

The Primavera Schedule Web tab contains data and properties that are to be imported into Smart Construction.

**IMPORTANT**

- Column names are fixed and cannot be modified.
- Columns can be moved to different locations on the same sheet.
- Do not add new columns. Smart Construction does not read or handle any newly added columns.
## Column Header Explanation

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>Identifies the table name. For example, the PROJWBS table in Primavera P6 (limited to WBS currently).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Identifies the Column name in the Project WBS. An attribute can also be a UDF.</td>
</tr>
<tr>
<td>SPCInterface</td>
<td>A Smart Construction Interface definition realizing the specified SPCProperty value.</td>
</tr>
<tr>
<td>SPCProperty</td>
<td>A Smart Construction Property definition realized by the specified SPCInterface.</td>
</tr>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the requested value from the Primavera WBS data.</td>
</tr>
</tbody>
</table>

### NOTES

- The field name in Primavera P6 maps to properties in Smart Construction.
- For more information on configuring UDFs and mapping arguments, see *Configure a User-Defined Field (UDF) in your Smart Construction mapping* (on page 64) or *Mapping arguments for your Smart Construction project data* (on page 65).

### Configure a User-Defined Field (UDF) in your Smart Construction mapping

In Primavera P6, User-Defined fields (UDFs) are custom fields, created to track information specific to your project, WBS, or activities. To use these UDFs in your Smart Construction project, you must map the UDF from Primavera to data in Smart Construction.

You can create this mapping in the Primavera schedule mapping workbooks.
### Column Header Explanation

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argument</td>
<td>Identifies a method (from the Project Data Mappings service) and argument list (optional, depending on the method) to generate the desired value from the Primavera WBS data. If you are mapping a one-to-one relationship between a UDF and a Smart Construction property, the Argument column is left blank.</td>
</tr>
</tbody>
</table>

For example, if you have a UDF named Discipline in your Primavera P6 system, you can map it like the following:

<table>
<thead>
<tr>
<th>Entity</th>
<th>Attribute</th>
<th>SPCInterface</th>
<th>SPCProperty</th>
<th>Argument</th>
</tr>
</thead>
<tbody>
<tr>
<td>WBS</td>
<td>UDF:Discipline</td>
<td>SPC_CWP</td>
<td>CWP_Discipline</td>
<td></td>
</tr>
</tbody>
</table>

### Mapping arguments for your Smart Construction project data

You can specify arguments for your project data in the Argument column of the Primavera mappings workbooks. You can map arguments in order to call an external mapping function, allowing you to personalize your project data.

The following list defines the default methods provided by the Project Data Mappings service:

- **BuildWBSPath()**—this method builds a WBS path based on the WBS hierarchy from the Primavera project data; the resulting value mirrors the value generated by the former Refresh Schedule command.
- **CalculateEarlyStartDate()**—this method calculates the early start date for WBS items transforming to CWPs.
- **CalculateEarlyFinishDate()**—this method calculates the early finish date for WBS items transforming to CWPs.
- **CalculateLateStartDate()**—this method calculates the late start date for WBS items transforming to CWPs.
- **CalculateLateFinishDate()**—this method calculates the late finish date for WBS items transforming to CWPs.
- **MinDate(Activity:DateField)**—this method calculates the earliest date from all Activities under a WBS item, using the date field specified.
- **MaxDate(Activity:DateField)**—this method calculates the latest date from all Activities under a WBS item, using the date field specified.
- **RollupValue(Activity:P6Field)**—this method calculates a sum from all Activities under a WBS item, using the numeric field specified.
**Attach the mappings workbook and XML files to the Primavera Schedule Web Mappings configuration document**

★ IMPORTANT

- After you generate schedule mapping data for your project for the first time, you must attach the Primavera Schedule Web Mappings workbook and XML file to the Primavera Schedule Web Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.

- Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the Primavera Schedule Web Mappings document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the Primavera Schedule Web Mappings workbook and Primavera Schedule Web Mappings.xml files.
5. Click Open, and then click OK to add the files to the list.
6. Click Finish.

**Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule Web Mappings.xlsm workbook**

After it is attached to the Primavera Schedule Web Mappings configuration document, the Primavera Schedule Web Mappings workbook and Primavera Schedule Web Mappings.xml file can be managed in the SmartPlant Foundation Desktop Client. For more information, see Attach the mappings workbook and XML files to the Primavera Schedule Web Mappings configuration document (on page 98).

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the SmartPlant Foundation Desktop Client User’s Guide.

**Import schedule data into Smart Construction**

★ IMPORTANT In order to see a project data system in the Import Project Data window in Smart Construction, the access group SPC_ScheduleUpdate (or the access group assigned to the user who is allowed to use this feature) must be associated with the project data system object. For new sites created with version 2017 and later, in order to see the Primavera SDK and Primavera Web Services data sources, you need to associate them with the appropriate access group. For more information on access groups, see Configure access groups (on page 41).

1. Log on to Smart Construction as an administrator.
2. Click Administration > Import Project Data.
3. In the Import Project Data window, select a system name in the System Name box.

4. Click Settings.

5. Edit your project settings for the project data system, and then click OK.

**NOTES**
- Use the Browse dialog box to navigate to the Microsoft Excel workbook that contains the project data you want to load or the XML file that contains the Primavera schedule you want to load.
- Confirm the schedule settings for your schedule system.

6. Using the table in the Import Project Data window, select the objects from the file that you want to load into your Smart Construction database.

**TIPS**
- The grid displays the contents of the input source. If a Microsoft Excel workbook contains multiple sheets, each sheet appears in the window as a separate tab of the table.
- For each item found in the input source, the Action column indicates which process is needed to synchronize the data file with the database.
- Use the options in the Quick Selection pane for fast navigation and selection of your data.

7. Select the check boxes by the items to be added to the database, modified in the database, or removed from the database.

**NOTE** Select the check box in the Name column to apply all changes to the object. You can select individual check boxes for an object to apply specific changes to that object.

8. Click Process.

**NOTES**
- This process creates a new SmartPlant Foundation design document and attaches an XML file that includes the content of the selected data file. The document name is [System Name]_[Service Name]. This document cannot be checked out. It is managed by Smart Construction and exists in the CURRENT state.
- If your import project data file is large in size, you can configure IIS to process large file sizes. For more information, see Configure IIS to process large files (on page 82).
- For more information on the Import project data window, see Learn more about the Import Project Data window in the Intergraph Smart Construction User's Guide.
- If you remove a CWP from your project data but the CWP is associated with an IWP, the CWP cannot be deleted.
Turn on Smart Construction queues

By default, Smart Construction delivers all queues turned off. You must start the queues in order to use them.
1. Log on to SmartPlant Foundation as an administrator.
2. Click Smart Construction > Find > Administration > Queues.
3. In the Find dialog box, type the name of the queue and click OK.
4. Right-click the queue name and select Queue > Start.

**NOTES**
- Right-click the queue name and select Queue > Stop to stop the queue.
- In the Smart Construction client, click Administration > Show Queue Status to view which queues are enabled and their status.

Retrieve and refresh data in Smart Construction

In order to work with the latest information in Smart Construction, you must refresh and retrieve data regularly. You can refresh and retrieve data using the Smart Construction client. You must log on to Smart Construction as an administrator.

In Smart Construction, you can perform the following tasks:
- Import project data - loads and refreshes construction work packages (CWPs), and it imports project data such as contracts, contractors, and CWPs.
- Retrieve data - retrieves documents and data from the SmartPlant Foundation data warehouse configured with your Smart Construction server and project, making the documents available for viewing in Smart Construction.

Retrieve documents in Smart Construction

In order to view documents in Smart Construction, tools, such as PDS or Smart 3D, must publish documents to the SmartPlant Foundation data warehouse configured with a Smart Construction server and project. Using the Smart Construction Retrieve Data dialog box, users can query SmartPlant Foundation and retrieve documents into their Smart Construction project. The Smart Construction retrieve moves documents from the Shared domain to the Smart Construction domain. After Smart Construction retrieves documents, users can view, navigate, and work with the documents.

After a retrieve is started, the Smart Construction Rules of Progress queue generates and associates the rules of progress information with retrieved components. The Rules of Progress queue creates a separate scheduler task, SPC Process ROP Scheduler, to relate the scheduler to the Rules of Progress queue. The SPC Process ROP Scheduler task regularly polls the queue to process the rules of progress data for retrieved documents.

**IMPORTANT** Mapping must be done in order to retrieve documents into Smart Construction. Mapping helps configure properties and data between the publishing tool and Smart Construction. For more information, see Configure Mapped Properties for a Published Document in the Intergraph Smart Construction Customization Guide.
Example retrieve scenarios

The following diagram illustrates a generic retrieve scenario for Smart Construction.

1. After creating a document in a tool, users publish the document to SmartPlant Foundation. Tools must publish to the SmartPlant Foundation data warehouse that is configured with the Smart Construction server.

2. Smart Construction queries SmartPlant Foundation to retrieve the document into the Smart Construction domain.

*IMPORTANT* Intergraph highly recommends that users first retrieve model data into Smart Construction, then drawing data and documents. For more information, contact Intergraph Customer Support (http://support.intergraph.com).

In order to retrieve documents into Smart Construction, users must log on to SmartPlant Foundation Desktop Client and Smart Construction as an administrator. Users must also start the Smart Construction Scheduler in the SmartPlant Foundation Desktop Client. If email is configured in SmartPlant Foundation, users can receive email notifications when the retrieve operation is complete.

Users can retrieve and work with many different types of data in Smart Construction. If a tool can publish to SmartPlant Foundation, then Smart Construction can retrieve and open the document in the **Model View, Drawing View, SmartPlant Markup Plus**, or the **Component Registers** window.

The following diagram illustrates a basic overview of how to retrieve a PDS model into Smart Construction:

1. After creating a model in PDS, users publish the model to SmartPlant Foundation, using the Material Data Publisher.

2. Smart Construction queries SmartPlant Foundation to retrieve the model. After retrieving the model, users can display and filter the model.
The following diagram illustrates a basic overview of how to retrieve a spool from Smart 3D and SmartPlant Spoolgen® into Smart Construction:

1. After creating a pipeline model in Smart 3D, users export the spool to SmartPlant Spoolgen.
2. In SmartPlant Spoolgen, users can create, edit, refine, and generate spools. Then they publish the spool to SmartPlant Foundation.
3. Smart Construction queries SmartPlant Foundation to retrieve the spool. After retrieving the spool, users can display the spool data in models and IWPs.

For more information on best practices of spool creation with fabrication modifications, see Loading and using data with fabrication modifications in Smart Construction in the Intergraph Smart Construction Administration and Configuration Guide.

**IMPORTANT** Refer to individual tool documentation for more information on publishing documents to SmartPlant Foundation. You can also refer to the Integration User’s Guide for more information.

### Retrieve data

You can retrieve documents from the SmartPlant Foundation data warehouse to your Smart Construction project.

**IMPORTANT**

- You must start the Smart Construction Scheduler in SmartPlant Foundation Desktop Client in order to retrieve documents into Smart Construction.
- The **Retrieve Data** queue must be enabled and turned on in order to retrieve documents in Smart Construction. For more information, see *Turn the retrieve queue on or off* in the Intergraph Smart Construction User's Guide or Restart the Retrieve Data queue in the Intergraph Smart Construction Administration and Configuration Guide.
- Any 2D isometric drawing with the exception of those from Spoolgen or SmartPlant Isometrics can be retrieved in Smart Construction after the 3D model data has been published, loaded, and consolidated in SmartPlant Foundation.
- In order to retrieve a spool into Smart Construction, first retrieve the model related to the spool, drawings related to the spool, and then retrieve the spool drawing (.pod).
- You can disable the rules of progress functionality in order to improve retrieve performance.
- Before you retrieve a large amount of data, recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.
- Data is committed to the database in chunks as it is retrieved. This commit is final, meaning no rollback operation is performed if an error occurs. For more information, see the description of the **SPCTransactionMode** property in *Smart Construction site properties in*
Set Up and Configure Smart Construction Services

Server Manager in the Intergraph Smart Construction Administration and Configuration Guide.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.

2. Start the Smart Construction Scheduler in the SmartPlant Foundation Desktop Client.
   a. Click Find > Administration > Schedulers.
   b. In the Find Schedulers dialog box, type the name of the Scheduler, and click OK.
   c. Right-click the Scheduler, and click Scheduler > Start.

3. Log on to Smart Construction as an administrator.

4. Click Administration on the Smart Construction Standard Toolbar and select Retrieve Data to open the Retrieve Data dialog box.

5. On the Retrieve Data dialog box, type or select search criteria to view data available for retrieval, then click Execute Search.

6. Select documents to retrieve into Smart Construction.

   **TIPS**
   - To retrieve parts of a composite model, click Expand next to the model name. Then, select the parts of the model you want to retrieve.
   - Press SHIFT or CTRL and select multiple documents to retrieve into Smart Construction.

7. Click Retrieve.

8. To verify documents were retrieved, click Drawings, Models, or Component Registers on the Smart Construction home page to view newly retrieved documents.

   **TIPS**
   - You can turn on the SmartPlant Foundation server logging in order to gather useful information about the retrieve and rules of progress generation. In SmartPlant Foundation Server Manager, you can set the Trace Settings for your site. SmartPlant Foundation Server Manager uses the Custom property to log data for Smart Construction. For more information, see Use SmartPlant Foundation Server Logging in the Intergraph Smart Construction Troubleshooting Guide. You can also see Setting Up SmartPlant Foundation Server Logging in the SmartPlant Foundation Troubleshooting Guide and Set tracing levels for a site in the SmartPlant Foundation Server Manager User's Guide.

   - If a document fails to retrieve, the document status displays in the Status column. The failure message is available on the Information column. You can try to retrieve the document again by selecting the document, and clicking Retrieve. See the SmartPlant Foundation documentation for information on the failure message.

   - You can cancel the retrieval of a document after it has begun. For more information, please see Cancel the retrieval of a document in the Intergraph Smart Construction Administration and Configuration Guide.
Click the progress bar in the **Status** column for more information about the model or drawing that is being retrieved.

**NOTES**

- You can link composite documents to retrieved documents in the **Retrieve Data** dialog box in Smart Construction using the **Link composite document to retrieved documents** option. This option is helpful if you need to synchronize different versions and revisions of a composite document, or you can use the option to link directly to a previously retrieved composite document without having to retrieve all of the documents again. For more information, see *Link composite documents to retrieved documents* in the *Intergraph Smart Construction Administration and Configuration Guide*.

- After a retrieve is started, the Smart Construction **Rules of Progress** queue generates and associates the rules of progress information with retrieved components. The **Rules of Progress** queue creates a separate scheduler task, **SPC Process ROP Scheduler**, to relate the scheduler to the **Rules of Progress** queue. The **SPC Process ROP Scheduler** task regularly polls the queue to process the rules of progress data for retrieved documents. For more information, see *Query for the status of the rules of progress association* in the *Intergraph Smart Construction Administration and Configuration Guide*.

- In the Smart Construction client, click **Administration > Show Queue Status** to view which queues are enabled and their status.

- The viewable file for models and drawings is defined in the **SPCViewableFile** property in Server Manager. If you retrieve a component register or if the published file does not have a file extension defined in the **SPCViewableFile** property in Server Manager, the file is retrieved as a component register. It displays on the **Retrieve data** dialog box when you search for component registers, and the file is retrieved as a component register. For more information, see *Smart Construction site properties in Server Manager* in the *Intergraph Smart Construction Administration and Configuration Guide*.

- By default, the **SPC_BrowserItemView** access group is associated to models and drawings after being retrieved into Smart Construction. You can edit access groups on models and drawings to fit your business needs.

- If a class definition is not assigned a component category, engineered published components related to the class definition are excluded from the Smart Construction retrieve.
SECTION 9

Install and Set Up Smart Construction on Workstations

After you install required software on a client workstation computer, you can install Smart Construction.

Any workstation can be set up as an administrative client. The security settings of the logged-in user determine the type of work the user can do in Smart Construction.

**NOTE** You can also install software in silent mode, which requires no user interaction as the software installs. For more information, see *Install Smart Construction in Silent Mode* (on page 132).

Install prerequisite software

Before you install Smart Construction on a client workstation, verify the installation of the recommended software. For more information, see the *Smart Construction Hardware and Software Recommendations* (on page 18).

Install Smart Construction on a client workstation

1. From the product installation DVD, if the installation does not start automatically, double-click *setup.exe*.
2. In the *Welcome* window, click *Start Setup*.
3. In the *Details and Features* window, enter your *Serial Number*, *User Name*, and *Company*.
4. In the *Select Features To Install* section, select *Smart Construction Client*.
5. In the *Smart Construction Server Host Information* section, enter the following:
   - *Server Host* - Name of the SmartPlant Foundation application server.
   - *Server Name* - Name of the SmartPlant Foundation site on the server to which the client will connect.
6. In the *Install Path* section, enter the path where the software is to be installed.
7. Click *Install*.
   - **TIP** Required information is marked by a red star. The *Install* button is not enabled until all this information is provided.
8. In the *License Agreement* window, from the *Country or Region* list, select your country or region.
9. Carefully read the license agreement. When you are finished, select *I agree to the license agreement and conditions*. 

Intergraph Smart Construction Installation and Setup Guide
10. Click **Install**.
11. Click **Finish** when the installation is complete.

**NOTE** If you choose to install prerequisite software using the Setup Wizard for Smart Construction, you may be required to reboot your system during the installation process.

### Install SmartPlant Review and its modules on a client workstation

In Smart Construction, you can open SmartPlant Review to open 3D models, sequence components in an IWP, and create animation data. In order to take advantage of this functionality, you must install SmartPlant Review with the API Module and the Simulation and Visual Effects Module.

The API Module and the Simulation and Visual Effects Module can be installed during the SmartPlant Review installation, or they can be installed at a later time using the Select Modules Utility.

**NOTE** Each SmartPlant Review module requires its own serial number and license file.

For more information on installing SmartPlant Review, see the *SmartPlant Review Installation Guide*. For more information on installing the SmartPlant modules after installation, see the *SmartPlant Review Select Modules Utility User’s Guide*.

### Automatically log on to Smart Construction

Click **Start > All Programs > Intergraph Smart Construction > Smart Construction**. The client automatically logs you onto Smart Construction.

If you have a shortcut to Smart Construction on your desktop, double-click the shortcut.

**NOTES**
- If the SmartPlant Foundation application server has been configured to automatically log on users, you can automatically log on to Smart Construction. See the *SmartPlant Foundation Installation and Setup Guide* for more information about configuring automatic logon.
- The view of the Smart Construction interface depends on your security configuration and settings.
- Smart Construction logs you into the last project you worked in.

**IMPORTANT** Contact your Smart Construction administrator to change your password and logon information.
Install and Set Up Smart Construction on Workstations

Start Smart Construction

After you install Smart Construction, click Start > All Programs > Intergraph Smart Construction > Smart Construction.

Log on to Smart Construction

1. Click Start > All Programs > Intergraph Smart Construction > Smart Construction to open the Logon Information dialog box.
2. Type your user name in the User name box.
3. Type your password in the Password box.
4. Select a server name from the Server list.
5. Click OK.
6. Select a project from the Project Selection dialog box, if applicable.
7. Click OK.

★ IMPORTANT
- Your logon name and password are the same for both Smart Construction and SmartPlant Foundation.
- Contact your Smart Construction administrator to change your password and logon information.

✎ NOTES
- The Smart Construction project scope uses the SmartPlant Foundation active scope.
- Smart Construction automatically selects your scope, if only one plant is configured in SmartPlant Foundation.
- If your SmartPlant Foundation scope is set at the project level and not the plant level, Smart Construction automatically sets your scope to the plant level. The scope is updated in SmartPlant Foundation.
- If your SmartPlant Foundation scope is set at multiple projects and not the plant level, Smart Construction opens the Project Select dialog box, prompting you to select your scope. The scope is updated in SmartPlant Foundation.
- If scope is not set and multiple scopes are available for selection, Smart Construction opens the Project Select dialog box, prompting you to select your scope. If you click Cancel without selecting a scope, Smart Construction closes.
Remove Smart Construction from a client workstation

1. Click **Start > Control Panel > Uninstall a Program**.
2. On the **Uninstall or change a program** dialog box, click **Intergraph Smart Construction**.
3. Click **Change** to run the Setup wizard.
4. Click **Change**.
5. Select **Uninstall**.
6. Click **Next** to begin the uninstallation.
7. Click **Finish**.
SECTION 10

Set Up and Configure Smart Construction OnSite

Smart Construction OnSite is a mobile app on-site construction crews can use to reference work steps, view drawings and track progress for installation work packages. OnSite is available for Android devices.

Before you begin

Before you can set up and configure Smart Construction OnSite on your mobile device, you must make sure the following has been done:

- You must set up and configure SmartPlant Foundation API Services. Your authentication server must be set up to use SSL. For more information, see the SmartPlant Foundation How to Configure API Services guide.
- Smart Construction server and its prerequisite software must be installed and configured.

Setting up and configuring Smart Construction OnSite

The following diagram illustrates the steps required to set up and configure a system to use Smart Construction OnSite.
Register Smart Construction OnSite with the Authorization Server

1. In your web browser, go to the Intergraph Authorization Server website:
   http://[myserver.mydomain.com]/[mysitename]ConfigSvc/spfauthentication/
2. Log on as admin.
3. In the left toolbar, click Applications > Add New Client.
4. Type INGR_CID_SMARTCONSTRUCTIONMOBILE in the Client ID box.
5. Type a value in the Client Name box.
7. Add a new secret for Smart Construction OnSite.
   Click Add new record. Type MobileSecret for the Client Secret Type, and type secret in the Value box. Leave the description empty.
8. Click Create.

   **NOTE** For a list of the available client application settings, see Client application settings in the SmartPlant Foundation How to Configure API Services guide.

Configure users for Smart Construction OnSite

In order to use Smart Construction OnSite, users must meet following requirements:

- A password must be set for the user, and it cannot be blank.
- The user must be assigned the SmartPlant Foundation Viewer role.
- The user must be assigned a construction responsibility.

For more information about construction responsibilities, see Associate Smart Construction users with a construction responsibility (on page 45).

For more information on configuring users, see Create login users in the SmartPlant Foundation How to Configure the Security Model guide.

Install SSL certificates on your mobile device

Follow the instructions from the third-party certificate provider for creating and installing the SSL certificate used to securely communicate with the Smart Construction site.
Install Smart Construction OnSite on your Android device

1. On your Android device, open a browser window, then navigate to the following address: http://[Machine name].[Domain name].com/[Server name]/OnSite/android.html.
2. Click INSTALL to download and install the app.

Reinstalling Smart Construction OnSite

1. On your Android device, open a browser window, then navigate to the following address: http://[Machine name].[Domain name].com/[Server name]/OnSite/android.html.
2. Click INSTALL.
3. Click REPLACE FILE to reinstall the app.
4. Click Open. Or navigate to the Download folder.
5. Select the file, and click INSTALL.
After You Install and Set Up Smart Construction

After you install and set up Smart Construction, you can start working with your system.

If you are an administrator of Smart Construction, you can find administration and configuration information in the *Intergraph Smart Construction Administration and Configuration Guide*.

If you are a user of Smart Construction, you can find user-specific information in the *Intergraph Smart Construction User's Guide* or context-sensitive help within the client. Or, you can find out how to get started in the client in the *Intergraph Smart Construction Getting Started Guide*.

**Intergraph Work Process Guides**

Intergraph Work Process guides map the process, power, and marine industries’ basic work processes to SmartPlant Enterprise and SmartMarine Enterprise solutions. This documentation helps your organization transition from previous work practices to using Intergraph tools as the new way of executing projects. These documents are available on [https://smartsupport.intergraph.com](https://smartsupport.intergraph.com) under View Documentation > Work Process Guides.

**Enterprise Work Processes** describe an entire engineering discipline or process at two different levels, including:

- Providing a swim lane diagram to define the typical roles and high-level processes involved in a project
- Showing how Intergraph tools are used to produce required deliverables

**Integration Capability Statements** describe a specific work process among a set of Intergraph tools, including:

- Explaining the out-of-the-box capabilities of the tools and their recommended use
- Providing a swim lane diagram to show how the tools interact in the work process
- Stating critical requirements and precautions

Enterprise Work Processes and Integration Capability Statements offer a better understanding of how Intergraph tools work together and how to adapt the tools to improve existing work processes.
SECTION 12

Upgrading Smart Construction

The following section provides instructions for upgrading Smart Construction to the 2017 version of the software from the 2015 R2 version of the software. Contact Intergraph Customer Support (http://support.intergraph.com) to upgrade from a release before version 2015 R2.

For information on upgrading SmartPlant Foundation and SmartPlant Foundation sites, see the SmartPlant Foundation Upgrade Guide.

Smart Construction upgrade sequence

Typically, the upgrade process involves the steps listed below; however, your software may require a slightly different sequence, depending on your system configuration.

- **Prepare to upgrade to Smart Construction 2017** (on page 113)
  - Make backups (on page 114)
  - Upgrade SmartPlant Foundation (on page 114)
- **Upgrade the Smart Construction server** (on page 114)
  - Verify prerequisite software is installed (on page 114)
  - Upgrade Smart Construction on the SmartPlant Foundation application server (on page 115)
- **Configure Smart Construction in Server Manager** (on page 116)
  - Configure the Smart Construction server (on page 116)
- **Upgrade Smart Construction client workstations** (on page 126)
  - Verify prerequisite software is installed (on page 126)
  - Upgrade Smart Construction on a client workstation (on page 126)

Prepare to upgrade to Smart Construction 2017

This section provides information on preparations that should be made before beginning the upgrade.
Make backups

Intergraph recommends that you back up your Smart Construction site, vault and database before you upgrade. You can locate your web site by browsing to [Drive:]\SmartPlant Foundation [Software version] Server Files\Web_Sites\[Web Site].

You can export your configuration using the Export Configuration option in SmartPlant Foundation Server Manager. For more information, see Export and import a configuration in the SmartPlant Foundation Upgrade Guide.

[TIP] When you upgrade Smart Construction to another version, you must back up all customized reports in a separate location than the sites that are being upgraded. After the upgrade, you can move these report files back to upgraded site location.

Upgrade SmartPlant Foundation

Before upgrading Smart Construction, you must first upgrade and configure SmartPlant Foundation and its prerequisite software.

Smart Construction 2017 uses SmartPlant Foundation 2016 HF4.

For more information about upgrading SmartPlant Foundation, see the SmartPlant Foundation Upgrade Guide delivered with the SmartPlant Foundation software.

Upgrade the Smart Construction server

This section details how to upgrade the Smart Construction server.

- Verify prerequisite software is installed (on page 114)
- Upgrade Smart Construction on the SmartPlant Foundation application server (on page 115)
- Configure Smart Construction in Server Manager (on page 116)
- Configure the Smart Construction server (on page 116)

Verify prerequisite software is installed

Before you upgrade Smart Construction on the SmartPlant Foundation application server, verify the installation of the prerequisite and recommended software.

For more information, see the Smart Construction Hardware and Software Recommendations (on page 18) or the SmartPlant Foundation hardware and software recommendations in the SmartPlant Foundation Installation and Setup Guide delivered with SmartPlant Foundation software.
Upgrade Smart Construction on the SmartPlant Foundation application server

Typically, the upgrade process involves the steps listed below; however, your software may require a slightly different sequence if upgrading from a previous version. For more information, see Upgrade SmartPlant Foundation (on page 114).

1. From the product installation DVD, if the installation does not start automatically, double-click setup.exe.
2. In the Welcome window, click Upgrade.
3. In the Details and Features window, enter your Serial Number, User Name, and Company.
4. In the Select Features To Install section, select the features you want to install:
   - All Features - Installs all the items described below.
   - Smart Construction Client - Installs the Smart Construction Client, which provides client functionality on the local computer.
   - Smart Construction Server - Installs the Smart Construction Server component, which includes the software required to set up Smart Construction on the application server.
5. If you are installing Smart Construction Client, in the Smart Construction Server Host Information section, enter the following:
   - Server Host - Name of the SmartPlant Foundation application server.
   - Server Name - Name of the SmartPlant Foundation site on the server to which the client will connect.

   **NOTE** This section is enabled only when you have chosen to install Smart Construction Client as a feature.
6. In the Install Path section, enter the path where the software is to be installed.
7. Click Install.
   - **TIP** Required information is marked by a red star. The Install button is not enabled until all this information is provided.
8. In the License Agreement window, from the Country or Region list, select your country or region.
9. Carefully read the license agreement. When you are finished, select I agree to the license agreement and conditions.
10. Click Install.
11. Click Finish when the installation is complete.

   **NOTE** Smart Construction server installation installs a printer named Smart Construction PDF Converter 550. This printer is used to attach drawings to reports and should not be removed or used for any other purpose.
Configure Smart Construction in Server Manager

After upgrading the software on the Smart Construction server, you must configure the Smart Construction site in SmartPlant Foundation Server Manager.

Create a new Smart Construction site or import a site in Server Manager

After you upgrade Smart Construction on the server, you can create a new Smart Construction site using SmartPlant Foundation Server Manager. You can also import your site to SmartPlant Foundation Server Manager.

For more information, see Configure Smart Construction in Server Manager (on page 30) and Importing and Exporting a Configuration in the SmartPlant Foundation Server Manager User's Guide.

Update the Smart Construction site

After you have your site imported or created, you can update the site in SmartPlant Foundation Server Manager to use the latest files from the installation location.

Click Tools > Smart Construction > Update Site to update a site.

For more information, see Update a site in the SmartPlant Foundation Upgrade Guide.

★ IMPORTANT After you update your site, recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.

Configure the Smart Construction server

After you upgrade the Smart Construction server to the latest version, you must configure the Smart Construction server to use the latest schema files and load files.

Stop all Smart Construction queues

1. Log on to SmartPlant Foundation as an administrator.
2. Click Smart Construction > Find > Administration > Queues.
3. In the Find dialog box, type the name of the queue and click OK.
4. Right-click the queue name and select Queue > Stop.
Set your active scope in SmartPlant Foundation Desktop Client

Before setting up and configuring Smart Construction services, you must set your SmartPlant Foundation Desktop Client active scope to your Smart Construction plant. Smart Construction supports plant-level configurations, not project-level.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click File > Set Active Scope to open the Set Active Scope dialog box.
   
   You can also set the active scope by clicking the text beside Selected Roles, Query Scope, or Create/Update Scope in the Desktop Client status bar.
3. In the Set Active Scope dialog box, select your scope.
   
   **NOTE** You can select one plant for your query and create scope. Smart Construction does not support multiple query scopes.
4. Click OK.

Import Smart Construction schema

Use the SmartPlant Foundation Schema Import Wizard to import schema files into your Smart Construction project. For more information on the Schema Import Wizard, see the SmartPlant Foundation Desktop Client User's Guide.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Administration > Schema Import Wizard in the Desktop Client.
3. Browse to the schema location.
4. Select a compare context option.
   
   **IMPORTANT** Intergraph recommends you select the Compare content of selected files against all database items with a matching container ID option to compare your schema for Smart Construction.
5. Select the schema file to import. Click Browse on the Schema Import Wizard window to browse to the Smart Construction installation location. Select 01_SPC_AuthoringSchema.xml in the 001-Schema folder (For example, browse to \[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\001-Schema).
6. Select a Compare Option. This step is optional.
7. Click Next. The Comparison Results form displays. The totals (New, Updated, and Removed objects and relationships) are displayed at the bottom of the form.
8. Select schema objects to import into your Smart Construction project. Select the check box next to each object name and click Next to import them one by one. Or, click Select All to import all objects, and click Next.
9. Verify the correct schema objects were loaded into the Smart Construction site in the Review Changes window. Click Finish.
   
   **IMPORTANT** After loading schema changes, close SmartPlant Foundation Desktop Client and recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.
Upgrading Smart Construction

Load the Plant Breakdown Structure schema

After loading the Smart Construction schema, you must load the Plant Breakdown Structure (PBS) schema. For more information, see Load the Plant Breakdown Structure schema (on page 35).

If upgrading a system with a custom PBS, see Upgrade a Smart Construction project with a custom PBS (on page 123).

If you are using a custom PBS, see Configuring a Custom Plant Breakdown Structure (PBS) for Smart Construction in the Intergraph Smart Construction Customization Guide.

Load the work package enumerated list schema

After loading the PBS schema, you can load the package enumerated list schema, which loads the enumerated lists for the delivered package disciplines, purposes, and statuses (related to CWAs, CWPs, and IWP). If you choose to not load the delivered package enumerated list schema, you must configure your own disciplines, purposes, and statuses. For more information, see Configure Work Package Disciplines and Purposes and Configure IWP Status in the Intergraph Smart Construction Administration and Configuration Guide.

For more information on loading the work package enumerated list schema, see Load the work package enumerated list schema (on page 36).

Run SQL scripts for Smart Construction 2017

1. Browse to the DatabaseScripts folder in the Smart Construction server product installation location. For example, navigate to [Drive]:\Program Files (x86)\SmartConstruction\2017\LoadFiles\Upgrades\2017\DatabaseScripts.

2. Browse to the folder named for the database system you are using for your Smart Construction database (Oracle or SQL Server).

3. Log on to your database system with system administrator privileges and run the SQL scripts on the database in the numerical order indicated by the number preceding the file name.

★ IMPORTANT After running SQL scripts, recycle the Internet Information Services (IIS) application pools for your project’s site. For more information on resetting IIS application pools, see IIS documentation.

Run SQL scripts if auxiliary table usage has not been enabled

Smart Construction uses a set of auxiliary tables for performing some resource-intensive system operations. If your implementation of Smart Construction included the disabling of the use of these tables, you must run a set of SQL scripts in order to manually upgrade these tables in the database.

★ IMPORTANT If your implementation has already enabled the use of the auxiliary tables, you do not need to run these scripts. By default, the auxiliary tables are enabled. If you have never changed the default setting, you do not need to run these scripts.
The site properties for controlling the use of the auxiliary tables are `UseAuxiliaryTables` and `UseAuxiliaryComponentTables`. In version 2017, these site properties are no longer available through Server Manager.

1. Browse to the **Database** folder in the Smart Construction server product installation location. For example, navigate to `[Drive]:\Program Files (x86)\SmartConstruction\2017\Database.

2. Navigate to the **RebuildAuxTables** folder under the folder that is named for the database system you are using for your Smart Construction database (Oracle or SQL Server). For example, `[Drive]\Program Files (x86)\SmartConstruction\2017\Database\[database system]\RebuildAuxTables.

3. Log on to your database system with system administrator privileges and run the SQL scripts on the database in the numerical order indicated by the number preceding the file name.

**IMPORTANT** After running SQL scripts, recycle the Internet Information Services (IIS) application pools for your project’s site. For more information on resetting IIS application pools, see IIS documentation.

**Load Smart Construction upgrade files**

Use the SmartPlant Foundation Loader to load Smart Construction upgrade load files. Run the upgrade files per SmartPlant Foundation configuration.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.

2. Click **File > Loader**.

3. On the **Loader** dialog box, browse to the **Loader** folder located in the Smart Construction installation location. For example, navigate to `[Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles\Upgrades\[upgrade versions]\Loader.

**IMPORTANT** When you are upgrading from a version of Smart Construction that is older than the most recent previous version, you must load the upgrade files for the versions you are skipping in sequence before loading the files for the newly installed version. For example, if you are upgrading from version 2013R2, you would need to begin by loading the files in the version 2015 folder, then the 2015 R1 folder, and so on, ending with the folder for version 2017.

4. Select all of the files in the **Loader** folder.

5. Verify the files are in numerical order. The files must be loaded in the order indicated by the number preceding the file name. Click **Move Selected Item Up** or **Move Selected Item Down** in the **Selected load files** window to put the files in a numerical order.

6. Click **Process** to view results of the load in the **Processed load files** list.

7. Click **Load Results** to view load process details.

8. Click **Close**.
Load the Smart Construction administrative files after the upgrade

After upgrading Smart Construction, you must run the administrative load files to update your site with the latest administrative functions. For more information, see *Load Smart Construction administrative files* (on page 37).

**IMPORTANT** Running the administrative load files can override any personalized access groups and security settings. For more information about access groups, see *Configure Smart Construction Security* in the *Intergraph Smart Construction Administration and Configuration Guide* or the *How to Configure the Security Model Guide* delivered with SmartPlant Foundation.

Turn on Smart Construction queues

By default, Smart Construction delivers all queues turned off. You must start the queues in order to use them.

For more information, see *Turn on Smart Construction queues* (on page 100).

Start the Smart Construction Data Migration tool

The *Smart Construction Data Migration* tool migrates data in the Smart Construction database to be compatible with the latest Smart Construction version. You can run the tool from the SmartPlant Foundation Desktop Client.

1. If you want to use the latest retrieve mappings in the new version of Smart Construction, you must upgrade your retrieve mappings first before using the *Smart Construction Data Migration* tool. For information, see *Configure Mapped Properties for a Published Document* in the *Intergraph Smart Construction Customization Guide*.

   **IMPORTANT** You must update your Retrieve Mapping workbook for Smart Construction to use the latest version.

2. Log on to SmartPlant Foundation Desktop Client as an administrator.

3. Click *Smart Construction > Find > Administration > Options*.

4. In the *Find Smart Construction Options* dialog box, type *SPC System Options* and click *OK*.

5. In the search results, right-click *SPC System Options* and select *Smart Construction Data Migration* to start the *Smart Construction Data Migration* tool.

   **NOTE** In the search results, right-click *SPC System Options* and select *Details* to view the Smart Construction data version.

6. After the *Smart Construction Data Migration* tool processes, recycle the Internet Information Services (IIS) application pools for your project's site. For more information on resetting IIS application pools, see IIS documentation.
**Query the Smart Construction Data Migration status**

You can query the SPC Data Migration Scheduler tasks to view the status of the Smart Construction Data Migration tool.

1. Log on to SmartPlant Foundation as an administrator.
2. Click *Query > Schedule Tasks*, or click *Query for Scheduled Tasks* on the toolbar.
3. In the Schedule Tasks dialog box, type the name of the task and any other details for the query.
4. Click *Finish* to view search results in the list view.

**View the SPC Data Migration log file**

After the upgrade scheduled task processes, a log file is generated, recording a log of the successes and failures of the upgrade.

1. Browse to the UpgradeLibraries folder in the Bin directory of your site. For example, you can browse to the Smart Construction server installation location, \[Drive\]:\SmartPlant\Foundation\[Software version\] Server Files\Web_Sites\[Web Site]\Bin\UpgradeLibraries.
2. Open the SPC Data Migration.log file to view the status of the upgrade.

**Upgrade your correlation type**

In previous versions of Smart Construction, you could choose which kind of correlation was used in your project, either indirect or direct. Smart Construction 2017 uses indirect correlation.

If you use indirect correlation in your project, you must run an upgrade script to update your correlation type.

If you use direct correlation in your project, you can skip this step.

This script does not change previously retrieved data. All data retrieved in Smart Construction 2017 will be retrieved using indirect correlation. For more information about correlation in Smart Construction, see *Loading and using data with fabrication modifications in Smart Construction* in the Intergraph Smart Construction Administration and Configuration Guide.

1. Browse to the RebuildAuxTables folder in the Smart Construction server product installation location.
   
   For an Oracle database, navigate to \[Drive\]:\Program Files (x86)\SmartConstruction\2017\Database\Oracle\RebuildAuxTables.

   For a SQL database, navigate to \[Drive\]:\Program Files (x86)\SmartConstruction\2017\Database\SQLServer\RebuildAuxTables.

2. Log on to your database system with system administrator privileges and run the 02-Populate_SPC_DwgComps.sql and 03-Populate_SPC_DwgComps_Assemblies.sql scripts for your database system.
**Specify how material items are consumed and generate material items**

**Specify which material items are consumed**

You can specify which work step consumes material in the RoP Configuration workbook. Materials can be consumed by multiple work steps in IWPs with different purposes; however, materials cannot be consumed by multiple work steps in IWPs with the same purpose. For more information, see *Specify which work steps consume materials* (on page 51).

**Generate materials items**

The **Generate material items** tool generates material items for the latest Smart Construction version. You can run the tool from the SmartPlant Foundation Desktop Client.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **Smart Construction > Find > Administration > Options**.
3. In the **Find Smart Construction Options** dialog box, type **SPC System Options** and click **OK**.
4. In the search results, right-click **SPC System Options** and select **Generate material items** to generate material items.

**Upgrade the material system configuration**

If you have been using a SmartPlant Materials system with Smart Construction before version 2017, in order for this functionality to work with version 2017 and later, you must perform additional configuration steps after upgrading Smart Construction.

**Load the materials system administrative file**

Use the SmartPlant Foundation Loader to load an administrative file that is required to add the materials system mapping template to SmartPlant Foundation.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click **File > Loader** to open the **Loader** dialog box.
3. Browse to the administrative files in the LoadFiles folder in the Smart Construction installation location. For example, navigate to [Drive]\Program Files (x86)\SmartConstruction\2017\LoadFiles.
4. Navigate to the **005-ConfigDocuments** folder.
5. Select the **08-ConfigDoc_MaterialMappings.xml** file.
6. Click **Process**. Results of the load display in the **Processed load files** list.
7. Click **Load Results** to view load process details.
**Attach materials template files to the materials system configuration document**

**IMPORTANT**
- You must attach the SP Material Mappings.xlsxm workbook and XML file to the Material Mappings configuration document located in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the document, allowing users with the proper permissions to check the document out and in with revisions.
- Set your **Create scope** in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click **Smart Construction > Find > Administration > Configuration Documents** to open the **Query for Configuration Documents** dialog box.
2. Type your search criteria and click **Finish** to find the configuration documents.
3. In the search results, right-click the **Material Mappings** document and select **Files > Attach File** to open the **Attach File** dialog box.
4. Click **Add File** and browse to the **SP Material Mappings.xlsxm** workbook and **SP Material Mappings.xml** file.
   - The files are delivered by default to `[drive]\Program Files (x86)\SmartConstruction\2017\Templates\Material Mappings.`
5. Click **Open**, and then click **OK** to add the files to the list.
6. Click **Finish**.

**Use the SmartPlant Foundation Desktop Client to manage the template files**

After they are attached to the **Material Mappings** configuration document, the SP Material Mappings.xlsxm workbook and SP Material Mappings.xml file can be managed in the SmartPlant Foundation Desktop Client.

You can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the *SmartPlant Foundation Desktop Client User's Guide*.

**Upgrade a Smart Construction project with a custom PBS**

If you are upgrading to Smart Construction with a project that uses a custom PBS structure, complete the following steps:

1. Delete previously created custom search criteria.
2. Run the **Smart Construction Custom PBS Utility** tool to create new custom search criteria. For more information, see *Configure a PBS with the Smart Construction PBS Configuration Utility* in the *Intergraph Smart Construction Customization Guide*.

   **NOTE** The **Smart Construction Custom PBS Utility** tool generates two XML files that must be loaded into Smart Construction - **02_SPC_PBS_AuthoringSchema.xml** and **051-02-SPC_PBS_CustomSearchCriteriaData.xml**.
3. Load the 02_SPC_PBS_AuthoringSchema.xml file using the Import Schema Wizard. For more information, see *Import Smart Construction schema* (on page 117).

4. Load the 051-02-SPC_PBS_CustomSearchCriteriaData.xml file using the Loader.

   **TIP** You can load the 051-02-SPC_PBS_CustomSearchCriteriaData.xml file when you load the administrative files for Smart Construction. For more information, see *Load the Smart Construction administrative files after the upgrade* (on page 120).

5. Continue upgrading your system by running the Smart Construction Administrative Files. For more information, see *Load the Smart Construction administrative files after the upgrade* (on page 120).

For more information, see *Configuring a Custom Plant Breakdown Structure (PBS) for Smart Construction* in the *Intergraph Smart Construction Customization Guide* or contact Intergraph Customer Support (http://support.intergraph.com).

**Configure Smart Construction services**

After you upgrade the Smart Construction server, you can configure Smart Construction services, including the following:

- Configure permissions and settings for Smart Construction printing. For more information, see *Configure Permissions and Settings for Smart Construction Printing* (on page 26).
- Load the Smart Construction domains. For more information, see *Load Smart Construction domains* (on page 37).
- Configure security on the Smart Construction server. For more information, see *Configure Smart Construction security* (on page 39).
- Configure a materials system on the Smart Construction server. For more information, see *Configure and Update a Materials System* (on page 46).
- Configure the **Material Request** window and report. For more information, see *Enable the Material Request window and report in Smart Construction* (on page 52).
- Configure a schedule system on the Smart Construction server. For more information, see *Configure a schedule system for schedule data import* (on page 83).
- Configure and load project data on the Smart Construction server. For more information, see *Import project data into Smart Construction* (on page 60).
- Configure and load rules of progress on the server. For more information, see *Configure the Rules of Progress* (on page 54).
Configure the Rules of Progress and Retrieve Mapping for Smart Construction 2017

You must update your Retrieve Mapping workbook for Smart Construction to use the latest version.

**IMPORTANT**

- You must update the Rules of Progress data before you retrieve documents.
- If you want to use the latest retrieve mappings in the new version of Smart Construction, you must upgrade your retrieve mappings first before using the Smart Construction Data Migration tool. For details, see Start the Smart Construction Data Migration tool (on page 120).

For more information, see Rules of progress configuration workbook details in the Intergraph Smart Construction Administration and Configuration Guide and Configure Mapped Properties for a Published Document in the Intergraph Smart Construction Customization Guide.

Disable the rules of progress functionality

If you do not want to implement the rules of progress feature in Smart Construction, you can disable the rules of progress from processing by stopping the Rules of Progress queue. Disabling the rules of progress feature saves time and resources and improves performance during retrieve.

**IMPORTANT** You must disable the rules of progress functionality before you retrieve documents.

1. In SmartPlant Foundation Desktop Client, click Smart Construction > Find > Administration > Queues and search for the Rules of Progress queue.
2. Right-click the queue and select Queue > Stop.

Attach files to the Configuration Documents in SmartPlant Foundation Desktop Client

Configuration documents, such as the ROP Configuration.xlsm workbook and XML file, SPCRetrieveMappings.xlsm workbook and XML file, Primavera Schedule Mappings.xlsm and XML file, Primavera Schedule SDK Mappings.xlsm and XML file, and Project Configuration Mappings.xlsm and XML, are managed in the SmartPlant Foundation Desktop Client, allowing users to check in, check out, and sign off the documents.

In order to manage these documents in SmartPlant Foundation Desktop Client, files must be attached to the configuration document. For more information, see Attach template files to configuration documents (on page 81).
Retrieve data into Smart Construction

As a final step of the upgrade process, retrieve data into your Smart Construction project. Retrieving documents is not required, but it is recommended if you are expecting new properties to be mapped because of new retrieve mappings that are delivered with the upgrade. For more information, see Retrieve and refresh data in Smart Construction (on page 100).

Regenerate and re-retrieve PDS composite documents

When PDS documents with the same graphical ID are merged into a composite document and retrieved into Smart Construction, selecting an object in the model may result in the extended selection of additional objects with that same graphical ID. This issue can be fixed in the new version of Smart Construction by performing the following procedure.

1. Recreate the composite documents in SmartPlant Foundation.
2. Retrieve the recreated composite documents into Smart Construction.

Upgrade Smart Construction client workstations

This section details how to upgrade the Smart Construction workstations to the latest version of the software.

- Verify prerequisite software is installed (on page 126)
- Upgrade Smart Construction on a client workstation (on page 126)

Verify prerequisite software is installed

Before you upgrade Smart Construction on a client workstation, verify the installation of the recommended software. For more information, see the Smart Construction Hardware and Software Recommendations (on page 18).

Upgrade Smart Construction on a client workstation

Typically, the upgrade process involves the steps listed below; however, your software may require a slightly different sequence if upgrading from a previous version. For more information, see Upgrade SmartPlant Foundation (on page 114).

1. From the product installation DVD, if the installation does not start automatically, double-click setup.exe.
2. In the Welcome window, click Upgrade.
3. In the Details and Features window, enter your Serial Number, User Name, and Company.
4. In the Select Features To Install section, select Smart Construction Client.
5. In the Smart Construction Server Host Information section, enter the following:
   - Server Host - Name of the Smart Foundation application server.
   - Server Name - Name of the Smart Foundation site on the server to which the client will connect.
6. In the **Install Path** section, enter the path where the software is to be installed.

7. Click **Install**.

   - **TIP** Required information is marked by a red star. The **Install** button is not enabled until all this information is provided.

8. In the **License Agreement** window, from the **Country or Region** list, select your country or region.

9. Carefully read the license agreement. When you are finished, select **I agree to the license agreement and conditions**.

10. Click **Install**.

11. Click **Finish** when the installation is complete.
Appendix A

Configure Smart Construction for Citrix

The following section is useful for organizations that want to run Smart Construction remotely using Citrix®.

★ IMPORTANT Intergraph suggests that you perform administrative activities either on your server computer or on a client computer using a configuration other than Citrix.

★ NOTE For information about running SmartPlant Enterprise products remotely using Citrix®, see the SmartPlant Enterprise Citrix Configuration Guide delivered with SmartPlant Foundation.

System requirements for Citrix servers

Smart Construction prerequisites

To run Smart Construction on a Citrix server, you must install the prerequisite software for Smart Construction on the Citrix server.

Citrix prerequisites

See the Citrix documentation for system hardware and software requirements for the Citrix software.

★ IMPORTANT To install software on a Citrix server, you must log on to the computer as an administrator.

Install Citrix software

Before you configure Smart Construction on the Citrix server, you must install and configure Citrix software on the server. See the Citrix documentation for more information.

Install and configure the software for Citrix

Configure the viewer streaming directory key

1. Browse to and open the SPC.Client.exe.config file. For example, browse to [Drive]\Program Files (x86)\SmartConstruction\2017\SPCClient.
2. In the SPC.Client.exe.config.xml file, locate the <appSettings> node.
3. Edit the value for the ViewerStreamingDirectory key to TEMP. For example, the key would be <add key="ViewerStreamingDirectory" value="TEMP" />.
4. Save and close the SPC.Client.exe.config file.
Create a shared installation

To run Smart Construction software using Citrix, you are not required to install any software on the Citrix server. Instead, you create a shared installation of the software on another server.

Create a shortcut

Because the Smart Construction is a .NET application and requires no installation or registration on a computer for users to run it, you can create a shortcut to the shared installation on the desktop of the Citrix server. For more information about creating shortcuts to applications, see the Microsoft Windows Help.

Then, users can connect to the Citrix server and double-click the Smart Construction shortcut on the desktop to run the software. For more information about connecting to a Citrix server, see the Citrix documentation.

Using Smart Construction with Citrix

Users can connect to their Smart Construction project using Citrix. For information on using Smart Construction, see the Intergraph Smart Construction User's Guide.

NOTES

- In Smart Construction, reports display as PDFs and are opened from a URL on the client application. In order to properly view the report, the application requires elevated security permissions to open the report through the URL when using a temporary profile. You can change the CopyReportsLocal setting in the SPC.Client.exe.config file to True in order to copy the reports to the local machine. The report then opens using an installed PDF viewer. For more information, see Reports do not display in a Citrix environment in the Intergraph Smart Construction Troubleshooting Guide.

- If you are working in a virtual environment, Intergraph recommends that you disable the Motion Fly-To feature to improve your experience. For more information, see Change my preferences in the Intergraph Smart Construction User's Guide.
APPENDIX B

Smart Construction Launch Parameters

Smart Construction supports a set of parameters that can be used when launching the application from the command line. The following section explains the parameters that can be used when launching these applications.

Smart Construction command line parameters

Command line parameters are typically used when launching Smart Construction from another application. They allow you to control who the user logs in as and what plant/project access they have. The command line parameters can also be used to log on to the Smart Construction client.

When launching Smart Construction from the command line, all parameters begin with a slash (/) and require a colon (:) between the parameter and the value. If the value contains spaces, it must be enclosed inside double quotation marks (" "). The parameter values for /Roles: and /P: are case sensitive.

Logon Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/U:</td>
<td>User</td>
</tr>
<tr>
<td>/P:</td>
<td>Password</td>
</tr>
<tr>
<td>/S:</td>
<td>Server</td>
</tr>
<tr>
<td>/H:</td>
<td>Host</td>
</tr>
<tr>
<td>/W:</td>
<td>Web directory</td>
</tr>
<tr>
<td>/Plant:</td>
<td>Plant</td>
</tr>
<tr>
<td>/Project:</td>
<td>Project</td>
</tr>
<tr>
<td>/Roles:</td>
<td>Roles</td>
</tr>
<tr>
<td>/Secure:</td>
<td>True/False: if logging on to server using SSL</td>
</tr>
<tr>
<td>/O:</td>
<td>Opens windows from the Smart Construction Home Page. Use the Workspace Item name in SmartPlant Foundation Desktop Client as the parameter.</td>
</tr>
</tbody>
</table>

**TIP** SPC.Client.exe /? or SPC.Client.exe /help displays help for command line parameters in the command prompt window.
Detailed below is the behavior, depending on what you pass in on the command line:

/U: /P:
This autopopulates the user name and password in the client.

/U: /P: /Plant: /Project: /S:
This logs you in as the user specified with the plant/project specified on the given server if the server is *not* authenticated. The user and password are ignored if the server is authenticated. If the server is authenticated, the logon dialog box displays with the **User name** and **Password** boxes populated, and the **Server** list is set to the correct server.

/U: /P: /Plant: /Project: /H: /W:
This is the same as the previous example, but it uses the host and web directory instead of the server.

/U: /P: /Plant: /Project:
A logon dialog box displays with the **User name** and **Password** boxes populated.

/S: /Plant: /Project:
If the server is authenticated, this logs you on to Smart Construction. If the server is not authenticated, the logon dialog box displays with the **Server** list disabled showing the specified server.

/H: /W: /Plant: /Project:
Same as the previous example except that if the specified Web host and Web directory have not been defined, a new server is created from these. If the new server is authenticated, this logs you on. If the new server is not authenticated, the logon dialog box displays with the **Server** list disabled showing the specified server.

/Plant: /Project:
This displays the logon dialog box, but once you have selected a server and logged on, the specified Plant and Project are honored.

/U: /S: /O:
This logs onto the server and opens a specified window from the Home Page.

**NOTES**
- If you do not specify any command line parameters, the logon dialog box displays.
- If you pick an authenticated server from the list, the **User name** and **Password** are disabled. They are enabled if you pick a server that is not authenticated.
- If a server is not responding, a message box displays to tell the user, and the **OK** button is disabled. The **OK** button is enabled if you select another server that is responding.

**Examples**
- `SPC_Client.exe /U:[UserName] /P:[Password] /S:[ServerName]
- SPC_Client.exe /U:[UserName] /P:[Password] /PLANT:[PlantName] /PROJECT:[ProjectName] /S:[ServerName]
- SPC.Client.exe /U:[UserName] /S:[ServerName] /O:"Work Packages"`
APPENDIX C

Install Smart Construction in Silent Mode

To install Smart Construction software in silent mode, use the installation executable file in a command line with the required information passed as arguments.

For example, the following commands install one of the Smart Construction software components alone:

```
Setup.exe -silent -install ADDLOCAL=SPCCore,SPCClient SLAACCEPT=YES
SERIALNUM=000000000 USERNAME=UserName COMPANYNAME=YourCompany

Setup.exe -silent -install ADDLOCAL=SPCCore,SPCServer SLAACCEPT=YES
SERIALNUM=000000000 USERNAME=UserName COMPANYNAME=YourCompany
```

To install both Smart Construction components, use the following command:

```
Setup.exe -silent -install SLAACCEPT=YES ADDLOCAL=ALL
SERIALNUM=000000000 USERNAME=UserName COMPANYNAME=YourCompany
```

★ IMPORTANT All arguments and values are case-sensitive.

Required silent install parameters

- `-q`, `-quiet`, `-s`, `-silent` Runs in silent mode (no prompts).
- `-install` Performs an installation.
- `SLAACCEPT` Accepts the sales license agreement. Value must be YES.
- `SERIALNUM` Provides the product serial number.
- `USERNAME` Provides the user name associated with the product serial number.
- `COMPANYNAME` Provides the company name associated with the product serial number.
Optional silent install parameters

- **-l, -log**  
  Writes log information to a file.

- **-uninstall**  
  Removes all installed components of the software.

- **-repair**  
  Reinstalls all installed components of the software.

**ADDLOCAL**  
Specifies the components to be installed. Names are case-sensitive.

  For both components, use ALL.

  To install one of the components alone, use SPCCore with one of the following values separated by commas with no spaces, as shown:
  SPCCore,SPCClient
  SPCCore,SPCServer

**INSTALLLOCATION**  
Specifies a path to the location where the software is to be installed.

**REMOVE**  
Specifies the list of features to be removed, separated by commas. Feature names are case-sensitive.
APPENDIX D

Manage Template Files for Smart Construction

Smart Construction has many features that can be personalized and configured to fit your business and project needs using Microsoft Excel workbook template files.

**Smart Construction features that use a template**

The following Smart Construction features use template files:

- Rules of progress
- Importing your schedule in the **Import project data** window
- Importing your Primavera P6 schedule in the **Import project data** window
- Mapping project configuration data for the **Import project data** window
- Mapping retrieve properties
- Materials mapping

**Template delivery location**

The template files are delivered to the **Templates** folder in the Smart Construction installation directory (browse to \[Drive]\:\Program Files (x86)\SmartConstruction\2017\Templates).

**How the templates work**

Each template is a Microsoft Excel file that contains a macro. You configure your data as needed in the template workbook and save it. Then, you click the **Generate** button on the **Main** tab of the template. The **Generate** button starts the macro, generating an XML file. Smart Construction uses the generated XML file to configure data in your project.

Getting the newly configured data into Smart Construction varies per service and feature. For example, Smart Construction automatically pulls the mapping for project configuration and schedule data for the **Import project data** window. You must start a retrieve or refresh work steps in order to pull in the latest Rules of Progress data. And, you must start a retrieve to get the latest retrieve mappings.

**How to manage the files**

Intergraph recommends that you use the document management feature in the SmartPlant Foundation Desktop Client to manage these template files. The SmartPlant Foundation Desktop Client stores the configuration document, allowing users with the proper permissions to check the document out and in with revisions.

Each template (and XML file) has a corresponding configuration document in the SmartPlant Foundation Desktop Client. (You can find these configuration documents by clicking **Smart Construction > Find > Administration > Configuration Documents**).
Manage Template Files for Smart Construction

After you make changes to your template and generate the XML file, Intergraph recommends that you attach the Microsoft Excel file and the XML file to its configuration document in the SmartPlant Foundation Desktop Client. For more information, see Attach template files to configuration documents (on page 81).

**Open a Smart Construction template file**

Smart Construction template files are delivered in the *Templates* folder in the installation location. Intergraph recommends that you manage the files in the SmartPlant Foundation Desktop Client where you can check the documents in and out, and you also can sign off the documents. The SmartPlant Foundation Desktop Client can manage the versions and revisions of the documents. For more information about document management in the SmartPlant Foundation Desktop Client, see the *SmartPlant Foundation Desktop Client User's Guide*.

**IMPORTANT** You must configure a vault for files attached to the configuration document objects in SmartPlant Foundation. For more information, see Configure a vault for files attached to configuration documents (on page 46).

**Opening the file for the first time**

1. Browse to the *Templates* folder in the installation location. For example, browse to `[Drive]\Program Files (x86)\SmartConstruction\2017\Templates`.

2. Open the folder for the template you want to view.

**Opening the template file from SmartPlant Foundation Desktop Client**

1. Log on to SmartPlant Foundation Desktop Client as an administrator.

2. Click **Smart Construction > Find > Administration > Configuration Documents** to open the **Query for Configuration Documents** dialog box.

3. Type your search criteria and click **Finish** to find the configuration documents.

4. In the search results, right-click the configuration document that contains the template and select **Edit > Check out**.

5. Select a location for the file and click **OK**. For more information, see Check in and check out a document in the *SmartPlant Foundation Desktop Client User's Guide*.

**Enable the macro content for the workbook**

1. On the **Security Warning** bar, click **Options**.

2. Select **Enable this content** on the **Microsoft Office Security Options** and click **OK**.
Attach template files to configuration documents

After you configure data in a template file for the first time, you must attach all necessary files (in some cases an Excel workbook and an XML file) to the appropriate configuration document in the SmartPlant Foundation Desktop Client. The SmartPlant Foundation Desktop Client stores the configuration document, allowing users with the proper permissions to check the document out and in with revisions.

**IMPORTANT** Set your Create scope in the SmartPlant Foundation Desktop Client to the configuration top when attaching files to a Smart Construction configuration document.

1. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
2. Type your search criteria and click Finish to find the configuration documents.
3. In the search results, right-click the configuration document and select Files > Attach File to open the Attach File dialog box.
4. Click Add File and browse to the necessary files.
5. Click Open and then click OK to add the files to the list.
6. Click Finish.

Check in and sign off a Smart Construction template file

After making your edits, save the template and generate any XML files, as required. You can then close, check in, and sign off the template file in SmartPlant Foundation Desktop Client.

1. Log on to SmartPlant Foundation Desktop Client as an administrator.
2. Click Smart Construction > Find > Administration > Configuration Documents to open the Query for Configuration Documents dialog box.
3. Type your search criteria and click Finish to find the configuration documents.
4. In the search results, right-click a configuration document, and click Edit > Check In. Select the document and click OK.
5. Sign off the document in the SmartPlant Foundation Desktop Client. For more information, see Sign off on a document in the SmartPlant Foundation Desktop Client User's Guide.
# Smart Construction Acronyms

The following table shows a list of acronyms and associated meanings in this documentation.

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>API</td>
<td>Application Programming Interface</td>
</tr>
<tr>
<td>BOM</td>
<td>Bill of Materials</td>
</tr>
<tr>
<td>CWA</td>
<td>Construction Work Area</td>
</tr>
<tr>
<td>CWP</td>
<td>Construction Work Package</td>
</tr>
<tr>
<td>ENS</td>
<td>Engineering Numbering System</td>
</tr>
<tr>
<td>EPC</td>
<td>Engineering, Procurement, and Construction</td>
</tr>
<tr>
<td>ETA</td>
<td>Estimated Time of Arrival</td>
</tr>
<tr>
<td>EWP</td>
<td>Engineering Work Package</td>
</tr>
<tr>
<td>IWP</td>
<td>Installation Work Package</td>
</tr>
<tr>
<td>MTO</td>
<td>Material Take Off</td>
</tr>
<tr>
<td>ODBC</td>
<td>Open Database Connectivity</td>
</tr>
<tr>
<td>O/O</td>
<td>Owner/Operator</td>
</tr>
<tr>
<td>RFQ</td>
<td>Request for Quotation</td>
</tr>
<tr>
<td>ROP</td>
<td>Rules of Progress</td>
</tr>
<tr>
<td>SDK</td>
<td>Software Development Kit</td>
</tr>
<tr>
<td>SID</td>
<td>Standard Installation Diagram/Detail</td>
</tr>
<tr>
<td>SOW</td>
<td>Scope of Work (can also be Statement of Work)</td>
</tr>
<tr>
<td>WBS</td>
<td>Work Breakdown Structure</td>
</tr>
</tbody>
</table>
**adjustment factor**

Conditions, such as weather or elevation, can affect the performance and productivity of a construction site. An adjustment factor can be applied to a project, individual IWPs, and individual work steps to compensate for any influencing conditions. Adjustment factors calculate the number of hours required to perform a task under project conditions, compared to the number of hours required to perform the same task under standard conditions.

**API**

Application Programming Interface.

**assembly**

Unit composed of a collection of parts or other assemblies. Assembly creation consumes the individual part names and provides the unit a unique identification in the fabrication process.

**authoring tools**

Applications where documents are created and then shared through integration. Can also refer to applications where 3D model data is created. Integrated authoring tools can be third-party applications or Intergraph applications, and include Aspen Basic Engineering, SmartPlant P&ID, SmartPlant Electrical, SmartPlant Instrumentation, Smart 3D, SmartPlant Materials, and SmartPlant Foundation.

**bill of materials (BOM)**

List of material for a node of the work breakdown structure (WBS). It can be created for a Unit, Area, line number, or an ISO.

**complex assembly**

A unit composed of at least one subassembly.

**constraint**

Resources associated with an IWP that are required for activities to be executed and completed.

**construction resource**

Assets that are required for a construction project to be completed. Examples include crew size and duration, permits required for work, and equipment such as cranes.

**Construction Work Area (CWA)**

Definitive amount of space for which construction activities are physically executed within the boundaries of the plant or project. A construction work area (CWA) may be defined geographically or by geographical position and elevation. An active CWA is marked with approved entrance and exit areas based on safety and construction sequence factors. Generally, Construction Work Packages (CWPs) are associated with CWAs.
Construction Work Package (CWP)
A relatively high-level scope of construction work that describes work for 50,000 to 250,000 man hours, depending on the phase of the project. The scope of work described in a CWP contains one discipline and can be broken into multiple IWPs. The contents of a CWP generally include a definition of the work to be performed, the Construction Work Area (CWA), key schedule, budget, safety, equipment, materials, craft dependencies, and constraints. In many cases, CWPs are developed in a fashion so contracts can be issued to a specific contractor or contractors.

contract
A group of documents that are collected and issued for bid, construction, review, and so on.

correlation
The relationship between items that represent the same object in multiple authoring tools.

cost code
Codes used to track, manage, and report specific categories of work on a project.

database
Collection of files of comprehensive information that have predefined structure and organization; a specific program can communicate, interpret, or process these files.

design area
Discrete areas within the project for which major design activities are executed. General projects are broken into key design areas that contain multiple disciplines. Generally, Engineering Work Packages (EWPs) are associated with design areas.

discipline
A specific field of craft, such as piping, electrical, or welding.

document
An object used to track revisions to a design file in the software.

document revision
An officially recognized change to a document.

Engineering Work Package (EWP)
A formal engineering deliverable required of the Engineering, Procurement, Construction (EPC) organization by the Owner or Client. An EWP describes a discrete scope of work to be executed in a fashion to feed the definition of CWPs. Generally there is a one-to-one relationship between an EWP and a CWP, although in some cases a single EWP may result in multiple CWPs. Contents of an EWP generally include key engineering deliverables such as 3D models, drawings, reports, datasheets, and other details required to procure the materials, labor, and other indirect support functions required to construct the package. Typically, an EWP is executed by area and discipline; although, an EWP can be executed by specific units, buildings, processing facilities, etc.
file type
A setting in SmartPlant Foundation that specifies the format of attached files based on file extension. This setting determines how files are viewed, edited, and printed in SmartPlant Foundation.

forecast
Query that determines the status and availability of needed materials at a construction site, location of needed materials, and the estimated time of arrival (ETA) of materials.

hang sequence
Sequenced list of components in an IWP that defines the order in which work should be performed.

heterogeneous environment
An internationalization configuration using elements from different, or even multiple locales. For example, you may enter or view Japanese data on a US/English operating system or use German Regional Settings (where the decimal is a comma) on a US/English operating system.

hierarchy
A structure with superiors, or roots, and subordinates, or dependents, used for grouping data.

homogeneous environment
An internationalization configuration that uses elements from only a single locale. For example, a German customer running on a German operating system using only German characters and German cultural conventions is a fully supported homogeneous environment configuration.

host
A computer that stores files.

implies
The relationship between two interface definitions in the SmartPlant schema. If an interface definition implies another interface definition, then any class definition that realizes the first interface definition can also realize the implied interface definition.

Installation Work Package (IWP)
A detail-level description of construction work. IWPs typically describe an amount of work that a foreman and a 10 person crew can perform in a shift over a one to two week period, generally on the order of 100 to 2,000 man hours. The contents of an IWP are similar to that of a CWP but at a more granular level and include a definition of materials, labor, equipment and other constraints required to execute the IWP. The cumulative progress of the IWPs makes up the progress of their parent CWP.

integration
Technology that standardizes and improves communication among the various SmartPlant Enterprise authoring tools used in design, construction, and operation of a plant. Integration manages data exchange among these authoring tools, which enables sharing and re-use of plant information throughout the plant lifecycle.
**material take off**
Also known as MTO. A list of materials with quantities and types that are required to complete a project.

**module**
A section of an area built and shipped as a unit and interconnected with other modules to form a complete area.

**Plant Breakdown Structure (PBS)**
The composition of the plant based on the grouping of physical objects by their function in the plant. The plant usually occupies the top level of the hierarchy and is typically followed by areas and units.

**progress**
Functionality that allows users to track the development of deliverables, such as documents or items, against a project plan, indicating any deviations from the original plan.

**project**
A logical unit of data that is a subset of the items that make up a plant. A project is used for making controlled, incremental changes to the data in a plant. There can be multiple projects for a plant at any given time.

**property**
An object characteristic.

**publish**
To share a document and its data with other authoring tools by exporting an XML file containing the document data and relationships. When a document is published, the software places the XML file in the appropriate SmartPlant Foundation vault and loads the data from the XML file into the SmartPlant Foundation database. After the document is published, users can retrieve the data from the XML file located in the SmartPlant Foundation vault into other authoring tools.

**query**
A detailed search based on object properties.

**relationship**
An association between two objects.

**relationship definition**
Associations between interface definitions in the SmartPlant schema. Relationship definitions identify two specific objects that fulfill the roles on each end of the relationship.

**reservation**
Reserves materials needed for a project.

**retrieve**
To import document data from an .XML file that was published by another authoring tool for the purpose of maintaining consistency of data across tools. When you retrieve a document, most
authoring tools analyze the impact of the newly retrieved data on the existing database and then place tasks on the authoring tool's To Do List. The tasks on the To Do List allow you to create, delete, or modify items at the appropriate time in the design process.

**revision**

An officially recognized change to a document. Each revision of a document may have multiple versions.

**revision scheme**

A numbering convention for document revisions.

**schema**

A model used to describe and validate the structure of XML files.

**scope of work**

Header information that explains the requirements for a specific contract.

For example: "This contract requires the manufacturing, supply, installation, and commissioning of all civil work as defined in the contract."

**server**

A computer that stores or processes files.

**SI**

International System of Units, sometimes referred to as the metric system. When values for units of measure are published, they are converted to SI units and stored, regardless of the units of measure selected when the user defined the value in the authoring tool.

**SID**

Standard Installation Diagram/Detail. SIDs contain a drawing, fabrication instructions, installation instructions, and material details. SIDs detail the scope of work and method of fabrication and installation for a component and its support items, such as stands, connections, and so forth.

**simple assembly**

A unit composed of only component items.

**SmartPlant Enterprise**

A suite of Intergraph engineering applications that are delivered together.

**spool**

A pipe spool is a piece of pre-assembled pipe and fittings, usually prepared in a shop so that installation on the construction site can be more efficient.

**superseded**

Indicates that a newer, working version of the selected document exists.
**tombstone**

Delete instructions for an object that has been removed in one of the authoring tools. Upon retrieval of a tombstone, delete tasks are created in the authoring tool's **To Do List** to allow the tool to delete the object from its database.

**tool**

See authoring tool.

**unit**

Group of parts of the schematic and individual worlds of a plant that together perform a given process function. The identifying number of the unit is unique within the project and within the plant. Most companies, but not all, use the concept of unit.

**UoM**

A unit of measurement.

**view definition**

A named group of properties extracted from the possible properties that a graph definition exposes. View definitions are used in an integrated environment to provide a different view of data from that provided by the underlying schema.

**Work Breakdown Structure (WBS)**

The composition of the plant based on the construction work to be completed. The plant usually occupies the top level of the hierarchy; it is typically followed by projects, contracts, and documents.

**XML**

Extensible Markup Language; the format for all documents published or retrieved in an integrated environment. These XML files must conform to the structure defined by the SmartPlant schema.
Index

A
Add SPFUsers and enable Local Launch and Local Activation • 26
adjustment factor • 138
After You Install and Set Up Smart Construction • 112
Analyze documents on your Smart Construction site • 38
API • 138
assembly • 138
Associate Smart Construction users with a construction responsibility • 45
Attach files to the Configuration Documents in SmartPlant Foundation Desktop Client • 125
Attach materials template files to the materials system configuration document • 49, 123
Attach template files to configuration documents • 81, 136
Attach the mappings workbook and XML files to the Primavera Schedule SDK Mappings configuration document • 90
Attach the mappings workbook and XML files to the Primavera Schedule Web Mappings configuration document • 98
Attach the Primavera Schedule Mappings workbook and XML files to the Primavera Schedule Mappings configuration document • 66
Attach the Project Configuration Mappings.xlsxm workbook and Project Configuration Mappings.xml file to the Project Configuration Mappings configuration document • 71
Attach the ROP Configuration workbook and XML files to the Rules of Progress configuration document • 57
Attach the SPCRetrieveMappings.xlsxm and XML files to the Retrieve Mappings configuration document • 60
authoring tools • 138
Automatically log on to Smart Construction • 106

B
bill of materials (BOM) • 138

C
Cancel or terminate relationships among objects • 78
Change the PrimaveraWCFServicePool user • 85
Check in and sign off a Smart Construction template file • 82, 136
complex assembly • 138
Configure a materials system with Smart Construction • 47
Configure a schedule system for schedule data import • 83
Configure a User-Defined Field (UDF) in your Smart Construction mapping • 64, 89, 96
Configure a vault for files attached to configuration documents • 46
Configure access groups • 41
Configure and enable the Material Request window • 52
Configure and import project configuration data • 71
Configure and update a materials system • 46
Configure IIS to process large files • 82
Configure mapped properties for a published document • 58
Configure Permissions and Settings for Smart Construction Printing • 25
Configure project configuration mappings and relationships • 68
Configure relationships for project configuration objects • 77
Configure schedule mapping for import • 86, 94
Configure Smart Construction for Citrix • 128
Configure Smart Construction in Server Manager • 30, 116
Configure Smart Construction security • 39
Configure Smart Construction services • 124
Configure SmartPlant Markup Plus and printing for Smart Construction • 25
Configure the Primavera SDK schedule system • 85
Configure the Primavera Web Services schedule system • 93
Configure the rules of progress • 54
Configure the Rules of Progress and Retrieve Mapping for Smart Construction 2017 • 125
Configure the rules of progress in the rules of progress configuration workbook • 54
Configure the Smart Construction Administrator role • 38
Configure the Smart Construction server • 116
Configure users for Smart Construction OnSite • 110
Configure vaults for snapshots and files • 46
Configure your schedule mapping for import • 62
Configuring a schedule system with Primavera P6 SDK • 83
Configuring a schedule system with Primavera P6 Web Services • 92
constraint • 138
construction resource • 138
Construction Work Area (CWA) • 138
Construction Work Package (CWP) • 139
contract • 139
correlation • 139
cost code • 139
Create a new Smart Construction site in Server Manager • 31
Create a new Smart Construction site or import a site in Server Manager • 116
Create a TNS entry for the SmartPlant Materials database • 47
Create and manage role assignments • 40
Create relationships among objects • 77
Create Smart Construction users • 40
Customization information • 20
Customizing the material mappings template • 50

D

database • 139
Delivered project configuration objects and relationships • 70
design area • 139
Disable the rules of progress functionality • 125
discipline • 139
document • 139
document revision • 139

E

Enable the Material Request Form report • 53
Enable the Material Request window and report in Smart Construction • 52
Engineering Work Package (EWP) • 139
Export your schedule from your scheduling software • 62

F

file type • 140
Find project configuration objects in SmartPlant Foundation • 77
forecast • 140

G

Graphics card information • 21

H

hang sequence • 140
heterogeneous environment • 140
hierarchy • 140
homogeneous environment • 140
host • 140

I

implies • 140
Import project configuration data into Smart Construction • 68
Import project data in Smart Construction • 66
Import project data into Smart Construction • 60
Import schedule data into Smart Construction • 91, 98
Import Smart Construction schema • 34, 117
Importing your schedule into Smart Construction • 61
Install and Configure SmartPlant Foundation • 24
Install and Configure SmartPlant License Manager • 22
Install and Configure SmartPlant Markup Plus • 25
Install and configure the software for Citrix • 128
Install and Set Up a Smart Construction Server • 29

Intergraph Smart Construction Installation and Setup Guide
Install and Set Up Smart Construction on Workstations • 105
Install Citrix software • 128
Install prerequisite software • 29, 105
Install Primavera P6 Software Development Kit (SDK) on the Smart Construction server • 84
Install Smart Construction in Silent Mode • 132
Install Smart Construction on a client workstation • 105
Install Smart Construction on the SmartPlant Foundation application server • 29
Install Smart Construction OnSite on your Android device • 111
Install SmartPlant Review and its modules on a client workstation • 106
Install SQL scripts for a SmartPlant Materials database • 48
Install SSL certificates on your mobile device • 110
Installation and location of the workbook • 63, 69, 73, 87, 95
Installation Work Package (IWP) • 140
Integration • 140
Internationalization • 13

L
Licensing • 17
Load Smart Construction administrative files • 37
Load Smart Construction domains • 37
Load Smart Construction upgrade files • 119
Load the materials system administrative file • 122
Load the Plant Breakdown Structure schema • 35, 118
Load the Smart Construction administrative files after the upgrade • 120
Load the work package enumerated list schema • 36, 118
Log on to Smart Construction • 107

M
Make backups • 114
Manage project configuration in SmartPlant Foundation • 76
Manage template files for Smart Construction • 80
Manage Template Files for Smart Construction • 134
Manually create project configuration objects in SmartPlant Foundation • 76
Map properties and generate XML for a Smart Construction retrieve • 59
Mapping arguments for your Smart Construction project data • 65, 89, 97
material take off • 141
module • 141

O
Open a Smart Construction template file • 81, 135
Open Microsoft Excel as the plant application pool user and the SPFRemoteServices user • 28
Open SmartPlant Markup Plus from the plant application pool user • 27

P
Plant Breakdown Structure (PBS) • 141
Preface • 8
Prepare to upgrade to Smart Construction 2017 • 113
Primavera Schedule Mappings.xlsx details • 63
Primavera Schedule SDK Mappings.xlsx details • 87
Primavera Schedule Web Mappings.xlsx details • 95
progress • 141
project • 141
Project Configuration Mappings.xlsx details • 69
Project configuration workbook details • 73
property • 141
Publish • 141
query • 141
Query the Smart Construction Data Migration status • 121

R
Regenerate and re-retrieve PDS composite documents • 126
Register Smart Construction OnSite with the Authorization Server • 110
Reinstalling Smart Construction OnSite • 111
relationship • 141
relationship definition • 141
Remove Smart Construction from a client workstation • 108
Remove SPFRemoteServices and SPFServer users from the Administrators group (Optional) • 26
reservation • 141
Reset IIS application pools and retrieve documents • 54
retrieve • 141
Retrieve and refresh data in Smart Construction • 100
Retrieve data • 102
Retrieve data into Smart Construction • 126
Retrieve documents in Smart Construction • 100
revision • 142
revision scheme • 142
Run database scripts for a Smart Construction site • 31
Run SQL scripts for Smart Construction 2017 • 118
Run SQL scripts if auxiliary table usage has not been enabled • 118

S
schema • 142
scope of work • 142
Search for construction resources • 79
server • 142
Set the default printer • 28
Set up a project forecast in a materials system • 49
Set Up and Configure Smart Construction OnSite • 109
Set Up and Configure Smart Construction Services • 32
Set up the schedule system source • 84, 93
Set up the SmartPlant Materials site API • 48
Set your active scope in SmartPlant Foundation Desktop Client • 32, 117
SI • 142
SID • 142
simple assembly • 142
Smart Construction Acronyms • 137
Smart Construction architecture • 16
Smart Construction client • 19
Smart Construction command line parameters • 130
Smart Construction Hardware and Software Recommendations • 18
Smart Construction Installation and Setup • 11
Smart Construction internationalization • 15
Smart Construction Launch Parameters • 130
Smart Construction licensing • 22
Smart Construction OnSite • 20
Smart Construction server • 18
Smart Construction upgrade sequence • 113
SmartPlant Enterprise • 142
Specify how material items are consumed and generate material items • 122
Specify which work steps consume materials • 51
spool • 142
Start Smart Construction • 107
Start the Smart Construction Data Migration tool • 120
Stop all Smart Construction queues • 116
Structure of the workbook • 63, 69, 73, 87, 95
superseded • 142
System requirements for Citrix servers • 128

T
tombstone • 143
tool • 143
Turn on Smart Construction queues • 100, 120

U
unit • 143
UoM • 143
Update a Commissioning System property on a drawing • 78
Update materials system information in SmartPlant Foundation Desktop Client • 47
Update security for services on the Import Project Data window • 61
Update the Smart Construction site • 116
Upgrade a Smart Construction project with a custom PBS • 123
Upgrade Smart Construction client workstations • 126
<table>
<thead>
<tr>
<th>Upgrade Smart Construction on a client workstation • 126</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upgrade Smart Construction on the SmartPlant Foundation application server • 115</td>
</tr>
<tr>
<td>Upgrade SmartPlant Foundation • 114</td>
</tr>
<tr>
<td>Upgrade the material system configuration • 122</td>
</tr>
<tr>
<td>Upgrade the Smart Construction server • 114</td>
</tr>
<tr>
<td>Upgrade your correlation type • 121</td>
</tr>
<tr>
<td>Upgrading Smart Construction • 113</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule Mappings.xlsm workbook • 66</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule SDK Mappings.xlsm workbook • 91</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the Primavera Schedule Web Mappings.xlsm workbook • 98</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the Project Configuration mapping files • 71</td>
</tr>
<tr>
<td>Use the SmartPlant Foundation Desktop Client to manage the template files • 50, 123</td>
</tr>
<tr>
<td>Using a custom plant breakdown structure (PBS) hierarchy with Smart Construction • 33</td>
</tr>
<tr>
<td>Using Smart Construction with Citrix • 129</td>
</tr>
</tbody>
</table>

**W**

Welcome to Smart Construction • 10

Work Breakdown Structure (WBS) • 143

**X**

XML • 143