Copyright
Copyright © 1999-2016 Intergraph® Corporation. All Rights Reserved. Intergraph is part of Hexagon.

Including software, file formats, and audiovisual displays; may be used pursuant to applicable software license agreement; contains confidential and proprietary information of Intergraph and/or third parties which is protected by copyright law, trade secret law, and international treaty, and may not be provided or otherwise made available without proper authorization from Intergraph Corporation.

Portions of this software are owned by Spatial Corp. © 1986-2016. All Rights Reserved.

Portions of the user interface are copyright © 2012-2016 Telerik AD.

U.S. Government Restricted Rights Legend
Use, duplication, or disclosure by the government is subject to restrictions as set forth below. For civilian agencies: This was developed at private expense and is "restricted computer software" submitted with restricted rights in accordance with subparagraphs (a) through (d) of the Commercial Computer Software - Restricted Rights clause at 52.227-19 of the Federal Acquisition Regulations ("FAR") and its successors, and is unpublished and all rights are reserved under the copyright laws of the United States. For units of the Department of Defense ("DoD"); This is "commercial computer software" as defined at DFARS 252.227-7014 and the rights of the Government are as specified at DFARS 227.7202-3.

Unpublished - rights reserved under the copyright laws of the United States.

Intergraph Corporation
305 Intergraph Way
Madison, AL 35758

Documentation

Other Documentation
Other Documentation shall mean, whether in electronic or printed form and delivered with software or on Intergraph Smart Support, SharePoint, or box.net, any documentation related to work processes, workflows, and best practices that is provided by Intergraph as guidance for using a software product.

Terms of Use
a. Use of a software product and Documentation is subject to the End User License Agreement ("EULA") delivered with the software product unless the Licensee has a valid signed license for this software product with Intergraph Corporation. If the Licensee has a valid signed license for this software product with Intergraph Corporation, the valid signed license shall take precedence and govern the use of this software product and Documentation. Subject to the terms contained within the applicable license agreement, Intergraph Corporation gives Licensee permission to print a reasonable number of copies of the Documentation as defined in the applicable license agreement and delivered with the software product for Licensee's internal, non-commercial use. The Documentation may not be printed for resale or redistribution.

b. For use of Documentation or Other Documentation where end user does not receive a EULA or does not have a valid license agreement with Intergraph, Intergraph grants the Licensee a non-exclusive license to use the Documentation or Other Documentation for Licensee's internal non-commercial use. Intergraph Corporation gives Licensee permission to print a reasonable number of copies of Other Documentation for Licensee's internal, non-commercial use. The Other Documentation may not be printed for resale or redistribution. This license contained in this subsection b) may be terminated at any time and for any reason by Intergraph Corporation by giving written notice to Licensee.

Disclaimer of Warranties
Except for any express warranties as may be stated in the EULA or separate license or separate terms and conditions, Intergraph Corporation disclaims any and all express or implied warranties including, but not limited to the implied warranties of merchantability and fitness for a particular purpose and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of such disclaimer. Intergraph believes the information in this publication is accurate as of its publication date.

The information and the software discussed in this document are subject to change without notice and are subject to applicable technical product descriptions. Intergraph Corporation is not responsible for any error that may appear in this document.
The software, Documentation and Other Documentation discussed in this document are furnished under a license and may be used or copied only in accordance with the terms of this license. THE USER OF THE SOFTWARE IS EXPECTED TO MAKE THE FINAL EVALUATION AS TO THE USEFULNESS OF THE SOFTWARE IN HIS OWN ENVIRONMENT.

Intergraph is not responsible for the accuracy of delivered data including, but not limited to, catalog, reference and symbol data. Users should verify for themselves that the data is accurate and suitable for their project work.

Limitation of Damages

IN NO EVENT WILL INTERGRAPH CORPORATION BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL INCIDENTAL, SPECIAL, OR PUNITIVE DAMAGES, INCLUDING BUT NOT LIMITED TO, LOSS OF USE OR PRODUCTION, LOSS OF REVENUE OR PROFIT, LOSS OF DATA, OR CLAIMS OF THIRD PARTIES, EVEN IF INTERGRAPH CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

UNDER NO CIRCUMSTANCES SHALL INTERGRAPH CORPORATION'S LIABILITY EXCEED THE AMOUNT THAT INTERGRAPH CORPORATION HAS BEEN PAID BY LICENSEE UNDER THIS AGREEMENT AT THE TIME THE CLAIM IS MADE. EXCEPT WHERE PROHIBITED BY APPLICABLE LAW, NO CLAIM, REGARDLESS OF FORM, ARISING OUT OF OR IN CONNECTION WITH THE SUBJECT MATTER OF THIS DOCUMENT MAY BE BROUGHT BY LICENSEE MORE THAN TWO (2) YEARS AFTER THE EVENT GIVING RISE TO THE CAUSE OF ACTION HAS OCCURRED.

IF UNDER THE LAW RULED APPLICABLE ANY PART OF THIS SECTION IS INVALID, THEN INTERGRAPH LIMITS ITS LIABILITY TO THE MAXIMUM EXTENT ALLOWED BY SAID LAW.

Export Controls

Intergraph Corporation’s software products and any third-party Software Products obtained from Intergraph Corporation, its subsidiaries, or distributors (including any Documentation, Other Documentation or technical data related to these products) are subject to the export control laws and regulations of the United States. Diversion contrary to U.S. law is prohibited. These Software Products, and the direct product thereof, must not be exported or re-exported, directly or indirectly (including via remote access) under the following circumstances:

a. To Cuba, Iran, North Korea, Sudan, or Syria, or any national of these countries.
c. To any entity when Licensee knows, or has reason to know, the end use of the Software Product is related to the design, development, production, or use of missiles, chemical, biological, or nuclear weapons, or other un-safeguarded or sensitive nuclear uses.
d. To any entity when Licensee knows, or has reason to know, that an illegal reshipment will take place.

Any questions regarding export or re-export of these Software Products should be addressed to Intergraph Corporation’s Export Compliance Department, Huntsville, Alabama 35894, USA.

Trademarks

Intergraph, the Intergraph logo, PDS, SmartPlant, FrameWorks, I-Sketch, SmartMarine, Intelliship, ISOGEN, SmartSketch, SPOOLGEN, SupportManager, SupportModeler, Sapphire, and Intergraph Smart are trademarks or registered trademarks of Intergraph Corporation or its subsidiaries in the United States and other countries. Hexagon and the Hexagon logo are registered trademarks of Hexagon AB or its subsidiaries. Microsoft and Windows are registered trademarks of Microsoft Corporation. ACIS is a registered trademark of SPATIAL TECHNOLOGY, INC. Infragistics, Presentation Layer Framework, ActiveTreeView Ctrl, ProtoViewCtrl, ActiveThreed Ctrl, ActiveListBar Ctrl, ActiveSplitter, ActiveToolbars Ctrl, ActiveToolbars Plus Ctrl, and ProtoView are trademarks of Infragistics, Inc. Incorporates portions of 2D DCM, 3D DCM, and HLM by Siemens Product Lifecycle Management Software III (GB) Ltd. All rights reserved. Gigasoft is a registered trademark, and ProEssentials a trademark of Gigasoft, Inc. VideoSoft and VXFlexGrid are either registered trademarks or trademarks of ComponentOne LLC 1991-2013. All rights reserved. Oracle, JD Edwards, PeopleSoft, and Retek are registered trademarks of Oracle Corporation and/or its affiliates. Tribon is a trademark of AVEVA Group plc. Alma and act/cut are trademarks of the Alma company. Other brands and product names are trademarks of their respective owners.
## Contents

**Preface** ........................................................................................................................................... 8
  
  What's New in the Installation Guide ................................................................................................. 8

**Installation Overview** ....................................................................................................................... 10
  
  Third-Party Integration ...................................................................................................................... 12
  Installation Checklist .......................................................................................................................... 13

**Internationalization** ......................................................................................................................... 14

**Smart 3D Hardware and Software Recommendations** ................................................................. 17
  
  Smart 3D Database Server Recommendations .................................................................................. 18
  Smart 3D Workstation Recommendations ......................................................................................... 19
  Software Loading Order ...................................................................................................................... 22
  Disk Partitioning Guidelines .............................................................................................................. 25
  Smart 3D Project Hardware Sizing Recommendations ..................................................................... 25
    Concurrent Users ............................................................................................................................... 26
    Project Size Estimates ....................................................................................................................... 26
    Modeling (Detail Design) Workstation Sizing ................................................................................... 27
    System Administrator Workstation Sizing ......................................................................................... 28
    Database Server Sizing ...................................................................................................................... 29
    Global Workshare Configuration Distribution Server Sizing .......................................................... 30
    Interference Checking (IFC) Server Sizing ....................................................................................... 30
    Batch Server Sizing .......................................................................................................................... 30
    File Server Sizing ............................................................................................................................. 31
    License Server and Name Generator Server Sizing ......................................................................... 31
    License Server ................................................................................................................................. 31

**Database Server Setup** .................................................................................................................... 32
  
  Loading Prerequisite Software on the Database Server ....................................................................... 33
  Install Microsoft .NET Framework (Database Server) ........................................................................ 33
  Installing and Configuring Microsoft SQL Server 2012 .................................................................... 34
  Install Microsoft SQL Server 2012 ..................................................................................................... 34
  Install any Required SQL Server 2012 Upgrades .............................................................................. 37
  Verify Automatic Startup of Microsoft SQL Server 2012 Services .................................................... 38
  Register the Microsoft SQL Server .................................................................................................... 38
  Assign System Administrator Privileges for SQL Server 2012 .......................................................... 39
  Create a SQL Server Database Alert .................................................................................................. 40
  SQL Server Port Assignments ............................................................................................................. 42
  Installing and Configuring Microsoft SQL Server 2008 ................................................................... 42
  Install Microsoft SQL Server 2008 .................................................................................................... 43
  Install any Required SQL Server 2008 Upgrades .............................................................................. 45
  Verify Automatic Startup of Microsoft SQL Server 2008 Services ................................................... 45
  Register the Microsoft SQL Server .................................................................................................... 46
Client/Workstation Setup .......................................................................................................................... 81

Loading Prerequisite Software on the Client ........................................................................................... 82
  Install Microsoft Office ................................................................................................................................. 82
  Install Microsoft SQL Server 2012 Client ....................................................................................................... 82
  Install Microsoft SQL Server 2008 Client ....................................................................................................... 85
  Installing and Configuring Oracle Client Software ...................................................................................... 87
    Oracle 11g Release 2 32-bit Client Installation .......................................................................................... 87
    Oracle 11g Release 2 64-bit Client Installation .......................................................................................... 90
    Configure the Oracle Client ....................................................................................................................... 92
    Configure Windows Firewall for the Oracle Client ..................................................................................... 93
  Install Smart 3D Client Software .................................................................................................................. 94
    Civil Task Installation ................................................................................................................................. 96
    Silent Installation ......................................................................................................................................... 103
    Citrix Installations ...................................................................................................................................... 106
    Register Solid Edge .DLL File ..................................................................................................................... 107
    Name Generator Service Setup .................................................................................................................. 108
    Reference Data Setup .................................................................................................................................. 117
    Programming Resources Setup .................................................................................................................. 120
    Smart 3D Tribon Interface Setup ................................................................................................................ 123

Create Databases ........................................................................................................................................ 125

  Create the Site, Catalog, and Schema Databases for SQL .......................................................................... 128
    Add Principle Particular Properties for Structural Manufacturing ............................................................ 132
  Create the Model and Reports Databases for SQL ....................................................................................... 135
    Linking Servers ........................................................................................................................................... 137
  Assign Access Permissions for SQL ................................................................................................................ 138
  Create the Site, Catalog, and Schema Databases for Oracle ....................................................................... 138
  Create the Model and Reports Databases for Oracle ................................................................................... 141
  Minimum Reference Data .............................................................................................................................. 143
  Bulkload SmartPlant Layout Reference Data ............................................................................................... 148
  Convert Database Mode ............................................................................................................................... 149
  Change plant databases to marine ................................................................................................................ 150
Upgrade Database Version .................................................................................................................. 152

Working in an Integrated Environment .......................................................................................... 153
Configure for an Integrated Environment ...................................................................................... 154
Viewing 3D Model Data .................................................................................................................. 155
Install SmartPlant Schema Component ......................................................................................... 155
Integrating with PDS ....................................................................................................................... 155
Install PDS Export Tools ................................................................................................................ 155
Install PDS Data Access .................................................................................................................. 156
Install Smart 3D PDS Model & Data Translators .......................................................................... 157
Integrating with SmartPlant P&ID .................................................................................................. 158
Enable Network Access in Windows Server 2008 .......................................................................... 158
Configure the Piping Specification Remote Access Server Service .............................................. 159
Register the Site Database for P&ID Access ................................................................................... 163
Integrating with SmartPlant Reference Data .................................................................................. 164

Interference Checking Setup .......................................................................................................... 165
Install Database Interference Detection Service ............................................................................. 167
Configure Interference Service Properties ..................................................................................... 167
Start the Database Interference Detection Service ......................................................................... 168
Set IFC Permission Requirements ................................................................................................ 168
Create IFC Permission Group Folder and Permission Group ....................................................... 169
Set IFC Permissions ....................................................................................................................... 170
Check Database Interferences ........................................................................................................ 170
Interference Server Settings Dialog Box ........................................................................................ 172
Database Detect Tab (Interference Server Settings Dialog Box) ................................................... 172
Status Tab (Interference Server Settings Dialog Box) ..................................................................... 174
GSCADFoulCheckCmds.cSetIFCForRestart .................................................................................... 175

Batch Services ............................................................................................................................... 176
Installing Intergraph Batch Services .............................................................................................. 178
Starting and Stopping Batch Services ............................................................................................. 180
Granting Batch Service Privileges .................................................................................................. 181
Configure Account Mappings .......................................................................................................... 182
Create Batch Services Queues ........................................................................................................ 183
Configure Queues for Jobs .............................................................................................................. 184
Making Other Batch Servers Available ........................................................................................ 186
Configuring the Batch Services Server for Drawings Tasks .......................................................... 186

Board Management Service ........................................................................................................... 187
Run the board management service ............................................................................................... 189

Block Assignment Service ............................................................................................................ 190
Block Assignment .......................................................................................................................... 192
Stop the block assignment process ............................................................................................... 194
Contents

Start the block assignment process ................................................................. 194
  Block Assignment Dialog Box ....................................................................... 195
  General Tab (Block Assignment Dialog Box) .................................................. 195
  Configuration Tab (Block Assignment Dialog Box) ......................................... 196

Getting Started .................................................................................................. 198
  Update Site Database Name and Path .............................................................. 198
  Open Smart 3D ............................................................................................... 200
  Configure Your Tasks ..................................................................................... 200
  Define Your Workspace .................................................................................. 201
    Define Workspace Dialog Box ...................................................................... 201
    Defining your Workspace ........................................................................... 205
  Save Session Files .......................................................................................... 205

Application Maintenance .................................................................................... 206
  Modify or Repair Intergraph Smart 3D Software ............................................. 207
  Remove Smart 3D Software ........................................................................... 208

Recommendation for Database Monitoring ......................................................... 209
  Monitoring the Databases .............................................................................. 209
    Disk I/O ........................................................................................................ 209
    Disk Usage ................................................................................................... 210
  Server Monitoring ......................................................................................... 212
  Results Analysis ............................................................................................. 215

Troubleshooting the Software ............................................................................. 218
  User Assistance .............................................................................................. 220
  Customer Assistance ...................................................................................... 222
  Common Acronyms ....................................................................................... 222

SmartPlant License Manager Environment Variables ........................................ 224
  Adding Environment Variables ....................................................................... 224

Core Display Settings ......................................................................................... 226
  Motion Settings .............................................................................................. 226
  View Settings ................................................................................................. 227
  Vendor-Specific Settings ................................................................................. 229

Index .................................................................................................................. 230
Preface

This document is an installation guide for Intergraph Smart™ 3D. The purpose of this document is to explain how to install and configure Smart 3D and all necessary prerequisite software.

**IMPORTANT** This document does not cover basic Windows Server, Windows, Oracle© or Microsoft SQL Server operation. Refer to those products’ printed documentation for basic operation information.

Intergraph® gives you permission to print as many copies of this document as you need for non-commercial use at your company. You cannot print this document for resale or redistribution outside your company.

**NOTE** For information on commands, refer to the online help available inside the software. You can find the most recent guides and online help at Intergraph's Smart Support site: https://smartsupport.intergraph.com.

Documentation Comments

For the latest support information for this product, comments or suggestions about this documentation, and documentation updates for supported software versions, please visit Intergraph Smart Support (https://smartsupport.intergraph.com).

What's New in the Installation Guide

The following changes have been made to the installation guide.

**Hot Fix and Service Pack Updates**

- Added information on enabling password verification in Oracle. For more information, see Password Verification in Oracle (on page 77). (P2 CP:306910)
- Smart 3D now supports Oracle 11g R2 (11.2.0.4) and Microsoft SQL Server 2012 Service Pack 2 (11.0.5058.0).
- Added instructions on how to install the Civil task and upgrade the schema. For more information, see Civil Task Installation (on page 96).
- You can now update all drawings by rule documents with the Full Update action in Intergraph Smart Batch Services. For more information, see Full Update Action. (P1 CP:160700) (P3 CP:199390)

**Version 2014 R1 (10.1)**

- SmartSketch is prerequisite software for material handling mode. For more information, see Smart 3D Workstation Recommendations (on page 19).
- The procedure has changed for Making Other Batch Servers Available (on page 186). (P2 CP:246723)
- Corrected the bulkload mode for Add Principle Particular Properties for Structural Manufacturing (on page 132). (P3 CP:279685)
- Added new information about SQL permissions for Smart 3D users. For more information, see Assign Access Permissions for SQL (on page 138). (P4 CP:261802)
SECTION 1

Installation Overview

This document guides you through the process of installing Intergraph Smart™ 3D. Smart 3D has three industry-specific modes: plant, marine, and material handling. The mode you choose determines the functionality that is available in Smart 3D. Throughout the installation instructions, watch for notes and tips based on the mode you plan to use.

Which mode do I want?
The mode you want depends on your industry.

Plant - The plant mode contains functionality for designing plant systems and structures. This mode is powered by SmartPlant® 3D.

Marine - The marine mode contains all the functionality contained in the plant mode plus functionality for designing ships, offshore platforms, and FPSOs. This mode is powered by SmartMarine® 3D. The marine mode does not support Oracle. You must use Microsoft SQL Server.

Material Handling - The material handling mode contains all the functionality contained in the plant and marine modes plus functionality useful for designing conveyor systems. This mode is powered by SmartPlant 3D Materials Handling Edition®. The material handling mode does not support Oracle. You must use Microsoft SQL Server.

How do I choose a mode?
The mode is set automatically by the site database to which you connect.

- If you are upgrading from a previous version of SmartPlant 3D, you get the plant mode automatically when you upgrade and connect to your site database.
- If you are upgrading from a previous version of SmartMarine 3D, you get the marine mode automatically.
- If you are upgrading from a previous version of SmartPlant 3D Materials Handling Edition, you get the material handling mode automatically.
- If you are creating a new site, the mode is set based on the first catalog database that you add to the site. Three starter catalog databases are available, one for each mode.

Can I move between modes?
At the client computer level, you can switch between modes by connecting to a site with a different mode. For example, from the same client computer, you can connect to a plant site, a marine site, or a material handling site using the Modify Database and Schema Location utility. The functionality available changes depending on the site to which you are connected.

Can I convert a site to another mode?
Yes, with some limitations. Convert Database Mode is a separate utility delivered with the Project Management task in the [Product Folder]Core\Container\Bin\Assemblies\Release folder
as ConvertDatabaseMode.exe. You must have Microsoft SQL Server SysAdmin privileges to the databases on the database server. Using this utility, you can:

- Convert from plant databases to marine databases.
- Convert from plant databases to material handling databases.
- Convert from marine databases to material handling databases.

When converting databases, be aware of the following limitations:

- You can only convert Microsoft SQL Server databases. Oracle is not supported.
- Replicated databases must be consolidated before conversion. This utility supports only non-replicated databases.
- You cannot convert:
  - marine to plant,
  - material handling to plant
  - material handling to marine.

**Getting Started with the Installation**

Step-by-step instructions are provided whenever possible. However, because of operating system and database updates released after this document was published, the steps provided in this document might not reflect the new updated workflow. Please be prepared to use your technical knowledge to perform the same overall workflow.

After reading the *Internationalization* (on page 14) information, please review the *Smart 3D Hardware and Software Recommendations* (on page 17) section carefully before you proceed to *Database Server Setup* (on page 32).
**Work Process Diagram**

**Third-Party Integration**

**Equipment Modeling Capability**

Whether using one of the delivered symbols or a custom symbol that you define yourself, symbols are a key building block used to create your model. The software uses two basic types of symbols: 2D and 3D.

The 2D symbols are used to represent structural member cross-sections. Two-dimensional symbols for structural cross-sections are delivered in the `[Product Folder]\SharedContent\CrossSections` and `[Product Folder]\SharedContent\Profile Xsections` folders. You can use any of the defined cross-sections or define your own cross-sections using the software's 2D Symbols application. This application allows you to define different representations for the cross-section using layers. You can also define variables to drive the dimensions of the cross-section symbol.

An extensive library of 3D symbols is delivered in the various subfolders located in the `[Product Folder]\SharedContent` folder on the reference data server computer. The 3D symbols are used to represent equipment, hangers, HVAC components, piping components, and so forth in your model. You can also create custom three-dimensional symbols using the SmartPlant 3D Symbol/Part Definition Wizard.

The SmartPlant 3D Symbol/Part Definition Wizard allows you to create and customize three-dimensional symbols that fit your company or project. The wizard produces a Visual Basic® project for building the symbol ports and graphics, and generates an Excel workbook for bulkloading the symbol data into the Catalog database.
While not prerequisite software, you can also use Solid Edge with Smart 3D. With Solid Edge, you can build intelligent equipment reference data libraries of base parts that can be placed into the Smart 3D model. An entire catalog of standard equipment can be modeled with Solid Edge, as well as custom, one-of-a-kind equipment for specific plants.

Additional information on the software’s equipment modeling capabilities, including parameter descriptions of the delivered symbols, how to create 2D and 3D symbols and incorporate them into your reference data, is available in the *Smart 3D Reference Data Guide*, the *2D Symbols User’s Guide*, and the 3D symbols documents for Piping, HVAC, Equipment, Electrical, and Structure tasks. Each of these documents is available from **Help > Printable Guides** in the software.

**Isometric Drawing Capability**

The software’s isometric drawing interface gives users the ability to create piping isometric drawings by extracting data from 3D models. Additionally, the Smart 3D isometric drawing interface works with ISOGEN® software that not only enables users to create piping isometric drawings, including dimensioning, but that also allows users to generate notes, recognize attribute changes, and define which symbols to use in the final drawings. Knowledge of isometric drawings is required to effectively utilize this functionality. For more information on isometric drawing capabilities, see the *Piping Isometric Drawings User’s Guide*.

**Installation Checklist**

For the recommended installation workflow, please see the installation checklist (S3DInstall_Checklist.pdf), available in the Help folder on the product media. This checklist is also delivered during product set up to C:\Program Files (x86)\Common Files\Intergraph\Smart3D\Help folder for future reference.
SECTION 2

Internationalization

Supporting internationalization in a homogeneous environment is one of the enhancements available in SmartPlant Enterprise. A homogeneous environment uses elements from only a single locale. For example, a German customer running on a German operating system using only German characters and German cultural conventions is a fully supported homogeneous environment configuration.

Homogeneous Environments

When starting a new project, use extra care during installation and configuration to ensure the proper creation and maintenance of homogeneous environments:

- All the computers (servers and clients) within an integrated SmartPlant Enterprise implementation must have the same regional settings, and no one should change the regional settings after the project has started.
- Do not cross the decimal locale boundary. This is the most common cause of numeric data corruption and calculation errors. Having users with different regional settings (such as with a period versus a comma for the decimal point) causes the software to interpret values unpredictably. For example, a pipe run with a pressure of 35.3 psi can be read by the software as 353 psi to the user with different regional settings. A cable length defined as 39 ft 11.21 inches has been interpreted as 121718910971323 meters when published to an XML file. These incorrect interpretations may be used in internal software calculations and can be impossible to backtrack or correct. Do not change the decimal point character to try to solve an issue. Doing so will only corrupt values in the database or in text files.
- Do not cross the character-set locale boundary. For example, the character set boundary between Western (Latin-based) and Eastern Europe (Cyrillic-based), or between Eastern Europe and Japan.
- Create Oracle databases using AL32UTF8 for the database character set and AL16UTF16 for the NLS character set.
- Never modify the NLS_LANG registry entry on an Oracle client. Doing so causes the character data not to convert to Unicode.
- Create Microsoft SQL Server databases with locale-specific collation settings and ensure that all databases have the same setting.

Heterogeneous Environments

In contrast, a heterogeneous environment using elements from different, or even multiple locales, is not supported. Many customers are currently operating in unsupported heterogeneous environments and are often not aware of that fact. Examples of heterogeneous environments:

- Entering or viewing Japanese data on an US/English operating system
- Using German Regional Settings (where the decimal point is a comma) on a US/English operating system
Internationalization

- Using databases with different character encodings such as CL8MSWIN1251 or JA16SJIS
- Using multiple languages in a project, especially when crossing language-group boundaries
- Using an English server with different local language clients

International / Bi-lingual Projects

International bi-lingual projects are possible; however, great care must be used when configuring these environments. Limitations exist and must be properly understood:

- Oracle and MS SQL Server databases can reside on any language operating system, as long as the databases have been created and configured with proper Unicode and collation settings.

- All SQL Server databases must have the same collation setting and reflect the master language. Text is stored, sorted, indexed, and presented based on the collation setting. You must determine which language will be used primarily to generate output (P&IDs, SLDs, reports, approval documents, and so forth.) If Russian and English text is entered, and Russian is the target locale, choose the collation based on the Cyrillic character set.

- All Microsoft operating systems (Japanese, Russian, German, and so forth) can enter English characters. The reverse, however, is not true in most cases.

- Keyboard-locale can be changed as long as a character-set and code-page boundary is not crossed. For example, English, German, French, and Spanish characters can all be used in the same project because the same Windows® code-page (1252) is used. However, Russian characters (code-page 1251) cannot be used in a US/English environment.

- You must decide which language operating system is the master for bi-lingual projects.

The following is an example of a Russian-based project:

Companies in the United States and the United Kingdom are working a project with a Russian company and the deliverables (drawings, reports, and so forth) must ultimately be provided in Russian. The companies in the U.S. and the U.K. are working the project using the master Russian operating systems (possibly using virtual Russian operating systems running on VMware Workstation). The U.S. and U.K. companies can install and use English Microsoft Office products on the Russian operating system because Office products are globally enabled. If a Russian interface exists for the SmartPlant Enterprise application, then Russian users can use the Russian interface while the English-speaking users continue to use the US/English interface. English-speaking engineers can enter English characters. Russian-speaking engineers can enter Russian characters.

However, because the Russian locale uses different decimal and character-set locales, everyone (English and Russian engineers) must use the Russian decimal symbol which is a comma. For customization purposes, databases can be modified to accommodate new Russian-specific requirements (fields, properties, and so forth.) Using filters, display sets, and other software features, bi-lingual projects can be further customized. Graphic data, reports, and so forth can be created in either or both languages.

**CAUTION** Do not change regional settings to reflect a U.S. environment in order to resolve problems in a non-US/English homogeneous configuration. Doing this creates a heterogeneous configuration that will cause other possibly hidden problems that cannot be corrected. Everyone working on a project must use the same regional settings and character set throughout the life of the project.
Citrix XenApp Solutions for International Projects

Using Citrix XenApp Solutions, you can define environments that isolate users from having to interact with non-native language operating systems while improving data integrity and minimizing opportunities for data corruption. However, users must enter data using master locale conventions for the project (decimal separator and date conventions, for example). You can create these environments using different combinations of languages, but some limitations exist. For example, you cannot use Russian and Chinese text together in a project. In addition, special language characters (the German ä and ß for example) cannot be used if the master locale is outside the western Latin-based languages (the master locale is Russian, Chinese, Japanese, or Korean, for example).

Questions and Assistance

Please contact your support representative for assistance and answers to your questions: see Intergraph Customer Support.
A typical data flow between client and server computers is shown below. Before beginning an installation of Smart 3D, verify that your computers meet the hardware recommendations and software requirements.

**NOTE** Multiple services can be installed on the same physical computer for small projects.
In This Section
Smart 3D Database Server Recommendations ...................... 18
Smart 3D Workstation Recommendations ............................. 19
Software Loading Order .................................................. 22
Disk Partitioning Guidelines .............................................. 25
Smart 3D Project Hardware Sizing Recommendations ............ 25

Smart 3D Database Server Recommendations
Before beginning an installation of Smart 3D, verify that your servers meet the following hardware recommendations and software requirements.

Applicable Hardware
- Database server
- File server

Hardware Recommendations
- Intel Xeon® 5600 Series or better (64-bit instruction set, not Itanium®)
- 16 GB to 64 GB or greater RAM depending on project size
- For hard drive size, see Smart 3D Project Hardware Sizing Recommendations (on page 25)
- Backup system for server
- Access to DVD drive, either locally or through a network connection
- 1 GbE or higher network interface for client connections

Supported Operating Systems
- Microsoft Windows Standard/Enterprise Server 2008 R2 (64-bit)

Supported Database Servers
- Microsoft SQL Server 2012 Service Pack 2 (Standard edition for stand-alone environments; Enterprise edition for Global Workshare environments; 64-bit) (available for plant, marine, and material handling modes)
- Microsoft SQL Server 2008 Service Pack 3 (Standard edition for stand-alone environments; Enterprise edition for Global Workshare environments; 64-bit) (available for plant, marine, and material handling modes)
- Oracle 11g R2 (11.2.0.4) (Standard edition or Enterprise edition 64-bit) (available for plant mode only)
- Oracle 11g R2 (11.2.0.2) with Patch 22 (Standard edition or Enterprise edition 64-bit) (available for plant mode only)
  - If you are going to use Oracle in a Global Workshare configuration, you also need Oracle GoldenGate 11.2.1.0.3, which is separately purchased from Oracle.
There are internationalization considerations concerning the SQL Server collation settings you specify that relate to reference data, using SmartPlant Enterprise integrated systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to future releases. Please contact Intergraph Customer Support for specific configuration questions.

Software Prerequisites

- Adobe Reader (required to view the Software License Agreement and Printable Guides. You can download Acrobat Reader from the Adobe web site.)
- Microsoft XML Core Services (MSXML) 6.0 (Database server only)
- Microsoft .NET 4.5 (Database server only)

**NOTES**

- For more information on hardware requirements, see *Smart 3D Project Hardware Sizing Recommendations* (on page 25).
- For information on disk space usage and determining RAID configuration, see *Disk Usage* (on page 210).
- For specifications regarding minimum hard drive disk space requirements by the product setup, see *Disk Partitioning Guidelines* (on page 25).
- On the server, distribute files across several disk drives with the following minimum distribution: operating system and database software on one drive, database data files on another drive, and the database log file on the third drive.
- Ensure that your system’s security certificates are updated prior to installation.

**See Also**

*Smart 3D Hardware and Software Recommendations* (on page 17)

**Smart 3D Workstation Recommendations**

Before beginning the installation of Smart 3D, verify that your end-user workstation computers meet the following hardware recommendations and software requirements.

**Applicable Hardware**

- Administrative client
- Modeling client
- Interference detection computer
- Drawings batch computer
- Name generator computer
- Duplication and synchronization computer
- SmartPlant Piping Specification Remote computer

**Hardware Recommendations**

- Intel Core i7, Quad Core
- 6 GB RAM (2 GB RAM for operating system plus 4 GB RAM for single Smart 3D instance. Other concurrently running programs will require additional RAM based on the programs specific requirements.)
- Access to a DVD drive, either locally or through a network connection
- Monitor capable of a minimum of 1280 x 1024 resolution
- Graphics card designed for 3D intensive applications that meets the following requirements:
  - 32-bit main RGBA pixel buffer
  - Hardware OpenGL 2.1 support
  - Hardware Z buffer: 24 bit or higher
  - 256 MB RAM
  - 8-bit stencil buffer
  - Hardware Alpha blending support
  - Graphics acceleration set to full
  - Hardware Anti-aliasing support recommended
  - Latest available drivers should be installed
- 1 GbE network interface

**Video Cards**

There have been many enhancements to the graphic engine of Smart 3D. Most issues are resolved by loading the most current display driver or rolling your current display driver back one version. If the current driver does not fix your particular card's problem, then please copy the "CoreDisplaySettings.ini" file from [Product Folder]/Core/Tools/Administrator/Bin to [Product Folder]/Core/Shared/bin and contact your Smart 3D support representative.

We recommend workstation class graphics cards (designed for use with CAD applications) with as much RAM as is affordable. The minimum RAM is 256MB, but more RAM is better. Because the world of graphics cards changes so quickly, we can only document the specifications required by Smart 3D.

**NOTE** All clients referencing Z+F Point Cloud data need to turn off the Smart 3D hardware with the CoreDisplaySettings.ini file.

As a supplement to this information, a Microsoft Excel workbook is provided on Intergraph Smart Support that records anecdotal evidence obtained from users. Please go to Intergraph Smart Support at [https://smartsupport.intergraph.com](https://smartsupport.intergraph.com) and select View Downloads > Smart 3D > Technical Notes and White papers > Display > Graphics cards used with Smart 3D. This list is not comprehensive. In some cases, the Smart 3D middle tier error log (with the error logging level set to at least "2-Detailed") will provide more information. Please see the examples of messages returned in the error log listed below:

- The graphics card or graphics card driver does not support Textures/Shaders. An updated graphics driver could improve performance.
  
  This indicates that the graphics adapter, driver or display settings do not support the "Shaded with Hardware Enhanced Edges" Render Mode on the Format View dialog box. In addition, the graphics adapter, driver or display settings do not support textures.
The graphics card or graphics card driver does not support Shaders. An updated graphics driver could improve performance.

This indicates that the graphics adapter, driver or display settings do not support the "Shaded with Hardware Enhanced Edges" Render Mode on the Format View dialog box. However, textures are supported.

The graphics card or graphics card driver does not support Textures. An updated graphics driver could improve performance.

This indicates that the graphics adapter, driver or display settings do not support textures. However, the "Shaded with Hardware Enhanced Edges" Render Mode on the Format View dialog box is supported. Please note that the performance may be slow on an ATI card.

Hardware Acceleration is Turned off VBO Texture and Hardware edges will not be supported.

This message indicates that Hardware Acceleration in Display Settings is disabled or the client is being accessed via Remote Desktop or Citrix Client. If Hardware Acceleration in Display Settings is disabled, it should be enabled by selecting the "Advanced" button on the Settings tab of the Display Properties dialog. Then, the Hardware Acceleration can be modified from the Troubleshoot tab.

IMPORTANT Due to the 32-bit precision limitations of graphic cards, you may need to create several design coordinate systems so that the objects being modeled are within 10,000 meters (6.2 miles) of the global coordinate system. Objects modeled outside this limit will not display correctly. If your model coordinate values are larger than this limit (for example, E = 20,000, N = 30,000), to get the coordinate readout that you want, you should define a coordinate system at correspondingly large negative values (example, E = -20,000, N = -30,000). Then, use the coordinate system that you created as your active coordinate system for modeling and output. Do not bring this new coordinate system into your workspace, or you will have the display problems that you are trying to avoid. In addition to the 10,000 meter global coordinate system limit described above, the marine mode is limited to a 5,000 meter cube.

Supported Operating Systems

- Microsoft Windows 7 Service Pack 1 - Professional or Enterprise with UAC 'On' at Level 3 (Default) (64-bit)
- Microsoft Windows Server 2008 R2 (64-bit) only as a client for Citrix XENDesktop 7.0

NOTE Citrix XENDesktop 7.0 can be installed only on the Windows 2008 Server R2 64-bit operating system. The Windows 2008 Server acts as a client in this case. The Windows 2008 Server R2 64-bit operating system can also be used to install an ancillary server, such as IFC, Drawings, or Batch Services.

Supported Database Clients

- Microsoft SQL Server 2008 Standard Service Pack 3 (64-bit) (Required for Project Management and Interference Checking, otherwise optional)
- Microsoft SQL Server 2012 Standard Service Pack 2 (64-bit) (Required for Project Management and Interference Checking, otherwise optional)
- Oracle 11g R2 (11.2.0.2) with Patch 22; 32-bit Oracle client only (Required for all client computers) (Plant mode only)
Software Prerequisites

- Oracle 11g R2 (11.2.0.4) 32-bit Oracle client only (Required for all client computers) (Plant mode only)

- Microsoft Internet Explorer 9.0 or later (required for viewing the documentation delivered with the software)

- Adobe Reader 9.0 or later (required for viewing Printable Guides. You can download Acrobat Reader from the Adobe web site.)

- Microsoft .NET Framework 4.5

- Microsoft XML Core Services (MSXML) 6.0 SP1

- Microsoft Office 2010 (32-bit only) (Windows 7 or Windows Server 2008 R2)

- Intergraph Batch Services 2010 SP1 (06.01.08.00 or later) if you plan to use the computer for remote batch processing

- Intergraph SmartSketch 2014 (08.00.00.98 or later), if you are using material handling mode. You must separately purchase SmartSketch (SGBY297AV).

**NOTES**

- For specifications regarding minimum hard drive disk space requirements by the product setup, see Disk Partitioning Guidelines (on page 25).

- Dual screen configurations should have either a single graphics card with two VGA outputs or two identical graphics cards. The graphics cards should otherwise meet the requirements of the specified graphics card recommendations.

- Use thread safe video drivers and CAD application certified video cards when using multiple processor systems.

- Ensure that your system's security certificates are updated prior to installation.

See Also

*Smart 3D Hardware and Software Recommendations* (on page 17)

## Software Loading Order

The ability to run the software successfully is greatly affected by the order in which all the necessary and underlying products are loaded. Follow the loading order below to prevent components being out-of-sync. Following this loading order also helps with analysis of any post-installation problems you might encounter.

The following table outlines the established load order for the prerequisites associated with each of the Smart 3D installations:

<table>
<thead>
<tr>
<th>Database Server Installation</th>
<th>Workstation Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2 SP1 (64-bit)</td>
<td>Windows 7 SP1 Professional or Enterprise with UAC 'On' at Level 3 (Default) (64-bit)</td>
</tr>
<tr>
<td>Microsoft .NET 4.5</td>
<td>Microsoft .NET Framework 4.5</td>
</tr>
</tbody>
</table>
### Smart 3D Hardware and Software Recommendations

<table>
<thead>
<tr>
<th>Database Server Installation</th>
<th>Workstation Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer 9.0 or greater</td>
<td>Microsoft XML 6.0</td>
</tr>
<tr>
<td><strong>NOTE</strong>: Microsoft SQL Server 2008 requires XML 6.0 and will automatically install it as part of the SQL Server 2008 Prerequisite installation.</td>
<td></td>
</tr>
<tr>
<td>Adobe Reader</td>
<td>Adobe Reader</td>
</tr>
<tr>
<td><strong>Office 2010 (32-bit)</strong></td>
<td>Oracle 11g R2 (11.2.0.2) with Patch 22 (Standard Edition or Enterprise Edition 64-bit)</td>
</tr>
<tr>
<td><strong>-OR-</strong></td>
<td>Oracle 11g R2 (11.2.0.2) with Patch 22 Client Release 32-bit; (Do not use the Oracle “light client” as it does not include some DLLs required by Smart 3D.)</td>
</tr>
<tr>
<td>Oracle 11g R2 (11.2.0.4) (Standard Edition or Enterprise Edition 64-bit)</td>
<td>Oracle 11g R2 (11.2.0.2) with Patch 22 Client Release 64-bit is required if you are running 64-bit Interference Checking or 64-bit Drawings Batch.</td>
</tr>
<tr>
<td><strong>-OR-</strong></td>
<td>Oracle 11g R2 (11.2.0.4) 64-bit is required if you are running 64-bit Interference Checking or 64-bit Drawings Batch.</td>
</tr>
<tr>
<td>Microsoft SQL Server 2008 Service Pack 3</td>
<td>Microsoft SQL Server 2008 Client Service Pack 3; (64-bit)</td>
</tr>
<tr>
<td><strong>-OR-</strong></td>
<td>Microsoft SQL Server 2012 Client Service Pack 2; (64-bit)</td>
</tr>
<tr>
<td>Microsoft SQL Server 2012 Service Pack 2 (Standard Edition for stand-alone environments; Enterprise Edition for Global Workshare environments; 64-bit)</td>
<td>SmartPlant License Manager 2010 (11.0) or higher</td>
</tr>
<tr>
<td>SmartSketch 2014 (08.00.00.98 or later), if you are using material handling mode.</td>
<td>Install other Intergraph SmartPlant applications, such as SmartPlant P&amp;ID, before you install Smart 3D if you plan to run both applications on the same computer. Always install Smart 3D last.</td>
</tr>
</tbody>
</table>
Microsoft SQL Server Client is required only for the client software installation if the **Project Management** option is installed; otherwise, they are not integral to the default workstation software installation.

When creating drawing borders or embedded reports within the Drawings and Reports task on computers with Office 2010 (32-bit), you must modify the security settings in Microsoft Excel to allow Visual Basic projects to run. For more information about Office 2010 and service packs, refer to the Microsoft web site (http://www.microsoft.com/).

Oracle is an available database only if you are running in plant mode.

**IMPORTANT** Do not skip any restarts that are recommended by the system. Doing so can have unintended consequences.

Other users who want to perform different tasks in the overall design workflow might need additional software, such as:

- Visual Basic 6.0
- Visual Studio 2008 SP1
- Siemens Solid Edge Version 20 or ST3
- MicroStation J (V7) - only required if 3D DGN output will be created. MicroStation J (V7) has a 32MB DGN file size limit. MicroStation 8 can be used to open DGN files created with MicroStation J (V7).
- Leica Cyclone 7.4.1 or 8
- Leica CloudWorx for Smart 3D 1.2.5
- Tekla Structures Version 19

Additionally, if you intend to reference or export PDS projects, you must install the appropriate PDS add-in. The PDS data reference and export add-ins are delivered on the product DVD.

**NOTES**

- This version of the software supports PDS 2010 SE and PDS 2011 SE.
- PDS software and all of its prerequisite software are also required in order to use the PDS integration functionality. For more information, see **Integrating with PDS** (on page 155).
- If you are installing the Name Generator Service on an Oracle 32-bit Client computer, the computer must be configured to access the Oracle database server through Net Manager.
- If you are installing the 64-bit Name Generator Service on an Oracle 64-bit database server computer, the firewall must be configured to allow DCOM Dynamic Ports. For more information, see **Configure the Firewall to Allow DCOM Communication in Windows 2008 Server** (on page 115).

**Special Consideration for Non-English Locales**

The system language specified for Microsoft Office must be the same as the system language specified by the operating system. For example, if your operating system language is English, Microsoft Office must also be set to English. For overall assistance with installing the software in a non-US English environment, visit the Intergraph Support web site at http://www.intergraph.com/support.

**Virus Scanners and Performance**

Other programs running on the computer, such as virus scanners, media players, and mail programs, might affect the performance of Smart 3D. Virus scanners affect performance by continuously checking the data files and log files. Exclude the database data folder on the
database server from the virus scanner. For maximum performance, reduce the number of processes running while using Smart 3D.

See Also
Smart 3D Hardware and Software Recommendations (on page 17)

Disk Partitioning Guidelines

For best performance when loading and running the software, partition the hard drive according to the following guidelines:

- Format all partitions as NTFS file systems.
- By default, the software is installed to your C: partition. Verify that you have sufficient free space on your C: partition (or another partition if you want to install there).

Recommended Disk Space for Software Setup

<table>
<thead>
<tr>
<th>Setup</th>
<th>Disk Space</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart 3D default installation for a workstation computer¹</td>
<td>1.8 GB</td>
</tr>
<tr>
<td>Smart 3D complete installation for an administrative computer²</td>
<td>2.85 GB</td>
</tr>
<tr>
<td>Reference Data installation</td>
<td>3.25 GB</td>
</tr>
<tr>
<td>Name Generator installation</td>
<td>13 MB</td>
</tr>
<tr>
<td>Programming Resources installation</td>
<td>670 MB</td>
</tr>
</tbody>
</table>

¹ The default setup for a Smart 3D workstation computer provides all the environments necessary for general Smart 3D modeling.

² The complete setup for a Smart 3D workstation computer includes all features and adds the administrative functionality: plant creation, database migration, access management, database interference detection, and includes the following options only: Project Management, Server Connectivity, Bulkload Reference Data, and Database Interference Detection Service. Additionally, a complete setup includes the Piping Specification Remote Access Server option, which installs the necessary software for correlating piping specification data between Smart 3D and SmartPlant P&ID, respectively.

You also will need additional disk space if you intend to use other products, such as Visual Studio or Solid Edge. Please consult your system administrator for this and additional software not provided by Intergraph.

CAUTION: Do not continue with installation until enough disk space is free on the computer acting as the database server and each workstation computer as stated in the aforementioned guidelines.

Smart 3D Project Hardware Sizing Recommendations

Use these guidelines and examples in sizing Smart 3D hardware configurations, including those that include Global Workshare Configuration (GWC).

Hardware sizing, especially for servers, depends on many factors such as:

- The number of concurrent users per site
Smart 3D Hardware and Software Recommendations

- The number of sites (Global workshare)
- The size of the project (which translates into the size of the databases)
- Other software that is running on the machine

For best performance in medium to large Global Workshare Configurations, we recommend using 64-bit hardware and operating system.

With a Microsoft SQL database on 64-bit hardware and operating system, Smart 3D was tested with 11 Global Workshare sites. The 64-bit version of Oracle can support a few more sites.

**Concurrent Users**

The size of the system depends partly on the number of concurrent users, that is, users actively working at the same time. In a Global Workshare Configuration (GWC), it is probable that work will be done at several sites in a non-concurrent way. In this case, there is less impact on performance. For example, if you have two sites with 60 users at each site but the users at the two sites do not work at the same time, you could consider the user load to be 60 users.

In a Global Workshare Configuration when users are working concurrently at several sites, the work done at one site will impact each site as the data is pushed to the other sites. In a hub and spokes configuration, the data is first pushed to the hub then the hub pushes it to the other sites. We estimate that the equivalent user load (the number of effective users) for each server to be the users on that server plus 25% of the total concurrent users of all the other sites. For example, in a configuration with 6 sites and 40 users at 5 sites, and 5 users at 1 site:

- When 3 sites (with 40 users) are working concurrently, the equivalent number of users at each site is: 40 (concurrent users for this site) + (0.25 * (2 * 40)) (users for the 2 other sites) = 60 users.
- When all 6 sites are working concurrently:
  a. The equivalent number of users at each of the 40-user sites is: 40 + (0.25 * (165)) = 81 users
  b. The equivalent number of users at the 5-user site is: 5 + (0.25 * (200)) = 55 users.

**Project Size Estimates**

Use the following estimates to help define project size. The model database is an important factor in determining project size.

The number of users for each project size below (small, medium, and large) is the effective number connected to a single server. The effective number of users should be calculated by taking into consideration:

1. Global Workshare Setup - use the 25% formula above
2. Drawing Batch server - add 3 users
3. Remote IFC - add 1 user

**One small project**

- 1 to 15 effective users on one database server
- 16 GB of RAM recommended
- Model database up to 5 GB
- Server is used for model and catalog databases and catalog file server
- Separate interference checking (IFC) computer
- Separate drawing batch computer
- Name generator server and licensing computer
- Modeling (detail design) and administrator workstations can be on separate or on the same computers

One medium project
- 16 to 50 effective users on one database server
- 32 GB of RAM recommended
- Model database 6 - 20 GB
- Databases and catalog file server
- Separate interference checking (IFC) computer
- One or more separate drawing batch computer
- Name generator server and licensing computer
- Modeling (detail design) and administrator computers can be on separate or on the same computer
- Use a separate distribution server for Global Workshare Configuration

One large project
- 51 to 100 effective users on one database server (contact Intergraph if you plan to have more than 100 effective users on one database server)
- 64 GB of RAM recommended
- Model database 20 GB or more
- Databases and catalog file server (have a separate catalog file server for multiple large projects or plants sharing the same catalog)
- Separate interference checking (IFC) computer
- Multiple separate drawing batch computer
- Name generator server and licensing computer
- Modeling (detail design) computers
- Use a separate distribution server for Global Workshare Configuration
- Administrator computer

Modeling (Detail Design) Workstation Sizing

The project size does not have a significant impact on the workstation because users will use filters to define the objects with which they will be working.
- Intel Core i7, Quad Core
- 6 GB RAM (2 GB RAM for operating system plus 4 GB RAM for single Smart 3D instance. Other concurrently running programs will require additional RAM based on the programs specific requirements.)
- Access to a DVD drive, either locally or through a network connection
- Monitor capable of a minimum of 1280 x 1024 resolution
- 1 GbE network interface

**OpenGL Graphics Cards**

**NOTE** The following graphics card information is specific to 32-bit workstations. Intergraph is investigating graphics cards for 64-bit workstations.

Graphics cards designed for 3D intensive applications that generate low CPU overhead and meet the following requirements (AGP or better):
- 32-bit main RGBA pixel buffer
- Hardware OpenGL 2.1 support
- Hardware Z buffer: 24 bit or higher
- 256 MB RAM, 8-bit stencil buffer
- Hardware Alpha blending support recommended to improve speed of translucent object display
- Hardware Anti-aliasing support recommended
- Use latest available drivers

Not all OpenGL graphics cards provide satisfactory results. Many of the recent generation video cards provide some level of OpenGL acceleration. Some manufacturers provide poor OpenGL drivers that can cause artifacts. Testing has shown that NVIDIA provides good drivers for its Geforce2 and beyond Graphics Processing Units (GPU). Cards with double-buffered overlay planes (such as the Wildcat cards) have an advantage because highlighting can be done without having to do saves and restores, which may benefit performance in specific cases.

**See Also**

*Smart 3D Workstation Recommendations* (on page 19)

**System Administrator Workstation Sizing**

The System Administrator workstation includes Project Management synchronization, a memory intensive process.
- Intel Core i7, Quad Core
- 6 GB RAM (2 GB RAM for operating system plus 4 GB RAM for single Smart 3D instance. Other concurrently running programs will require additional RAM based on the programs specific requirements.)
- Access to a DVD drive, either locally or through a network connection
- Monitor capable of a minimum of 1280 x 1024 resolution
- 1 GbE network interface
Database Server Sizing

With Smart 3D, 64-bit servers are required. The 64-bit versions of Microsoft SQL Server and Oracle run on the 64-bit version of Microsoft Windows Server.

For large projects, we recommend having a database server that is dedicated to Smart 3D and runs only one project. For medium and small projects, several projects can be run on the same database server. However, having multiple projects on the same server increases the server requirements. When sharing several projects, add additional hard drives and increase the memory and CPUs. Also consider the impact of sharing on your network. The network latency between the client and the database server should be less than 1ms on a gigabyte network.

Server Specifications

<table>
<thead>
<tr>
<th>Project size</th>
<th>Small</th>
<th>Medium</th>
<th>Large</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of processor cores</td>
<td>4</td>
<td>4-8</td>
<td>8 or more</td>
</tr>
<tr>
<td>Memory for Microsoft SQL Server and Oracle</td>
<td>16 GB</td>
<td>32 GB</td>
<td>64+ GB</td>
</tr>
<tr>
<td>Bus Size, OS, and Database</td>
<td>64-bit</td>
<td>64-bit</td>
<td>64-bit</td>
</tr>
</tbody>
</table>

The type of memory has a limited impact on the overall performance.

**NOTE** Running a Microsoft SQL Server or Oracle database on an Itanium processor-based server has not been certified and should not be done.

**Hard Drives**

Distribute files across several disk drives on the server. Each drive does not need a large capacity. The speed of the drive is important, so use 15K RPM or faster.

**Project with SQL Server**

The following example shows a configuration for a project using Microsoft SQL Server. The minimum distribution is four physical drives to separate the data files to increase the I/O band operation performance.

<table>
<thead>
<tr>
<th>C: Drive</th>
<th>Operating system</th>
</tr>
</thead>
<tbody>
<tr>
<td>D: Drive</td>
<td>SQL Server software</td>
</tr>
<tr>
<td>E: Drive</td>
<td>Database data files (.mdf files)</td>
</tr>
<tr>
<td>F: Drive</td>
<td>Database log files (.ldf files)</td>
</tr>
</tbody>
</table>

**Project with Oracle**

The following example shows a configuration for a project using Oracle Server running on 64-bit. The minimum distribution is five physical drives to separate the data files to increase the I/O band operation performance.
Global Workshare Configuration Distribution Server Sizing

Global Workshare Configuration (GWC) might require a separate server for distribution for large projects.

- Intel Xeon® 5600 Series or better (64-bit instruction set, not Itanium®)
- 16 GB to 64 GB or greater RAM depending on project size
- For hard drive size, see Smart 3D Project Hardware Sizing Recommendations (on page 25)
- Backup system for server
- Access to DVD drive, either locally or through a network connection
- 1 GbE or higher network interface for client connections

For small projects, a single server (the hub in a hub and spoke configuration) can act as a publisher, a distributor, and a subscriber all at the same time. For medium projects in a Global Workshare Configuration, the database server can also serve as the distribution server.

For large projects with many sites, use two different servers: one as publisher and subscriber and the other as the distributor. Using a separate server as the distributor helps to reduce the load on the publisher.

Interference Checking (IFC) Server Sizing

You should have a remote project processing computer for interference checking (IFC) that is separate from the computer hosting the databases. The interference checking computer can process more than one model. This computer does not need to be a high-end server, but should meet the minimum hardware requirements for a client computer. See Smart 3D Workstation Recommendations (on page 19) for these requirements.

There is not a specific hard drive size requirement because the interference detection service does not store information locally. However, we do recommend 8 GB of RAM for the IFC server when processing one model. When scaling up to process multiple plants, the memory requirements might increase depending on the sizes of the databases being processed.

Batch Server Sizing

You can use remote project processing computers, or batch servers, to off-load compute intensive tasks such as updating drawings in the Drawings task or running database backups and integrity checks in Project Management.
You should have at least one remote project processing computer for each site database. This remote computer does not have to be a high-end server, but should at least meet the minimum hardware requirements for a client computer. See *Smart 3D Workstation Recommendations* (on page 19) for these requirements.

**File Server Sizing**

You will need a computer to act as a file server with enough disk space for symbols and files. This computer does not need to be a high end-server, but should meet the minimum hardware requirements for a client computer. See *Smart 3D Workstation Recommendations* (on page 19) for these requirements.

**License Server and Name Generator Server Sizing**

The Name Generator Service can be installed on a stand-alone computer or can be installed on the same computer used for the file server, batch server, IFC server, or license server.

**License Server**

SmartPlant License Manager (SPLM) uses server/client architecture to distribute licenses for Smart 3D (and other SmartPlant Enterprise products.) SPLM requires very little system resources and so can be installed on the batch server, file server, IFC server, or database server as long as the hardware configurations below are observed.

Intergraph recommends that the SmartPlant License Manager license machine software be installed on a stable, single node, hardware configuration (such as a simple PC), with a static IP address, because license key installation and license seat usage authentication depends on the information gathered from the physical hardware.

**IMPORTANT** Any changes that cause the hardware information to differ from the information used to generate the license key will result in a failure of the authentication process.

For information about using SmartPlant License Manager in virtual environments, see Appendix F: SmartPlant License Manager and Virtual Configurations.

Multiple SmartPlant License Manager license machines can be used in the user's network as long as each system is a unique hardware system/installation. If SmartPlant License Manager license machines are cloned after the license key has been installed, license management will fail on the cloned system. Each SmartPlant License Manager license machine requires its own unique license key.
This section covers database setup and basic configuration. Operating system updates and database provider updates available after this installation guide was published might cause changes to the step-by-step instructions. In that case, use your technical knowledge to complete the workflow using the steps provided as a guide.

Installing any database involves significant decisions regarding the size of the database, the maximum number of users, the frequency of automatic backups, and other important issues. Therefore, the following sections provide only suggestions for tuning your database.
configuration to work with Smart 3D. The ultimate database creation and configuration depends on the policies and standards at your company.

**Supported Databases**

Smart 3D currently supports Microsoft SQL Server 2008 SP3 or Microsoft SQL Server 2012 SP2 for the plant, marine, and material handling mode. Oracle 11g R2 (11.2.0.2) with Patch 22 or Oracle 11g R2 (11.2.0.4) are supported only when using the plant mode.

**NOTE** When using the software in a Global Workshare Configuration (GWC), you can install Oracle Enterprise Edition or Oracle Standard Edition. If you are using Microsoft SQL Server, you must install Microsoft SQL Server Enterprise Edition.

For more information about supported databases, see *Smart 3D Database Server Recommendations* (on page 18).

**Loading Prerequisite Software on the Database Server**

The following prerequisite software is required in order to install and use the software on a database server:

- Microsoft .NET Framework 4.5
- Adobe Acrobat Reader (available from www.adobe.com)

**See Also**

*Loading Prerequisite Software on the Client* (on page 82)

**Install Microsoft .NET Framework (Database Server)**

Stop any real-time virus checkers before you proceed because they can interfere with installation.

1. Log on to the computer as an administrator.
2. Start *Server Manager*.
3. Select *Features* in the console tree.
4. Select *Add Features* in the *Features Summary* area.
   - The *Add Features Wizard* appears.
5. Select *Microsoft .NET Framework 4.5 Features* from the list of features that you can install.
6. Click *Install* and follow the prompts.

**NOTE** The software also supports the latest .NET Framework service packs. Run Windows Update to check for the latest .NET service pack and fixes.

**See Also**

*Loading Prerequisite Software on the Database Server* (on page 33)
Installing and Configuring Microsoft SQL Server 2012

Because system configurations, database software, and individual company standards vary, use this section as a checklist instead of step-by-step instructions for Microsoft SQL Server 2012 SP2 (64-bit) running on a Windows Server 2008 R2 operating system. Please contact Intergraph Customer Support for specific configuration questions.

If you are using a Global Workshare Configuration, you need to install the Enterprise Edition of Microsoft SQL Server for your Host and Satellite locations.

**IMPORTANT** There are internationalization considerations concerning the SQL Server collation settings you specify that relate to reference data, using SmartPlant Enterprise integrated systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to future releases. Please contact Intergraph Customer Support for specific configuration questions.

**Topics**
- Install Microsoft SQL Server 2012 ........................................... 34
- Install any Required SQL Server 2012 Upgrades ................. 37
- Verify Automatic Startup of Microsoft SQL Server 2012 Services 38
- Register the Microsoft SQL Server ................................. 38
- Assign System Administrator Privileges for SQL Server 2012 ..... 39
- Create a SQL Server Database Alert ................................... 40
- SQL Server Port Assignments ............................................. 42

Install Microsoft SQL Server 2012

1. Insert your Microsoft SQL Server DVD, and start the setup program.
2. From the **Planning** page, select **System Configuration Checker** to check for pre-requisite applications and identify potential installation problems. You might have to restart your computer if any pre-requisite applications were installed.
3. Click **Installation**, and then select the **New SQL Server stand-alone installation or add features to an existing installation** option.

4. As you go through the installation process, make sure you install the **Setup Support Files** and review any Setup Support Rules that identify potential problems.

5. Enter your SQL Server 2012 product key provided by Microsoft, and click **Next**.

6. Accept the license terms, and click **Next**.

   *Wait while the SQL Server Setup files are installed on the computer.*

7. Click **Next**.
8. Select **SQL Server Feature Installation**, and click **Next**.

9. When you get to **Feature Selection**, select the features below.
   - **Database Engine Services**
   - **SQL Server Replication** (required if the SQL server instance is set up for the Global Workshare configuration)
   - **Client Tools Connectivity**
   - **Management Tools - Basic**
   - **Management Tools - Complete**

10. Click **Next**.

11. Verify that all the installation rules pass, and click **Next**.

12. Define your instance name and the instance root directory. Click **Next**.
13. Verify the disk space requirements, and then click Next.

14. On the Server Configuration page, specify a domain account name with administrative privileges on the system to be used. Also, set Automatic as the Startup Type and continue.

**TIPS**

- If you are not sure, you can use NT AUTHORITY\NETWORK SERVICE or NT AUTHORITY\SYSTEM and change the login later on the service.
- A domain user account offers more flexibility and is typically used because many server-to-server activities can be performed only with a domain user account, including remote procedure calls, replication, and backing up network drives.

15. Select the Collation tab. Use locale-specific collation. These collation settings include the character set, sort order, and other locale-specific settings.

16. Click Next.


18. Specify at least one SQL Server Administrator. You will need this administrator login later to open SQL Server Management Studio.

19. Click Next, and complete the installation as prompted.

If any errors occur during installation, refer to the Summary Log for more information and contact Intergraph Support for further assistance.

**Install any Required SQL Server 2012 Upgrades**

You might require an upgrade or service pack of Microsoft SQL Server 2012. See Smart 3D Database Server Recommendations (on page 18) for version information. If you do need to upgrade, go to the Microsoft website and follow instructions provided in the Microsoft Download Center.
Verify Automatic Startup of Microsoft SQL Server 2012 Services

1. Open Control Panel > Administrative Tools, and then double-click Services.

2. Verify that the Status field is set to Started and the Startup Type field is set to Automatic, for SQL Server (MSSQLSERVER).

   ![Service Status](image)

   TIP: The MSSQL service is appended with the named instance you specified when you installed Microsoft SQL Server. For example, if you installed SQL Server as an instance named Instance1, the service displays as MSSQL$Instance1.

3. To change the Status or Startup Type fields, right-click the service name, and select Properties from the shortcut menu.
   a. On the General tab, select Automatic from the Startup type list.
   b. In the Service status section, click Start.
   c. Click OK.

Register the Microsoft SQL Server

You must register the database server instance in SQL Server Management Studio on the database server computer and on each client computer that you plan to use for:

- Administration tasks such as Project Management and creating or upgrading databases
- Running the Interference Checking Service

   **NOTE**: Verify that Authentication is set to Windows Authentication.

1. Open Microsoft SQL Server Management Studio.
2. Connect to your instance using the administrator login that you created during setup.
3. Select View > Registered Servers.
4. Under Database Engine, right-click Local Server Groups and select New Server Registration.
   The system displays the New Server Registration dialog box.
5. On the General tab, enter the name of the server instance that you want to register.
   or
   Select a server from the Server name drop-down list.
6. Click Save.
Before exiting Microsoft SQL Server Management Studio, perform the steps in Assign System Administrator Privileges for SQL Server 2008 (on page 46).

Assign System Administrator Privileges for SQL Server 2012

Perform the following steps on the Smart 3D database server.

1. Open Microsoft SQL Server Management Studio, and expand the listing for your database server in the left tree view.

2. In the tree view, expand the listing under Security, right-click Logins, and select New Login.

   The Login - New dialog box displays.

3. Type the user account to be assigned administrative privileges in the Login name text box. For example, type AdminUser1.

4. Select Server Roles under the Select a page heading to display the Server Roles list.

5. In the Server Roles list, select the sysadmin check box.

   Administrators need the sysadmin role. Standard users need public, db_datareader, and db_datawriter database role membership mapping to each one of the Smart 3D databases. Standard users also need Execute permission to each database. We do not recommend giving standard users db_owner permissions as it gives the users a very high privilege to the database.

6. Click OK.
Create a SQL Server Database Alert

When the Smart 3D database server is running low on disk space, the software begins to display error messages because data can no longer be persisted or logged. Microsoft SQL Server, however, does not issue any particular alerts for the workstation computers when the disk is full or becoming limited.

Using the Performance Monitor, the Smart 3D administrator can create a Data Collector Set that contains an alert to be issued when a threshold value for a System Monitor has been reached. In response to the alert, System Monitor can launch an application to handle the alert condition.

You must perform the following procedure on the database server computer.

2. Expand Monitoring Tools in the Performance tree view and start the Performance Monitor.
3. Expand Data Collector Sets in the tree view and right-click on User Defined.
4. Select New > Data Collector Set from the shortcut menu.
5. Type the name you want to use for the data collector set, click Create manually (Advanced), and then click Next.
6. Select Performance Counter Alert, and click Next.
7. Click Add to open the Add Counter dialog box.
8. Set the database server name in the Select counters from computer field.
9. Select the Microsoft SQL Server object in the **Available counters** section.

10. Select a counter in the **Select counters from list** list, select a counter, and click **Add**. The new counter displays in the **Added counters** list.

    **TIP** Use CTRL+ or SHIFT+ to select multiple objects.

11. After all counters have been added, click **OK** to close the **Add Counters** dialog box.

    **NOTE** To add local counters from a remote computer, you must have one of the following permissions on the computer:
    - Local administrator privilege
    - Be a member of the Performance Monitor Users local group.

12. Under the **Performance counters** list, select either **Above** or **Below** for the **Alert when** value.

13. In the **Limit** box, enter a threshold value. Depending on the object you selected, the alert will be generated when the value for the counter is more than or less than the threshold value. Click **Next** to continue.
14. Click **Finish**.
   
   *Your new data collector set displays in the **User Defined** page.*

15. To configure the alerts, double-click on your data collector set name and then right-click the data collector. Select **Properties** from the shortcut menu.

16. On the **Alerts** tab, you can set additional alerts and define the unit of time for the duration of the sample interval.

17. Set options in the **Alert Action** and **Alert Task** tabs to specify the actions to occur each time the alert is triggered.

18. Click **OK** to close the **Properties** dialog box and activate the alert settings.

**NOTE** For more information about using System Monitor and setting up SQL Server alerts, see the documentation delivered with Microsoft SQL Server and Windows Server.

### SQL Server Port Assignments

The Microsoft SQL Server database uses the following port assignments.

**NOTE** This assignment might not be required if Microsoft SQL Server is not used as a database within your SmartPlant Enterprise implementation.

<table>
<thead>
<tr>
<th>Port Number</th>
<th>TCP/UDP</th>
<th>Communication</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1433</td>
<td>TCP</td>
<td>From workstation to server; from server to workstation</td>
<td>SQL Server Instance</td>
</tr>
<tr>
<td>1434</td>
<td>UDP</td>
<td>From workstation to server; from server to workstation</td>
<td>SQL Browser</td>
</tr>
</tbody>
</table>

### Installing and Configuring Microsoft SQL Server 2008

Because system configurations, database software, and individual company standards vary, use this section as a checklist instead of step-by-step instructions for SQL Server 2008 SP3 (64-bit) running on a Windows Server 2008 R2 operating system. Please contact Intergraph Customer Support for specific configuration questions.

If you are using a Global Workshare Configuration, you need to install the Enterprise Edition of Microsoft SQL Server 2008 Service Pack 3 for your Host and Satellite locations.

**NOTE** Microsoft SQL Server 2008 SP3 requires XML 6.0 and will automatically install it as part of the SQL Server 2008 Prerequisite installation.

**IMPORTANT** There are internationalization considerations concerning the SQL Server collation settings you specify that relate to reference data, using SmartPlant Enterprise integrated systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to future releases. Please contact Intergraph Customer Support for specific configuration questions.
Install Microsoft SQL Server 2008

1. Insert your SQL Server DVD and start the setup program.

2. From the Planning page, select System Configuration Checker to check for pre-requisite applications as well as identify potential installation problems.

   **NOTE** You may be asked to restart your computer if any pre-requisite applications were installed.

3. Click Installation and select the New SQL Server stand-alone installation or add features to an existing installation option.

4. As you go through the installation process, make sure you install the Setup Support Files and review any Setup Support Rules that identify potential problems.

5. When you get to Feature Selection, select the features below.
   - Database Engine Services
   - SQL Server Replication (required if the SQL server instance is set up for the Global Workshare configuration)
6. On the **Server Configuration** page, specify a domain account name with administrative privileges on the system to be used. Also, set **Automatic** as the **Startup Type** and continue.

**TIPS**

- If you are not sure, you can use **NT AUTHORITY\NETWORK SERVICE** or **NT AUTHORITY\SYSTEM** and change the login later on the service.
- A domain user account offers more flexibility and is typically used because many server-to-server activities can be performed only with a domain user account, including remote procedure calls, replication, and backing up network drives.

7. Click the **Collation** tab. Use locale-specific collation. These collation settings include the character set, sort order, and other locale-specific settings.

8. On the **Database Engine Configuration** page, specify at least one SQL Server Administrator.
9. Select **Windows authentication mode**.

![Database Server Setup screenshot](image)

10. Complete the installation as prompted.

11. If any errors occur during installation, refer to the Summary Log for more information and contact Intergraph Support for further assistance.


### Install any Required SQL Server 2008 Upgrades

You might require an upgrade or service pack of Microsoft SQL Server 2008. See Smart 3D Database Server Recommendations (on page 18) for version information. If you do need to upgrade, go to the Microsoft website and follow instructions provided in the Microsoft Download Center.

### Verify Automatic Startup of Microsoft SQL Server 2008 Services

1. Open **Control Panel > Administrative Tools**, and then double-click **Services**.

2. Verify that the **Status** field is set to **Started** and the **Startup Type** field is set to **Automatic**, for SQL Server (MSSQLSERVER).
The MSSQL service is appended with the named instance you specified when you installed Microsoft SQL Server 2008 SP3. For example, if you installed SQL Server 2008 as an instance named Instance1, the service displays as MSSQL$Instance1.

3. To change the Status or Startup Type fields, right-click the service name, and select Properties from the shortcut menu.
   a. On the General tab, select Automatic from the Startup type list.
   b. In the Service status section, click Start.
   c. Click OK.

Register the Microsoft SQL Server

You must register the database server instance in SQL Server Management Studio on the database server computer and on each client computer that you plan to use for:

- Administration tasks such as Project Management and creating or upgrading databases
- Running the Interference Checking Service

**NOTE** Verify that Authentication is set to Windows Authentication.

1. Open Microsoft SQL Server Management Studio.
2. Connect to your instance using the administrator login that you created during setup.
3. Select View > Registered Servers.
4. Under Database Engine, right-click Local Server Groups and select New Server Registration.
   The system displays the New Server Registration dialog box.
5. On the General tab, enter the name of the server instance that you want to register.
   or
   Select a server from the Server name drop-down list.
6. Click Save.

**NOTE** Before exiting Microsoft SQL Server Management Studio, perform the steps in Assign System Administrator Privileges for SQL Server 2008 (on page 46).

Assign System Administrator Privileges for SQL Server 2008

Perform the following steps on the Smart 3D database server.

1. Open Microsoft SQL Server Management Studio, and expand the listing for your database server in the left tree view.
2. In the tree view, expand the listing under Security, right-click Logins, and select New Login.
   The Login - New dialog box displays.
3. Type the user account to be assigned administrative privileges in the **Login name** text box. For example, type **AdminUser1**.

![Login name text box](image)

4. Select **Server Roles** under the **Select a page** heading to display the **Server Roles** list.

5. In the **Server Roles** list, select the **sysadmin** check box.

   ![Server Roles list](image)

   **NOTE** Administrators need the **sysadmin** role. Standard users need **public**, **db_datareader**, and **db_datawriter** database role membership mapping to each one of the Smart 3D databases. Standard users also need Execute permission to each database. We do not recommend giving standard users **db_owner** permissions as it gives the users a very high privilege to the database.

6. Click **OK**.

### Create a SQL Server Database Alert

When the Smart 3D database server is running low on disk space, the software begins to display error messages because data can no longer be persisted or logged. Microsoft SQL Server, however, does not issue any particular alerts for the workstation computers when the disk is full or becoming limited.

Using the Performance Monitor, the Smart 3D administrator can create a Data Collector Set that contains an alert to be issued when a threshold value for a System Monitor has been reached. In response to the alert, System Monitor can launch an application to handle the alert condition.

You must perform the following procedure on the database server computer.

1. Open **Control Panel > Administrative Tools > Performance Monitor**.

2. Expand **Monitoring Tools** in the **Performance** tree view and start the **Performance Monitor**.
3. Expand **Data Collector Sets** in the tree view and right-click on **User Defined**.

4. Select **New > Data Collector Set** from the shortcut menu.

5. Type the name you want to use for the data collector set, click **Create manually (Advanced)**, and then click **Next**.

6. Select **Performance Counter Alert**, and click **Next**.

7. Click **Add** to open the **Add Counter** dialog box.

8. Set the database server name in the **Select counters from computer** field.

9. Select the Microsoft SQL Server object in the **Available counters** section.

10. Select a counter in the **Select counters from list** list, select a counter, and then click **Add**.
The new counter displays in the **Added counters** list.

**Tip** Use CTRL+ or SHIFT+ to select multiple objects.

11. After all counters have been added, click **OK** to close the **Add Counters** dialog box.

**Note** To add local counters from a remote computer, you must have one of the following permissions on the computer:

- Local administrator privilege
- Be a member of the Performance Monitor Users local group.

12. Under the **Performance counters** list, select either **Above** or **Below** for the **Alert when** value.

13. In the **Limit** box, enter a threshold value. Depending on the object you selected, the alert will be generated when the value for the counter is more than or less than the threshold value. Click **Next** to continue.

14. Click **Finish**.

**Your new data collector set displays in the User Defined page.**

15. To configure the alerts, double-click on your data collector set name and then right-click the data collector. Select **Properties** from the shortcut menu.

16. On the **Alerts** tab, you can set additional alerts and define the unit of time for the duration of the sample interval.

17. Set options in the **Alert Action** and **Alert Task** tabs to specify the actions to occur each time the alert is triggered.

18. Click **OK** to close the **Properties** dialog box and activate the alert settings.

**Note** For more information about using System Monitor and setting up SQL Server alerts, see the documentation delivered with Microsoft SQL Server and Windows Server.

### SQL Server Port Assignments

The Microsoft SQL Server database uses the following port assignments.

**Note** This assignment might not be required if Microsoft SQL Server is not used as a database within your SmartPlant Enterprise implementation.
### SQL Server Collation Utility

The SQL Server Collation Utility provides a way for you to specify the default collation that should be used by the Database Wizard, Project Management, and the Bulkload utility for creating databases. This utility creates a copy of the delivered schema templates (`AppRepos.dat` and `CatalogDB.dat`) with the required SQL Server collation. Any site, catalog, model, and reports databases and schemas created from these templates will use the specified SQL Server collation.

Only homogeneous configurations are supported at this time, not heterogeneous. For more information see *Internationalization* (on page 14).

**CAUTION** The CatalogDB.dat template file contains sample Smart 3D reference data and, while this template contains many useful examples, it is not certified for production use by Intergraph.

**See Also**
- *Change Database Collation* (on page 51)
- *SQL Server Collation Utility Dialog Box* (on page 50)

### SQL Server Collation Utility Dialog Box

The SQL Server Collation Utility provides a way for you to specify the default collation that should be used by the Database Wizard, Project Management, and the Bulkload utility for creating databases.

- **Collation** - Specifies the collation to be used for the database template. See the Microsoft documentation for more information on collation.

Smart 3D does not support case-sensitive collation.

- **Existing AppRepos template** - Specifies the path and file name of the existing `AppRepos.dat` template to be copied and converted to the new collation.

- **New AppRepos template** - Specifies the path and file name of the new `AppRepos.dat` template to be created. This name updates automatically to a new default whenever you change the value in the **Collation** field.

- **Existing CatalogDB template** - Specifies the path and file name of the existing `CatalogDB.dat` template to be copied and converted to the new collation.

- **New CatalogDB template** - Specifies the path and file name of the new `CatalogDB.dat` template to be created. This name updates automatically to a new default whenever you change the value in the **Collation** field.

- **OK** - Creates the new templates with the selected collation.

- **Cancel** - Closes the SQL Server Collation Utility without creating any new templates.

---

<table>
<thead>
<tr>
<th>Port Number</th>
<th>TCP/UDP</th>
<th>Communication</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1433</td>
<td>TCP</td>
<td>From workstation to server; from server to workstation</td>
<td>SQL Server Instance</td>
</tr>
<tr>
<td>1434</td>
<td>UDP</td>
<td>From workstation to server; from server to workstation</td>
<td>SQL Browser</td>
</tr>
</tbody>
</table>

---


**Change Database Collation**

1. Install SQL Server with locale-specific collation. These collation settings include the character set, sort order, and other locale-specific settings.

2. Install Smart 3D client and server.

3. Click **Start > All Programs > Intergraph Smart 3D > Database Tools > SQL Server Collation Utility.**

   The SQL Server Collation Utility displays. See SQL Server Collation Utility Dialog Box (on page 50).

4. Specify the collation that you need.

   The file names for the “new” templates update to reflect the selected collation automatically.

5. You can modify the default file names and paths.

6. Click **OK** to update the collation in the templates. These templates can now be used to create every Smart 3D database in the correct collation for the project.

7. Click **Start > All Programs > Intergraph Smart 3D > Database Tools > Database Wizard.**

8. Follow the steps to create a new site.

9. In the **Template file to be used to create site schema** field, select the new template with the desired SQL Server collation that you created with the SQL Server Collation Utility.

10. When creating or restoring the catalog database for the new site, be sure to select the template with the correct collation. If the collation for the selected catalog does not match the collation for the site, the following message appears: “The collation for the selected
template, CatalogDB.dat, does not match the collation for the site. Please select another template.”

**NOTE** This message also appears in the Bulkload Utility and in the New Catalog command in Project Management if the collation does not match the site.

**CAUTION** The CatalogDB.dat template file contains sample Smart 3D reference data and, while this template contains many useful examples, it is not certified for production use by Intergraph.

11. When you create the plant, reports, and reports schemas in Project Management, Smart 3D automatically uses the collation of the site database.

12. In the future, when you create additional sites or catalogs, remember to select the correct template with the desired collation.

**See Also**
*Install Microsoft SQL Server 2008* (on page 43, “Install Microsoft SQL Server 2012” on page 34)
*Install Microsoft SQL Server 2012* (on page 34)

### Installing and Configuring Oracle Server Software

Because system configurations and individual company standards vary, use this section as a checklist instead of step-by-step instructions. Please contact support for specific configuration questions.

**NOTE** We recommend that you set up the Windows server network before installing Oracle. Also, Oracle recommends a static IP address. You should install the Oracle server software as the local administrator, not as a domain user in the local Administrator Windows group. For more information, refer to your Oracle installation documentation.

**IMPORTANT** All domain verified user names and passwords must use ASCII7/English characters. Oracle does not support non-ASCII / English characters in domain user names or passwords and will not work. In addition, do not use the @ character in an Oracle password. This limitation applies only to Oracle, not Intergraph.

### Oracle Instances

If one server hosts the databases of several products, we recommend that each product database be a separate instance, each of which can host multiple plants.

The advantage of placing each product database in its own instance is that only the affected application will be off-line during backup, performance tuning, and other database maintenance activities. Additionally, global tuning parameters that apply to one instance can be tailored to the specific product requirements.

According to Oracle documentation, the only limit to the number of instances you can have on any machine is the availability of resources. However, the number of instances on one database server should be minimized because each additional instance puts additional load on the server.
Each instance adds redundant tablespaces, rollback segments, background processes, and memory requirements for each SGA (System Global Area). For this reason, you should start by putting the database of one product for several plants into a single instance. Then, when the number of plants increases, or a plant becomes very large, consider separating the database into new instances, adding server memory, or even adding database servers.

**IMPORTANT**

- Oracle recommends that database activity on the database server consume no more than 60 percent of the available memory. Refer to your Oracle documentation for specific requirements.
- Do not use the @ character in any Oracle passwords.
- There are Oracle restrictions for the database global name and corresponding database link name (they are required to match). There are three known restrictions on global database names:
  a. No hyphens are allowed.
  b. The computer name cannot start with a number.
  c. There is a maximum of 30 characters for the name.

**Topics**

- Oracle Server Configuration .................................................. 53
- Install and Configure Oracle Server Software ...................... 54
- Install Oracle Database 11g Release 2 Server Software (11.2.0.4) .................................................. 54
- Install Oracle Database 11g Release 2 Server Software (11.2.0.2) .................................................. 64
- Initialize the Oracle Database ........................................... 74
- Configure Oracle Networking Components ......................... 76
- Verify Automatic Startup of Oracle Database Services ........ 76
- Oracle Post-Installation Requirements ............................. 77
- Password Verification in Oracle ........................................ 77
- Add Firewall Exceptions on the Oracle Database Server ....... 78
- Oracle Database Port Assignments .................................... 79

**Oracle Server Configuration**

1. Log in as a user with administrator access to the server.
2. Turn off **Windows Firewall**. If this is not an option, please refer to the *Oracle Installation Guide* for information on the exceptions that must be put into place prior to installing Oracle on Windows.
3. In the **Folder Options** of Windows Explorer, clear the **Simple File Sharing** option.
   a. Open **Windows Explorer**.
   b. Press ALT and select **Tools**.
   c. Select **Folder Options**.
   d. Select the **View** tab.
   e. Scroll to the bottom and clear the **Use Sharing Wizard (Recommended)** option.
4. Click OK.

**Install and Configure Oracle Server Software**

During installation of the database components, setup displays various dialog boxes that prompt you for information. We recommend that you refer to your Oracle documentation for specific instructions concerning the dialog boxes and wizard pages.

**IMPORTANT** All domain verified user names and passwords must use ASCII/English characters. Oracle does not support non-ASCII/English characters in domain user names or passwords and will not work. In addition, do not use the @ character in an Oracle password. This limitation applies only to Oracle, not Intergraph.

**Install Oracle Database 11g Release 2 Server Software (11.2.0.4)**

This section will guide you through the installation process for Oracle 11g R2 (11.2.0.4) server software.

1. Open the hosts file and enter the IPv4 address and server host name. The hosts file is located in the C:\windows\system32\drivers\etc\hosts folder.
2. Add the environment variable `ORACLE_HOSTNAME=<server name>` in the System Environment Variables.
3. Run `setup.exe` from the install disk or folder while logged in as a local administrator.
4. Enter your security update information in the **Configure Security Updates** screen, and click **Next**.
5. Select **Skip software updates**, and click **Next**.
6. Select **Create and configure a database** in the **Select Installation Option** screen, and click **Next**.
7. Select **Server Class** in the **System Class** screen, and click **Next**.
8. Select **Single instance database installation** in the **Grid Installation Options** screen, and click **Next**.
9. Select **Advanced install** in the **Select Install Type** screen, and click **Next**.
10. Select the installation language in the **Select Product Languages** screen, and click **Next**.
11. Select **Enterprise Edition** or **Standard Edition** in the **Select Database Edition** screen, and click **Next**.
12. Specify the **Oracle Base** location for the base folder and the **Software Location** for the home folder by browsing to the location, and click **Next**.

13. Select **General Purpose / Transaction Processing** in the Select Configuration Type screen, and click **Next**.

14. Specify the **Global database name** and **Oracle Service Identifier (SID)** values in the Specify Database Identifiers screen, and click **Next**.
15. Select the **Memory** tab on the **Specify Configuration Options** screen, and then select the **Enable Automatic Memory Management** option. The percentage of memory allowed for an instance of Oracle should not exceed 40%. If you have more than one Oracle instance on this server, the total allocated memory for Oracle should not exceed 40% of the system memory.

16. Select the **Character sets** tab on the **Specify Configuration Options** screen, and then select the **Use Unicode (AL32UTF8)** option.

**NOTES**

- All products in SmartPlant Enterprise that participate in integration should set their encodings to **Use Unicode (AL32UTF8)** for the **Database Character Set** option, and to **AL16UTF16 - Unicode UTF-16 Universal character set** for the **National Character Set** option.

- For more information about the **Character sets** option, see your Oracle installation documentation.

17. Select the **Security** tab on the **Specify Configuration Options** screen, and choose your security settings option.

18. Select the **Sample Schemas** tab on the **Specify Configuration Options** screen, and select the **Create database with sample schemas** option. Click **Next**.

19. Select the **Use Database Control for database management** option on the **Specify Management Options** screen. You can also enable notifications through email with this option.

20. Select **File System** in the **Specify Database Storage Options** screen, and specify a database file location. Click **Next**.

21. Specify your recovery options in the **Specify Recovery Options** screen, and click **Next**.

**IMPORTANT** Do not enable Automated backups.
22. Specify your schema passwords in the **Specify Schema Passwords** screen, and click **Next**. You must choose either the **Use different passwords for these accounts** or **Use the same password for all accounts** option.

   The software checks that all prerequisite software is installed on the computer.

23. Click **Finish** in the **Summary** screen.

24. Click **Close** after the installation process is finished.

### Delete the Default Oracle Database

The default database created earlier in this workflow must now be deleted. The following steps will guide you through this process.

1. From the **Start** menu, select **All Programs > Oracle > Configuration and Migration Tools > Database Configuration Assistant**.
2. Click **Next** on the **Welcome** screen.
3. Select **Delete a Database**, and click **Next**.
4. Select the default database that was created, and click **Finish**.
5. Click **Yes** when asked if you want to proceed.
6. The **Database Configuration Assistant** asks if you want to perform another operation. Click **No**.

### Verify Oracle Registry Settings

Use the Microsoft Registry Editor (regedit.exe) to verify the following:

- The session timeout is implemented by the registry setting `ORAMTS_SESS_TXNTIMETOLIVE`.
- MSDTC timeout (default 60) (IIS Setting) < `ORAMTS_SESS_TXNTIMETOLIVE` (set to 120) < `distributed_lock_timeout` (set to 180).
Create the Smart 3D Oracle 11g Database

These steps guide you through the database creation process. You must log in to the server as a local administrator to create the Oracle database.

1. From the Start menu, select All Programs > Oracle > Configuration and Migration Tools > Database Configuration Assistant.

2. In the Database Configuration Assistant screen, select Create a Database, and click Next.

3. In the Database Template screen, select the Custom Database option, and click Next.
4. Enter the name of the new database in the **Database Identification** screen. Generally, the **Global Database Name** and the **SID** are identical. These names can be no longer than eight characters.

5. In the **Management Options** screen, click **Next** without changing the default selections. **Configure Enterprise Manager** and **Configure Database Control for local management** are the default options.

6. In the **Database Credentials** screen, select a security option and provide the appropriate information. Click **Next**.

7. On the **Database File Locations** screen, select **File System** and **Use Common Location for All Database Files**. Browse to the appropriate files location, and click **OK**.
A subfolder is created in the folder you choose and is named with the SID you provided earlier in step 4.

8. Click Next.

9. If the database will not be used in a Global Workshare Configuration, select Specify Flash Recovery Area in the Recovery Configuration screen, and click Next.

**IMPORTANT** If the database will be used in a Global Workshare Configuration, select Enable Archiving and click Edit Archive Mode Parameters. Select Automatic Archiving to specify the location of the archive log files.
10. In the **Database Content** screen, select the **Enterprise Manager Repository** option and click **Next**.

11. Select the **Memory** tab on the **Initialization Parameters** screen, and then select the **Typical** option. The percentage of memory allowed for an instance of Oracle should not exceed 40%. If you have more than one Oracle instance on this server, the total allocated memory for Oracle should not exceed 40% of the system memory.

12. On the **Sizing** tab, configure the **Processes** option based on this formula.

   \[
   \text{Processes} = (\text{Maximum Number of Users} \times 10) + \text{(Number of Oracle System Processes)}
   \]

   **NOTE**: The number of Oracle system processes can vary based on the number of background processes that are running. This number is a high estimate. Overestimate the number to ensure it will only use the number of processes that the instance needs.

13. Select the **Character Sets** tab, and then select the **Use Unicode (AL32UTF8)** option.

   **NOTES**

   - All products in SmartPlant Enterprise that participate in integration should set their encodings to **Use Unicode (AL32UTF8)** for the **Database Character Set** option, and to **AL16UTF16 - Unicode UTF-16 Universal character set** for the **National Character Set** option.
For more information about the Character Set options, see your Oracle installation documentation.

14. Select the **Connection Mode** tab, and select **Dedicated Server Mode**.

15. In the **Connection Mode** tab, select **All Initialization Parameters**.

16. Click **Show Advanced Parameters**.

The parameters required by Smart 3D in are listed below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>db_files</td>
<td>1000</td>
</tr>
<tr>
<td>distributed_lock_timeout</td>
<td>180</td>
</tr>
<tr>
<td>open_cursors</td>
<td>3000</td>
</tr>
<tr>
<td>os_authent_prefix</td>
<td>***</td>
</tr>
<tr>
<td>processes</td>
<td>200</td>
</tr>
<tr>
<td>undo_retention</td>
<td>3600</td>
</tr>
</tbody>
</table>

17. Click **Close** after the changes have been made, and click **Next** on the **Database Configuration** dialog box.

   **NOTE** The control files should be divided among multiple physical hard drives. This file is needed by the database to start.

18. Verify that the path in the **Tablespaces** folder is correct for SYSAUX, SYSTEM, TEMP, UNDOTBS1, and USERS.

   **NOTE** The information in the **Datafiles** and **Redo Log Groups** folders can retain the default settings as long as the folder path does not need updating.

19. Create an additional Redo log file, and set the Redo log file size for each group to 512000 K.

20. Click **Next**.

   **NOTE** The **Creation Options** screen allows you to save your database configuration as a template file, and also allows you to generate database creation scripts.

   **IMPORTANT** Not every setting is preserved in the template file. If you re-use template files, check the parameters carefully to verify the settings are correct.

21. When you have finished configuring the database, click **Finish**.

   **NOTE** The first 15% of the creation process validates the configuration settings. After the first 15% of the process has successfully passed, the database creation succeeds without any errors.

22. After the **Database Configuration Assistant** completes the database creation, click **Exit**.
Configure Oracle Net Services

With regard to the steps below, all of the Oracle service names that will participate in the workshare must be configured as a local net service at each location. For example, on the host server you must add the Oracle service name for each satellite server that is participating in the workshare. On each satellite server that is participating in the workshare, you must add the Oracle service name for the host.

1. Start the Oracle Net Configuration Assistant.
2. On the Welcome page, select Local Net Service Name configuration, and then click Next.
3. Click Add on the Net Service Name Configuration page, and then click Next.
   
   **NOTE** The Service Name cannot contain a period.
4. On the Service Name page, enter the name that identifies the database service in the Service Name box that you want to add, and then click Next.
   
   **TIP** The service name is the Oracle database instance name, not the database server computer name.
5. Select the TCP protocol, and then click Next.
6. Type the computer name of the database server in the Host name box. You can also enter the TCP/IP address.
7. Click Next.
8. Select Yes, perform a test to perform the connection test, and then click Next.
9. Click Change Login, and enter the system user name and password to use to test this connection.
10. If the test is successful, then click Next.
11. Enter the Net Service name. This name becomes the alias by which the Oracle database server is identified.
12. Click No when asked if you want to configure another service, and then finish the wizard.

When you complete the step above, select the option to perform a test of the net service name information. During a test, Oracle Net Configuration Assistant attempts to contact the remote database service, establishes a connection, and then ends contact.

**NOTES:**

- Repeat this procedure until all of the Oracle service names participating in the Workshare have been configured as a local net service.
- For more information about using Oracle Net Configuration Assistant, see the Oracle Database Net Services Administrator’s Guide delivered with the Oracle database software.

This completes the Oracle database installation. Continue to *Initialize the Oracle Database* (on page 74).
Install Oracle Database 11g Release 2 Server Software (11.2.0.2)

This section will guide you through the installation process for Oracle 11g R2 (11.2.0.2) server software with Patch 22.

1. Open the hosts file and enter the IPv4 address and server host name. The hosts file is located in C:\windows\system32\drivers\etc\hosts.

2. Add the environment variable `ORACLE_HOSTNAME=<server name>` in the System Environment Variables.

3. Run `setup.exe` from the install disk or folder while logged in as a local administrator.

4. Enter your security update information in the Configure Security Updates screen, and click Next.

5. Select Skip software updates, and click Next.

6. Select Create and configure a database in the Select Installation Option screen, and click Next.

7. Select Server Class in the System Class screen, and click Next.

8. Select Single instance database installation in the Grid Installation Options screen, and click Next.

9. Select Advanced install in the Select Install Type screen, and click Next.

10. Select the installation language in the Select Product Languages screen, and click Next.


12. Specify the Oracle Base location for the base folder and the Software Location for the home folder by browsing to the location, and click Next.
13. Select **General Purpose / Transaction Processing** in the **Select Configuration Type** screen, and click **Next**.

14. Specify the **Global database name** and **Oracle Service Identifier (SID)** values in the **Specify Database Identifiers** screen, and click **Next**.

![Specify Database Identifiers](image)

15. Select the **Memory** tab on the **Specify Configuration Options** screen, and select the **Enable Automatic Memory Management** option. The percentage of memory allowed for an instance of Oracle should not exceed 40%. If you have more than one Oracle instance on this server, the allocated memory should not exceed 40% of the system memory.

![Specify Configuration Options](image)

16. Select the **Character sets** tab on the **Specify Configuration Options** screen and select the **Use Unicode (AL32UTF8)** option.

**NOTES**

- All products in SmartPlant Enterprise that participate in integration should set their encodings to **Use Unicode (AL32UTF8)** for the **Database Character Set** option, and to
AL16UTF16 - Unicode UTF-16 Universal character set for the National Character Set option.

- For more information about the Character sets option, see your Oracle installation documentation.

17. Select the Security tab on the Specify Configuration Options screen, and choose your security settings option.

18. Select the Sample Schemas tab on the Specify Configuration Options screen, and select the Create database with sample schemas option. Click Next.

19. Select the Use Database Control for database management option on the Specify Management Options screen. You can also enable notifications through email with this option.


21. Specify your recovery options in the Specify Recovery Options screen, and click Next.

   **IMPORTANT** Do not enable Automated backups.

22. Specify your schema passwords in the Specify Schema Passwords screen, and click Next. You must choose either the Use different passwords for these accounts or Use the same password for all accounts option.

   The software checks that all prerequisite software is installed on the computer.

23. Click Finish in the Summary screen.

24. Click Close after the installation process is finished.

**See Also**

*Delete the Default Oracle Database* (on page 66)
*Install and Configure Oracle Server Software* (on page 54)

**Delete the Default Oracle Database**

The default database created earlier in this workflow must now be deleted. The following steps will guide you through this process.

1. From the Start menu, select All Programs > Oracle > Configuration and Migration Tools > Database Configuration Assistant.

2. Click Next on the Welcome screen.

3. Select Delete a Database, and click Next.

4. Select the default database that was created, and click Finish.

5. Click Yes when asked if you want to proceed.

6. The Database Configuration Assistant asks if you want to perform another operation. Click No.

   **TIP** Because no databases exist yet, this is a convenient time to load Oracle patches on the server. Oracle patch 22 needs to be installed before creating the Oracle database.
Verify Oracle Registry Settings

Use the Microsoft Registry Editor (regedit.exe) to verify the following:

- The session timeout is implemented by the registry setting ORAMTS_SESS_TXNTIMETOLIVE.
- MSDTC timeout (default 60) (IIS Setting) < ORAMTS_SESS_TXNTIMETOLIVE (set to 120) < distributed_lock_timeout (set to 180).

Create the Smart 3D Oracle 11g Database

These steps guide you through the database creation process. You must login to the server as a local administrator to create the Oracle database.

1. From the **Start** menu, select **All Programs > Oracle > Configuration and Migration Tools > Database Configuration Assistant**.
2. In the **Database Configuration Assistant** screen, select **Create a Database**, and click **Next**.
3. In the **Database Template** screen, select the **Custom Database** option, and click **Next**.

4. Enter the name of the new database in the **Database Identification** screen. Generally, the **Global Database Name** and the **SID** are identical. These names can be no longer than eight characters.

5. In the **Management Options** screen, click **Next** without changing the default selections. **Configure Enterprise Manager** and **Configure Database Control for local management** are the default options.
6. In the **Database Credentials** screen, select a security option and provide the appropriate information. Click **Next**.

![Database Configuration Assistant, Step 5 of 12: Database Credentials](image)

7. On the **Database File Locations** screen, select **File System** and **Use Common Location for All Database Files**. Browse to the appropriate files location, and click **OK**.

   A subfolder is created in the folder you choose and is named with the SID you provided earlier in step 4.

![Database Configuration Assistant, Step 6 of 12: Database File Locations](image)

8. Click **Next**.

9. If the database will not be used in a Global Workshare Configuration, select **Specify Flash Recovery Area** in the **Recovery Configuration** screen, and click **Next**.

![Database Configuration Assistant, Step 6 of 12: Database File Locations](image)
If the database will be used in a Global Workshare Configuration, select **Enable Archiving** and click **Edit Archive Mode Parameters**. Select **Automatic Archiving** to specify the location of the archive log files.

10. In the **Database Content** screen, select the **Enterprise Manager Repository** option and click **Next**.

11. Select the **Memory** tab on the **Initialization Parameters** screen and select the **Typical** option. The percentage of memory allowed for an instance of Oracle should not exceed 40%. If you have more than one Oracle instance on this server, the allocated memory should not exceed 40% of the system memory.
12. On the **Sizing** tab, configure the **Processes** option based on this formula.

\[
\text{Processes} = (\text{Maximum Number of Users} \times 10) + (\text{Number of Oracle System Processes})
\]

**NOTE** The number of Oracle system processes can vary based on the number of background processes that are running. This number is a high estimate. Overestimate the number to ensure it will only use the number of processes that the instance needs.

13. Select the **Character Sets** tab, and select the **Use Unicode (AL32UTF8)** option.

**NOTES**
- All products in SmartPlant Enterprise that participate in integration should set their encodings to **Use Unicode (AL32UTF8)** for the **Database Character Set** option, and to **AL16UTF16 - Unicode UTF-16 Universal character set** for the **National Character Set** option.
- For more information about the Character Set options, see your Oracle installation documentation.

14. Select the **Connection Mode** tab, and select **Dedicated Server Mode**.

15. In the **Connection Mode** tab, select **All Initialization Parameters**.

16. Click **Show Advanced Parameters**.

The parameters required by Smart 3D in are listed below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>db_files</td>
<td>1000</td>
</tr>
<tr>
<td>distributed_lock_timeout</td>
<td>180</td>
</tr>
<tr>
<td>open_cursors</td>
<td>3000</td>
</tr>
<tr>
<td>os_authent_prefix</td>
<td>&quot;&quot;</td>
</tr>
<tr>
<td>processes</td>
<td>200</td>
</tr>
<tr>
<td>undo_retention</td>
<td>3600</td>
</tr>
</tbody>
</table>

17. Click **Close** after the changes have been made, and click **Next** on the **Database Configuration** dialog box.

**NOTE** The control files should be divided among multiple physical hard drives. This file is needed by the database to start.

18. Verify that the path in the **Tablespaces** folder is correct for **SYSAUX**, **SYSTEM**, **TEMP**, **UNDOTBS1**, and **USERS**.

**NOTE** The information in the **Datafiles** and **Redo Log Groups** folders can retain the default settings as long as the folder path does not need updating.

19. Create an additional Redo log file, and set the Redo log file size for each group to 512000 K.

20. Click **Next**.
The Creation Options screen allows you to save your database configuration as a template file, and also allows you to generate database creation scripts.

Not every setting is preserved in the template file. If you re-use template files, check the parameters carefully to verify the settings are correct.

21. When you have finished configuring the database, click Finish.

The first 15% of the creation process validates the configuration settings. After the first 15% of the process has successfully passed, the database creation succeeds without any errors.

22. After the Database Configuration Assistant completes the database creation, click Exit.

See Also

Oracle Post-Installation Requirements (on page 77)
Install and Configure Oracle Server Software (on page 54)
Appendix: Install and Configure Oracle Software

Configure Oracle Net Services

With regard to the steps below, all of the Oracle service names that will participate in the workshare must be configured as a local net service at each location. For example, on the host server you must add the Oracle service name for each satellite server that is participating in the workshare. On each satellite server that is participating in the workshare, you must add the Oracle service name for the host.

1. Start the Oracle Net Configuration Assistant.
2. On the Welcome page, select Local Net Service Name configuration, and then click Next.
3. Click Add on the Net Service Name Configuration page, and then click Next.

The Service Name cannot contain a period.
4. On the Service Name page, enter the name that identifies the database service in the Service Name box that you want to add, and then click Next.

The service name is the Oracle database instance name, not the database server computer name.
5. Select the TCP protocol, and then click Next.
6. Type the computer name of the database server in the Host name box. You can also enter the TCP/IP address.
7. Click Next.
8. Select Yes, perform a test to perform the connection test, and then click Next.
9. Click Change Login, and enter the system user name and password to use to test this connection.
10. If the test is successful, then click Next.
11. Enter the Net Service name. This name becomes the alias by which the Oracle database server is identified.
12. Click No when asked if you want to configure another service, and then finish the wizard.
When you complete the step above, select the option to perform a test of the net service name information. During a test, Oracle Net Configuration Assistant attempts to contact the remote database service, establishes a connection, and then ends contact.

**NOTES**

- Repeat this procedure until all of the Oracle service names participating in the Workshare have been configured as a local net service.
- For more information about using Oracle Net Configuration Assistant, see the Oracle Database Net Services Administrator's Guide delivered with the Oracle database software.

### Post Installation Instructions

After installing the patch, run the SQL files in the Oracle instance as mentioned in the Oracle Patch 22 Readme document.

1. For each database instance running out of the ORACLE_HOME being patched, connect to the database using SQL*Plus as SYSDBA and run the **catcpu.sql** script as follows.

   > cd %ORACLE_HOME%\Bundle\Patch22
   > sqlplus /nolog
   > SQL> CONNECT / AS SYSDBA
   > SQL> STARTUP
   > SQL> @catcpu.sql
   > SQL> QUIT

2. Check the following log files in $ORACLE_BASE/cfgtoollogs/catbundle for any errors.

   catbundle_WINBUNDLE_<database SID>_APPLY_<TIMESTAMP>.log
   catbundle_WINBUNDLE_<database SID>_GENERATE_<TIMESTAMP>.log

3. Run the following query to confirm the patch level of the instance.

   select comments from registry$history;
4. Ensure all dependent objects are valid after running the catcpu.sql script. If needed recompile invalid objects by running the utlrp.sql script as follows.

```
> cd %ORACLE_HOME%/rdbms/admin
> sqlplus /nolog
SQL> CONNECT / AS SYSDBA
SQL> @utlrp.sql
```

5. Execute the following statement to check for invalid objects.

```
SQL> SELECT OBJECT_NAME FROM DBA_OBJECTS WHERE STATUS = 'INVALID';
```

**NOTE** For large numbers of objects, this compilation step can take some time. If you are applying this patch through the Oracle Enterprise Manager console, you will be prompted to run this compilation script.

This completes the Oracle database installation. Continue to *Initialize the Oracle Database* (on page 74).

## Initialize the Oracle Database

After the Oracle server software is installed and configured (that is, you can connect from a client to the Oracle database), you must configure the database to run with Smart 3D software.

The Smart 3D Reference Data Installation (see *Reference Data Setup* (on page 117)) delivers the following sample script files to the `<Product Folder>\Tools\OracleScriptsToInitDB\Roles` folder. These files must be run in the following order:

1. SP3DUser_ROLES.sql
2. SP3DProjectAdministrator_ROLES.sql
3. SP3DUser.sql
4. SP3DProjectAdministrator.sql

These script files create the necessary schemas, users, and roles that are used to run the software on Oracle. The delivered script files, however, are only samples and must be edited to fit your server configurations.

**CAUTIONS:**

- An administrative user must run the scripts on the server. Before proceeding, place a copy of each of the sample script files on the server computer.
- The scripts must be run in the order listed because previous scripts create items that are used in subsequent scripts. Do not deviate from the following sequence of steps.

### Create the Roles Needed for Smart 3D Users

1. Log on to the Oracle database server computer using the local administrative account.
2. Open SQL Plus. The SQL Plus dialog box displays.
3. In the User Name field, type SYS as SYSDBA or SYSOPER.
4. In the Password field, type the password for the SYS account.
5. At the SQL prompt, type `@<File Location>\SP3DUser_ROLES.sql`, and press Enter.
Database Server Setup

**TIP** For example, if you placed a copy of the script file in the root folder on the C drive, type `@C:\SP3DUser_ROLES.sql`.

6. After the script finishes, type `@<File Location>:\SP3DProjectAdministrator_ROLES.sql`, and press Enter.

7. After the second script finishes, click File > Exit.

**Create the Users Needed for Smart 3D**

1. Log on to the Oracle database server computer using the local administrative account.
2. Navigate to the `SP3DUser.sql` script file, and open it in Notepad.
3. Edit the external user identified in the file as needed. Use the following syntax: `DOMAIN NAME\USERNAME`, and then click File > Save.
   
   **NOTE** User logins cannot contain spaces. Any typed alpha character must be capitalized.
4. Open SQL Plus. The Log On dialog box appears.
5. In the User Name field, type `SYS AS SYSDBA`.
6. In the Password field, type the password for the SYS account.
7. At the SQL prompt, type `@<File Location>:\SP3DUser.sql`, and press Enter.
   
   For example, if you placed a copy of the script file in the root folder on the C drive, type `@C:\SP3DUser.sql`.
8. After the script finishes, click File > Exit.

**Create the Administrative User**

1. Log on to the Oracle database server computer using the local administrative account.
2. Navigate to the `SP3DProjectAdministrator.sql` script file, and open it in Notepad.
3. Edit the external user identified in the file as needed. Use the following syntax: `DOMAIN NAME\USERNAME`, and then click File > Save.
   
   **NOTE** Any typed alpha character must be capitalized.
4. Open SQL Plus. The Log On dialog box appears.
5. In the User Name field, type `SYS AS SYSDBA`.
6. In the Password field, type the password for the SYS account.
7. At the SQL prompt, type `@<File Location>:\SP3DProjectAdministrator.sql` and press Enter.
   
   For example, if you placed a copy of the script file in the root folder on the C drive, you type `@C:\SP3DProjectAdministrator.sql`.
8. After the script finishes, click File > Exit.
Configure Oracle Networking Components

Oracle Net combines configuration abilities with component control to provide an integrated environment for configuring and managing client connections to services via a net service name. The Smart 3D software uses the Oracle net service to establish and maintain network sessions from client applications to the Oracle database server. After a network connection is established, this utility acts as a data courier for the client application and the database server.

If you follow the procedures provided to Install Oracle Database 11g Release 2 Server Software (11.2.0.2) (on page 64) and Install Oracle Client Software 11g Release 2, the Oracle Networking Components should be configured correctly.

Oracle Net Configuration Assistant

The Oracle Net Configuration Assistant allows you to configure the listening protocol address and service information for an Oracle database. See the Oracle Net Services Administrator's Guide in your Oracle documentation for more information about using this utility and creating net service name connections.

**IMPORTANT** If you are using Global Workshare, you should configure a net service for each server involved in the workshare environment.

See Also
Installing and Configuring Oracle Server Software (on page 52)
Configure the Oracle Client (on page 92)

Verify Automatic Startup of Oracle Database Services

1. Open Control Panel > Administrative Tools.
2. Double-click Services.
3. Verify that the Status field is set to Started, and the Startup Type field is set to Automatic, for each of the following services:
   - OracleService<SID>
   - OracleDBConsole<SID>
   - Oracle<oracle_home>TNSListener

   **NOTES**
   - The OracleService is your Oracle database instance. It is appended with the named Oracle System identifier (SID) you specified when you created the Oracle database. For example, if your SID is Plant1, the service appears as OracleServicePlant1.
   - The TNSListener service is required to allow clients to connect to the Oracle database.
4. To change the Status or Startup Type fields, right-click the service name, and select Properties from the shortcut menu.
5. On the General tab, select Automatic from the Startup type list.
6. In the Service status section, click Start.
7. Click OK.
Oracle Post-Installation Requirements

1. Create an administrator user (local or domain).
2. Add this administrator to the ORA_DBA group.
   
   **NOTE** There is no need to have both Oracle Server and Oracle Client on the same computer.
3. Make sure the Administrators, System, and Users Windows groups have full access to the SharedContent folder on the reference data computer.
4. Make sure the Administrators and System account have full permissions to the Database Templates folder.

Password Verification in Oracle

**NOTE** If you create or restore a database in Oracle, the software creates the user with a DEFAULT profile.

To verify the password, you can add the password verification function to the DEFAULT profile. The password verification function is delivered with the product. The password:

- Must be different from the username
- Cannot begin or end with a number
- Must contain at least two embedded numbers
- Must contain at least one uppercase and lowercase letter
- Must be at least 8 characters and should not exceed 15 characters
- Cannot use any of the following combinations - welcome, database, account, user, password, oracle, computer, and abcd.

Enable the Password Verification Function on the Server

**IMPORTANT** The Oracle database administrator is responsible for modifying and enabling the password verification function.

1. On the server, run the `OraclePasswordVerification.sql` application available at `[Product Folder]\\ProjectMgmt\\Server\\Schema\\Oracle`.
   
   The application creates a PASSWORDCHECK function under the [Oracle Service] > Functions node.

   ```sql
   select * from fga_profiles where profile = 'DEFAULT'
   ```

   2. Select a DEFAULT profile, and then run the following query:
"Alter profile default limit PASSWORD_VERIFY_FUNCTION PASSWORDCHECK;"
Commit;

The default profile Limit is set to PASSWORDCHECK, indicating that the profile is ready with the password verification.

---

Add Firewall Exceptions on the Oracle Database Server

**Add Exceptions for Programs on the Oracle Database Server**

1. In the left panel of the *Windows Firewall with Advanced Security* management console, click *Inbound Rules*.

2. In the *Action* panel on the right, click *New Rule*.

   *The New Inbound Rule Wizard appears.*

3. On the *Rule Type* page, select *Program*, and then click *Next*.

4. On the *Program* page, select *This program path*.

5. Type the path or browse to a program on the Oracle server, and then click *Next*. See the table below for the list of programs.

6. On the *Action* page, select *Allow the connection*, and then click *Next*.

7. On the *Profile* page, select the needed options for *Domain*, *Private*, and *Public*, as required by your network configuration and allowed by the security policy of your company. Click *Next*.

8. On the *Name* page, type the name for the program exception. Optionally, you can type a description.

9. Click *Finish*.

10. In the center of the *Inbound Rules* panel, verify that the new program exception name appears.

11. Repeat these steps for the remaining programs in the table.

<table>
<thead>
<tr>
<th>Program Path and File Name</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Oracle_home]bin\oracle.exe</td>
<td>Oracle Database Executable</td>
</tr>
<tr>
<td>[Oracle_home]bin\tnslsnr.exe</td>
<td>Oracle Listener</td>
</tr>
<tr>
<td>[Oracle_home]bin\emagent.exe</td>
<td>Oracle Database Control</td>
</tr>
</tbody>
</table>
NOTE: [Oracle_home] is the fully-qualified path name of the Oracle Database Server software.

Oracle Database Port Assignments

The Oracle database uses the following port assignments.

NOTE: These assignments might not be required if Oracle is not used as a database within your SmartPlant Enterprise implementation.

IMPORTANT: For the Oracle components listed below, port assignments can be custom-configured as indicated. For each component, additional information can be found in the cited Oracle documentation. These Oracle references contain links to additional Oracle content, providing important considerations, including discussions about other affected components that may require matching port changes to be made, as well as the instructions for changing the assigned ports.

<table>
<thead>
<tr>
<th>Port Number</th>
<th>TCP/UDP</th>
<th>Communication</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>TCP</td>
<td>From workstation to server</td>
<td>For Oracle HTTP. Can be reassigned. Configurable port range is 80, 7777-7877, 8888. For information, see <a href="http://download.oracle.com/docs/cd/E12524_01/core.1013/e10403/portnums.htm#i653967">http://download.oracle.com/docs/cd/E12524_01/core.1013/e10403/portnums.htm#i653967</a>.</td>
</tr>
<tr>
<td>1521, 1526</td>
<td>TCP</td>
<td>From workstation to server; from server to workstation</td>
<td>For Oracle Client SQL Net Connection (1521 is default). Can be changed using Oracle Net Configuration Utility to port within range 1024-65535. For information, see <a href="http://download.oracle.com/docs/cd/E11882_01/install.112/e16773/ports.htm#CIHCCJCF">http://download.oracle.com/docs/cd/E11882_01/install.112/e16773/ports.htm#CIHCCJCF</a>.</td>
</tr>
<tr>
<td>1158</td>
<td>TCP</td>
<td>From workstation to server</td>
<td>For Oracle Enterprise Console (1158 is default). Configured during database installation. Can be changed within range 5500-5519. For information, see <a href="http://download.oracle.com/docs/cd/E11882_01/install.112/e16773/ports.htm#CIHCCJCF">http://download.oracle.com/docs/cd/E11882_01/install.112/e16773/ports.htm#CIHCCJCF</a>.</td>
</tr>
<tr>
<td>Port Number</td>
<td>TCP/UDP</td>
<td>Communication</td>
<td>Comments</td>
</tr>
<tr>
<td>-------------</td>
<td>---------</td>
<td>--------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>5560, 5580</td>
<td>TCP</td>
<td>From workstation to server</td>
<td>For Oracle SQL Plus (5560 is default). Can be changed within range 5560-5579. For information, see <a href="http://download.oracle.com/docs/html/B13805_02/ports.htm#BEHFDBEE">http://download.oracle.com/docs/html/B13805_02/ports.htm#BEHFDBEE</a> – section D.5.</td>
</tr>
<tr>
<td>443</td>
<td>TCP</td>
<td>From workstation to server</td>
<td>For Oracle HTTP Server SSL Port (443 is default). Can be set to either 443 or 4443. For information, see <a href="http://download.oracle.com/docs/cd/E12524_01/core.1013/e10403/portnums.htm#i653967">http://download.oracle.com/docs/cd/E12524_01/core.1013/e10403/portnums.htm#i653967</a>.</td>
</tr>
<tr>
<td>7809</td>
<td>TCP</td>
<td>From server to server</td>
<td>Required for Oracle Global Workshare. GoldenGate is now used for replication and this port is needed for the GoldenGate Manager to handle communication between the servers.</td>
</tr>
<tr>
<td>7810-7820</td>
<td>TCP</td>
<td>From server to server</td>
<td>Required for Oracle Global Workshare. Golden Gate is now used for replication and this port is needed to facilitate the transfer of transaction information between the GoldenGate instances.</td>
</tr>
</tbody>
</table>
SECTION 5
Client/Workstation Setup

The Smart 3D client software is used for general modeling, as well as for performing a variety of administrative activities, including managing permissions, backing up and restoring data, creating plants, and monitoring database interference detection. Additionally, the software provides features that extend the capabilities of the software to include importing model data and integrating Smart 3D with SmartPlant P&ID.

CAUTION

- If you have a previous version of Smart 3D installed, you need to remove it before installing the new version. For more information, see Application Maintenance (on page 206) in the Intergraph Smart™ 3D Installation Guide.
Loading Prerequisite Software on the Client

The following prerequisite software is required in order to install and use the software on a client computer:

- Microsoft Office 2010 (32-bit)
- Adobe Acrobat Reader
- SmartPlant License Manager 2010 (V11.0) or 2012 (V12.0)
- Intergraph SmartSketch 2014 (08.00.00.98 or later), if you are using material handling mode.

**IMPORTANT** You must install SmartSketch before installing Smart 3D. If you install Smart 3D first, then Smart 3D will not work properly.

**See Also**

*Loading Prerequisite Software on the Database Server (on page 33)*

Install Microsoft Office

Several of the tasks require Microsoft Office. Designers need Microsoft Excel to create reports and system administrators rely on Excel to make changes to the reference data spreadsheets and bulk load them into the Catalog database. The current release of the software supports Office 2010 (32-bit).

**IMPORTANT**

- The system language specified for Microsoft Office must be the same as the system language specified by the operating system. For example, if your operating system language is English, Microsoft Office must also be set to English.
- If you choose to do a custom installation of Office, be sure to select the .NET Programming Support for Excel, which is required for the Model Data Reuse command.
- If running in a Citrix environment, the MSDN license key must be a VLM license key for multiple users to run reports.

**See Also**

*Loading Prerequisite Software on the Client (on page 82)*

Install Microsoft SQL Server 2012 Client

Because system configurations and individual company standards vary, use this section as a checklist instead of step-by-step instructions for Microsoft SQL Server. Please contact Intergraph Customer Support for specific configuration questions.

You need Microsoft SQL Server Client if:

- The computer is an administrative workstation.
- You plan to run Project Management on the computer.

You do not need to install Microsoft SQL Server Client if:

- The computer is used for general design work (piping, HVAC, and so forth).
- You are using Oracle as your database provider.
There are internationalization considerations concerning the SQL Server collation settings you specify that relate to reference data, using SmartPlant Enterprise integrated systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to future releases. Please contact Intergraph Customer Support for specific configuration questions.

If a XenApp 6.5 or XenDesktop 7 RDS, local data store (farm) will be used, Microsoft SQL Server Client must be installed before installing XenApp 6.5 or XenDesktop 7 RDS.

1. Insert your Microsoft SQL Server DVD, and start the setup program.
2. From the Planning page, select System Configuration Checker to check for pre-requisite applications and identify potential installation problems. You might have to restart your computer if any pre-requisite applications were installed.
3. Click Installation, and then select the New SQL Server stand-alone installation or add features to an existing installation option.
4. As you go through the installation process, make sure you install the Setup Support Files and review any Setup Support Rules that identify potential problems.
5. Enter your SQL Server 2012 product key provided by Microsoft, and click Next.
6. Accept the license terms, and click Next.
7. Click **Next**.

8. Select **SQL Server Feature Installation**, and click **Next**.

9. Select these client features:
   - **Client Tools Connectivity**
   - **Management Tools - Basic**
   - **Management Tools - Complete**

10. When you get to Installation Rules, make sure all operations have passed.
11. From Ready to Install, click Install.
12. When the installation has been completed, review the summary log file for any problems.

**Install Microsoft SQL Server 2008 Client**

Because system configurations and individual company standards vary, use this section as a checklist instead of step-by-step instructions for Microsoft SQL Server 2008 SP3. Please contact Intergraph Customer Support for specific configuration questions.

You need Microsoft SQL Server 2008 Client if:
- The computer is an administrative workstation.
- You plan to run Project Management on the computer.

You **do not** need to install Microsoft SQL Server 2008 Client if:
- The computer is used for general design work (piping, HVAC, and so forth).
- You are using Oracle as your database provider.

**NOTES**
- Microsoft SQL Server 2008 SP3 requires XML 6.0 and will automatically install it as part of the SQL Server 2008 Prerequisite installation.
- There are internationalization considerations concerning the SQL Server collation settings you specify that relate to reference data, using SmartPlant Enterprise integrated systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to future releases. Please contact Intergraph Customer Support for specific configuration questions.
- If a XenApp 6.5 or XenDesktop 7 RDS, local data store (farm) will be used, Microsoft SQL Server Client must be installed before installing XenApp 6.5 or XenDesktop 7 RDS.

1. Insert your SQL Server DVD and start the setup.
2. From the **Planning** page, select **System Configuration Checker** to check for pre-requisite applications as well as identify potential installation problems.

   **NOTE**: You may be asked to restart your computer if any pre-requisite applications were installed.

3. Click **Installation** and select the **New SQL Server stand-alone installation or add features to an existing installation** option.

4. As you go through the installation process, make sure you install the **Setup Support Files** and review any Setup Support Rules that identify potential problems.

5. When you get to **Feature Selection**, select the client features that you want to include:
   - **Client Tools Connectivity**
   - **Management Tools - Basic**
   - **Management Tools - Complete**

6. When you get to **Installation Rules**, make sure all operations have passed.

7. From **Ready to Install**, click **Install**.

8. When the installation has been completed, review the summary log file for any problems.
9. Before you use the software, you must register it. For more information, see Register the Microsoft SQL Server (on page 38).

10. Install any required service packs or upgrades for SQL Server 2008. See Install any Required SQL Server 2008 Upgrades (on page 45).

Installing and Configuring Oracle Client Software

Because system configurations and individual company standards vary, use this section as a checklist instead of as step-by-step instructions. Please contact Intergraph Customer Support for specific configuration questions.

**IMPORTANT**

- Smart 3D is a 32-bit application that uses the 32-bit Oracle Client even when loaded on a 64-bit client operating system.
- However, the 64-bit Oracle Client is required on computers where the 64-bit Interference Checker or 64-bit Drawings Batch Publishing is installed.
- Do not use the Oracle "light client" as it does not include some DLLs required by Smart 3D.
- You do not need to install the Oracle Client if you are using Microsoft SQL Server as your database provider.
- The Oracle Client and the tnsnames.ora file must be installed and configured on the Batch Services and Interference Server computers.

**Topics**

- Oracle 11g Release 2 32-bit Client Installation .......................87
- Oracle 11g Release 2 64-bit Client Installation .......................90
- Configure the Oracle Client ..............................................92
- Configure Windows Firewall for the Oracle Client ...................93

**Oracle 11g Release 2 32-bit Client Installation**

This section guides you through the installation process for Oracle 11g R2 (11.2.0.2 and 11.2.0.4) 32-bit client.

1. Run setup.exe from the installation disk or folder as an administrator.
2. Select Custom in the Select Installation Type screen, and click Next.
3. Select Skip software updates in the Download Software Updates screen, and click Next.
4. Select the installation language in the Select Product Languages screen, and click Next.
5. Specify the **Oracle Base** location for the base folder and the **Software Location** for the home folder by browsing to the location, and click **Next**.

![Specify Installation Location](image)

6. Select the product components to install in the **Available Product Components** screen, and click **Next**.

![Component Name](image)

7. Wait while the software performs the prerequisite checks, and click **Next**.

8. Click **Install** in the **Summary** screen and wait while Oracle client installs. 

   *The Oracle Net Configuration Assistant displays.*
9. Select **Perform typical configuration** in the **Welcome** screen, click **Next**.

10. In the **Welcome to the Oracle Net Configuration Assistant** screen, click **Next**.

11. Click **Finish**.

12. Click **Close** after the installation process is finished.

**NOTE:** In MSDTC, the session timeout is implemented by the registry setting `ORAMTS_SESS_TXNTIMETOLIVE`. The general rule for setting timeouts are:

- MSDTC timeout (default 60) (IIS Setting) < `ORAMTS_SESS_TXNTIMETOLIVE` (set to 120) < `distributed_lock_timeout` (set to 180)
Use regedit to verify the setting as shown:

![Image of regedit window]

**IMPORTANT**

- For Oracle 11.2.0.2 32-bit client you must install Patch 22 now. Stop the service OracleMTSRecoveryService if it exists and disable the service DistributedTransactionCoordinator **BEFORE** you install Patch 22.
- For Oracle 11.2.0.4 32-bit client there is no patch installation requirement.

**See Also**

*Delete the Default Oracle Database* (on page 66)

*Install and Configure Oracle Server Software* (on page 54)

**Oracle 11g Release 2 64-bit Client Installation**

This section guides you through installation Oracle 11g 64-bit Client (11.2.0.2 and 11.2.0.4). Oracle 64-bit client is required on computers running 64-bit interference checking and 64-bit drawings batch publishing.

1. Double-click the Oracle **Setup.exe**.
2. Select **Custom** installation, and then click **Next**.
3. Select **Skip software updates**, and then click **Next**.

4. Select **English**, and then click **Next**.

5. In the **Oracle Base** box, enter a unique folder location for the Oracle 64-bit client.

6. In the **Software Location** box, enter a unique folder location.

7. Click **Next**.

8. Select the product components to install in the **Available Product Components** screen. Clear the **Oracle SQL Developer** option.

9. Click **Next**.

10. Click **Next**.

   *Oracle performs prerequisite checks.*

11. Click **Install**.
12. Select **Perform typical configuration**, and then click **Next**.

13. Click **Next**.
14. Click **Finish**.
15. Click **Close**.

**IMPORTANT**
- For Oracle 11.2.0.2 64-bit client, you must install the 64 bit Patch 22 now. Stop the service OracleMTSRecoveryService if it exists and disable the service DistributedTransactionCoordinator BEFORE you install Patch 22.
- For Oracle 11.2.0.4 64-bit Oracle client, there is no patch installation requirement.

**Configure the Oracle Client**

Oracle client computers must be configured before they can connect to an Oracle database.

1. Start Oracle **Net Manager**.
2. Select the Service Naming node, and then click the green plus sign to start the **Net Service Name Wizard**.
3. Specify a **Service Name**.
5. Specify the Host name (typically the network name of the database server computer) and Port Number (default=1521) for your protocol settings.
6. Specify the Service Name and Connection Type.
7. Test the new service.
8. If the default test fails, click Change Login, type a valid username/password combination and, retest the connection.
9. When the login test is successful, click Finish to close the wizard.
10. Click File > Save Network Configuration to save your new network service.

See Also
Installing and Configuring Oracle Client Software (on page 87)

Configure Windows Firewall for the Oracle Client

The Windows Firewall state is On by default to block incoming connections on most TCP network ports. As a result, an Oracle client reports errors when it requires an incoming connection from an Oracle server. You must adjust the Windows Firewall settings after installing Oracle client software to allow exceptions for the needed incoming connections.

**IMPORTANT** If the Windows Firewall state is Off on the Oracle client, then you do not need to change the configuration.

Follow these steps to configure firewall exceptions in Windows 7:

Open the Windows Firewall Control Panel

   
   The Windows Firewall control panel appears.
2. In Public networks, verify that the Windows Firewall state is On.
   
   The Windows Firewall with Advanced Security management console appears.

Add an Exception for the Oracle Listener Port

1. In the left panel of the Windows Firewall with Advanced Security management console, click Inbound Rules.
2. In the Action panel on the right, click New Rule.
   
   The New Inbound Rule Wizard appears.
3. On the Rule Type page, select Port and then click Next.
4. On the Protocol and Ports page, select TCP.
5. Select Specific local ports, and then type 1521. Click Next.
The default Oracle listener port is 1521. Your network configuration might require a different port number.

6. On the **Action** page, select **Allow the connection** and then click **Next**.

7. On the **Profile** page, select the needed options for **Domain**, **Private**, and **Public**, as required by your network configuration and allowed by the security policy of your company. Click **Next**.

8. On the **Name** page, type **Oracle Listener Port** as the name for the port exception. Optionally, you can type a description.

9. Click **Finish**.

10. In the center of the **Inbound Rules** panel, verify that the new exception name appears.

## Install Smart 3D Client Software

Prior to installing Smart 3D on a workstation computer, verify that the workstation computer meets the required hardware and software requirements and that all prerequisite software has been installed. For more information, see **Smart 3D Workstation Recommendations** (on page 19) in the *Intergraph Smart™ 3D Installation Guide*. For more information about the prerequisite software, see **Loading Prerequisite Software on the Client** (on page 82).

Remove the older version of Smart 3D before loading the new version. For more information, see **Remove Smart 3D Software** (on page 208) in the *Intergraph Smart™ 3D Installation Guide*.

You must have administrator privileges on the computer to install the software. We recommend using the **Run as Administrator** option.

If you have not already installed and configured SmartPlant License Manager on your computer, we recommend doing so before installing Smart 3D.

### IMPORTANT

- If you are using material handling mode, you must install Intergraph SmartSketch 2016 (9.0 or later) before installing Smart 3D. If you install Smart 3D first, then Smart 3D will not work properly. You must separately purchase SmartSketch (SGBY297AV).

- Smart 3D requires the SmartPlant License Manager software for concurrent licensing for both the core Smart 3D product and for each module. This licensing software is delivered on its own DVD that comes with your Smart 3D DVD. For more information about using and configuring concurrent licensing, see the *SmartPlant License Manager Installation and User’s Guide* (SPLMInstall_UserGuide.pdf).

- During setup, the %temp% value is defined as the user %temp% of the person who runs the setup. In Windows, each user's C:\Documents and Settings\username\Local Settings\Temp is protected from other Windows users. Consequently, you must set the system environment variable TEMP value to a folder location where everyone has write access (for example, c:\temp). For more information about editing system variables, see the Help and Support Center (click Start > Help and Support Center from the Windows task bar).

1. Insert the *Intergraph Smart 3D* DVD. If the DVD does not start automatically, right-click **Setup.exe** in the root folder of the DVD and select **Run as administrator**.

2. Click **Additional Software**, and the select the optional software that you need to install, if any:
3. Click **Back** if needed.

4. Click **Full Installation**.

5. Type your name or organization information.

6. Select the components to install on this computer:
   - **Smart 3D Installation** - Installs the Smart 3D client component that contains the modeling tasks such as Common, Piping, Equipment, Structure, and so forth.
   - **Project Management** - Installs the **Project Management** client used for creating models, managing access control, and upgrading databases. Select this option for an administrator's computer. You must also install the **Server Connectivity** option (below) and the Microsoft SQL Server client tools. The Microsoft SQL Server client tools are not required on computers where **Project Management** is not installed or if you are using Oracle as your database provider.
   - **Bulkload Reference Data** - Installs sample Microsoft Excel reference data workbooks and the utilities needed to bulkload the workbooks into the Catalog task. Select this option for people working with reference data and the Catalog task. You must also install the **Server Connectivity** option if you select this option.
   - **Piping Specification Remote Access Server** - Installs the necessary software for correlating piping specification data between Smart 3D and SmartPlant P&ID. This option sets up the computer as a remote access server by registering the SP3DPIPipingSpecRemoteAccessServer COM+ component. For more information about the P&ID integration capabilities of the software, see *Integrating with SmartPlant P&ID* (on page 158) in the *Intergraph Smart 3D Installation Guide*. **IMPORTANT** If you select this option, make sure that the Distributed Transaction Coordinator service is not set to **Disabled**. The Piping Specification Remote Access Server installation will fail if this service is disabled.
   - **Database Interference Detection Service** - Installs the software required for database interference detection. You must configure this service through Windows Services. Requires the **Project Management** and the **Server Connectivity** components. For more information, see *Interference Checking Setup* (on page 165).
   - **Server Connectivity** - Installs required database connectivity components for **Project Management**, the Bulkload Utility, **Piping Specification Remote Access Server**, and the **Database Interference Detection Service**.
   - **64-bit Services** - Installs the 64-bit version of the Interference Checking and Drawings Batch Services components. **IMPORTANT** 64-bit Services cannot be uninstalled individually. You must remove all of Intergraph Smart 3D from the computer to remove the 64-bit Services component.
   - **Name Generator Installation** - Installs the 32-bit version of the Name Generator. Install this one if you are installing the Name Generator on a computer where the Oracle 32-bit client is installed.
   - **Name Generator 64-bit Installation** - Installs the 64-bit version of the Name Generator. Install this one if you are installing the Name Generator on a computer running a server
operating system, you are using Microsoft SQL Server, or you are installing on an Oracle database server.

**IMPORTANT**

- For more information about which version of the Name Generator you need and about the Name Generator in general, see *Name Generator Service Setup* (on page 108).

- Make sure that the Distributed Transaction Coordinator service is not set to **Disabled**. Name Generator installation will fail if this service is disabled.

- **Reference Data Installation** - Installs the reference data needed to run Smart 3D. You should pick one server on which to install the reference data. Do not install reference data on each client or administrator computer. For more information, see *Reference Data Setup* (on page 117).

- **Intergraph Smart 3D PDS Model & Data Translators Installation** - Installs the PDS Model & Data Translators (licensed-separately, SEBY801) component that further extends the PDS integration capabilities by allowing you to export Piping, HVAC, Electrical, Equipment, and Structure model data from PDS into Smart 3D. For more information, see *Install Smart 3D PDS Model & Data Translators* (on page 157).

- **Intergraph Smart 3D Tribon Interface Installation** - Installs the Tribon Interface (licensed-separately, SEBY812) component that allows you to import Tribon Initial Design M3 structural data into Smart 3D in marine mode for planning and outfitting purposes. For more information, see *Smart 3D Tribon Interface Setup* (on page 123).

- **Programming Resources Installation** - Installs the Programming Resources component which provides developers with the tools necessary to customize the software by creating custom commands or custom programs. For more information, see *Programming Resources Setup* (on page 120).

**IMPORTANT** Serial numbers are used for product identification only. A license key is required to run the software. For more information about installing and using SmartPlant License Manager, see the *SmartPlant License Manager Installation and User’s Guide* (SPLMInstall_UserGuide.pdf).

7. Read the license agreement. Click to agree to the Software License Agreement, and then click **Install**.

   *The selected options are installed on the computer.*

8. Click **Finish**.

**IMPORTANT** If you installed Smart 3D on a computer with version 4.5 of the .NET Framework installed, you must reboot your computer after installation completes.

**Civil Task Installation**

Before installing the Civil task, verify that Smart 3D Version 2014 R1 (10.1) has been installed. Then you need to install the Civil hot fix and then update the Civil schema.

**Install the Civil Hot Fix**

1. Double-click the hot fix setup.exe.
2. Select the Intergraph Smart™ 3D Hotfix Installation link.

3. Click Install.
   
   The hot fix installs.

4. Click Finish.

5. Select Reference Data Hotfix Installation.

6. Click Next on the welcome page.

7. Click Update.
   
   The reference data updates install.

8. Click Finish.

9. Select Programming Resources Hotfix Installation if example code such as naming rules have to be delivered.

10. Click Close.

    **NOTE** If your company copied the shared content to a custom folder, then you must upgrade your shared contents after the Civil Hotfix Reference Data installation is complete. For more details on upgrade procedure for shared content, refer to "Upgrade Procedure for the SharedContent (Symbols) Share" in Intergraph Smart™ 3D Plant Mode Upgrade Guide. Symbol files included in this hot fix are located in the [Product Folder]\3DRefdata\SharedContent\Bin\Civil folder.

**Update the Civil Schema**

**IMPORTANT** Do not update replicated databases. You must consolidate replicated databases before updating the civil schema. Be sure to backup your databases before using this command.

1. Click Start > All Programs > Intergraph Smart 3D > Project Management.

2. Select Tools > Custom Commands.
   
   The Custom Commands dialog box displays.

3. Click Add.
The *Add Custom Command* dialog box displays.

4. In the *Progid* box, type
   UpdateCivilSchema, Ingr.SP3D.Civil.Client.Commands.Update

5. In the *Command Name* box, type *Update Civil Schema*

![Add Custom Command dialog box](image)

6. Click **OK**.

7. Select the *Update Civil Schema* custom command, and then click **Run**.

*The Update Civil Schema dialog displays.*

![Update Civil Schema dialog](image)

All catalog databases that are linked to the active site along with the respective model databases display. You must select one or more Catalogs, and click **Update** to update the Civil schema. Catalogs that have already been updated are disabled and have the ✔ icon. Catalog databases for which you do not have permissions are not shown.
8. Select one or more catalogs to update.

9. Select **Regenerate Reports Database** to regenerate the reports database views for all the selected plants. Clear the checkbox if you plan to update the reports database manually. **IMPORTANT**: You must regenerate the reports database at some point after updating the schema.

10. Click **Update**. *A progress bar shows the progress of the update. A log file is written in the %temp% folder with the name "UpdateCivilSchema.log". Review the log to check if there are any failures. If any failures occur, you must manually perform that step.*

11. Click **View log file**.

12. Click **Close**.

**Bulkload Sheets**

Bulkload these workbooks using the **Add, modify, and delete records in existing catalog** mode to all the catalog databases that have to be updated. The workbooks are in [Product Folder]\Smart3D\CatalogData\BulkLoad\AdditionalDataFiles\Delta2014to2014R1\

1. 1_AMD_Delta_2014_2014R1_GenericNamingRules.xls
2. 1_AMD_Delta_2014_2014R1_Reports.xls
3. 1_AMD_Delta_2014_2014R1_Trench_CrossSections.xls
4. 1_AMD_Delta_2014_2014R1_Trench_General_Composition.xls
5. 1_AMD_Delta_2014_2014R1_HS_System.xls

**Create the Trench Parts Catalog Filter**

1. Click **Start > All Programs > Intergraph Smart 3D >Smart 3D** and define a workspace, or open an existing session.

2. Select **Tools > Select by Filter**.

   *The Select Filter dialog box displays.*

3. Navigate to **Catalog Filters\Default Filters\SP3D Object Filters\Object Types\Civil** in the hierarchy and select the Civil folder.

4. Click **New Filter (Simple or Asking)**.

   *The New Filter Properties dialog box displays.*
5. Type *Trench Parts* in the **Name** box, and select *SP3D\Civil\Trench Parts* as the filter criteria on the **Object Type** tab.

6. Click **OK**.  
   
The software creates a *Trench Parts* filter in the Civil folder in the **Select Filter** dialog box.

7. Click **OK**.

**Delete and Recreate Civil Report Filters**

1. Open Smart 3D, and select **File > Define Workspace**.
2. In the **Filter** drop down, select **More**.
3. Expand **Catalog Filters > Default Filters > SP3D Report Filters > Types of Reports > Civil**.
4. Delete these four filters:
   - Civil TrenchRun Detailed Properties
   - Civil TrenchFeature Detailed Properties
   - Civil TrenchStraightFeature Detailed Properties
   - Civil TrenchTurnFeature Detailed Properties
5. Now create these Filters in this order.
The names of the filters must be names specified here.

a. Create the filter with the name *Civil TrenchRun Detailed Properties* and filter criteria of *Trench Runs* in the hierarchy SP3D > Civil > Trench Runs.

b. Create the filter with the name *Civil TrenchFeature Detailed Properties* and filter criteria *Trench Features* in the hierarchy SP3D > Civil > TrenchFeatures.
c. Create the filter with the name *Civil TrenchStraightFeature Detailed Properties* and filter criteria *Trench Straight* in the hierarchy SP3D > Civil > Trench Features > Trench Straight.

d. Create the filter with the name *Civil TrenchTurnFeature Detailed Properties* and filter criteria *Trench Turn* in the hierarchy SP3D > Civil > Trench Features > Trench Turn.

e. A Catalog filter has to be created with the name *Trench Parts* in the hierarchy Catalog Filters > Default Filters > SP3D Object Filters > Object Types > Civil > TrenchParts*
by selecting the Trench Parts BOC node under the hierarchy SP3D > Civil > Trench Parts as the filter criteria.

Silent Installation

You can install and remove the software using a command line rather than the normal user interface allowing you to perform unattended installations. The following command line parameters and arguments can be used to perform a silent installation of the product:

S3DInstallation.exe SERIALNUMBER=### SLAACCEPT=YES [INSTALLDIR=<Path>] [X64SERVICES=Yes] [ADDLOCAL=Feature1,Feature2] [REMOVE=Feature1,Feature2]

**IMPORTANT** If you installed Smart 3D on a computer with version 4.5 of the .NET Framework installed, you must reboot your computer after installation completes.

**Required Arguments**

SERIALNUMBER=<serial number>

SLAACCEPT=YES

**NOTE** SLAACCEPT=Yes means that you are accepting the Software License Agreement.

If the PIDService feature is added, the following are also required:

- **NAMEGENUSERNAME**=<mydomain\myuserid>
- **NAMEGENPASSWORD**=<mypassword>

**Optional Arguments**

INSTALLDIR=<path to install to>  
The default is C:\Program Files (x86)\Smart3D

ADDLOCAL=<comma delimited list of features to install>  
See the table below for additional information.

REMOVE=<comma delimited list of features to remove>  
See the table below for additional information.

**NOTES**

- **ADDLOCAL** and **REMOVE** refer to user-selectable features. There are features that the user cannot see that are automatically installed that are not referenced in the list below.
For **ADDLOCAL** and **REMOVE**, ALL can be used, as in, **ADDLOCAL=ALL** or **REMOVE=ALL**

**X64SERVICES=Yes**

**IMPORTANT**

- The arguments for the command line are case-sensitive.
- If you are going to install Smart 3D silently with a script under a Terminal Services Server in Application Server mode, we recommend that you update the script to include a Change User mode command to set the user mode to Install mode first, and then back to Execute mode after the Smart 3D installation command. This ensures that changes written to registry key HKEY_CURRENT_USER are properly redirected to their corresponding HKEY_LOCAL_MACHINE registry after each user logs in into the system. These steps are also recommended when applying hot fixes and service packs in a silent install.

**List of User-Selectable Features**

To add or remove user-selectable features, use **ADDLOCAL** and **REMOVE**. If neither of these arguments is used, the features shown below are not installed. For example, if **ADDLOCAL** is set to **ProjectEnvironment** and **Server** (**ADDLOCAL=ProjectEnvironment,Server**), **ProjectEnvironment** (Project Management) and **Server** (Server Connectivity) are installed.

<table>
<thead>
<tr>
<th>Displayed Feature Name</th>
<th>Command Line Feature Name</th>
<th>Installed by Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Management</td>
<td>ProjectEnvironment</td>
<td>No</td>
</tr>
<tr>
<td>Piping Specification Remote Access Server</td>
<td>PIDService</td>
<td>No</td>
</tr>
<tr>
<td>Server Connectivity</td>
<td>Server</td>
<td>No</td>
</tr>
<tr>
<td>Bulkload Reference Data</td>
<td>Bulkload</td>
<td>No</td>
</tr>
<tr>
<td>Database Interference Detection Service</td>
<td>IFCService</td>
<td>No</td>
</tr>
<tr>
<td>64-bit Services</td>
<td>X64SERVICES</td>
<td>No</td>
</tr>
</tbody>
</table>

Examples of running client silent install from the command line:

This command line installs the product into the default location, `C:\Program Files (x86)\Smart3D`. No logging file is created unless a problem occurs. If a problem occurs, a logging file with a brief description of the problem is created in the Temp folder.

```
S3DInstallation.exe SERIALNUMBER=12345678901234 SLAACCEPT=Yes
```

This command line installs the product into location, `D:\Program Files\Smart3D`.

```
S3DInstallation.exe SERIALNUMBER=12345678901234 SLAACCEPT=Yes INSTALLDIR="D:\Program Files\Smart3D"
```
This command line installs all features, including **PIDServ** into the location, \D:\Program Files\Smart3D.

S3DInstallation.exe SERIALNUMBER=12345678901234 SLAACCEPT=Yes
INSTALLDIR="D:\Program Files\Smart3D" ADDLOCAL=ALL
NAMEGENUSERNAME=<mydomain\myuserid> NAMEGENPASSWORD=<mypassword>

This installs all of the features listed above except **PIDServ** into the location \D:\Program Files\Smart3D.

S3DInstallation.exe SERIALNUMBER=12345678901234 SLAACCEPT=Yes
INSTALLDIR="D:\Program Files\Smart3D" ADDLOCAL=ALL REMOVE=PIDServ

This command line removes the software with no user interaction but displays the progress on screen.

S3DInstallation.exe UNINSTALL

This command line installs all features with Smart 3D except for the 64-bit service.

S3DInstallation.exe SERIALNUMBER=### SLAACCEPT=YES [INSTALLDIR=<Path>] [ADDLOCAL= X64SERVICES,Feature2]

Reference Data Installation Options

The Smart 3D reference data can also be installed using a command-line. Examples of running reference data silent install from the command line:

To install reference data in default location (C:\Program Files (x86)\Smart3D\3DRefData):

msiexec /i "<path>\S3DReferenceData.msi" SLAACCEPT=Yes ADDLOCAL=ALL /qn

To uninstall reference data:

msiexec /passive /x "<path>\S3DReferenceData.msi"

Name Generator Installation Options

The name generator requires a separate installation procedure after installing the reference data. You must include the **NAMEGENUSERNAME** and **NAMEGENPASSWORD** arguments when installing the name generator. The default location is C:\Program Files (x86)\Smart3D.

Examples of running name generator silent install from the command line:

On the 32-bit and 64-bit computers, you can use the following command-line argument:

msiexec /i "<path>\S3DNameGenerator.msi" SLAACCEPT=Yes ADDLOCAL=ALL
NAMEGENUSERNAME=<mydomain\myuserid> NAMEGENPASSWORD=<mypassword> /qn

To install the 32-bit version of the Name Generator on 64-bit computers, use the following command-line argument:

msiexec.exe /i "<path>\S3DNameGenerator.msi" SLAACCEPT=Yes ADDLOCAL=ALL
X86NAMEGEN=true NAMEGENUSERNAME=<mydomain\myuserid>
NAMEGENPASSWORD=<mypassword> /qn
To uninstall the name generator:

`msiexec /passive /x "<path>\S3DNameGenerator.msi"`

**Citrix Installations**

If you are installing Smart 3D in a Citrix environment, you need to be aware of the following.

Windows stores system path statements for individual executable files under the following registry path (depending on the platform):

- **32-bit O/S:** HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\App_name.exe
- **64-bit O/S:** HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\App_name.exe

When a program registers an application path this way, Windows adds the path statement to the search path whenever the application is run. This path information becomes part of the System Search Path search order.

When applications are launched through Terminal Services (or Citrix), these path statements are not automatically added. If an application requires this path, then the path information from the appropriate AppPath registry key must be added to the path variable of the System Environment.

**CAUTION:** Ensure that you back up the current value of the system path to a file for later reference if there is an issue. Making a mistake during the modification of the system path variable can render the computer unusable. It is essential to know the path contents prior to the modification to bring the computer back with any real confidence if there is a problem.

1. In the Registry, copy the data of the **Path** value for the application executable:
   - **32-bit O/S:** HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\App_name.exe
   - **64-bit O/S:** HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\App_name.exe

2. Display the **System Properties** window via the Control Panel.
3. Click the **Advanced** tab.
4. Click **Environment Variables**.
5. In the **System variables** list, select **Path** and click **Edit**.
6. Paste the value data from the Registry to the end of the Path string.
7. Click **OK** to dismiss all windows.

**Citrix Server Requirements**

Before installing Smart 3D, you need to consider factors such as project size and the number of users. Contact Intergraph Support ([http://www.intergraph.com/support](http://www.intergraph.com/support)) for more information about Citrix and Smart 3D.

**Register Solid Edge .DLL File**

While not a prerequisite, Solid Edge can be used with Smart 3D. For optimum performance, install Solid Edge prior to running the Smart 3D software setup. In the event that Solid Edge is installed after Smart 3D, you will need to manually register the *Pvdt80.ocx* file.

Additionally, if you uninstall or reinstall either Smart 3D or Solid Edge from the workstation computer, use the steps outlined in the following procedure to manually register the *Pvdt80.ocx* file.

**IMPORTANT** You must have administrator privileges for the workstation computer on which you want to register the file.

1. Open Windows Explorer. On the Windows task bar, right-click on **Start** and select **Explore**.
2. Browse to *[INSTALLDIR]/Smart3D/Core/Register* and double-click **RegisterPvtd80.vbs** to register the Pvdt80.ocx file on your computer.

**See Also**

*Third-Party Integration* (on page 12)
Name Generator Service Setup

The Name Generator Service supplies unique names to items placed in the model database. Although we recommend installing the Name Generator Service on the same computer as the reference data software, you can install the Name Generator Service on any computer running on the Windows domain.

Refer to Install Smart 3D Client Software (on page 94) for setup instructions.

Hardware Requirements

For optimal performance, the following minimum hardware requirements are recommended:

- 2.8 GHz Pentium® 4 processor or higher
- Minimum of 1 GB memory
- 100 BaseT or higher network interface
- Minimum of 5 MB hard drive disk space on the drive where Name Generator Service is installed

Prerequisite Software

For optimal performance, the following minimum software requirements are recommended:

- For large installations: Microsoft Windows Server 2008 R2
  or
  For small installations: Windows 7 64-bit (maximum 20 connections)
- Microsoft .NET Framework 4.5
- Adobe Acrobat Reader
- 32-bit or 64-bit Oracle Client if you are using Oracle as your database

**Important**

- Distributed Transaction Coordinator service must be enabled. Name Generator installation will fail if this service is disabled.
If you are installing the Name Generator Service on a Windows Server 2008 R2 computer, you must add the Role service Com+ Network Access. For more information, see *Enable Network Access in Windows Server 2008* (on page 114).

If you are installing the Name Generator Service on the database server computer, you must register the Microsoft SQL Server, see *Register the Microsoft SQL Server* (on page 38).

If you are installing the Name Generator Service on an Oracle 32-bit Client computer, the computer must be configured to access the Oracle database server through Net Manager.

You must install the 32-bit Name Generator if you are using a 32-bit Oracle client.

Installing the 32-bit Name Generator with 32-bit Oracle Client on a 64-bit Oracle server causes slower database performance.

You can install the 32-bit Name generator on 64-bit workstations with 32-bit Oracle client loaded.

The Name Generator Service works when installed on 64-bit Oracle database servers. We recommend that if you are running Oracle 64-bit on a 64-bit server, install the 64-bit Name Generator.

After installing the Name Generator Service, the firewall on that computer must be configured to allow DCOM Dynamic Ports. For more information, see *Configure the Firewall to Allow DCOM Communication in Windows 2008 Server* (on page 115).

### Configure the Name Generator Service

Perform the following steps to verify and, if necessary, manually configure the Smart 3D Name Generator Service on a computer. This procedure is only necessary if you received the following error message during installation of the Name Generator Service:

1. Log on with an account that has administrator privileges.

2. Open the Control Panel, double-click **Administrative Tools**, and then double-click **Component Services** to start the component services MMC snap-in.
The **Component Services** window appears as shown in the following illustration:

3. Expand the **Component Services** node under the **Console Root**, and then expand the **Computers** and **My Computer** nodes.

4. Expand the **COM+ Applications** node.

5. Verify the **SP3DNameGenerator** icon appears under **COM+ Applications**. If it exists, skip to step 14. If it does not exist, perform steps 6-13.

6. Select **COM+ Applications** under the **My Computer** node, and then click **Action>New>Application** on the horizontal toolbar.

7. Click **Next** on the **Welcome to the COM Application Install Wizard** page.
8. Select **Create an empty application** on the **Install or Create a New Application** page.

9. On the **Create an Empty Application** page, type **SP3DNameGenerator** in the **Enter a name for the new application** text box.

10. Select **Server application** as the **Activation type**, and then click **Next**.

11. On the **Set Application Identity** page, enter the user name and password to set the proper identity under which the COM+ application will run on the computer, and then click **Next**.

   **IMPORTANT**
   - You must specify an account with Windows administrative privileges on the computer.
   - If you are configuring the Name Generator Service on a computer on which Microsoft SQL Server is installed, the user account must also be a SQL Server Login that has a system administrator role in SQL Servers; otherwise, the Name Generator Service will not run. For information about creating a SQL Server Login and assigning administrator privileges, see **Register the Microsoft SQL Server** (on page 38).

12. Click **Finish** to begin the installation.

   **NOTE** When the installation is complete, a **SP3DNameGenerator** node is placed under **COM+ Applications**.

13. Next, expand the **SP3DNameGenerator** node.

14. Expand the **Components** node. Verify the **NTNameService.UpdateNumber.1** component appears. If it exists, skip to step 20. If it does not exist, perform steps 15-19.

15. On the horizontal toolbar, click **Action > New > Component**. The **COM Component Installation Wizard** appears.

16. Click **Next** on the **Welcome to the COM Component Install Wizard**.
17. Select **Install new component(s)** and browse for **NTNameService.dll**.

   TIP The 32-bit component .DLL is located in `[Product Folder]\CommonApp\Server\Bin`. The 64-bit component .DLL is located in `[Product Folder]\CommonApp\Server\Bin64`.

18. Click **Next** on the **Install new components** page, and then click **Finish** to complete the installation procedure.

   NOTE The **Component Services** window indicates that the **NTNameService.UpdateNumber.1** component is installed in the SP3DNameGenerator Application.

19. Select the **SP3DNameGenerator** application icon.

20. Click **Action > Properties**, and then click on the **Identity** tab.

21. Select the **This user**: option.
22. Enter the user and password to set the proper identity under which the COM+ application will run on the computer.

![SP3DNameGenerator Properties](image)

**Account**
- System Account:
  - Interactive user - The current logged on user
  - Local Service - Builtin service account.
  - Network Service - Builtin service account with network access.
  - Local System - Complete access to local machine
- The user:
  - User: `ingnet\vince`
  - Password: `***********`
  - Confirm password: `***********`

**IMPORTANT**
- You must specify an account with Windows administrative privileges on the computer.
- If you are configuring the Name Generator Service on a computer on which Microsoft SQL Server is installed, the user account must also be a SQL Server Login that has a system administrator role in SQL Servers; otherwise, the Name Generator Service will not run. For information about creating a SQL Server Login and assigning administrator privileges, see *Register the Microsoft SQL Server* (on page 38).

23. Click **Apply**.

24. Select the **Security** tab.

25. Under **Authorization**, clear the **Enforce access checks for this application** option if selected.

26. Click **OK** to complete the configuration procedure.

27. Configure MSDTC. For more information, see *Configure Microsoft Distributed Transaction Coordinator* (on page 114).
Enable Network Access in Windows Server 2008

The following procedures for enabling network access are required only if you are using Windows Server 2008 R2 (64-bit) on the computer.

Enable COM+ Network Access

1. Open the Control Panel.
2. Click Turn Windows features on or off to open the Server Manager.
4. Ensure that you have completed the preceding steps listed on the Before You Begin page, and click Next.
5. On the Select Server Roles page, select Application Server and click Next.
   
   **NOTE** If the server finds any of the required features for Application Server are missing, a prompt is displayed informing you to install those features. Click Add Required Features to allow the server to install them automatically.
6. On the Application Server page, click Next.
7. On the Select Role Services page, select COM+ Network Access, and click Next.
8. Confirm your installation selections and click Install.
9. After the installation is complete, click Close to exit the wizard.
   
   **NOTE** If Application Server is already enabled on Windows Server 2008, follow these steps to enable COM+ Network Access:
10. Open the Control Panel.
11. Click Turn Windows features on or off to open the Server Manager.
12. Click Roles > Application Server.
13. In the Role Services section, click Add Role Services.
14. On the Select Role Services page, select COM+ Network Access, and click Install.

Configure Microsoft Distributed Transaction Coordinator

All network Microsoft Distributed Transaction Coordinator (MSDTC) transactions are disabled. Use the following procedure to manually configure MSDTC and re-enable your distributed scenarios.

1. Click Start > All Programs > Accessories > Run.
2. Type dcomcnfg, and click OK.
3. Under Console Root, expand the Component Services, Computers, My Computer, and Distributed Transaction Coordinator nodes.
4. If you get a Windows Firewall alert regarding Microsoft Management Console features being blocked, select Domain networks, such as a workplace network, and then click Allow access.

5. Under the Distributed Transaction Coordinator node, right-click on Local DTC and select Properties.


8. In the Client and Administration section, enable Allow Remote Clients and Allow Remote Administration options.

9. In the Transaction Manager Communication section, enable the Allow Inbound, Allow Outbound and No Authentication Required options.

10. Enable the Enable XA Transactions option.

11. In the DTC Logon Account section, verify that NT AUTHORITY/Network Service appears in the Account box.

12. Click OK.

13. Click Yes if you are prompted to stop and restart the MSDTC service.

**Configure the Firewall to Allow DCOM Communication in Windows 2008 Server**

The following procedure presumes that you are using the firewall delivered by Microsoft with Windows 2008 R2 Server. If you are using third-party firewall software, please consult that product's documentation.

You must configure the firewall on the Windows 2008 R2 Server computer as described below for the Name Generator to run:

- All RPC Dynamic Ports in the firewall must be open in order for the Name Generator to communicate with the client computers.
- The Name Generator must be able to communicate with the SQL Server default instance running over TCP and the SQL Server Browser service.

**IMPORTANT** The firewall can reset itself to its default settings. If you encounter an error, review your Windows Firewall settings and verify that they are as outlined in this procedure.

**Windows Firewall Instructions for RPC Dynamic Ports**


2. In the left panel section, select Advanced settings.

3. In the left panel section, select Inbound Rules.

4. In the right panel section under Actions, click New Rule.

5. Select Port, and then click Next.

6. Select TCP and Specific local ports.

7. Type 135 in the Specific local ports box.

8. Click Next.
9. Select **Allow the connection**, and then click **Next**.
10. Verify that **Domain**, **Private**, and **Public** are selected, and then click **Next**.
11. In the **Name** box, type RPC.
12. In the **Description** box, type Smart 3D Name Generator RPC.
13. Click **Finish**.
14. Right-click the new RPC rule in the list, and then select **Properties**.
15. Select the **Protocols and Ports** tab.
16. In the **Local port** option, select **RPC Dynamic Ports**.
17. Click **OK**.
18. Restart your computer so that the changes can take effect.

**Windows Firewall Instructions for Microsoft SQL Server**

1. Click **Start > Control Panel > System and Security > Windows Firewall**.
2. In the left panel section, select **Advanced settings**.
3. In the left panel section, select **Inbound Rules**.
4. In the right panel section under **Actions**, click **New Rule**.
5. Select **Port**, and then click **Next**.
6. Select **TCP** and **Specific local ports**.
7. Type 1433 in the **Specific local ports** box.
8. Click **Next**.
9. Select **Allow the connection**, and then click **Next**.
10. Verify that **Domain**, **Private**, and **Public** are selected, and then click **Next**.
11. In the **Name** box, type SQL Server Instance.
12. In the **Description** box, type Smart 3D Name Generator SQL Instance.
13. Click **Finish**.
14. In the right panel section under **Actions**, click **New Rule**.
15. Select **Port**, and then click **Next**.
16. Select **UDP** and **Specific local ports**.
17. Type 1434 in the **Specific local ports** box.
18. Click **Next**.
19. Select **Allow the connection**, and then click **Next**.
20. Verify that **Domain**, **Private**, and **Public** are selected, and then click **Next**.
21. In the **Name** box, type SQL Browser.
22. In the **Description** box, type Smart 3D Name Generator SQL Browser.
23. Click **Finish**.
Reference Data Setup

Prior to installing Smart 3D Reference Data on the database server, verify that the server computer meets the required hardware and software requirements and that all prerequisite software has been installed. For more information about hardware and software requirements, see Smart 3D Database Server Recommendations (on page 18). For more information about the prerequisite software, see Loading Prerequisite Software on the Database Server (on page 33).

Refer to Install Smart 3D Client Software (on page 94) for setup instructions.

If you have an older version of Smart 3D software installed on your computer, uninstall it before loading the new software. Refer to the section entitled Remove Smart 3D Software (on page 208).

If you are installing the Smart 3D Reference Data software on a computer running Windows Server 2008 R2, you must first enable COM+ Network and DTC access and add the necessary users to the Distributed COM Users group. For more information, see Instructions for Microsoft Windows Server 2008.

Approximately 4.29 GB of hard disk space is required to load the Smart 3D Reference Data software. Prior to installing Smart 3D Reference Data, select and size the hard disk partitions accordingly. For additional information, see Disk Partitioning Guidelines (on page 25).

**IMPORTANT** You must share the SharedContent folder after installation is complete. For more information, see Configure Network Shares (on page 117).

Configure Network Shares

Before using Smart 3D, you must configure the following network shares. The paths to these shares are needed while working in the software.

Database Templates Share

**IMPORTANT** Creating a share for the database templates that are delivered during the Reference Data setup is necessary only if you are planning to use Oracle databases.

Create a share on a computer to hold the database templates that you create for use with the software. By default, the database templates are delivered as part of the Reference Data setup.

The user login used to create the Smart 3D databases and the account on which the Oracle service (OracleService<SID>) is running require Write permissions to this share.

**NOTE** For Oracle, the *userid* under which the Oracle service runs must have Write permission on both the share and the folder where the database templates are located. If the Oracle service
is running as the local SYSTEM account, you should add the NT AUTHORITY/SYSTEM account to both.

**SharedContent Share**

Create a share for the SharedContent folder that is created during the Reference Data setup. All users must be granted read permissions on the share; those users responsible for creating output and reference data must have write access. You will need to specify this location name when you use the Database Wizard to create the Site and Catalog databases.

Additionally, if you installed Reference Data in the default folder (C:\Program Files (x86)\Smart3D\3DRefData), you must adjust access permissions as follows:

- Access the Properties page for the SharedContent folder and modify the share permissions on the Sharing tab. At a minimum, permissions must allow read access for all users, and write access to those users responsible for creating output.
- Access the Properties page for the SharedContent folder and modify the share permissions on the Security tab to give users full control disk access for the SharedContent folder and subfolders.

**See Also**

Reference Data Setup (on page 117)

**Move Custom DLLs to SharedContent Folder**

Custom DLLs are any DLLs that are not originally delivered with Smart 3D or delivered DLLs that have been modified by you to suit a specific purpose. Custom DLLs should be saved in the [Reference Data Folder]\SharedContent\Custom Symbols folder on your SharedContent share. Use the following workflow to copy your customized DLLs to this single location instead of registering each DLL on all client computers.

1. Recompile each Visual Basic project in a Version 2014 R1 (10.1) client installation.
2. Copy the new DLLs to the [Reference Data Folder]\SharedContent\Custom Symbols folder.

   **NOTES**
   
   - You can create hierarchy folders as needed under the Custom Symbols folder.
   - If a custom DLL has a localizer DLL, both files should be located in the same folder.
   - DLLs ending with "-Ref.dll" or ".Ref.dll" are treated as reference DLLs and are ignored. These DLLs do not need to be copied from the client machine containing the rules Visual Basic source code.

3. In the Project Management task, select a catalog that uses the SharedContent folder in which your custom DLLs are located.
4. Click **Tools > Update Custom Symbol Configuration**, or right-click the catalog node, and select **Update Custom Symbol Configuration**.

   The **Update Custom Symbol Configuration** dialog box displays.

   **NOTE** Update Custom Symbol Configuration creates or updates the **CustomSymbolConfig.xml** in the [Reference Data Folder]\SharedContent\Xml folder. CustomSymbolConfig.xml contains entries with the ProgID, CLSID, and DLL name for each class in the custom DLLs. After CustomSymbolConfig.xml is created, the software uses the
custom DLLs from the [Reference Data Folder]\SharedContent\Custom Symbols folder without needing to register the DLL on the local computer.

5. Click OK to begin processing.

After you click OK, the options and commands on the dialog box are unavailable. This is to prevent you from interrupting the update process. The status bar at the bottom of the dialog box displays a message that the software is updating the symbol mapping file. When processing completes, the status bar shows whether the process finished with or without errors.

6. Click View log files to open the log file in your default text editor, and review the results.

7. Click Close to exit the dialog box.

IMPORTANT

- The software searches [Reference Data Folder]\SharedContent\Xml\CustomSymbolConfig.xml first and then SystemSymbolConfig.xml. If there are duplicate entries in CustomSymbolConfig.xml and SystemSymbolConfig.xml for the same ProgID, an error or warning is written to the error log that appears when the Update Custom Symbol Configuration command finishes processing, and the DLL is not added to either XML file (CustomSymbolConfig.xml and SystemSymbolConfig.xml). Please clear any errors or warnings that appear in the error log after running this command to prevent such a scenario.

- Whenever a symbol or naming rule class is accessed, the software searches for the DLL as follows:
  a. It checks whether or not an entry for the ProgID exists in the xml files. If an entry exists, then the corresponding DLL is loaded, and an instance of the class is created.
  b. If an entry does not exist, it searches previously registered DLLs on the local computer.
  c. If any entry is not found for the ProgID in either XML file, and the DLL is also not registered on the local machine, the software returns an error. In this case, you should copy the DLL to the [Reference Data Folder]\SharedContent\Custom Symbols folder and run the Update Custom Symbol Configuration command in Project Management.

If an entry exists for a ProgID in the xml files, it is used even though another or the same copy of the DLL is registered on the local machine. The order of priority when creating an instance of an object is: CustomSymbolConfig.xml, SystemSymbolConfig.xml, and then the registry.

- When a new custom DLL is added to the [Reference Data Folder]\SharedContent\Custom Symbols folder or an existing custom DLL is modified, you must re-run the Tools > Update Custom Symbol Configuration command in Project Management.

- If you choose to use option 1, then the custom DLLs in the [Reference Data Folder]\SharedContent\Custom Symbols folder should not be registered on the local computer.

- If any of these components use helper classes, and the helper classes are instantiated by calling "CreateObject," the "CreateObject" needs to be replaced. If the helper class is in the same project, then "new" can be used instead of "CreateObject". If the helper class is in a different project, then "SP3DCreateObject" needs to be used, instead of "CreateObject". SP3DCreateObject tries to instantiate the object using the information in xml files. If no entry is found in xml files for the given ProgID, then it calls "CreateObject." SP3DCreateObject is implemented in [Product Folder]\Core\Runtime\SP3DCoCreateInstance.dll. When
SP3DCreateObject needs to be used, 

```
SP3DCoCreateInstance.dll needs to be referenced in the Visual Basic project. Example usage of SP3DCreateObject is shown below:
Set oHelperObject = SP3DCreateObject(strHelperProgId)
```

- If the symbol class has any public structures or types, they should be made private. For example:

  ```
  Public Type InputType
      Name As String
      Description As String
      Properties As IMSDescriptionProperties
      uomValue As Double
  End Type
  
  Should be changed to:
  
  ```
  Private Type InputType
      Name As String
      Description As String
      Properties As IMSDescriptionProperties
      uomValue As Double
  End Type
  ```

- Debugging and maintaining Visual Basic project references, reference DLLs, and binary compatibility are beyond the scope of this document. Contact your Intergraph Support representative if you have questions.

### Programming Resources Setup

Before installing the Programming Resources component, verify that the Smart 3D software is installed on the workstation computer. For specific installation guidelines, see *Smart 3D Workstation Recommendations* (on page 19).

Approximately 620 MB of hard disk space is required to perform a complete installation of the Programming Resources component. Before proceeding, verify that enough disk space is available on the workstation computer.

Refer to *Install Smart 3D Client Software* (on page 94) for setup instructions.

**NOTE** The Microsoft Help Viewer is the latest integrated system in which to display help documentation for Visual Studio 2013 and later. We recommend that you complete Visual Studio configuration for the help display before installing Programming Resources. Refer to *Setting the Help display in Visual Studio* below for instructions.

The Programming Resources component provides developers with the tools necessary to customize the software by creating custom commands or custom programs. Before attempting to create commands or programs, you should be very familiar with Smart 3D interactively and understand its basic concepts of Projects, engineering, architecture, concurrency, and datastores, including the following:

- Microsoft Visual Basic (6.0 or later) at an advanced level, developing client and server systems and interfaces, and using Automation (C++ is not a requirement). Although any COM-compliant development platform can be used to interact with the software, Visual Basic is the preferred language because of its simplicity.
Unified Modeling Language® (UML)®. UML is a popular method used to represent object-oriented data models. A brief overview of UML describes its relationship to the Smart 3D data model.

Basic understanding of Smart 3D functionality. If you want to develop a command that performs placement of a vessel, you need to understand how to place the vessel interactively by using the software.

Architecture. Smart 3D software has an architecture that is component-oriented and built on three tiers.

Basic understanding of relational databases. Making the software task-oriented, Smart 3D uses one datastore.

Engineering and project knowledge.

The default installation of the Programming Resources component includes online documentation, sample code, and installation wizards that add tools to Visual Basic menus to help make commands. The following features are available with the Programming Resources component:

- **Command Wizard** - Provides tools and methods for a new Visual Basic project and build a basic command based on those selected requirements.
  
  **IMPORTANT** For more specific information about creating commands using the Smart 3D application programming interface (API), contact Intergraph Support (http://www.intergraph.com/support).

- **Symbol Wizard** - Creates and customizes three-dimensional symbols that fit your company or project. The wizard produces a Visual Basic project for building the symbol ports and graphics, and generates an Excel workbook for bulk-loading the symbol data into the Catalog database. Included with the Symbol Wizard, is a Visual Basic add-in called the Equipment Symbol Upgrade Wizard. This wizard allows you to upgrade Smart 3D version 5.0 Equipment symbols to Smart Occurrence-based equipment symbols.

- **References Helper** - Locates and references type libraries quickly and easily. The ability to reference a type library with this tool saves valuable time otherwise required when searching via Project > References in your Visual Basic project.

- **Programming Help** - Installs the Programming Help online documentation on the local computer.

- **Example Code** - Provides source code necessary for creating custom Visual Basic commands for Smart 3D. Also includes source code for customizing Visual Basic reference data rules and symbols. These rules are bulkloaded into the catalog.

- **Debug Code for Task Host** - Runs your Smart 3D Visual Basic project in debug mode.

- **.NET Programming** - Installs .NET Microsoft Visual Studio integrated programming help and examples.

  **NOTE** In order to display the .NET documentation delivered with .NET Programming, you must use the Visual Studio Help Library Manager to configure the Microsoft Help Viewer.

- **3D Schema Browser** - Displays the metadata and the relationships in the software.

### Setting the Help display in Visual Studio

The Microsoft Help Viewer implementation provides two options for displaying programming documentation. The default setting is to display online documentation from a website. To display
local programming documentation installed on your computer, you must set the viewer for local help. This allows you to use F1 and display installed Microsoft and Intergraph .NET programming documentation.

2. Click Help > Manage Help Settings to open the Help Library Manager.
3. Select Choose online or local help.
4. Select I want to use local help.
5. Click OK.
6. Click Exit to close the Help Library Manager.

For more information about using the Microsoft Help Viewer, see InstallationMSHelpViewerdocs delivered with the Smart 3D .NET Programmer’s Guide in [Product Install]\Smart3D\CommonApp\SOM\Doc.

See Also
Install the SmartPlant 3D Command Wizard (on page 122)
Install the SmartPlant 3D Symbol/Part Definition Wizard (on page 122)

Install the SmartPlant 3D Command Wizard

The SmartPlant 3D Command Wizard is available only as a feature with the Programming Resources component. For more information about Programming Resources, see Programming Resources Setup (on page 120).

To install the wizard, you must have administrator privileges on the client computer.

1. On a workstation computer, double-click SP3DCommandWizardV2.EXE in the [Product Folder]:\Smart3D\Programming\Tools\CommandWizard folder.
2. On the Welcome page, click Next.
3. On the Destination Folder page, click Next to install the SmartPlant 3D Command Wizard in the default installation folder.
   
   Tip: Click Browse to navigate to another installation location and then click OK.
4. On the Ready to Install the Application page, click Next.
5. After the wizard has successfully installed, click Finish.

See Also
Programming Resources Setup (on page 120)

Install the SmartPlant 3D Symbol/Part Definition Wizard

The SmartPlant 3D Symbol/Part Definition Wizard is available only as a feature with the Programming Resources component. For more information about Programming Resources, see Programming Resources Setup (on page 120).

To install the wizard, you must have administrator privileges on the computer.
1. On a workstation computer, double-click `setup.exe` in the folder `Product Folder:\Smart3D\Programming\Tools\SymbolWizard`.

2. On the **SmartPlant 3D Part Definition Wizard Setup** page, click **OK**.

3. If the default installation folder is acceptable, click the installation button. Otherwise, click **Change Directory**, browse to another installation folder, and click **OK**.

![SmartPlant 3D Part Definition Wizard Setup](image)

4. Click **OK** after the wizard has successfully installed.

**NOTES**

- During installation, the software registers the wizard on the client computer. The wizard can be accessed from the **Add-Ins** menu in the Visual Basic application.

- A Visual Basic add-in called the Equipment Symbol Upgrade Wizard is also delivered during installation of the SmartPlant 3D Symbol/Part Definition Wizard. The Equipment Symbol Upgrade Wizard allows you to upgrade Smart 3D version 5.0 Equipment symbols to Smart Occurrence-based Equipment symbols. For more information about registering and launching the Equipment Symbol Upgrade Wizard, see the **SmartPlant 3D/SmartMarine 3D Programmer's Guide** available from **Help > Printable Guides** in the software.

**See Also**

*Programming Resources Setup* (on page 120)

### Smart 3D Tribon Interface Setup

Installing the **Intergraph Smart™ 3D Tribon Interface** component allows you to import Tribon Initial Design M3 structural data into Smart 3D in marine mode for planning and outfitting purposes.

**Intergraph Smart™ 3D Tribon Interface** (SEBY812) is a separately-licensed product. Please contact Intergraph Support for licensing information.

Refer to *Install Smart 3D Client Software* (on page 94) for setup instructions.
Prior to installing the Smart 3D Tribon Interface, you must also have the Intergraph Smart™ 3D PDS Model & Data Translators (SEBY801) component installed, which is also a separately-licensed product. Please contact Intergraph Support for licensing information.

**IMPORTANT** If you have an older version of Smart 3D Tribon Interface installed on your computer, uninstall it before loading the new version.
Administrative privileges are required to create databases. Do not proceed unless you are an administrator on the database server computer and in the database provider software.

Understanding the Databases

Smart 3D uses seven databases: Site, Site Schema, Catalog, Catalog Schema, Model, Reports, and Reports Schema. These databases must be created before running Smart 3D.

The Site database and Site Schema database are containers for the other databases. The Site database stores work-breakdown and user access for the model. A Site database can have multiple Model and Catalog databases. Typically, there is one Site database set for each location. For information about Site databases, see the Project Management User's Guide available from Help > Printable Guides.

The Catalog database contains reference data, which includes part dimensions and industry standards. The Catalog database contains the non-graphical information derived from the reference data (in the form of Excel workbooks) delivered with the software. You can modify the delivered reference data by editing and bulk loading Excel workbooks. You also can use your own custom Excel workbooks and custom symbols, to create a new Catalog database specifically for your project. For more information about customizing the delivered reference data, refer to the Smart 3D Reference Data Guide available from Help > Printable Guides.

You can create a starting Catalog database and schema using the database template file delivered with the software. The CatalogDB.dat file is a backup of a sample Catalog database and contains the definition of a sample catalog of objects, including specific sizes of pipes, pipe specifications, steel section sizes, and so forth. Once the Catalog database is created, you can then bulk load your customized piping specifications into the Catalog database as needed. For more information about creating the required Catalog database for SQL, see Create the Site, Catalog, and Schema Databases for SQL (on page 128). If you are using Oracle, see Create the Site, Catalog, and Schema Databases for Oracle (on page 138).

CAUTION The CatalogDB.dat template file contains sample Smart 3D reference data and, while this template contains many useful examples, it is not certified for production use by Intergraph.

The Model database contains all instances of parts in the physical representation of the model. The Catalog and Model databases share the same schema. A model is all three databases used together: Catalog database, Catalog schema database, and Model database.

The Reports database and schema interact with the other five databases to generate tabular reports from Smart 3D data. For information about reports, see the Reports User's Guide and Drawings and Reports Reference Data Guide available from Help > Printable Guides.

The Catalog contains two hierarchies. The first is a Site database hierarchy made up of catalog permission group folders and permission groups. To view the Site database hierarchy for the Catalog, start the Project Management task. The second hierarchy is an object hierarchy made up of equipment, piping, and so forth. To view the hierarchy and its contents, start the Catalog task. For more information about the functionality in these tasks, refer to the Project Management Help and the Catalog Help files. These help files are delivered in C:\Program Files (x86)\Common Files\Intergraph\Smart3D\Help on the workstation computer.
For creation date and size information on each database, in Microsoft SQL Server you can open the SQL Server Enterprise Manager. This software also provides further technical details about the relational tables in each database.

The following illustration shows the relationships of the databases:

- (A) - Reports Database
- (B) - Site Database
- (C) - Model Database
- (D) - Catalog Database
- (E) - Site Schema
- (F) - Catalog Schema
- (G) - Reports Schema
These databases are created on a central server using the **Database Wizard** on a workstation computer on which the **Project Management** and **Server Connectivity** options are installed.

### Using Linked Servers

If your Site/Catalog/Model database server is different from your Reports database server, you can use linked servers for communication between the data sources. However, if linked servers are not configured correctly, the login can fail when you run queries against the linked server.

For linked servers to work correctly, ensure that the following conditions exist:

- The database link is created on the Site/Catalog/Model database server, not the Reports database server.
- The linked database server supports Windows Authentication Mode.
- The user is connected to SQL Server using Windows Authentication Mode on both database servers.
- Security account delegation is available on the client and the sending server.

For more information about setting up linked servers, see the Microsoft SQL Server documentation and *Linking Servers* (on page 137).

### See Also

- *Create the Site, Catalog, and Schema Databases for SQL* (on page 128)
- *Create the Site, Catalog, and Schema Databases for Oracle* (on page 138)
- *Assign Access Permissions for SQL* (on page 138)
Create Databases

Create the Site, Catalog, and Schema Databases for SQL

This procedure is for users of Microsoft SQL Server. If you are using Oracle, skip ahead to Create the Site, Catalog, and Schema Databases for Oracle (on page 138).

**NOTE** Site and Catalog database creation requires that you have Project Management and Server Connectivity components installed on the computer that you are using.

You must have the appropriate server components from Microsoft SQL Server installed on the server computer in order to create the databases. The user login used to create the databases must be part of the Administrators group on the local computer and the database server. Other users do not need to be part of the Administrators group on the local computer in order to run the product.

1. Click Start > All Programs > Intergraph Smart 3D > Database Tools > Database Wizard.
2. Select Create a new site, and then click Next.
3. From the Database type list, select MSSQL.

![Database Wizard Screen]

4. From the Site database server list, select the database server on which your Site database will reside.

**TIP** Only registered SQL Servers appear in the Site database server list. If your server does not appear, follow the steps in Register the Microsoft SQL Server (on page 38).
5. Enter the name of your Site database in the **Site database name** text box. Include the type of database in the name that you type. For example, type **MySiteDB**, **My_SDB**, or **ProjectXYZ_SDB**, where SDB stands for Site Database. Using the database type in the name makes identifying the Site database in SQL Server Management Studio easier. You must name the databases with unique names.

**TIP** When you name the Site database, the **Site schema server** and **Site schema name** boxes default to match the Site database server and name.

6. Enter the workshare location for the Site database in the **Site database workshare location** text box. You can use any string that represents your physical location.

**NOTE** This location is the location of the host Site database and is required even if the host is not going to be replicated for worksharing purposes. During generation of the Site database, the software creates a location object and associates it with the Site database.

7. Enter a name rule ID in the **Name rule ID** text box. By default, the software leaves this field blank. You can enter any string identifier, numeric or alpha.
The Name Generator Service that runs on the server computer you specify in the Name generator server for site box (step 8) supplies unique names to items placed in the Model database. In a replicated configuration, there are multiple servers and multiple instances of the Name Generator Service running at each location; consequently, there is no way to ensure unique and sequential naming of placed objects. The value entered in the Name rule ID text box functions as a substring (an internal ID number) that represents the location at which an item is placed into the replicated model.

8. Enter the name of the server computer on which the Name Generator Service is configured in the Name generator server for site box.

9. You cannot change the default locations for the site database files in the Physical database and Log file boxes.

10. Select Browse \(\ldots\) to the right of the Template file to be used to create site schema text box.

   The Browse for file on server: database_server_name dialog box appears.

11. If you installed the Reference Data on your database server, browse to the folder [Installation folder for Smart 3D Reference Data]\DatabaseTemplates\Plant.
If you did not install the Smart 3D Reference Data on your database server, you must copy the files in [Installation folder for Smart 3D Reference Data]\DatabaseTemplates\Plant on the reference data computer to a folder on a local drive on the database server computer.

12. Select the AppRepos.dat file, which is used by the software when creating your Site schema database.

13. Click Next.

The Catalog Database and Schema page displays.

14. Select whether you want to use an existing catalog or restore a catalog from backup.

- The Use existing catalog created in Project Management or Bulkload option to use an existing Catalog that is already available. If you intend to create a custom catalog, select this option and use the Bulkload utility delivered with the product. If you have used previous versions of SmartPlant 3D or SmartMarine 3D, more than likely this is the option that you want. If you select this option, then no further options are available.

- The Restore catalog from backup option restores a catalog from a Microsoft SQL Server backup file. If you choose to create a new Catalog database for the site using this option, the wizard will restore the .DAT file specified in the Template file to be used to create the Catalog database and schema box. Default Catalog database .dat files are delivered in [Installation folder for Smart 3D Reference Data]\DatabaseTemplates\Plant folder with the Reference Database installation.

15. Select the name of the database server in the Catalog database server list on which your Catalog database will reside.

16. Enter the name of your catalog database in the Catalog database name box. This step also automatically populates the name of your Catalog schema database in the Catalog schema name text box. Include the type of database in the name that you type. For example, type MyCatalogDB, My_CDB, or ProjectXYZ_CDB, where CDB stands for Catalog Database. Using the database type in the name makes identifying the Catalog database in SQL Server Management Studio easier.

17. Select the ellipsis button to the right of the Symbol and custom program file folder box, and browse for and select the SharedContent share on the Smart 3D reference data computer. If you did not create this share already, see Configure Network Shares (on page 117).

18. Select the ellipsis button to the right of the Template file to be used to create catalog database and schema text box and browse for the name of the catalog template file that you want the software to use when creating your Catalog and schema databases. If you
installed Reference Data on your database server, browse to the folder [Installation folder for Smart 3D Reference Data]\DatabaseTemplates\Plant.

If you did not install the Reference Data on your database server, you must copy the files in C:\Program Files (x86)\Smart3D\3DRefData\DatabaseTemplates\Plant on the reference data computer to a folder on a local drive on the database server computer.

**IMPORTANT:** The Catalog database that you use determines the Smart 3D mode for the site. For more information about modes, see Installation Overview (on page 10). Choose the Catalog database template carefully.

19. You cannot change the default locations for the catalog database files in the **Physical database** and **Log file** boxes.

20. Click **Next**.

21. On the **Ready to Create Databases** page, click **Create DB** to create your databases.

22. When the **Database Wizard** displays the database names that you entered, click **Finish**.

### Add Principle Particular Properties for Structural Manufacturing

The Structural Manufacturing Principle Particular properties are included in the Ship Catalog Data reference data in the \ShipCatalogData\BulkLoad\DataFiles\ProjectDBFiles\ShipClassCustomAttrs.xls workbook on the CustomInterfaces sheet. To add the Principle Particular properties to the Model database, you have to bulkload the workbook into the site database and modify the property values.

The **Principle Particular** custom classes include:

- Length Overall
- Length Between Perpendiculars
- Breadth
- Depth Molded
- Design Draft Molded
- Starting Point of Rise of Floor
- Rise of Floor
- Radius of Bilge Circle
- Start Point of Parallel Part
- End Point of Parallel Part
- Mid Ship or Position at Maximum Breadth
- X Position of AP
- X Position of FP
- Ship Type

**NOTE:** The **Mid Ship or Position at Maximum Breath** property is important because it is used to drive the molded forms conventions for plates and profiles. For example, the primary profile orientation for a deck may be: Forward for profiles fore of the Mid Ship Position and Aft for
profile aft of the Mid Ship Position. This definition will not work if the **Mid Ship or Position at Maximum Breadth** property is not defined.

**Bulkload the Structural Manufacturing Custom Attributes**

The custom classes are bulkloaded into the Marine Site database. The custom classes are inherited by the Model databases associated with the site. The values of the custom classes are assigned to each Model in the Project Management task.

1. Open **Start > Programs > Intergraph Smart 3D > Database Tools > Bulkload Reference Data**.
   
   *The Bulkload window appears.*

2. Under **Excel files**, click **Add** and browse to add `{Product Directory}\ShipCatalogData\BulkLoad\DataFiles\ProjectDBFiles\ShipClassCustomAttrs.xls`.

3. Under **Bulkload mode**, select **Append to existing catalog**.

4. In the **Catalog information** box, specify MSSQL as the **Database Type**, then select the appropriate **Site** database information.
   
   **IMPORTANT**: The custom classes are loaded into the Site database, so select the Marine Site database and Site Schema database. DO NOT select the Catalog database and Catalog Schema.

5. In the **Schema information** box, select the appropriate **Site schema** database information.

6. Specify a log file or browse to locate the log file using the ellipsis button.

7. Specify a **Symbol and custom program file location** or browse to locate the file using the ellipsis button.
8. Click **Load** to bulk load the Structural Manufacturing custom classes into the site.

![Bulkload](image)

9. Click **Close** when you have finished.

**Add the Principle Particular Properties to the Ship Model**

1. From the **Start** menu, select **Programs** > **Intergraph Smart 3D** > **Project Management**.

   *The Project Management task appears.*

2. Select a ship model database in the Project Management tree view.

3. Click **Edit** > **Properties**. You can also edit ship properties by clicking **Properties** ![Properties](image), or by right-clicking on a ship icon and selecting **Properties** on the shortcut menu.

4. Enter values for the **Principle Particular** custom classes.
   - **Length OverAll** – Overall length of the hull (along the x-axis).
- **Length Between Perpendiculars** – Length (along the x-axis) between the Aft Perpendicular (AP) and the Forward Perpendicular (FP).
- **Breadth** – Total width of the hull (along the y-axis).
- **Depth Molded** – Depth (along the z-axis) from the molded baseline to the upper deck level (freeboard); measured at midship.
- **Design Draught Molded** – Height (along the z-axis) from the baseline to the design waterline. The design waterline is based on the operational load of the ship.
- **Starting Point of Rise of Floor** – Distance (along the y-axis) from the centerline to the start of the Floor Rise at midship.
- **Rise of Floor** – Distance (along the z-axis) from the baseline to the floor at the beginning of the bilge radius.
- **Radius of Bilge Circle** – Radius of the bilge.
- **Start Point of Parallel Part** – Distance (along the x-axis) from the Aft Perpendicular to the start of the parallel midbody.
- **End Point of Parallel Part** – Distance (along the x-axis) from the Aft Perpendicular to the end of the parallel midbody.
- **Midship or position at Maximum Breadth** – Midship frame along the x-axis for a ship with a parallel midbody, or the midship frame along the x-axis where maximum breadth occurs for a ship without a parallel midbody.
- **X Position of AP** – Position of the Aft Perpendicular frame along the x-axis at the transom above the waterline.
- **X position of FP** – Position of the Forward Perpendicular frame along the x-axis at the bow above the waterline.
- **Ship Type** – Any text string for ship type, such as FPSO or LNG.

### Create the Model and Reports Databases for SQL

Model and Reports database creation requires that the **Project Management** and **Server Connectivity** options be installed on the computer that you are using.

1. Click **Start > All Programs > Intergraph Smart 3D > Project Management**.
2. In the tree view, select the Plants or Ships node.
3. Select **Database > New > Plant/Ship**.
   
   *The New Plant or New Ship dialog box appears.*

4. On the **General** tab, select the **Value** cell in the **Name** row, and enter a model name, such as **Model1**.

![Database Creation Screen](image)
5. In the **Value** cell in the **Description** row, enter a description, such as **Model Number 1**.

6. In the **Value** cell in the **Site** row, enter a site description, such as **Huntsville**.

7. In the **Value** cell in the **Owner** row, enter an owner description, such as **XYZ Group**.

8. On the **Databases** tab, click in the cell under **Type**, and select **Catalog** in the list.

9. Click in the **DB Provider** cell for the Catalog database, and select **MSSQL** from the list.

10. Click in the **Server** cell for the Catalog database, and select the server on which the Catalog database resides.

11. Click in the **Name** cell for the Catalog database, and select the Catalog database name that you created earlier.

12. In the second row, click the cell in the **Type** column, and select **Model** in the list.

   *The software automatically populates the **Name** field with the name of the new Model database.*

13. Click in the **DB Provider** cell for the Model database, and select **MSSQL** from the list.

14. Click in the **Server** cell for the Model database, and select the server on which the Model database will reside.

15. Edit the default name for the Model database if needed.

16. In the third row, click the cell in the **Type** column, and select **Reports** in the list.

   *The software automatically populates the **Name** field with the name of the new Reports database.*

17. Click in the **DB Provider** cell for the Reports database, and select **MSSQL** from the list.

18. Click in the **Server** cell for the Reports database, and select the server on which the Reports database will reside.

19. Edit the default name for the Reports database if needed.

20. In the **Name generator server for model** box, specify the server on which the Name Generator Service is installed.

   **NOTE** A name server must be a valid computer running on the Windows domain and one that has been properly configured to run as a name server. For more information about installing and configuring the Name Generator service, see the **Name Generator Service Setup** (on page 108).

21. You cannot edit the database file locations in the **Physical database** and **Log file** boxes.

22. Click **OK**. Wait for the process to complete.

*Icons for the new Model and its associated Catalog database appear in the tree view of the Project Management task.*

**IMPORTANT** Reports databases do not appear in the tree view. Reports database information can only be accessed using the **Database** tab of the Model database properties dialog box.

**NOTE** The Reports and Reports schema database are created automatically during the process.
Linking Servers

The **Linked Servers** option in Microsoft SQL Server Management Studio allows you to connect to another instance of SQL Server running on a different server.

If you have two or more database servers (target database servers) then you need to link them to the source database server. This allows **Copy by Family** in the Molded Forms task to support retrieving or copying data from different servers.

**Add User Account on Target Database Server**

1. Expand the listing under target database server in **Object Explorer**.
2. Expand the listing under **Security**.
3. Right-click **Logins**, and select **New > Login** from the shortcut menu.
4. On the **Login - New** dialog box, enter the user account in the **Login name** text box.
5. Select **SQL Server authentication**, and create a password.
6. Select **Server Roles** under the **Select a page** heading to display the **Server Roles** list.
7. In the **Server Roles** list, select the **sysadmin** check box.
8. Click **Ok**.

   *The new user account created is displayed under **Security > Logins** of the target database server.*

**Link Target Database Server to Source Database Server**

1. Connect to the target database server using the new user account you created. Change the password when prompted.
2. Expand the listing under for your source database server in **Object Explorer**.
3. Expand the listing under **Server Objects**.
4. Right-click **Linked Servers**, and select **New Linked Server** from the shortcut menu.
5. On the **New Linked Server** dialog box, enter the target database server name in the **Linked Server** text box.
6. Select **SQL Server** under **Server Type**.
7. Select **Security** under the **Select a page** heading to display security options.
8. Under **For a login not defined in the list above, connections will**; select **Be made using this security context**.; and enter the new user account information you created.
9. Click **Ok**.

   *The target database server added is displayed under **Server Objects > Linked Servers** of the source database server.*

**Test Connection**

Right-click the target database server that you linked to the source database server, and select **Test Connection** from the shortcut menu.

"**The test connection to the linked server succeeded.**" dialog box is displayed.
Assign Access Permissions for SQL

Perform the following steps on the database server computer.

1. Open Microsoft SQL Server Management Studio and expand your database server in the left tree view.
2. Expand the list under Security in the left tree view.
3. In the left pane, right-click Logins.
4. Select New Login from the shortcut menu.
5. On the Login - New dialog box, type the user account you want to be assigned administrative privileges in the Login name text box. For example, type AdminUser1.
6. Select Server Roles under the Select a page heading to display the Server Roles list.
7. In the Server Roles list, select the sysadmin and public check boxes. By default, users with sysadmin privileges have administrator rights to all databases.
8. Click OK.
9. To assign permissions for a user or a group of users, follow steps 2-5.
10. Select User Mapping under the Select a page heading to display the Users mapped to this Login list.
11. Select the Map check box for one of the seven databases containing a Smart 3D project, and then select db_owner and public as the database roles on the Database role membership for list.
12. Repeat the procedure for each of the remaining six databases.
13. Click OK.

See Also
Create Databases (on page 125)

Create the Site, Catalog, and Schema Databases for Oracle

This procedure is for Oracle databases. Site and Catalog database creation requires that you install the Project Management and Server Connectivity components. You must have the appropriate server components from Oracle server software installed on the server computer in order to create the databases.

NOTE: The dump files used to create the Site and Catalog database are delivered on the server computer to [Product Folder]\DatabaseTemplates. This location must be shared and write permissions given to both the user login used to create the Smart 3D databases and the account on which the Oracle service (OracleService<SID>) is running. For example, NT AUTHORITY\SYSTEM. Before proceeding, verify that the share (with the appropriate permissions) exists on the server computer.
1. Click **Start > All Programs > Intergraph Smart 3D > Database Tools > Database Wizard**.

2. Select **Create a new site**, and then click **Next**.

3. On the **Create Site Database and Schema** page, select **Oracle** from the **Database type** list.

4. In the **Oracle service** list, select the name of the Oracle net service for the site database connection.

5. Enter the name of your Site database in the **Site database name** text box.

   **TIPS**
   
   - To better differentiate between one database and another, include the type of database in the name you type. For example, type **Model1SiteDB**.
   
   - Do not use a name which starts with a digit as its first character. For example, if you enter a name such as 1ModelSiteDB, Oracle will not create the database.
   
   - When you name the Site database, the Oracle service (for the Site schema) and Site schema name default to match the Oracle service for the Site database and the Site database name.

6. Enter the workshare location for the Site database in the **Site database workshare location** text box. You can use any string that represents your physical location.

   **NOTE** This location is the location of the host Site database and is required even if the host is not going to be replicated for worksharing purposes. During generation of the Site database, the software creates a location object and associates it with the Site database.

7. Enter a name rule ID in the **Name rule ID** text box. By default, the software leaves this field blank. You can enter any string identifier, numeric or alpha; however, special characters are not supported.

   **NOTE** The Name Generator Service that runs on the server computer supplies unique names to items placed in the Plant (Model database). In a replicated configuration, there are multiple servers and multiple instances of the Name Generator Service running at each location; consequently, there is no way to ensure unique and sequential naming of placed objects. The value entered in the **Name rule ID** text box functions as a substring (an internal ID number) that represents the location at which an item is placed into the replicated Plant.

8. In the **Name generator server for site** box, type the name of the server computer on which the Name Generator Service is installed.

   **NOTE** A name server must be a valid server running on the Windows domain and one that has been properly configured to run as a name server.

9. Use the default paths for the site database files in the **Data tablespace file name** and **Index tablespace file name** boxes.

10. Click **Browse** to the right of the **Template file to be used to create site schema** text box to browse for the name of the dump file (**AppRepos.dmp**) the software uses when creating your Site schema database. The location of the file is on the reference data computer at `\[Server Name]\DatabaseTemplates\Plant\AppRepos.dmp`.

11. Click **Next**.
12. On the **Catalog Database and Schema** page, select the name of the Oracle net service for the Catalog database connection in the **Oracle service** list.

**TIPS**

- The option control at the top of the page allows you either to create a new Catalog database by restoring a backup or use an existing Catalog database. If you choose to create a new Catalog database using the **Restore** option, the wizard will restore the `.dmp` file specified in the **Template file to be used to create the Catalog database and schema** field. The software delivers one selection for this field, `CatalogDB.dmp`. The default is to **Restore catalog from backup**. If you select **Use existing catalog**, then no further options are available.

- If you intend to create a custom catalog, you must select the **Use existing catalog** option and use the Bulkload utility delivered with the product.

**CAUTION** The CatalogDB.dat template file contains sample Smart 3D reference data and, while this template contains many useful examples, it is not certified for production use by Intergraph.

13. Enter the name of your catalog database in the **Catalog database name** box. This step also automatically populates the name of the Catalog schema database in the **Catalog schema name** text box.

14. Use the default paths for the catalog database files in the **Data tablespace file name** and **Index tablespace file name** boxes.

15. Click **Browse** to the right of the **Symbol and custom program file folder** box to browse for and select the SharedContent share on the Reference Data computer.

**NOTES**

- The SharedContent share must be created after installing **Reference Data**. For more information, see **Configure Network Shares** (on page 117).

- The path in the **Symbol and custom program file folder** box must be a UNC path. To obtain a UNC path, click **Browse** and browse under **My Network Places**, not under **My Computer**.

16. Click **Browse** to the right of the **Template file to be used to create catalog database and schema** text box to browse for the name of the dump file (`CatalogDB.dmp`) you want the software to use when creating your Catalog and schema databases. The location of the file is on the reference data computer at `\[Server Name]\DatabaseTemplates\Plant\CatalogDB.dmp`.

**CAUTION** The CatalogDB.dat template file contains sample Smart 3D reference data and, while this template contains many useful examples, it is not certified for production use by Intergraph.

17. Click **Next**.

18. On the **Ready to Create Databases** page, click **Create DB** to create your databases.

19. When the Database Wizard displays the database names that you entered, click **Finish**.

**NOTES**

- The software delivers two log files - one for the Site database generation process and one for the Catalog database restore process - on the server computer at the local user `%temp%` folder.
Create Databases

- You must name the databases with unique entries.
- During the Site database creation process for an Oracle plant, the software attempts to connect to the Site database to create the user interface prior to generating the views, resulting in a "table or view does not exist" error being reported in the various log files. Since views are generated after the user interface is created, these errors cannot be avoided. Additionally, these errors do not have any negative impact on using the software and can be disregarded when reviewing the log files.
- We recommend that you increase and/or redefine initial tablespace values based on the expected scope of your project(s). For more information, see your Oracle documentation.

See Also
Create Databases (on page 125)

Create the Model and Reports Databases for Oracle

Model and Reports database creation requires that the Project Management and Server Connectivity options be installed.

1. Select Start > All Programs > Intergraph Smart 3D > Project Management.
2. Click the Plants icon in the Project Management tree view, and then click Database > New > Plant.
3. On the General tab of the New Plant dialog box, select the Value cell in the Name row, and enter a model name, such as Model1.
4. In the Value cell in the Description row, enter a description, such as Model Number 1.
5. In the Value cell in the Site row, enter a site description, such as Huntsville.
6. In the Value cell in the Owner row, enter an owner description, such as Plant Owner 1.

![New Plant Dialog Box]

7. On the Databases tab, click in the cell under Type, and select Catalog in the list.
8. Click in the DB Provider cell for the Catalog database, and select Oracle from the list.
9. Click in the Service cell for the Catalog database, and select the Oracle net service for the Catalog database connection.
10. Click in the **Name** cell for the Catalog database, and select the Catalog database name that you created earlier.

11. In the second row, click the cell in the **Type** column, and select **Model** in the list.

   *The software automatically populates the **Name** field with the name of the new Model database.*

12. Click in the **DB Provider** cell for the Model database, and select **Oracle** from the list.

13. Click in the **Service** column for the Model database, and select Oracle net service for the Model database connection.

14. In the third row, click the cell in the **Type** column, and select **Reports** in the list.

   *The software automatically populates the **Name** field with the name of the new Reports database.*

15. Click in the **DB Provider** cell for the Reports database, and select **Oracle** from the list.

16. Click in the **Service** column for the Reports database, and select Oracle net service for the Reports database connection.

17. In the **Name generator server for model** box, specify the server on which the Name Generation Service is installed.

   **IMPORTANT** A name server must be a valid computer running on the Windows domain and one that has been properly configured to run as a name server. For more information about installing and configuring the Name Generator service, see the **Name Generator Service Setup** (on page 108).
18. Specify the path for location of the model database files in the **Physical database** and **Index file** boxes.

19. Click **OK** on the **New Plant** dialog box. Wait for your computer to complete its processing. Icons for the new plant and its associated Catalog database appear in the tree view of the Project Management task.

**NOTE** Reports databases do not appear in the tree view of the Plant hierarchy. Reports database information can only be accessed via the **Database** tab of the **Plant Properties** dialog box. Right-click a plant and select **Properties** on the shortcut menu to display the **Plant Properties** dialog box.

**NOTES**

- The Reports and Reports schema database are created automatically during the plant generation process.
- After creating the plant, you can open the software on a workstation computer and begin designing the plant.
- We recommend that you increase and/or redefine initial tablespace values based on the expected scope of your project(s). For more information, see your Oracle documentation.

**See Also**

*Create Databases* (on page 125)

### Minimum Reference Data

When you create a new catalog, you must bulk load a minimum amount of reference data in order for the software to function properly. You must bulk load the workbook(s) for the disciplines that you want to work with and any other workbooks with related data such as codelists, naming rules, and so forth.

For example, if you want to create a catalog for piping and equipment only, bulk load AllCodelists.xls, AllCommon.xls, Equipment.xls, EquipmentComponent.xls, GenericNamingRules.xls, InsulationData.xls, Shapes.xls (for designed equipment), Ten_Specs_SpecificationData.xls, and Ten_Specs_CatalogData.xls.

**IMPORTANT** When using the Bulkload utility to create a new catalog, you must use the AppRepos.dat (for MSSQL) or AppRepos.dmp (for Oracle) template file to create the Catalog Schema. This file is located in **[Product Folder]/DatabaseTemplates** folder on the computer where the reference data was installed.

**NOTE** You can also run the Bulkload utility from the command line. For more information, see *Bulkload from the Command Line* in the *Reference Data Guide*, available from the **Help** > **Printable Guides** command.

<table>
<thead>
<tr>
<th>Discipline</th>
<th>Required Workbooks in Catalog</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cable</td>
<td>▪ AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ Cabling.xls</td>
</tr>
<tr>
<td></td>
<td>▪ GenericNamingRules.xls</td>
</tr>
<tr>
<td>Discipline</td>
<td>Required Workbooks in Catalog</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Cable Tray</td>
<td>▪ AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ AllCommon.xls</td>
</tr>
<tr>
<td></td>
<td>▪ CableTray.xls</td>
</tr>
<tr>
<td></td>
<td>▪ GenericNamingRules.xls</td>
</tr>
<tr>
<td>Cableway</td>
<td>▪ AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ AllCommon.xls</td>
</tr>
<tr>
<td></td>
<td>▪ CableWay.xls</td>
</tr>
<tr>
<td></td>
<td>▪ GenericNamingRules.xls</td>
</tr>
<tr>
<td>Conduit</td>
<td>▪ AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ Conduit.xls</td>
</tr>
<tr>
<td></td>
<td>▪ GenericNamingRules.xls</td>
</tr>
<tr>
<td></td>
<td>▪ MatingPort Sheet</td>
</tr>
<tr>
<td></td>
<td>▪ GenericDataPipingFemale Sheet</td>
</tr>
<tr>
<td></td>
<td>▪ PlainPipingGenericData Sheet</td>
</tr>
<tr>
<td>Drawings and Reports</td>
<td>▪ AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ Drawings.xls for volume drawings</td>
</tr>
<tr>
<td></td>
<td>▪ BulkLoadIsoKeys.xls for isometric drawings or spooling</td>
</tr>
<tr>
<td></td>
<td>▪ Reports.xls for report templates</td>
</tr>
<tr>
<td>Electrical</td>
<td>▪ AllCodeLists.xls</td>
</tr>
<tr>
<td></td>
<td>▪ Ductbank.xls</td>
</tr>
</tbody>
</table>
### Required Workbooks in Catalog

#### Equipment and Furnishings
- `AllCodelists.xls`
- `AllCommon.xls`
- `Equipment.xls`
- `EquipmentComponent.xls`
- `GenericNamingRules.xls`
- `InsulationData.xls`
- `Shapes.xls` for designed equipment
- `Standard Nozzle Data.xls` for designed equipment
- `Ten_Specs_CatalogData.xls`

#### Grids
- `AllCodelists.xls`
- `GridsCodelist.xls`
- `GenericNamingRules.xls`

#### Hangers and Supports
- `AllCodelists.xls`
- `HS_System_Codelists.xls`
- `AllCommon.xls`
- `GenericNamingRules.xls`
- `HS_System.xls`
- `HS_Property_Interface.xls`

**NOTE**: Apart from these workbooks, you must load the parts and assembly workbooks that you intend to use.

#### HVAC
- `AllCodelists.xls`
- `AllCommon.xls`
- `GenericNamingRules.xls`
- `HVAC.xls`
- `InsulationData.xls`
- `Carnes HVAC Catalog.xls` for Carnes HVAC parts
- `Lindab HVAC Catalog.xls` for Lindab HVAC parts
- `Spiral HVAC Catalog.xls` for Spiral HVAC parts
<table>
<thead>
<tr>
<th>Discipline</th>
<th>Required Workbooks in Catalog</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interference Checking</td>
<td>• AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>• GenericNamingRules.xls</td>
</tr>
<tr>
<td></td>
<td>• IFCRule.xls</td>
</tr>
<tr>
<td>Layout</td>
<td>• AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>• Auto Router Rules.xls</td>
</tr>
<tr>
<td>Piping</td>
<td>• AllCodelists.xls</td>
</tr>
<tr>
<td></td>
<td>• AllCommon.xls</td>
</tr>
<tr>
<td></td>
<td>• GenericNamingRules.xls</td>
</tr>
<tr>
<td></td>
<td>• InsulationData.xls</td>
</tr>
<tr>
<td></td>
<td>• Ten_Specs_SpecificationData.xls</td>
</tr>
<tr>
<td></td>
<td>• Ten_Specs_CatalogData.xls</td>
</tr>
</tbody>
</table>

**NOTES**
- Piping instruments require Instrument Data.xls and On-the-fly Instruments.xls
- Piping specialties require Piping Specialty Data.xls and On-the-fly Piping Specialties.xls
- A larger set of piping specifications and data are in Piping Specification.xls and Piping Catalog.xls.
- Metric piping specifications are in Piping.xls.
<table>
<thead>
<tr>
<th>Discipline</th>
<th>Required Workbooks in Catalog</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>▪ GenericNamingRules.xls</td>
</tr>
<tr>
<td></td>
<td>▪ SimpleDoor.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructAssemblyConnections.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructCrossSections_AISC_LRFD_3.1.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructCrossSections-MISC_SHAPES-1.0.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructEquipFoundations.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructFootings.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructFrameConnections.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructHandrails.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructInsulationSpec.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructLadders.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructMemberFireproofing.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructOpeningsMetric.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructPlateDimensions.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructSlabAssemblyConnections.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructSlabGeneral.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructSlabLayer.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructSplitConnections.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructStairs.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructWallAssemblyConnections.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructWallCrossSection.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructWallGeneral.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructWallLayer.xls</td>
</tr>
<tr>
<td></td>
<td>▪ StructWallOperators.xls</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Systems and Specifications</th>
<th>AllCodelists.xls</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>GenericNamingRules.xls</td>
</tr>
</tbody>
</table>

**NOTES:**

- The **Copy to Catalog** or **Paste from Catalog** commands require ModuleTypes.xls.
- Control points require GenericNamingRules.xls.
- Nozzles for piping, conduit, cable, and cable tray require Standard Nozzle Data.xls.
- **MatingPorts**, **PipingGenericDataFemale**, and **PlainPipingGenericData** worksheets are required when placing the conduit fittings. These sheets are located in the **Ten_Specs_SpecificationData.xls** and **Ten_Specs_CatalogData.xls**.
Additional reference data must be bulkloaded for a marine catalog. For more information, see Convert Database Mode (on page 149).

**Bulkload SmartPlant Layout Reference Data**

If you purchased SmartPlant® Layout with Intergraph Smart™ 3D (SEBY802), you need to bulkload several workbooks. If you did not purchase SmartPlant Layout, you can skip this section.

Several workbooks containing SmartPlant Layout reference data are delivered with the software in the \[Product Directory\]\Smart3D\Layout\Bulkload\Datafiles folder. For a detailed description of the workbooks, please refer to the Layout Reference Data Guide or the Layout Help file. After reviewing and customizing the contents of these workbooks, you need to bulk load them to your Catalog database. For more information about bulk loading workbooks, refer to Using the Bulkload Modes section of the Reference Data Guide.

1. On a client computer where you have installed Smart 3D, go to the \[Product Directory\]\Smart3D\Layout\Symbols\SymbolIcons folder.
2. Select all the .gif files in the folder and copy them to the symbols\SymbolIcons folder on your reference data server (\<refservername>\symbols\symbolIcons).
3. On a computer where the Project Management task has been installed, click Start > All Programs > Intergraph Smart 3D > Database Tools > Bulkload Reference Data.
4. Click Add next to the Excel codelist files list.
5. Browse to the \[Product Directory\]\Smart3D\Layout\Bulkload\Datafiles folder. The default location of the \[Product Directory\] is c:\Program Files.
6. Select the LayoutCodeLists_1.xls workbooks in the folder, and then click Open.
7. Click Add next to the Excel files list.
8. Browse again to the \[Product Directory\]\Smart3D\Layout\Bulkload\Datafiles folder.
9. Select the remaining workbooks in the folder, and then click Open.
10. Select the Append to existing catalog option.
11. In the Database server name option, select the name of the database server.
12. In the Database name option, select the Catalog database.
13. In the Catalog schema database option, select the Catalog schema database.
14. Enter a folder path and name for the log file.
15. Click Load.
   
   Depending on the Catalog database size and your computer speed. The bulk load process could take several minutes. The status bar at the bottom of the dialog box indicates the bulk load progress and when the bulk load is finished.
16. Click Close.
17. Review the log file.
Convert Database Mode

**Convert Database Mode** is a separate utility delivered with the Project Management task in the [Product Folder]\Core\Container\Bin\Assemblies\Release folder as ConvertDatabaseMode.exe. You must have Microsoft SQL Server SysAdmin privileges to the databases on the database server. Using this utility, you can:

- Convert from plant databases to marine databases.
- Convert from plant databases to material handling databases.
- Convert from marine databases to material handling databases.

**IMPORTANT**

- All users must be logged out of the source databases. No one can access or change the source databases during the conversion process.
- Backup all databases before using this utility in case of unforeseen failures during conversion.

The conversion process generates a log file as well as the usual Smart 3D error log files. The log file shows database details, conversion status, and validation of converted databases. For more information about the post-conversion process, see the *Smart 3D Plant Marine MHE Conversion Guide*.

**Limitations**

When converting databases, be aware of the following limitations:

- You can only convert Microsoft SQL Server databases. Oracle is not supported.
- Replicated databases must be consolidated before conversion. This utility supports only non-replicated databases.
- You cannot convert:
  - marine to plant,
  - material handling to plant
  - material handling to marine.

**Convert Database Mode Dialog Box**

Defines the settings for changing the site mode from plant to marine, plant to material handling, or marine to material handling.

**Server** - Select the database server that hosts the databases to change. Use SQL Server Management Studio to register the database server if the database server does not appear in the list.

**Site database** - Select the site database to change. You must have administrator access to this database on the database server.

**Log File** - Type a file name for the log file, such as c:\temp\ChangeMode.log.
Create Databases

Convert databases to - Select the destination mode for the databases. If the site database that you selected is a plant, you can select Marine or Material Handling. If the site database that you selected is a marine, you can only select Material Handling.

Type - Displays the database type (site, catalog, or model).

Database Name - Displays the name of the database.

Conversion Status - Displays the status of the database.

Convert - Changes the site database that you selected.

**IMPORTANT** You cannot stop the process after it has started. You have to restore a backup copy of the databases to go back to the previous mode if you change your mind.

What do you want to do?

- Change plant databases to marine (on page 150)
- Change plant databases to material handling (on page 150)
- Change marine databases to material handling (on page 151)

Change plant databases to marine

1. Double-click [Product Folder]\3D\Core\Container\Bin\Assemblies\Release\ConvertDatabaseMode.exe.

2. Select the registered Microsoft SQL Server that hosts the databases to change.

   **TIP** If the database server does not appear on the list, open Microsoft SQL Server Management Studio and register the database server.

3. In Site database, select the plant site database.

   *All the site databases as well as databases associated to the site appear.*

4. In Log File, type a log file path. All conversion status messages are written to this log file.

5. Select Marine.

6. Click Convert.

   *The utility changes the databases to the marine mode. The conversion status displays in the Conversion Status column.*

7. Click OK to close the message box and the utility.

8. Open Project Management, and regenerate the report databases.

Change plant databases to material handling

1. Double-click [Product Folder]\3D\Core\Container\Bin\Assemblies\Release\ConvertDatabaseMode.exe.

2. Select the registered Microsoft SQL Server that hosts the databases to change.

   **TIP** If the database server does not appear on the list, open Microsoft SQL Server Management Studio and register the database server.
3. In **Site database**, select the plant site database.

   *All the site databases as well as databases associated to the site appear.*

4. In **Log File**, type a log file path. All conversion status messages are written to this log file.

5. Select **Material Handling**.

6. Click **Convert**.

   *The utility changes the databases to the material handling mode. The conversion status displays in the Conversion Status column.*

7. Click **OK** to close the message box and the utility.

8. Bulkload the Belt general type part class workbook.


---

**Change marine databases to material handling**

1. Double-click *[Product Folder]*\3D\Core\Container\Bin\Assemblies\Release\ConvertDatabaseMode.exe.

2. Select the registered Microsoft SQL Server that hosts the databases to change.

   **[TIP]** If the database server does not appear on the list, open Microsoft SQL Server Management Studio and register the database server.

3. In **Site database**, select the marine site database.

   *All the site databases as well as databases associated to the site appear.*

4. In **Log File**, type a log file path. All conversion status messages are written to this log file.

5. Select **Material Handling**.

6. Click **Convert**.

   *The utility changes the databases to the material handling mode. The conversion status displays in the Conversion Status column.*

7. Click **OK** to close the message box and the utility.

8. Bulkload the Belt general type part class workbook.

Upgrading your databases from a previous version to the latest installed software version involves several different upgrade tasks using the **Database Wizard** and the Project Management task. You must have the **Project Management** and **Server Connectivity** options installed on the computer you are using to perform the upgrade.

**WARNING** Migrating symbols and updating reference data are detailed processes. For detailed upgrade information, refer to the **Upgrade Guide** delivered on the Smart 3D DVD, or contact Intergraph Support at http://www.intergraph.com/support.

### Upgrading Replicated Databases

Do not deviate from the following sequence of steps. Additionally, do not proceed to a subsequent step in the workflow until the previous one is complete.

1. **Stop the Replication Process**
   
   First, disable the transfer of data between the Host server and the Satellite servers. For more information, see Disable Replication on a

2. **Upgrade the Site and Site Schema Databases**
   
   Using the current version of the software, connect to the Host site database through the **Database Wizard** and upgrade it to the currently installed version. For more information, see Upgrade the Site and Site Schema Databases.

3. **Consolidate the Replicated Databases**
   
   Use the Tools > Consolidate Plant/Ship from Workshare command in the Project Management task to merge back all the replicated databases at the Satellite locations to the databases at the Host location to form a single database of each type. For more information, see Consolidate an Existing Configuration. If you are using Oracle, see Consolidate All Oracle Databases.

4. **Upgrade the Catalog and Model Databases**
   
   Use the Tools > Upgrade Version command in the Project Management task to upgrade the Catalog and Model databases to the currently installed version. For more information, see Upgrade the Catalog and Catalog Schema Databases and Upgrade the Model Database.

5. **Regenerate the Reports Database**
   
   Right-click Model database in the Project Management tree view, and then select Regenerate Reports Database. For more information on regenerating a Reports database, see Regenerate the Reports Database.
SECTION 8  
Working in an Integrated Environment

Working with the software in an integrated environment allows you to standardize and improve the communication among the various authoring tools you use in the course of designing, constructing, and operating a plant, ship, or offshore rig. SmartPlant Foundation acts as a central repository for data and a medium through which information is shared among other tools, such as SmartPlant Instrumentation, SmartPlant P&ID, SmartPlant Electrical, and Smart 3D.

The following graphic displays what SmartPlant publishes and retrieves and additional information about what data is exchanged.

Most of the commands that provide access to SmartPlant integration functionality exist on the SmartPlant menu in the various Smart 3D task environments. For example, in the Drawings and Reports task, you can use the commands on the SmartPlant menu to publish orthographic drawings, 3D model data, isometric drawings, and reports. You can also use the SmartPlant menu to access the SmartPlant Foundation Web Client in order to browse in SmartPlant Foundation and subscribe to change notifications and compare documents. In other Smart 3D tasks, you can use the SmartPlant menu commands to correlate items between the model and the SmartPlant Foundation database and retrieve P&IDs, DDP files, Cable Schedules, Plant Breakdown Structure, and Project Lists.

For detailed information about using the SmartPlant integration commands found in Smart 3D, see the Common User's Guide and the Orthographic Drawings User's Guide. Both documents are available with the Help > Printable Guides command in the software.
For more information about configuring Smart 3D to work in an integrated environment, see *Configure for an Integrated Environment* (on page 154).

**Intergraph Work Process Guides**

Intergraph Work Process guides map the process, power, and marine industries' basic work processes to SmartPlant Enterprise and SmartMarine Enterprise solutions. This documentation helps your organization transition from previous work practices to using Intergraph tools as the new way of executing projects. These documents are available on [https://smartsupport.intergraph.com](https://smartsupport.intergraph.com) under View Documentation > Work Process Guides.

**Enterprise Work Processes** describe an entire engineering discipline or process at two different levels, including:

- Providing a swim lane diagram to define the typical roles and high-level processes involved in a project
- Showing how Intergraph tools are used to produce required deliverables

**Integration Capability Statements** describe a specific work process among a set of Intergraph tools, including:

- Explaining the out-of-the-box capabilities of the tools and their recommended use
- Providing a swim lane diagram to show how the tools interact in the work process
- Stating critical requirements and precautions

Enterprise Work Processes and Integration Capability Statements offer a better understanding of how Intergraph tools work together and how to adapt the tools to improve existing work processes.

**Configure for an Integrated Environment**

Configuring Smart 3D to work in an integrated environment provides a platform for data exchange, sharing, and integration across various software tools, enabling concurrent use and rapid communication among all Smart 3D project participants. Critical information is stored only once in a data-neutral warehouse, eliminating duplication and ensuring that timely, accurate data is always available.

Two steps are required to take advantage of the Smart 3D integration functionality:

1. **Install the SmartPlant Client and Schema Component on your Smart 3D workstation computers, as necessary.** For more information about installing Smart 3D components, see the *Integration Setup Guide*, available in the SmartPlant Enterprise documentation set.

   **IMPORTANT** In order to take full advantage of the Smart 3D integration functionality, you must install the SmartPlant Client and Schema Component on a Smart 3D workstation computer on which the *Project Management*, *Server Connectivity*, and *Piping Specification Remote Access Server* options are installed.

2. **Use the Project Management task to register your Smart 3D model.** For more information about registering models, see the *Project Management User's Guide*, available from Help > Printable Guides.
Viewing 3D Model Data

You can output 3D model data as SmartPlant Review files or CAD (SAT) files through the Drawings and Reports task. In order to use this functionality, you must install the SmartPlant Schema Component on the local workstation computer. For more information on installing this component, see Install SmartPlant Schema Component (on page 155).

For more information on creating 3D model data, see the Orthographic Drawings User’s Guide available from Help > Printable Guides in the software.

Install SmartPlant Schema Component

The SmartPlant Schema Component allows you to save your 3D model data as a graphics file in VUE format (.vue) in the Drawings and Reports task so that it can be viewed using SmartPlant Review. For more information on creating 3D model data output, see the Orthographic Drawings User’s Guide available from Help > Printable Guides command in the software.

IMPORTANT Before you install the SmartPlant Schema Component, you must use log on to the workstation computer with a user account that has administrator privileges.

Integrating with PDS

To take advantage of the PDS integration functionality included with the software, PDS software is required. In addition to the standard PDS setup, an additional set of files external to PDS are also required. For information about installing the files you need to reference a PDS model in the software, see Install PDS Data Access (on page 156). For information about installing the files you need to export PDS model data into the software, see Install PDS Export Tools (on page 155).

IMPORTANT The Intergraph Smart™ 3D PDS Model & Data Translators component (SEBY801) that is required to support the export of PDS model data into the software is a separately licensed product. For licensing information, please contact Intergraph Support https://smartsupport.intergraph.com.

Install PDS Export Tools

Installing the PDS Export Tools component further extends the PDS integration capabilities by allowing you to export Piping, HVAC, Electrical, Equipment, and Structure model data from PDS into Smart 3D.

Before installing the PDS Export Tools component, you must install the following prerequisite software on a computer on which the Project Management and Server Connectivity options are also installed:

- Intergraph Batch Services
- RIS_Share (RIS Shared Components)
- MicroStation J (V7)
- SmartPlant License Manager
- PD_Shell (Plant Design System environment)
Working in an Integrated Environment

For more information about acquiring these components, please contact Intergraph Support (http://www.intergraph.com/support).

**IMPORTANT** The PDS Export Tools component is a separately licensed product. Before attempting to install the component, please contact Intergraph Support (http://www.intergraph.com/support) for licensing information.

**NOTE** For more information about exporting PDS model data into the software, see the Common User's Guide available with the Help > Printable Guides command in the software.

**Install PDS Data Access**

Smart 3D integrates with PDS version 2010 SE and higher, thereby extending your plant design capabilities. When you install the PDS data access setup files, you enable the software to communicate with PDS. As such, you can reference PDS design data in your model. You can also use the software to migrate piping specifications and associated catalog data from PDS, or directly translate PDS data into the software.

You need to install the PDS Data Access component on the administration computer where you will use the Project Management task to reference the PDS project and on each client workstation that needs to reference the PDS project.

Before installing the PDS Data Access component, you must install the following prerequisite software on a computer on which the Project Management and Server Connectivity options are also installed:

- Intergraph Batch Services
- RIS_Share (RIS Shared Components)
- SmartPlant License Manager
- PD_Shell (Plant Design System environment)

If you are accessing PDS projects from the same computer, then you need to install SmartPlant License Manager along with the other PDS products as required. For more information about acquiring these components, please contact Intergraph Support (http://www.intergraph.com/support).

**Locate the Schema File**

1. Log on with a user account that has administrator privileges.
2. Install RIS if you have not already done so.
3. Click Start > All Programs > RIS X.X > RIS Schema Manager.
4. In the RIS Schema Manager dialog box, click Schema File.
5. In the Schema File dialog box, click Locate Schema File.
6. Define the location of your PDS project schema file.
7. Click Apply.
8. Close.

**Configure the Plant Design System Environment (PD_Shell)**

1. Log on with a user account that has administrator privileges.
2. Install PD_Shell if you have not already done so.
3. Click Start > All Programs > PD_Shell > PDS Configure.
4. Click Modify.
5. Type the Proj_File information for the PDS project.
6. Type the Proj_Addr information for the PDS project.
7. Click Continue.
8. Click OK.

Create Batch Queues
1. Log on with a user account that has administrator privileges.
2. Install Intergraph Batch Services if you have not already done so.
3. Click Start > All Programs > PD_Shell > PDS Queue.
4. Create a batch queue for PD_Shell.

Verify Access to the Project in PD_Shell
1. Click Start > All Programs > PD_Shell > PD_Shell.
2. Verify that the PDS project that you want to reference displays in the PD_Shell environment. If it is not available in the PD_Shell environment, you will not be able to reference it.

Install Smart 3D PDS Model & Data Translators
Installing the Smart 3D PDS Model & Data Translators component further extends the PDS integration capabilities by allowing you to export Piping, HVAC, Electrical, Equipment, and Structure model data from PDS into Smart 3D.

Before installing the Smart 3D PDS Model & Data Translators component, you must install the following prerequisite software on a computer on which the Project Management and Server Connectivity options are also installed:

- Intergraph Batch Services
- RIS_Share (RIS Shared Components)
- MicroStation J (V7)
- SmartPlant License Manager
- PD_Shell (Plant Design System environment)

For more information about acquiring these components, please contact Intergraph Support (http://www.intergraph.com/support).

Refer to Install Smart 3D Client Software (on page 94) for setup instructions.

**IMPORTANT** The Smart 3D PDS Model & Data Translators component is a separately licensed product (SEBY801). Before attempting to install the component, please contact Intergraph Support (http://www.intergraph.com/support) for licensing information.

**NOTE** For more information about exporting PDS model data into the software, see the Common User's Guide available with the Help > Printable Guides command in the software.
Integrating with SmartPlant P&ID

To take full advantage of the software's SmartPlant P&ID integration functionality, we recommend that you install the Piping Specification Remote Access Server and Client setups. The remote access server setup is available as an option in the Smart 3D Installation setup for the workstation computer. The remote access client is an available option with the SmartPlant P&ID product and is installed on a computer running SmartPlant P&ID.

The Piping Specification utility works with PDS 3D or Smart 3D to validate the piping materials class with the temperatures, pressures, and diameters assigned to the pipe run. The utility also searches commodity codes (in all 3D databases) and fabrication categories (in PDS 3D databases only) for piping components. The database tables and library files in the 3D product provide source information for the validation and search. For more information about this utility, see the SmartPlant P&ID Remote Pipe Specification Access Quick Reference Guide, which is available in the Technical Notes and White Papers section on the Intergraph Smart Support Site (https://smartsupport.intergraph.com).

NOTES

- Install SmartPlant P&ID first if you plan to install SmartPlant P&ID and Smart 3D on the same computer.
- When installing the Piping Specification Remote Access Server component, you must also install the Bulkload Reference Data and the Server Connectivity components as they are required for the Piping Specifications Remote Access Server to work.
- Verify that the Distributed Transaction Coordinator service is enabled before installing the Piping Specification Remote Access Server.
- The “server” used by the Piping Specification Remote Access Client and the SP3D P&ID Client Tester application is the computer on which the Piping Specification Remote Access Server COM+ application has been installed and configured. This server can be different from the database server on which the Site database server and Site schema server reside.

For more specific information about using the SmartPlant P&ID integration functionality included with the software, please contact Intergraph Support (http://www.intergraph.com/support).

See Also
Configure the Piping Specification Remote Access Server Service (on page 159)
Register the Site Database for P&ID Access (on page 163)

Enable Network Access in Windows Server 2008

The following procedures for enabling network access are required only if you are using Windows Server 2008 R2 (64-bit) on the computer.

Enable COM+ Network Access

1. Open the Control Panel.
2. Click **Turn Windows features on or off** to open the **Server Manager**.

3. On the **Roles** page in **Server Manager**, click **Add Roles**.

   *The Add Roles Wizard opens.*

4. Ensure that you have completed the preceding steps listed on the **Before You Begin** page, and click **Next**.

5. On the **Select Server Roles** page, select **Application Server** and click **Next**.

   *NOTE* If the server finds any of the required features for Application Server are missing, a prompt is displayed informing you to install those features. Click **Add Required Features** to allow the server to install them automatically.

6. On the **Application Server** page, click **Next**.

7. On the **Select Role Services** page, select **COM+ Network Access**, and click **Next**.

8. Confirm your installation selections and click **Install**.

9. After the installation is complete, click **Close** to exit the wizard.

   *NOTE* If Application Server is already enabled on Windows Server 2008, follow these steps to enable COM+ Network Access:

10. Open the **Control Panel**.

11. Click **Turn Windows features on or off** to open the **Server Manager**.

12. Click **Roles > Application Server**.

13. In the **Role Services** section, click **Add Role Services**.

14. On the **Select Role Services** page, select **COM+ Network Access**, and click **Install**.

**Configure the Piping Specification Remote Access Server Service**

In order to take full advantage of the SmartPlant P&ID integration tools available with the software, we recommend that the Piping Specification Remote Access Server service be installed and properly configured on the system on which Smart 3D has been installed. Perform the following steps to verify and, if necessary, manually install and configure the COM+ application.

*IMPORTANT*

- You must have administrator privileges on the computer in order to perform this installation procedure.
- You must perform this procedure if you have installed Smart 3D on a server operating system, such as what happens in a Citrix environment.
- The Piping Specification Remote Access Server service is installed as part of the Smart 3D Installation setup. You must also install the Bulkload Reference Data and the Server Connectivity components as they are required for the Piping Specifications Remote Access Server to work. For more information, see **Install Smart 3D Client Software** (on page 94).
- The computer on which you have installed the Piping Specification Remote Access Server becomes a "server" for SmartPlant P&ID clients and therefore must be powered on and
available whenever P&ID needs to access the catalog. For example, you could use the computer that is used for the Interference Checking service.

Verify SP3D Piping Specification Remote Access Server Service

1. Click Start > All Programs > Accessories > Run.
2. Type dcomcnfg, and click OK. The Component Services window appears as shown in the following illustration:

3. Expand the Component Services node under the Console Root, and then expand the Computer and My Computer nodes.

4. Expand the COM+ Applications node.
5. Verify the SP3DPipingSpecRemoteAccessServer icon appears under COM+ Applications. If it exists, skip to step 17. If it does not exist, perform steps 6-14 to install and configure the COM+ application.
6. Select **COM+ Applications** under the **My Computer** node, and then click **Action > New > Application** on the horizontal toolbar. The **COM+ Application Install Wizard** displays.

7. Click **Next** on the **Welcome to the COM Application Install Wizard** page.

8. Select **Create an empty application** on the **Install or Create a New Application** page.

9. On the **Create an Empty Application** page, type **SP3DPipingSpecRemoteAccessServer** in the **Enter a name for the new application** text box.

10. Select **Server application** in the **Activation type** field, and then click **Next**.

11. On the **Set Application Identity** page, verify that **This user** is selected, and enter user name and password to set the proper identity under which the COM+ application will run on the computer.

   **IMPORTANT** You must specify an account with Windows administrative privileges on the computer.

12. Click **Next**.

13. Select **CreatorOwner** on the **Add Application Roles** page, and click **Next**.

14. On the **Add Users to Roles** page, add any additional users that may need access to this application, and click **Next**.

15. Click **Finish** to begin the installation.

   **TIP** When the installation is complete, a **SP3DPipingSpecRemoteAccessServer** node is placed under **COM+ Applications**.

16. In the left tree view, right-click **SP3DPipingSpecRemoteAccessServer** and select **Properties**.
17. On the Advanced tab of the **SP3DPipingSpecRemoteAccessServer** dialog box, select **Enable idle shutdown** and change the **Minutes** value to 0.

18. On the Security tab, disable **Enforce access checks for this application** and click OK.

19. Next, expand the **SP3DPipingSpecRemoteAccessServer** and the **Components** nodes.

20. Under the **Components** node, verify that the **SP3DRefDataMiddleTierService.RefdatalMiddle.1** component appears. If it does exist, you are finished with this procedure. If it does not exist, perform steps 21-25.


22. Click **Next** on the Welcome to the COM Component Install Wizard.

23. On the Import or Install a Component page, select **Install new component(s)** and browse for **SP3DRefDataMiddleTierService.dll**.
The component SP3DRefDataMiddleTierService.dll is located in \Product Folder\3DRefData\Middle\Bin.

24. Click Next on the Install new components page, then click Finish to complete the installation procedure.

25. The Component Services window shows the SP3DRefDataMiddleTierService.RefdataMiddle.1 component installed in the SP3DPipingSpecRemoteAccessServer application.

See Also
Integrating with SmartPlant P&ID (on page 158)

Register the Site Database for P&ID Access

Before you complete the steps in this procedure, you must install the Piping Specification Remote Access Server service and configure the COM+ application. For more information, see Install Smart 3D Client Software (on page 94).

You must have administrator privileges on the computer in order to perform this installation procedure.

1. Click Start > Run, and then click Browse in the Run dialog box.

2. Navigate to \Product Folder\3DRefData\Tools\Bin\SetSiteForPIDAccess.exe, and click OK.

3. Click OK in the Run dialog box.

4. In the Set Site Database for Piping Spec Remote Access dialog box, enter the Site and Site schema database names and servers in the appropriate fields.
5. Click **OK**.

### NOTES


- The "server" used by the SmartPlant 3D Piping Specification Remote Access Client and the SP3D P&ID Client Tester application is the computer on which the SmartPlant 3D Piping Specification Remote Access Server COM+ application has been installed and configured. This server can be different from the database server on which the Site database server and Site schema server reside.

### See Also

*Integrating with SmartPlant P&ID* (on page 158)

---

## Integrating with SmartPlant Reference Data

If you plan to integrate with SmartPlant Reference Data (SPRD), you will need to install the SmartPlant Reference Data Client. SmartPlant Reference Data (SPRD) is licensed separately from Smart 3D and is delivered on separate media.

Less than a megabyte of hard disk space is required to load the SmartPlant Reference Data Client software.

1. Insert the **SmartPlant Reference Data** delivery media. If the setup does not start automatically, double-click **Browser.exe** in the root folder.

2. Click **SmartPlant Reference Data (.NET) Installation** on the **SmartPlant Enterprise Materials** page.

3. Click **SmartPlant Reference Data (.NET) Client Installation** on the **SmartPlant Enterprise Reference Data** page.

   *SmartPlant Reference Data Client installs.*

4. After the installation is complete, you must enter your login credentials for SmartPlant Reference Data Client.

5. You can either use an existing login from the **Current Logins** tab, or you can create a new login from the **New Login** tab.

For more information, see the **SmartPlant Reference Data Installation Guide (.NET)** available on the **SmartPlant Enterprise Reference Data** installation page.

### NOTES

- Install Smart 3D and all of its components in a folder with a short path that does not contain any spaces.

- Set up the SmartPlant Reference Data listener for default mode running.
SECTION 9
Interference Checking Setup

Unlike the traditional file-based method of manually defining groups of parts to check against each other, Check Interference is a separate software process that runs directly on the Model database. Although the interference detection process can be run on any computer with the Database Interference Detection Service installed, due to the intensive nature of the interference check computations, the recommendation is to have a computer dedicated as the interference server.

**NOTE** In order to monitor interferences, you must install the Database Interference Detection Service option on the same computer that the Project Management option is installed.

Database detection options are set in the Project Management task. You can also start and stop the interference detection service in the Project Management task.

Interference detection requires disk space for the file cache that temporarily stores the interference data. Before starting the interference process, the interference server checks to see if enough space exists in the TMP location for the file cache. The server also checks to see if you have the proper permissions to write, read, and delete files in the TMP location. During the process, if the space becomes too low, the software stops IFC, and then displays an error.
message. These checks primarily apply to the server-based interference process. Although, they can apply to the local checking process if extremely low or no disk space is available for the temporary folder on the local computer.

**IMPORTANT** Configure automatic disk defragmentation in order to free space for the file cache.

After you start the process, use the Status tab on the **Interference Server Settings** dialog box to monitor the start time, progress of the interference checking, time when the last part was modified, and the status of the checking. A box at the top of the dialog box identifies the model that you are checking.

The software automatically checks new or modified objects apart from existing objects. When you create or modify an object, the software checks for interference against all objects in the Model database. The interferences generated by this process are persistent; that is, the interferences are stored in the database like any other objects in the software. You can also modify these objects by changing the properties. Interferences are also assigned to a permission group; thereby the entire process is under the control and restrictions of an administrator.

You can interrupt the automatic interference checking process during a work session without forcing a recheck of all parts in the database when the process is brought back online. When you restart the interference check process, the software begins checking where it left off when the process went offline. However, if you change any of the options on the **Interference Server Settings** dialog box for Database Detect, all pre-existing interference checking processes are cleared from the database, and checking restarts from the beginning.

The server-based interference checking runs continuously. Therefore, you can perform an interference check at any time and view the interferences of interest that result from the background check by refreshing the workspace. After you have reviewed the interferences, you can remove an interference automatically from the database by editing the objects so that the interference no longer exists. You can then see the results of your edit by refreshing the workspace. Because certain types of interferences are allowable, you also have the capability to mark such interferences as acceptable.

Be aware that there is a four minute interval between the time you make your edits and the time that the database detect service rechecks the objects. After the database detect process reaches 100%, the software issues a query only every two minutes to locate newly modified objects. Therefore, it is possible that there is a six minute delay before a modified object is processed. We do not recommend changing the default four minute interval. However, if you are in **Project Management** with the **Interference Server Settings** dialog box open, press CTRL+SHIFT+F12 to change the default four minute interval.

When the Database Detect process reaches 100%, it does not mean that all clashes between Smart 3D and other foreign objects, such as PDS, referenced MicroStation objects, 3D AutoCAD files, or referenced point cloud objects, have been processed. Here, 100% indicates that all Smart 3D objects have been processed against each other.

**NOTE** You must run the Database Detect process before running an interference report. The report is not intended to run on local interferences.

### What do you want to do?

- **Install Database Interference Detection Service** (on page 167)
- Services Authentication Settings
- **Configure Interference Service Properties** (on page 167)
Install Database Interference Detection Service

Prior to installing the Database Interference Detection Service on a computer, verify that all prerequisite software has been installed. If you have an older version of the Database Interference Detection Service installed on your computer, remove it before loading the new software.

You must have administrator privileges on the computer to install the software.

1. Open Control Panel.
2. Open Programs and Features.
3. Select Intergraph Smart 3D from the list of installed software's.
4. Click Change.
5. Select Database Interference Detection Service.
6. Optionally, select 64-bit Services if you want to install the 64-bit version of the interference detection service also.
   
   IMPORTANT: If you are running Oracle, you must install the 64-bit Oracle client on the computer running 64-bit interference detection.

7. Click Update.

NOTE: If you have not yet installed Smart 3D on the computer, see Install Smart 3D Client Software (on page 94) in the installation guide for detailed instructions.

If you plan to check interferences with a referenced PDS® project, you must install and configure the PDS Data Access component (with all prerequisites) on the IFC database detection server. For more information, see the Plant Design System (PDS) Guide.

See Also
Interference Checking Setup (on page 165)

Configure Interference Service Properties

1. Click Start > All Programs > Intergraph Smart 3D > Database Tools > Configure Interference Checking Service.
2. In the Configure Interference Service dialog box, select your database type.
3. Select the site database server (Microsoft SQL Server) or the Oracle Service for the site database.
4. Select the site database on which the interference service is to run.
5. Click OK.
Start the Database Interference Detection Service

Prior to starting the Database Interference Detection Service, you must configure its properties. For more information, see *Configure Interference Service Properties* (on page 167).

1. Log on with Administrative privileges to the computer on which the Project Management and Database Interference Detection Service options are installed.
2. Open the Control Panel, and then double-click Administrative Tools.
3. In the Administrative Tools window, double-click Services.
4. Right-click either the Smart 3D Interference Detection Service or the Smart 3D Interference Detection Service 64-bit, and then select Properties from the shortcut menu.

   **IMPORTANT:** The 64-bit Smart 3D Interference Detection Service does not process PDS attachments or Point Clouds. Use Reference 3D for PDS Projects if you are running 64-bit IFC, or you can switch to a 32-bit IFC server to process PDS attachments and supported Point Clouds.

5. On the Log On tab, select the This account option, and then type the user name that has Administrative privileges.

   **NOTE** This version of the software does not support the Local System account option.

6. In the Password and Confirm password boxes, type the password for the user account.
7. On the Recovery tab, set the options as required.
8. On the General tab, verify that the Startup type is set to Automatic.
9. In the Service status section, click Start.
10. Click OK.

**NOTES**

- The interference checking service does not consume a license when it starts. It consumes a license only while processing the model. For more information, see Checking Interferences.
- If clashes between the point cloud and the Smart 3D objects are selected to check for interferences, then Smart 3D Interference Detection Service or Smart 3D Interference Detection Service 64-bit should be started from the command prompt. From the command prompt, navigate to `install\Foul Check\Middle\bin`, and then type `IFCNtSvc.exe /Auto/0`, and press ENTER.
- Errors that are encountered during startup of the Database Interference Detection service are logged to the Event Viewer Application Log with the source name IfcNtSvc.
- Do not run the 32-bit and 64-bit interference detection services simultaneously on a computer. IFC must only run as a single instance for the entire model.

Set IFC Permission Requirements

You must install the Database Interference Detection Service option in order to monitor interferences. For more information about installing and configuring this service, see the Smart 3D Installation Guide available from Help > Printable Guides.
The user account running the IFC Windows service must have at least Read access to the SharedContent folder. Otherwise, IFC generates a bad part marker with clashes against structural fireproofing.

A Smart 3D Interference Detection Service icon is placed under the model node in the Project Management tree. After the proper access permissions are configured, you can start and stop the Database Detect process from any computer on which the Project Management option is installed.

The Smart 3D database hierarchy is comprised of a model configuration that consists of the model and catalog databases. For the IFC Database Detection process to run correctly, permissions must be set on the model and model permission groups according to the following guidelines:

Log on privileges for the IFC Administrator include:

- Read access on the model database at a minimum.
- Full Control permissions or access on a minimum of one permission group.

**TIP** In the Project Management task, create a new permission group folder and permission group under the model icon to store the IFC results. For example, type **IFC Permission Group Folder** and **IFC Permission Group** in the **New Permission Group Folder** and **New Permission Group** dialog boxes, respectively. For more information, refer to **Create IFC Permission Group Folder and Permission Group** (on page 169).

- Read access on all other model database permission groups at a minimum.

### Create IFC Permission Group Folder and Permission Group

1. Log on with administrative privileges to the computer where you have installed the **Project Management** and **Database Interference Detection Service** options.
2. In the Project Management tree view, navigate to the models icon.
3. Expand the models folder.
4. Right-click a model under the models folder, and select **New Permission Group Folder** on the shortcut menu.
5. Type **IFC Permission Group Folder** for the name of the new permission group folder.
6. Click **OK** to close the **New Permission Group Folder** dialog box.
7. In the tree view, navigate to the **IFC Permission Group Folder** icon.
8. Right-click the **IFC Permission Group Folder**, and select **New Permission Group** on the shortcut menu.
9. Type **IFC Permission Group** for the name of the new permission group.
10. Click **OK** to close the **New Permission Group** dialog box.

**NOTE** After the IFC permission group is created, you must assign the proper access permissions. For more information, see **Set IFC Permissions** (on page 170).
Set IFC Permissions

1. Log on with administrative privileges to the computer on which the Project Management and Database Interference Detection Service options are installed.

2. In the Project Management tree, navigate to the IFC Permission Group icon.

3. Right-click the IFC Permission Group icon, and select Permissions.

4. On the Access Permissions dialog box, click Add.

5. In the Add names grid, double-click in the User cell, and type the domain and name of the user or group to add.

   **TIPS**
   - You can also click Add and search for users using the Select Users and Groups dialog box. This is a common Windows dialog box. For information regarding the options in this dialog box, see your Windows documentation.
   - To remove a user or group from the Add names grid, select the appropriate row, and then click Remove.

6. In the Type of access list, select the type of access you want to assign. The software automatically updates the associated row in the Add names grid.

7. Click OK.

8. Click OK again to close the Access Permissions dialog box.

Check Database Interferences

Before performing the following procedure, you must first manually configure the SmartPlant 3D Interference Detection Service on the computer with the service installed.

1. In the Project Management tree, right-click the Interference Server icon under the model for which you want to start Database Detect. Then select Properties on the shortcut menu.

2. In the Interference Server Settings dialog box, assign interference checking priorities to aspects.

   **TIP** Maintenance, for example, is a typical aspect listed in the Aspect column. If a check of this aspect is important, you can indicate the priority as Required. If Maintenance is low priority or not important, you can indicate the priority as Optional or Not Checked.

3. Specify the interference comparison criteria:

   - **Required - Required** - Defines interferences classified as hard/hard. For example, one pipe physically intersects with another pipe. Severe interferences are shown in red.

   - **Required - Optional** - Defines interferences that are not as severe and are classified as hard/soft. For example, one pipe overlaps the optional aspect of the other object. Optional interferences are shown in yellow.

   - **Optional - Optional** - Defines interferences that are not severe and are classified as soft/soft. For example, the maintenance aspect of one piece of equipment overlaps the maintenance aspect of another. Optional interferences are shown in yellow.
Interference Checking Setup

- **Smart 3D - Foreign Interferences** - Considers objects outside the active model for interferences. For Local Detect, this option is enabled by default. For Database Detect, this box must be checked if you want referenced 3D models, referenced PDS objects, referenced MicroStation objects, and 3D AutoCAD files to be considered. This option only checks objects against foreign objects. It does not check for interferences between two foreign objects.

- **Smart 3D - Point Cloud** - Considers Smart 3D objects and point cloud objects for interferences. For Database Detect, this option must be selected to consider Smart 3D objects and point cloud objects. For Local Detect, select the **Smart 3D Point Cloud** check box to consider local interferences. The point cloud must have a valid connection to the model with no unresolved vendor licensing issues for this check box to be available.

4. In the **Include clearance** list, select the needed clearance rule. Clearance interferences are shown in green.

5. From the **Assign results to permission group** box, choose the permission group to which all the detected interferences are assigned.

6. In the **Marker size** field, type the value for the size of the interference symbols that generate in the model.

   **TIP** Choose a marker size that is clearly readable, but one that does not interfere with the smaller details in the workspace view.

7. Click **Start** on the **Database Detect** tab. After you click **Start**, the **Status** tab on the **Interference Server Settings** dialog box displays the progress of the processing for parts that existed previously and for new or changed parts during the run.

   **IMPORTANT** If the IFC Server detects that your system resources are too low (due to a significant process requiring the majority of system memory), then the IFC process stops and displays a message box notifying you that the service has stopped for this reason.

**NOTES**

- The Smart 3D Interference Detection service does not consume a license when it starts. It consumes a license only while processing the model. For more information, see

- To start the server interference detection process, you must have at least Read access to all objects in the model and Write access to the model itself. Access privileges are assigned for each permission group in the Project Management task. During the IFC process, if the software denies access to an object, the server process stops and a message appears.

- To view the status of the database interference detection process, right-click the **Interference Server** icon in the Project Management tree, and click **Properties**. On the **Interference Server Settings** dialog box, click the **Status** tab.

- When the database interference check process is running, only the **Stop** command is available. When the process is not running, the **Start** command and all process property gadgets are available. The **Stop** command is not available.

- When the database interference check is running and you add any permission group without Read permissions for the server, the server automatically receives Read permissions and finds collisions with the placed objects in that permission group.

- When you modify permission groups in Project Management, the host for the existing, running task does not receive the changes. To update the information, you must exit and restart the interference detection process.
Interference Checking Setup

See Also

*Interference Server Settings Dialog Box* (on page 172)

**Interference Server Settings Dialog Box**

Sets the properties associated with the selected interference server:

- Changes or accepts the default properties for the interference marker size.
- Checks the status of those interferences.
- Assign interference checking priorities to aspects and indicate whether the interferences are optional or required.
- Optionally, you can indicate if you want interference checking to include a clearance rule.

This dialog box is available by clicking Properties, Edit > Properties, or right-clicking the interference server in the Project Management tree.

If you change any of the options on the *Database Detect* tab and then click *Start*, the software displays a message box asking if you want to recheck the entire model while preserving the existing approved interferences.

**NOTE** The GSCADFoulCheckCmds.cSetIFCForRestart custom command is available if you need to delete all preexisting interferences from the database and start checking from scratch. For more information, see `GSCADFoulCheckCmds.cSetIFCForRestart` (on page 175).

**IMPORTANT** The *Interference Server Settings* dialog box is only available on computers on which the Project Management and Database Interference Detection Service options are installed.

*Database Detect Tab (Interference Server Settings Dialog Box)* (on page 172)

*Status Tab (Interference Server Settings Dialog Box)* (on page 174)

**Database Detect Tab (Interference Server Settings Dialog Box)**

Provides options for assigning interference checking priorities to aspects, specifying the comparison methods, and optionally including a clearance rule. You can also assign the interference results to a selected permission group. All properties on this tab when viewed outside the Project Management task are read-only.

**NOTE** You must run Database Detect before running the delivered Interference report. The Interference report is not intended to run on local interferences.

**Check Model**

 Specifies the name of the model that the server process needs to check. The server software must have the Site database locations predefined. This option is not available if you are in the Project Management task.

**On server**

 Specifies the name of the server on which the interference checking is processed for the identified model.
Assign interference checking priority to aspects

Select each aspect that you want checked and assign a priority to it.

- **Aspect** - Lists all the object aspects that are identified for use in the model. This includes the system-defined aspects and the user-defined aspects. Select those aspects in the Aspect column that apply to your objects, and then specify the type of comparison in the Type column. The Diagnostic Interference Checking report lists these aspects settings in its header.

- **Type** - Lists three types of checking you can apply to the selected aspect: **Required**, **Optional**, and **Not checked**. Choose the appropriate type for each aspect you select in the Aspect column. **Not checked** means the selected aspect is not used for interference checking.

Compare

Select which aspect types are to be compared against each other to find interferences.

- **Required - Required** - Defines interferences classified as hard/hard. For example, one pipe physically intersects another pipe.

- **Required - Optional** - Defines interferences that are not as severe and are classified as hard/soft. For example, one pipe overlaps the optional aspect of the other object but does not actually intersect the other object.

- **Optional - Optional** - Defines interferences that are not severe and are classified as soft/soft. For example, the maintenance aspect of one piece of equipment overlaps the maintenance aspect of another.

- **Smart 3D - Foreign Interferences** – Considers referenced 3D models, referenced PDS objects, referenced MicroStation objects, and 3D AutoCAD files for interferences. This option is enabled after you have selected a Model at the top of this tab. For PDS objects, the selected Model must have an attached PDS project. For Database Detect, this box must be checked for PDS objects to be considered. In the case of Local Detect, the software by default considers referenced 3D models, PDS objects, MicroStation objects, and 3D AutoCAD files that are in the workspace.

**NOTES**

- This option only checks active model objects against foreign objects. The option does not check for interferences between two foreign objects (PDS to 3D AutoCAD, for example), except when the two foreign objects are referenced 3D models.

- Direct PDS project references are not processed in 64-bit IFC. You can either use Reference 3D for your PDS projects or run 32-bit IFC.

- **Smart 3D - Point Cloud** - Considers an attached point cloud during interference checking. The Point Cloud check box must be selected to consider Smart 3D objects and the point cloud. The point cloud must have a valid connection to the model with no unresolved vendor licensing issues for the Point Cloud check box to be available.

Include clearance rule

Specifies the clearance rule to add to the **Required** type of interference check.

Assign results to permission group

Specifies the permission group to which all the detected interferences are assigned. The list displays only those permission groups to which the server containing the interference checking software has Write access.
Marker size

Specifies the size of the interference graphic marker. Choose a size that is clearly visible, but one that does not interfere with the smaller details in the workspace view.

Start

Begins the process. This option is only available in the Project Management task.

Stop

Closes the process. This option is only available in the Project Management task.

Status Tab (Interference Server Settings Dialog Box)

Displays the status of the Database Detect process on the server. The status information includes the percentage of checking that has been completed, the amount remaining, when the process was started, and the estimated completion time.

The information on this tab is read-only.

Plant

Displays the name of the model that is checked.

New and modified parts since process start

Displays the following time information for any new and modified parts after the process was started.

Last part modified

Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the last part was created or modified in the Model database.

Current range to

Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the last part modified was in consideration for interference checking.

From

Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference check completed checking the last part modified.

Elapsed time

Displays the amount of time (hour, min, sec) during which the interference checking has been running for the new or changed parts.

Estimated completion

Displays the amount of time (hour, min, sec) estimated until the interference checking process completes. Then displays Completed when the process is complete.

Process start

Displays the time (mm/dd/yyyy hh:mm:ss) the process started.

Existing parts at process start

Displays the following time information for existing parts when the process was started.
Interference Checking Setup

Current range to
Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference checking started for the existing parts.

From
Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference checking ended for the existing parts.

First part created
Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the first part was created in the database.

Elapsed time
Displays the amount of time (hour, min, sec) during which the interference checking has been running for the existing parts.

Estimated completion
Displays the amount of time (hour, min, sec) estimated until the interference checking process completes. Then displays Completed when the process is complete.

Status message
Displays textual information about the current status of the process on the server.

GSCADFoulCheckCmds.cSetIFCForRestart
Replaces the Interference Checking Restart functionality. The ProgID for this command is GSCADFoulCheckCmds.cSetIFCForRestart. No arguments are required. You must first select a plant in Project Management before you can run this custom command.

This command deletes all interferences in the selected plant. It then configures IFC to start in Warm Reboot mode the next time you start IFC through the Interference Server Settings dialog box. For more information, see Interference Server Settings Dialog Box (on page 172).

This command displays a warning that it is about to delete all interferences in the model. If you click Yes on the warning dialog box, the command executes and then displays a message indicating that the process is complete.

NOTES
- This command is only available in the Project Management task.
- You must stop the IFC process before running this command.
- You cannot undo this command.
- The permissions required to run this command are the same as those required to start IFC.
- You cannot run this command from satellite locations in global workshare configurations.
SECTION 10

Batch Services

Smart 3D uses the Intergraph Batch Services 2010 SP1 (06.01.09.00 or later) application to help you run large, time-consuming operations on a separate computer or during off hours, leaving your workstations available for other tasks. Due to the intensive nature of batch operations, using one or more computers dedicated as batch computers is recommended.

You can install both batch processing methods on any computer on which the Smart 3D client software has been installed. You must also install the Project Management and Server Connectivity features on your batch computers. Intergraph Batch Services is delivered on separate media from Smart 3D and does not require a serial number.

The batch computer supports the following processes:

- Updating drawings in the Drawings task
- Detailing and un-detailing parts in the Structural Detailing task
- Generating manufacturing parts and XML output files in the Structural Manufacturing task
- Updating the Manufacturing Services Manager in the Structural Manufacturing task
- Importing and exporting Structure objects
- Importing Tribon XML files
- Finding common parts
- Generating planning joints
- Running block assignments
- Printing, publishing, and refreshing drawings
- Updating Reference 3D models
- Backing up Smart 3D databases
- Restoring Smart 3D databases
- Checking database integrity
Installing Intergraph Batch Services

1. Open Control Panel > Administrative Tools > Services, and determine the current status of the TCP/IP NetBIOS Helper service on your computer. Start that service if it is not already running.

2. Insert the Intergraph Batch Services DVD into your computer.

3. To start setup, do one of the following:
   - Press the Windows key + R to display the Run dialog box. Type drive:\setup, where drive is the DVD drive letter.
   - In Windows Explorer, select the DVD drive, and then double-click setup.exe.

4. Select Batch Services Installation.

5. Click Next on the Welcome page.

6. Type your name and organization name, and then click Next.
7. On the **License Agreement** page, select your country.

8. Click **Display**. Read the license agreement, and then click **Yes**.

9. Review the default installation folder ($WindowsDrive:\Win32App\Ingr\Batch\).  

   **IMPORTANT**: If you plan to use this installation of Intergraph Batch Services with Plant Design System® (PDS), do not install Intergraph Batch Services to a folder path that contains spaces, such as c:\Program Files (x86)\Batch. Although Intergraph Batch Services supports spaces in folder paths, PDS does not.

10. Click **Next**.

11. Specify whether to run all jobs as the same user or use account mapping.

   If you select **Set up account mapping per user through Smart Batch Services**, you must configure account mapping before you can submit jobs. Use Batch Manager to configure account mapping after setup is complete. For more information, see *Configure Account Mappings* (on page 182).
If you select **Run all jobs as same user** to configure account mapping, define the user name and user name password under which jobs should run.

12. Click **Next**.
13. Click **Install**.

*Intergraph Batch Services is installed on your computer.*

14. Click **Finish**.
15. Restart your computer.

**NOTE** You can find the batch job log files in the %temp%\SP3DBatchSvcTemp file on the batch server computer.

### Starting and Stopping Batch Services

When you install Batch Services software, the batch server service is configured to start automatically each time you restart your computer. No further configuration is required. Intergraph recommends leaving the batch server service as configured. However, if you want to configure Batch Services to start manually, do the following:

1. Open **Control Panel > Administrative Tools > Services**.
2. In **Services**, right-click **Intergraph Batch Server**, and select **Properties**.
3. Set **Startup type** to **Manual**, and then click **OK**.
4. Close the **Services** window.

**NOTE** Batch Services also delivers an Intergraph NQS Listener service that is configured to start automatically. If your site is not using Intergraph NQS, you can configure the NQS Listener service to start manually. Repeat steps 1-3, selecting Intergraph NQS Listener from the **Services** list.

If you configure Batch Services to start manually, you must start the batch server each time you restart your system, or each time you want to run Batch Services.

To start Batch Services manually:

1. Open **Control Panel > Administrative Tools > Services**.
2. In Services, select Intergraph Batch Server, and then click Start.

To stop Batch Services:
2. In Services, select Intergraph Batch Server, and then click Stop.

Granting Batch Service Privileges

Before you begin using Batch Services, you should use Intergraph Batch Manager to ensure that users on your system (and users on other systems, if appropriate) are granted the proper privileges for access to Batch Services.

A user with manager privileges can use all the commands that affect batch server configuration and operation, including granting and removing privileges, and creating and deleting queues. A user with operator privileges can manage jobs, including those belonging to other users, and can start and stop batch server queues. Users or groups without privileges can only submit requests to queues to which they have been granted access. Most users or user groups are non-privileged users.

Using User Account Control turned on to level 3, the Administrators group on your system has manager privileges. From an account belonging to the Administrators group, you can add users and groups of users, on your system or other systems, to the manager and operator privilege lists.

1. Open Start > All Programs > Intergraph Smart Batch Services > Intergraph Batch Manager.
2. Select your computer name in the tree view on the left.
3. Click Server > Properties.
4. Select the Security tab.

Users and groups, and their Batch Service privileges, display in the Managers and Operators list.
5. Click Add, and then type the username of a user into the Add Names box, or the group name of a group, to which you want to grant privileges.

6. Specify local users and groups (on your computer) by username or group name only. Use one of the following formats when keying in a username or group name:
   - domain_name\username or system_name\username
   - domain_name\group_name or system_name\group_name
   Separate multiple users or groups with a semicolon (;).

7. Select the type of privilege you want to grant the user or group (Manager or Operator).

8. Click OK.

9. Repeat steps 5 through 8 for each user or group to which you want to grant privileges.

10. When you have finished assigning privileges to users or groups, click OK on the Server Properties dialog box.

To remove privileges from a user or group:

1. Open Start > All Programs > Intergraph Smart Batch Services > Intergraph Batch Manager.

2. Select your computer name in the tree view on the left.

3. Click Server > Properties.

4. Select the Security tab.

   The current users and groups with Batch Service privileges are displayed in the Managers and Operators list.

5. In the Managers and Operators list, select the user or group for which you want to remove privileges.

6. Click Remove.

7. Repeat steps 5 and 6 for each user or group from which you want to remove privileges.

8. When you have finished removing privileges from users and groups, click OK.

   **TIP** To change a user’s or group’s privileges, first remove the current privileges from the user or group; then re-add the user or group to the privilege list with the new privilege.

### Configure Account Mappings

Batch Services requires an account name and password to use when running jobs. The process of determining the account name to use is called account mapping. You can use Batch Manager to enter and modify account-mapping information for your system. An account mapping entry comprises two parts: the user information to match (the “from” user), and whom that user maps to (the “to” user). Account mapping entries allow users submitting a job to assume the environment and permissions of the user to whom they are mapped.

To perform account mapping, the batch server tries to match the job owner with an account mapping entry, using the following order (items are listed on the account mapping dialog box in the order in which they are applied):

1. The batch server first tries to find an exact match, matching the job owner’s domain or computer name and username with the “from” user in the account mapping entries.
2. If the batch server cannot find an exact match, the batch server then searches the account mapping entries using the job owner’s domain or computer name, with "*" (meaning any user) as the username.

3. If no match is found, the batch server then searches the account mapping entries using "*" (meaning any computer or domain) as the domain name, with the job owner’s username.

4. Finally, if a match still has not been found, the batch server searches with "*" as the domain name and "*" as the username.

How you configure account mapping depends on the security needs and configuration of your site. For more information on configuring account mapping, see Configure Account Mappings in the Installation Guide.

**Configure Default Account Mappings**

**IMPORTANT** The map-to-account user must have access to the Intergraph Smart 3D site, catalog, and model databases because it is under this user name that the batch jobs will run. Give this user those access rights using Intergraph Smart 3D Project Management.

1. Click Start > All Programs > Intergraph Smart Batch Services > Intergraph Batch Manager.
2. Select the computer name in the tree view.
4. Type * for the Map From Account Domain/Host and the User.
5. In the Map To Account Domain Controller box, type the name of the domain controller. The primary domain controller name displays as the default.
6. In the Map To Account Domain/Host box, select the domain of the Windows user account you want to run jobs as.
7. In the Map To Account User box, type the user name to use.
8. Click Add.
9. Type and confirm the password for the "to account" user name.
10. Click OK.

**NOTE** The ConfigureDrawingsBatch utility must be run each time mapped account settings are changed. For more information, see Configuring the Batch Services Server for Drawings Tasks (on page 186).

**Create Batch Services Queues**

You must create the Intergraph Batch Services queues that Smart 3D will use.

1. Open Windows Explorer on the computer on which Intergraph Batch Services is installed.
2. Navigate to and double-click C:\Program Files (x86)\Smart3D\ProjectMgmt\Tools\bin\ConfigureSP3DBatchQueue.exe.

   A message box appears informing you that the queues have been created and that you need to restart the Intergraph Batch Server service.
**TIP** Run this tool at least once on the computer on which the job needs to be submitted, or on the computer where the job needs to be run. This tool sets some environment variables as well as creating the batch queues.

3. Open **Control Panel > Administrative Tools > Services**.
4. In **Services**, select **Intergraph Batch Server** from the list, and then click **Stop**.
5. With **Intergraph Batch Server** service still selected, click **Start**.
6. To verify that the batch queues were created, open Intergraph Batch Manager and then select your server in the tree view.

**NOTES**
- The WinZip application is no longer required on the batch server to compress any emailed attachments. Compression is now done with functionality included in the Smart 3D delivery.
- This tool cannot create pipe queues. Use Intergraph Batch Services to create pipe queues.
- Verify that the C:\Windows\sysWOW64\config\systemprofile\Desktop folder exists if you are using Windows 7 (64-bit) or Windows Server 2008 R1. Ask your system administrator create the Desktop folder with full permissions if it does not exist.

### Configure Queues for Jobs

Configure Queues for Jobs is a utility in the Project Management task. The Smart 3D Project Administrator can configure different queues for different jobs. Then, the administrator can ensure that batch jobs are submitted to configured queues only. This prevents users from submitting jobs to inappropriate queues.

Configures batch queues for Smart 3D jobs.

You must have administrator privileges to access this tool. When you are logged in as an administrator, this tool is available in the **Tools** menu.

For sites, you must have the following privileges:
- In Oracle, you must have the SP3DProjectAdministrator role.
- In SQL Server, you must be a sysadmin on the server.

For models, you must have full access or write permissions on the selected model database.
**Time displayed in** - Displays the unit of measurement for the **Maximum Allowed Time**. The available units of measurement are **sec** (seconds), **min** (minutes), **hr** (hours), and **day**. The default unit is **hr**.

**Job Type** - Displays the name of the job. The jobs listed are specific to the site or model.

**Job Description** - Displays a brief description of the job.

**Default Queue** - Displays the default queue for a specific job, which can be a batch queue or a pipe queue. When this dialog box displays for the first time, it shows the first queue in the list of available queues on the local server. Administrator users can type a new default queue into this box, or they can select any queue from the list of available queues on the local server.

**NOTES**

- Ensure that the Default Queue is configured for a job in Project Management, and the configured queue exists on all client computers.
- For pipe queues, you need to add the required destinations to the queue. For more information, refer to Creating and Configuring Pipe Queues in Smart 3D Intergraph Batch Services User's Guide.

**Optional Queues** - Displays the Configure Optional Queues dialog box:

- **Available Queues** - Displays all of the queues registered in Intergraph Batch Server. To move an available queue into the **Allowed Queues** column, select the queue and click the **>** arrow.
- **Allowed Queues** - Displays the queues that the administrator has configured for a job type. To remove a queue from this column, select the queue and click the **<** arrow.
- **Maximum Allowed Time** - Specifies the maximum allowed time to process a job type in the queue. If the job is not completed in the allowed time, it is terminated and a time out notification is sent to the mailing list specified at the time that you submitted the job. By default, the **Maximum Allowed Time** is not specified, and the job runs without any time limit. To specify a **Maximum Allowed Time**, **Is TimeOut Supported** must be selected.

**NOTES**

- We recommend that you set a value for the **Maximum Allowed Time** that allows enough time for each job to execute.
- If a job is submitted on a pipe queue but is executed on a different queue, the **Maximum Allowed Time** for the job is read from the submitted pipe queue.
- **Is TimeOut Supported** - Enables **Maximum Allowed Time** functionality. This option is not selected by default.

  **Maximum Allowed Time** - Specifies the maximum allowed time to process a job type in the queue. For more information, see the description for **Maximum Allowed Time** in the **Configure Optional Queues** dialog box.

  **Is TimeOut Supported** - Enables **Maximum Allowed Time** functionality. This option is not selected by default.

### Making Other Batch Servers Available

You can run batch jobs on other computers that are running Intergraph Smart Batch Services by using pipe queues:

1. Create **Pipe Queues** in Intergraph Batch Manager. For details, see **Batch Manager** help.
2. Define different server destinations in piped queue destination tab. The format for giving destinations is "\ServerName\BatchQueueName".
3. In Project Management, configure queues for jobs with pipe queues. For more information, see **Configure Queues for Jobs** (on page 184) in the **Intergraph Smart 3D Installation Guide**.
4. When a user submits a job to a pipe queue, the job is automatically routed to and run on the destination batch server.

**NOTE** Make sure you install Smart 3D on the computer with Batch Services, and that destination batch queues are available on batch server.

### Configuring the Batch Services Server for Drawings Tasks

1. In the folder `[Smart 3D Installation folder]\Core\Container\Bin\Assemblies\Release`, run `ConfigureDrawingsBatch.exe`.
2. Click **Yes**, and then click **OK**.

**NOTES**

- The printer name on the client computer must match the printer name on the batch server.
- Every mapped account must open Microsoft Excel once on every batch server.
- Microsoft Excel must have the same security settings that are necessary for interactive updates. Excel must be configured correctly for every IBS-mapped account on the batch server.
- You must add the following entries to the system path for 3D model data documents to update:
  - `[Product Folder]\Core\Runtime`
  - `[Product Folder]\Common2D\Rad2d\Bin`
  - `[Product Folder]\GeometryTopology\Runtime`.
- You must run the `ConfigureDrawingsBatch` utility each time you change mapped account settings.
- If you are running 64-bit drawings batch services and Oracle, you must install the 64-bit Oracle client on the computer running the batch services.
SECTION 11
Board Management Service

Board Management is a separate software process that runs directly on the Model database. The board management process can be run on any workstation. For large projects, you can also run Board Management as a service on a separate computer, including a computer that is running other services. For more information, see Smart 3D Workstation Recommendations (on page 19).

You can run board management on any computer on which the Smart 3D Workstation software has been installed. Click Tools > Board Management Service in the Structural Detailing task of Smart 3D to set up and run the block assignment process.

The Tools > Board Management Service command determines structural part and seam symmetry about the center plane.

- Naming rules can consider symmetry information. For example, you can include a suffix indicating the symmetry property value for parts. Naming rules can also sort parts within a block by the symmetry value before assigning a part name index.

- The board property can be used in the nesting and cutting processes by possibly nesting and then cutting symmetrical parts at the same time, or nesting the symmetrical parts on the same raw material stock if the parts are in the same block. The Board Management Service determines if parts are symmetrically similar. Structural Manufacturing determines if the parts are symmetrically identical for manufacturing purposes.

- Unfolding algorithms use seam symmetry information when they calculate shapes for plates that cross the centerline.

- Some assembly planning tasks use the board property to automate creating and maintenance of assembly hierarchies for symmetrical parts.

- Reports include part symmetry information.

- Seam board information supports shell expansion drawing requirements. The shell expansion drawing for the entire ship displays and labels both port and starboard shell seams in one view.

- You can choose to manually override board management review for an object. If you choose this option, then board management disregards the object for subsequent review.

Whether you choose to run the Board Management service periodically or continuously depends upon your processes and workflow. If you need to see the symmetry immediately, then running this process continuously on a remote server may best suite your needs. If you do not need immediate results, then you can run it periodically on your local computer at times that best fit your workflow.

NOTE: This property affects how Smart 3D names parts. It also affects how the parts are handled in Planning and Structural Manufacturing. Because of this, we recommend that you run the Board Management service before you generate drawings, bills of materials, or manufacturing output.
Board Management Service Console
Specifies the settings for running the board management service.

Server
Displays the name of the server on which the board management service runs.

Started by
Displays the user name of the person who started the board management service.

Seams Selected for Evaluation
Hull Seams
Indicates that seams on hull surfaces should be evaluated for symmetry.

Interior Seams
Indicates that seams on interior surfaces should be evaluated for symmetry.

Filters Applied to Target Selection
by Type
Indicates that parts should be filtered by type. The Type property is set on the System Properties dialog box.

by Naming Category
Indicates that parts should be filtered by naming category. The Naming Category property is set on the System Properties or Part Properties dialog box.

by Region
Indicates that parts should be filtered by region or bounding box. The bounding box is defined by the minimum and maximum x, y, and z locations of the object.

Growth
Specifies the amount to expand or shrink the region before filtering. The intent is to find parts that are approximately the same size and in approximately the same (mirrored) location.

Previous Part List Date/Time
Displays the date and time of the previous generation of the list of new and modified parts.

Reset Date/Time to
Replaces the start value of the last time the service was run. This time is used to search for new and modified parts.

Processing Status
Displays information about the number of parts processed and an estimation of the time remaining.

Start
Starts the board management service.
Stop
   quits the board management service without completing the process.

Close
   Saves the values and closes the dialog box.

See Also
Smart 3D Workstation Recommendations (on page 19)

Run the board management service

1. Click Tools > Board Management Service.
   
   TIP Specify the seam types to include.

2. Specify the filters to include.

3. If necessary, reset the start date and time.

4. Click Start.
Block Assignment Service

Block Assignment is a separate software process that runs directly on the Model database. The block assignment process can be run on any workstation. For large projects, you can also run block assignment as a service on a separate computer, including a computer that is running other services. For more information, see Smart 3D Hardware and Software Recommendations (on page 17).

You can run block assignment on any computer on which Smart 3D Workstation software has been installed. Click Tools > Assembly Arrangements > Block Assignment in the Planning task of Smart 3D to set up and run the block assignment process.

The block assignment process assigns and reassigns parts to blocks. When the process is activated, the software automatically and continuously queries the database for new and modified parts to assign and reassign to a block.

You can also specify which types of parts should be processed and how they should be processed.

For the block assignment process to run automatically and continuously, a dedicated server or workstation computer is required. If a dedicated computer is available, you can initiate the block assignment process manually at regular intervals.

Initial Block Assignment of Parts

The purpose of Block Assignment is to take the first cut at where parts fall in the construction planning process. When the block assignment process is running, the software assigns a new part to a block based on the spatial location of the part and the spatial definition of the block. Parts are assigned to blocks at the deepest level possible in the assembly hierarchy within which the part is fully contained. If the part intersects with lower-level blocks and is within an overlap factor assigned in the rules, the part is assigned to the appropriate block. For example, if the overlap factor is 0.8, and at least 80% of a part is within a block, the part is assigned to that block. Otherwise, the software places the part on the list of intersections for the involved blocks and block cutting planes. Only parts that are in working status are considered by Block Assignment.

Each level of the hierarchy contains its own UnAssigned Parts folder. When parts are assigned to blocks, those parts are placed in the UnAssigned Parts folder for that level until they are assigned. In a completely planned ship, most parts will be ultimately assigned to assemblies that are children of the blocks.

After you manually assign a part to an assembly within or directly under the block, outside of the UnAssigned Parts folder, the part falls out of the domain of the assignment process. However, as long as the parts remain in the UnAssigned Parts folder, the block assignment process will reprocess them whenever a part or block is modified.

Modification of Parts

Whenever you modify a part in the UnAssigned Parts folder and an intersection with a block boundary occurs, the software places the part on the list of intersections and sets its status as Assigned to the block from which it originated.
When you modify a part that exists outside of the **UnAssigned Parts** folder, the assembly hierarchy is left unchanged. If an intersection with a block boundary occurs, the software places the part on the list of intersections and displays its status as **Assigned**. If you modify a part and as a result it is fully contained within a new parent block, the software considers the part as new and leaves it in the **UnAssigned Parts** folder.

**Creation and Modification of Blocks**

When you create or modify blocks, the block assignment process checks the parts in the **UnAssigned Parts** folder to determine whether a part can be moved to another block or listed as an intersecting part.

When parts have been assigned to assemblies, defining or modifying a block boundary is more complicated. Consequently, we recommend that as much of the designed building method be preserved as possible. Defining or moving block boundaries removes disassociated parts, assemblies, and part of assemblies from the block in which they were originally assigned during the initial design of the assembly hierarchy.

To preserve the design decisions documented in the assembly hierarchy, the block assignment process only moves parts to the block in which fully contained and duplicate parts of the assembly hierarchy are represented in the original block. The duplication includes the assigned assembly properties. If the duplication involves a whole branch of the assembly hierarchy, that branch is deleted from the original block. In the following illustration, Block B1 is reduced in size by the modification of a block cutting plane. The neighboring block, Block B2, is increased in size by the operation. Parts are moved and assembly A1.2 is duplicated to block B2:

If a part intersects with the block boundary between previously well-known blocks (block cutting plane modification), the part is left in the block from where it originated, and the status in the list of intersections is set as **Assigned** in that block. If the part intersects with one or two blocks that were previously unrelated, the software places the parts in the **UnAssigned Parts** folder of the parent block and lists them among the intersecting parts for the involved blocks or block cutting planes. Assemblies that are emptied of parts are deleted.

**NOTE** You can set a percentage tolerance to assign a part to a block that contains the greater portion of the part. When part that is inside a block has a percentage volume greater than the specified tolerance, it is assigned to this block. For information on how to set tolerance, see *Planning Reference Data Guide*. 
Block Assignment

The block assignment process assigns and reassigns parts to blocks. When the process is activated, the software automatically and continuously queries the database for new and modified parts to assign and reassign to a block.

You can also specify which types of parts should be processed and how they should be processed.

For the block assignment process to run automatically and continuously, a dedicated server or workstation computer is required. If a dedicated computer is available, you can initiate the block assignment process manually at regular intervals.

Initial Block Assignment of Parts

The purpose of Block Assignment is to take the first cut at where parts fall in the construction planning process. When the block assignment process is running, the software assigns a new part to a block based on the spatial location of the part and the spatial definition of the block. Parts are assigned to blocks at the deepest level possible in the assembly hierarchy within which the part is fully contained. If the part intersects with lower-level blocks and is within an overlap factor assigned in the rules, the part is assigned to the appropriate block. For example, if the overlap factor is 0.8, and at least 80% of a part is within a block, the part is assigned to that block. Otherwise, the software places the part on the list of intersections for the involved blocks and block cutting planes. Only parts that are in working status are considered by Block Assignment.

Each level of the hierarchy contains its own UnAssigned Parts folder. When parts are assigned to blocks, those parts are placed in the UnAssigned Parts folder for that level until they are assigned. In a completely planned ship, most parts will be ultimately assigned to assemblies that are children of the blocks.

After you manually assign a part to an assembly within or directly under the block, outside of the UnAssigned Parts folder, the part falls out of the domain of the assignment process. However, as long as the parts remain in the UnAssigned Parts folder, the block assignment process will reprocess them whenever a part or block is modified.

Modification of Parts

Whenever you modify a part in the UnAssigned Parts folder and an intersection with a block boundary occurs, the software places the part on the list of intersections and sets its status as Assigned to the block from which it originated.

When you modify a part that exists outside of the UnAssigned Parts folder, the assembly hierarchy is left unchanged. If an intersection with a block boundary occurs, the software places the part on the list of intersections and displays its status as Assigned. If you modify a part and as a result it is fully contained within a new parent block, the software considers the part as new and leaves it in the UnAssigned Parts folder.

Creation and Modification of Blocks

When you create or modify blocks, the block assignment process checks the parts in the UnAssigned Parts folder to determine whether a part can be moved to another block or listed as an intersecting part.
When parts have been assigned to assemblies, defining or modifying a block boundary is more complicated. Consequently, we recommend that as much of the designed building method be preserved as possible. Defining or moving block boundaries removes disassociated parts, assemblies, and part of assemblies from the block in which they were originally assigned during the initial design of the assembly hierarchy.

To preserve the design decisions documented in the assembly hierarchy, the block assignment process only moves parts to the block in which fully contained and duplicate parts of the assembly hierarchy are represented in the original block. The duplication includes the assigned assembly properties. If the duplication involves a whole branch of the assembly hierarchy, that branch is deleted from the original block. In the following illustration, Block B1 is reduced in size by the modification of a block cutting plane. The neighboring block, Block B2, is increased in size by the operation. Parts are moved and assembly A1.2 is duplicated to block B2:

If a part intersects with the block boundary between previously well-known blocks (block cutting plane modification), the part is left in the block from where it originated, and the status in the list of intersections is set as Assigned in that block. If the part intersects with one or two blocks that were previously unrelated, the software places the parts in the UnAssigned Parts folder of the parent block and lists them among the intersecting parts for the involved blocks or block cutting planes. Assemblies that are emptied of parts are deleted.

**NOTE** You can set a percentage tolerance to assign a part to a block that contains the greater portion of the part. When part that is inside a block has a percentage volume greater than the specified tolerance, it is assigned to this block. For information on how to set tolerance, see *Planning Reference Data Guide*.

**Scheduling Block Assignment with Batch Services**

**Planning** allows you to schedule some tasks during nonproductive hours, for example, nights or weekends, using Intergraph Batch Services.

**NOTE** For more information about Intergraph Batch Services, see the *Batch Services User's Guide* and the *Batch Services Quick Start Guide*.

**Block Assignment Dialog Box**

Allows you to start and stop the block assignment process and specify on which server the process is to run.
What do you want to do?

- Start the block assignment process (on page 194)
- Stop the block assignment process (on page 194)
- Schedule block assignment using Batch Services
- Create block assignment log file

Stop the block assignment process

1. Click Tools > Assembly Arrangements > Block Assignment.
2. Click Stop search process to stop the block assignment process.
3. Click Close to close the dialog box.

**NOTE** You must have read and write permissions to the model database to start and stop the block assignment process. For more information about access permissions, see your Smart 3D administrator.

Start the block assignment process

1. Click Tools > Assembly Arrangements > Block Assignment.
2. On the General tab of the Block Assignment dialog box, click Browse and locate the server on which the block assignment process is to run.
3. Select the part location: Database or Workspace.
4. In the Part selection box, select how you want the parts processed: By Time, By Block or By Filter.
   - If you select By Time, set the Query range options:
     i. Select Resume automatic query to resume the previous block assignment process that was halted.
     ii. Select User-defined query range and type the start date and time and end date and time in the appropriate fields.
     iii. Define the Number of grace minutes.
   - If you select By Block, click in the Block box and navigate to the appropriate block.
   - If you select By Filter, click in the Filter box and navigate to the appropriate filter.
5. Click Start to activate the block assignment process.
6. Check Run in background to close the dialog box.

**NOTES**

- If the software detects that the server you selected in step 2 is not running the appropriate software, you are prompted to select another server.
- You must have read and write permissions to the model database to start and stop the block assignment process. For more information about access permissions, see your Smart 3D administrator.
Block Assignment Dialog Box

Allows you to start and stop the block assignment process and specify on which server the process is to run.

General Tab (Block Assignment Dialog Box)

**NOTE**: Only users with read and write permissions to the model database can modify block assignment process settings. For more information about access permissions, see your Smart 3D administrator.

**Server name**
Specifies, via the **Browse** button, the server where the database assignment of parts to blocks is to be done for the identified Ship Class.

**IMPORTANT**: Running block assignment on the same database on two servers can cause database corruption. If the process was previously run or is currently running on another server, the software displays a message informing you of the name of the server. Before selecting another server, you must verify that the block assignment is not running.

**Part selection**

Provides options for selecting a part from a **Database** or a **Workspace**. Select **Database** to run block assignment as a continuous process, and select **Workspace** to run the process for a specific area.

- **By Time** - After selecting **By Time** and **Database** or **Workspace**, type the **User-defined query range** time in the **From** box and the **To** box. You can also set the **Number of grace minutes**.

- **By Block** - After selecting **By Block** and **Database** or **Workspace**, click in the **Block** box to select the appropriate block from the **Select Assembly** dialog box. The **Block** box only appears if you have selected **By Block**. A message opens when the process completes, instructing you to refresh the workspace to see the results.

- **By Filter** - After selecting **By Filter** and **Database** or **Workspace**, click in the **Filter** box to select the appropriate block from the **Select Filter** dialog box. The **Filter** box only appears if you have selected **By Filter**.

**Resume automatic query**

Resumes the previous process that was halted.

**User-defined query range**

Allows you to type in a user-defined date and time.

- **From** - Allows you to set the start date and time of the query range.
- **To** - Allows you to set the end date and time of the query range.

**Number of grace minutes**

Type a delay period before the software will look for new or modified parts. By specifying a delay, or grace period, for the part assignment, you are more likely to complete any modifications before the software tries to process the part. For example, often an object is created and then immediately modified. If block assignment is running in the background,
the process could immediately find a new or modified part and process it. Meanwhile, you may have also selected the part for modification, but your changes will likely be lost because of the assignment update.

**Current search range from**
Displays the start date and time of the current range. The date/time readout is continuously updated and is read-only.

**Current search range to**
Displays the end date and time of the current range. The date/time readout is continuously updated and is read-only.

**Found parts awaiting assignment**
Specifies the number of parts found by the block assignment process within the current search range and that are yet to be assigned. This data is continuously updated and is read-only.

**Total number of parts processed**
Displays the number of parts processed. This data is continuously updated and is read-only.

**Number of parts processed in grace period**
Displays the number of parts processed during the grace period. This data is continuously updated and is read-only.

**Estimated Remaining Time for Assignment**
Displays how long the process is expected to continue. This data is continuously updated and is read-only.

**Run In Background**
Accepts the changes and closes the dialog box. The block assignment process will continue to run in the background. This button is only available after you select **Start**.

**Submit Job**
Opens the Schedule [Task] dialog box, which is used to define the batch settings for block assignment using Intergraph Batch Services. For more information about the batch settings, see Schedule [Task] Dialog Box.

**Start**
Starts the block assignment process as a continuous process on the specified server.

**Stop**
Stops the block assignment process on the specified server.

**Close**
Accepts the changes and closes the dialog box. This button is only available after opening the **Block Assignment** dialog box when block assignment is already started.

**Configuration Tab (Block Assignment Dialog Box)**
Displays the creation, modification, and status information about an object.

**Model**
Displays the name of the model. You cannot change this value.

**Permission Group**

Specifies the permission group to which the object belongs. You can select another permission group, if needed. Permission groups are created in the Project Management task.

**Created**

Displays the date and time that the object was created.

**Created by**

Displays the user name of the person who created the object.

**Modified**

Displays the date and time when the object was modified.

**Modified by**

Displays the user name of the person who modified the object.

**Start**

Starts the block assignment process as a continuous process on the specified server.

**Stop**

Stops the block assignment process on the specified server.

**Close**

Accepts the changes and closes the dialog box. This button is only available after opening the *Block Assignment* dialog box when block assignment is already started.
SECTION 13

Getting Started

This section discusses how to map individual workstation computers to the server databases, start the software, and begin performing various tasks in the software environment.

**IMPORTANT** You must create the seven databases before running the software. For additional information, refer to the section entitled *Create Databases* (on page 125).

*In This Section*

- Update Site Database Name and Path .......................................................... 198
- Open Smart 3D ......................................................................................... 200
- Configure Your Tasks ................................................................................ 200
- Define Your Workspace .............................................................................. 201
- Save Session Files ..................................................................................... 205

**Update Site Database Name and Path**

Before starting the client software for the first time, you must point to the database server and site database that you want to use.

**SQL Server Databases**

1. Select Start > All Programs > Intergraph Smart 3D > Database Tools > Modify Database and Schema Location.
2. Select SQL Server as the database type.

3. In the Site database server box, type the name of the server on which the Site database resides or select it from the drop-down list of recently used Site database servers.
4. In the Site database name box, type the name of the Site database or select it from the drop-down list of recently used Site databases.
5. The **Site schema server** box value is set when you specify the Site database server and Site database name.

6. The **Site schema name** box value is set when you specify the Site database server and Site database name.

   **TIP** If SQL is not installed locally, you can get the names from your database administrator.

7. Click OK.

**Oracle Databases**

1. Open the **Modify Database and Schema Location** utility.

2. In the **Database type** list, select **Oracle**.

3. In the **Oracle service name** box, type the name of the Oracle net service for the Site database connection or select it from the drop-down list of recently used Oracle service names.

4. In the **Site database name** box, type the name of the Site database or select it from the drop-down list of recently used Site databases.

5. The **Oracle service name** box value is set when you specify the Oracle net service and Site database name.

6. In the **Site schema name** box value is set when you specify the Oracle net service and Site database name.

7. Click OK.

   **NOTE** The first time you run the software after installing it, the software prompts you for the Site database name and sets the Site database name and path automatically.

**See Also**

*Getting Started (on page 198)*
Open Smart 3D

When you work on your model in Smart 3D, you use a session that allows you to save certain settings, such as window size, layout, and view orientation from one work session to the next.

If you have a previously saved session, you can double-click the session file to open Smart 3D. The software loads your data from the last session, and then you can click **Refresh Workspace** to update all views with the most current information from the database.

If a session if not available, you can open Smart 3D from the operating system menu. The software then asks you to choose a template to create a new session.

**IMPORTANT** A user who is a member of the Windows Administrators group on the workstation computer must start the software once on the workstation computer before a user without administrative privileges can successfully start the software.

The following procedure shows the steps to open Smart 3D from the operating system menu.

1. Click **Start > All Programs > Intergraph Smart 3D > Smart 3D**.
2. Select one of the templates on the **New** dialog box.

   **TIP:** A template is a standard Workspace file. You use a template as a pattern to assemble the parameters that you want for a new work session. Two standard templates are delivered with the software: **English Units** and **Metric Units**.

3. Click **OK**.

   **NOTE** After you open Smart 3D, you can use commands on the **File** menu to create new sessions, open previous sessions, save sessions, and close sessions. For more information, refer to the online documentation for the **Common** task or the **Common User's Guide** available from **Help > Printable Guides** command in the software.

**See Also**

*Getting Started (on page 198)*

Configure Your Tasks

Common operations within the various tasks of Smart 3D are performed the same way. Therefore, the Common task refers to the functions shared with other tasks and identifies the commands required to accomplish these functions.

The Common task allows you to define a workspace, as well as perform common operations on that workspace. The workspace represents the portion of the plant data that you need to perform your intended task. The session includes the view settings for user modeling, as well as your personal filters for viewing the data. Many other tasks on the **Tasks** menu are not available until you have defined your workspace.

After defining your workspace, you can use the **Tasks** menu to move between the various design tasks. You can perform specified functions, depending on your access permissions. After you select a task, the interface and available functionality is displayed. Some of the commands and functionality are unique to the particular task. For example, some commands for the Piping task are not available in the Equipment and Furnishings task. However, most of the Common task commands are available in all of the various design tasks. You use the Common task commands and functionality the same way regardless of the active task. For example, the commands that appear on the **View** and **File** menus function the same way in every task.
To use the tasks available in Smart 3D, you must configure them for your session. After you configure the tasks that you want to use, you must then define your workspace. After you define your workspace and configure your task list, you can save your session file.

1. In Smart 3D, click **Tasks > Configure Task List**.
2. On the **Configure Task List** dialog box, select each task in the list that you want to add to the menu from the **Available task environments** list.
   - **TIP** You can select multiple tasks by dragging down the list or holding Shift and dragging.
3. Click **Add**.
4. Click **OK**.

- **NOTE**
  - You have to perform the above procedure only once for your session file. The software remembers the tasks when you re-open the session file.
  - For detailed information regarding how to configure tasks in Smart 3D, refer to the online documentation for the Common task or the Common User’s Guide available from Help > Printable Guides.

**Define Your Workspace**

When you begin to work in a task, you must first define the content of the workspace, that is, the items with which you want to begin working. By defining only those items that you want from the database, you avoid cluttering the workspace with unneeded and unrelated items.

Select the items for your workspace by using a filter. The filter is a query that retrieves from the database only those items that you specify in the filter criteria.

Defining a workspace also allows you to create and name filters that restrict the data of the entire model into more manageable subsets for working.

The workspace contents that you define appear in the **Workspace Explorer** (WSE) in a classification hierarchy that reflects the various relationships for the design objects. The contents represent the current items loaded from the database into the active workspace.

**Define Workspace Dialog Box**

Defines the workspace content using:

- The model in which you want to do your work
- A filter to retrieve objects for display in the workspace. For more information on filters, see Select by Filter.

**Plant/Ship**

Provides a list of the model databases for your site. Choose a model to work in from those listed in this box. If your site only has one Model database, then the software lists only one name. When you create a new Model database, it is added to the list. If you have multiple sites, only the models associated with the active site appear in the list.

**Filter**

Displays a maximum of ten of the last filters selected for the workspace. This box is blank if
no filters were previously defined and used.

If you select the More option, the Select Filter dialog box appears. This dialog box displays a tree view of other filters you can select. For more information, see Select Filter Dialog Box. The Create New Filter option opens the Filter Properties dialog box where you can create a new filter. The software places the resulting new filter in the My Filters folder. The software then returns to the Define Workspace dialog box where the new filter name is displayed. If your permissions include edit privileges, the Define Workspace dialog box also allows you to rename or delete filters and edit filter properties.

Properties
Displays the Filter Properties dialog box that provides tabs of optional properties for the selected filter, or query criteria, you can select and apply to your filter. The System, Assembly, and Named Space tabs allow you to select large groups of objects in the database. If you want a more restricted selection, choose a tab such as Permission Group or Object Type. The Permission Group tab properties limit the selection to only those objects in a designated group. The Object Type tab displays a tree view of all objects in the system. The objects are organized primarily by the task where you created them. Using this tab restricts your selection to only those objects of the selected types. For more information, see Filter Properties Dialog Box.

Role
Provides a list of user roles that you can select for the workspace. Each role is defined with a specific set of disciplines and subclass object types. If a role is selected, only the object types defined for the role are displayed in the workspace. Roles and their included object classes and subclasses are defined in the OptimizationForRole.xml file in the [Reference Data Folder]\SharedContent\XML folder. If the file is missing, the Define Workspace dialog box does not display the Role box. Your administrator can customize OptimizationForRole.xml. For more information, see Define roles (on page 202).

NOTES

- The shortcut keys for the Define Workspace command are CTRL+W.
- You can also access the Select Filter dialog box by clicking Tools > Select by Filter.
- Before loading the query results to your workspace, the software determines whether your computer has enough virtual memory to contain the results. If you do not have adequate memory available, the software displays a warning that your workspace size is likely to exceed the available memory of your computer. You can continue by clicking Yes. If you click No, the query load stops, and the Define Workspace dialog box returns so that you can redefine your search criteria.

See Also
Define roles (on page 202)

Define roles
The list of roles for selection in the Role box in the Define Workspace dialog box is defined in the OptimizationForRole.xml file in the [Reference Data Folder]\SharedContent\XML folder. Each role is defined with a set of disciplines and subclass object types. The role XML format mimics the object classification hierarchy used in Smart 3D. You can see a tree view of the object hierarchy in the Object Type tab of the Filter Properties dialog box.
Roles XML Format

The top-most node can be any user-defined name.

The second-level node is the Role class with the Name attribute. The role name is displayed in the Define Workspace dialog box Role drop-down list.

The third-level node is the Discipline class with the ClassName attribute. This provides the top-most level of filtering. If the class has no sub-nodes, then all object types of the discipline are included in the workspace. If the class has sub-nodes, then only the object types defined in the sub-nodes are brought into the workspace.

The fourth- and fifth-level nodes are the Node class with the ClassName attribute. They define discipline object types to be included in the workspace. Only the object types listed underneath the discipline are brought into the workspace. If a node has sub-nodes, then only the object types defined in the sub-nodes are brought into the workspace.

NOTES

- Roles applied to filters that pull in referenced files or referenced 3D files must include the classification nodes for these specific classes to populate the Workspace Explorer tree view. If these classes are missing from the role definition, references are pulled in but the Workspace Explorer cannot be populated.

  <Discipline ClassName="Reference 3d File" />
  <Discipline ClassName="Referenced File" />

- The discipline names and discipline sub-node names must match those defined in the Smart 3D object classification hierarchy. If in a role definition any of these node names do not match an existing classification, an error message similar to the following example is shown when the role filter is loaded. Click OK to continue, but the error node is excluded from the workspace.

![Error Message]

Example Roles Definition

```xml
<?xml version="1.0" encoding="windows-1252" ?>
```
<S3D>
  <Role Name="Electrical Designer" Version="1.0">
    <Discipline ClassName="Cableway">
      <Node ClassName="Cableway Features" />
      <Node ClassName="Cableways" />
    </Discipline>
    <Discipline ClassName="Cabling">
      <Node ClassName="Cable Features" />
      <Node ClassName="Cable Marker" />
      <Node ClassName="Cable Runs" />
    </Discipline>
    <Discipline ClassName="Equipment and Furnishing">
      <Node ClassName="Equipment">
        <Node ClassName="Equipment A" />
      </Node>
    </Discipline>
  </Role>
  <Role Name="Equipment Designer" Version="1.0">
    <Discipline ClassName="Equipment and Furnishing" />
    <Discipline ClassName="Grid Systems" />
    <Discipline ClassName="Structure">
      <Node ClassName="Equipment Foundations" />
      <Node ClassName="Members" />
      <Node ClassName="Slabs" />
      <Node ClassName="Walls" />
    </Discipline>
  </Role>
</S3D>

In the above example, two roles are defined:

<table>
<thead>
<tr>
<th>Role</th>
<th>Discipline</th>
<th>Object Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electrical Designer</td>
<td>Cableway</td>
<td>Cableway Features</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cableways</td>
</tr>
<tr>
<td></td>
<td>Cabling</td>
<td>Cable Features</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cable Marker</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cable Runs</td>
</tr>
<tr>
<td></td>
<td>Equipment and Furnishing</td>
<td>Equipment</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Equipment A</td>
</tr>
<tr>
<td>Hangers and Supports</td>
<td>Supports</td>
<td></td>
</tr>
<tr>
<td>Equipment Designer</td>
<td>Equipment and Furnishing</td>
<td>All Equipment and Furnishing objects</td>
</tr>
<tr>
<td></td>
<td>Grid Systems</td>
<td>All Grid objects</td>
</tr>
</tbody>
</table>
### Defining your Workspace

1. If you are not already in the Common task, click **Tasks > Common**.
2. Click **File > Define Workspace**.
3. Select the name of the model database that you want.
4. Select **Create New Filter** in the **Filter** box.
5. On the **New Filter Properties** dialog box, type a name for the new filter in the **Name** box.
6. Specify the filter search properties by using one or more of the displayed tabs.
7. Click **OK** to close the **New Filter Properties** dialog box.
8. Click **OK** to return to the model.

**NOTES**
- After the Define Workspace dialog box closes, the window refreshes. After the refresh is complete, the Common window is active. Everything in the Tasks menu is now available.
- For more information on workspaces, sessions, and filters refer to the online documentation for the Common task or the Common User's Guide available from Help > Printable Guides.

### Save Session Files

After you define your workspace and configure your task list, you can save your session file.

1. Click **File > Save**.
2. Browse to the folder location where you want to store your session file, such as your Desktop.
3. On the **Save As** dialog box, type the name of your session file in the **File Name** box.
4. Click **Save**.

**NOTES** For more information on saving session files, refer to the online documentation for the Common task or the Common User's Guide available from Help > Printable Guides command in the software.
SECTION 14

Application Maintenance

You have three options for Application Maintenance for Smart 3D:

- **Update** - Change the selected features that were installed. Install and/or uninstall individual features to match the new selection.

- **Repair** - Using the current feature set installed, repair any missing or corrupted files from the installation.

- **Uninstall** - Removes registry entries, files, and directories that do not contain user data and are not shared by other programs and were put there by the installation.

You can access Application Maintenance from Control Panel > Programs and Features > Intergraph Smart 3D, and then click Change.

**NOTE** Selecting Uninstall from Programs and Features does not access the Application Maintenance utility. The uninstall process is started automatically.

For more information on modifying, repairing, or removing the software, see *Modify or Repair Intergraph Smart 3D Software* (on page 207).
Modify or Repair Intergraph Smart 3D Software

You can use the Application Maintenance utility to modify, repair, or even remove the Smart 3D application. The procedure below shows how to modify or repair the application. For more information on removing (uninstalling) the software, see Remove Smart 3D Software (on page 208). You can access this dialog box by selecting Control Panel > Programs and Features, then selecting the Intergraph Smart 3D application, and then click Change.

Modify the Currently Installed Features

You can change the selected features that were installed. Install and/or uninstall individual features to match new selections.

1. On the Optional Features page, select the features that you want to install. For example, if you want to create databases, click the Project Management and Server Connectivity options.

   **IMPORTANT**

   - Before adding and removing features from the setup, review the dependencies that can exist between one feature and another. For more information, see Setting Up the Client (see "Client/Workstation Setup" on page 81).
   - If you selected the Piping Specification Remote Access Server feature to be installed, you need to enter a username with administrative privileges to the computer. In the Password box, enter the password of the user.

2. Click Update.

3. When the installation process is complete, click Finish.

   **IMPORTANT**

   - During the setup, the %temp% value is defined as the user %temp% of the person who runs the setup. In Windows, each user’s C:\Documents and Settings\username\Local Settings\Temp is protected from other Windows users. Consequently, you must set the system environment variable TEMP value to a folder location where everyone has write access (that is, C:\Temp). For more information about editing system variables, see the Windows online documentation (click Start > Help from the Windows task bar).
   - If you installed the Piping Specification Remote Access Server feature during the setup, you must verify that the COM+ application is installed and configured on the administrator computer. For more information, see Configure the Piping Specification Remote Access Server Service (on page 159).
   - You can install the Database Interference Detection Service on a different workstation computer. For more information, see Install Database Interference Detection Service (on page 167).

Repairing the Currently Installed Features

Using the current feature set installed, you can use the Application Maintenance utility to repair any missing or corrupt files from the installation.

1. Click Repair dialog box.

2. On the Ready to Repair the Application dialog box, click Next to begin the repair process.
Remove Smart 3D Software

There are two ways to remove, or uninstall, the software from the computer. You can go through the Control Panel and use Programs and Features to remove the software, or you can insert the product DVD and select Uninstall on the Application Maintenance dialog box.

You should keep the following things in mind before removing the software:

- Remove previous versions of Smart 3D software before installing any new versions.
- The Interference Checking Server service must be stopped manually before you uninstall.
- The Duplication Synchronization Service must be stopped before you uninstall.
- You must have administrative privileges on the computer before removing the software. Refer to Windows Help for instructions on how to establish administrative privileges.
- Before removing Smart 3D software, ensure that you have preserved all reference data Excel files that are pertinent to your specific project. When you uninstall the software, all files that are stored in the Smart 3D product folders are removed from your computer.

Removing the Software

1. Click Start > Control Panel.
2. Double-click Features and Programs.
3. Select Intergraph Smart 3D or Intergraph Reference Data from the installed programs list, depending on the product that you need to remove.
4. Click Uninstall.
Recommendation for Database Monitoring

This section is a recommendation for monitoring your SQL Server or Oracle databases for Smart 3D. There are many possible hardware and software configurations that you can use to set up your Smart 3D databases. Refer to the documentation for your components for more information on performance and scalability issues.

See Also
Server Monitoring (on page 212)

Monitoring the Databases

You can use the following guidelines for setting up and monitoring your databases. Because there are many viable hardware and software configurations that you can use to set up the databases, refer to the documentation for your components for more information on performance and scalability issues.

IMPORTANT Database administrators should continuously monitor the status of Smart 3D databases, especially as the project grows. If you are using a Global Workshare environment, database administrators must ensure that the replication process is functioning.

To achieve adequate performance and measurements while monitoring the system, use the settings outlined in Set Up the Database Server.

See Also
Recommendation for Database Monitoring (on page 209)
Disk Usage (on page 210)
Disk I/O (on page 209)

Disk I/O

Data file and log file location and sizing are critical to obtaining optimal performance. I/O is one of the most common bottlenecks in database servers. Consequently, sizing I/O is critical to performance.

CAUTION Disk drives should not be run at more than 75% of the maximum I/O capacity.

The two types of I/O are Random I/Os and Sequential I/Os. The type of I/O determines the number of I/Os per second that a disk drive can handle. Random I/Os require a longer time to complete than sequential I/Os.

Random I/Os

The amount of time spent performing random I/Os is governed by the time it takes to perform the seek operations. Since the random I/O involves requests for data on different parts of the disk, most of the time spent in the I/O will be the seek time. If a disk drive takes 10 milliseconds (averaging read and write), it is theoretically possible to perform 100 random seeks per second.
Recommendation for Database Monitoring

(1/.001 sec), excluding such things as overhead associated with the I/O bus or latencies associated with processing the I/O. Queuing begins as you get closer to the theoretical limit of the disk drive. As queuing occurs, the I/O latency increases and database performance begins to suffer.

**NOTE:** You can increase the system’s random I/O capacity by spreading the data across multiple files or install the data files on a RAID array.

Data files are mostly accessed by random I/Os.

**Sequential I/Os**

Because there is no seek operation involved in sequential I/O, a disk drive can handle several hundred sequential I/Os per second without seeing increasing latencies. Therefore, using sequential I/O whenever possible can greatly improve the performance of the disk drives. Microsoft SQL Server and Oracle keep a log of the transactions; this log is primarily sequential to take advantage of sequential I/Os.

**IMPORTANT:** In order to achieve maximum performance, the data file and log file must not be on the same physical drive.

**See Also**

*Recommendation for Database Monitoring* (on page 209)

*Monitoring the Databases* (on page 209)

*Disk Usage* (on page 210)

**Disk Usage**

Disk usage should remain under 85% of the maximum disk capacity, and the partition should not be compressed.

**Sizing the Files**

With Microsoft SQL Server, a database is created by default with a data file of 1MB and a log file of 1MB.

**NOTE:** A database can be associated to more than one data file and more than one log file.

Both files are set to grow by 10% increments until space is no longer available on the drive. These defaults, however, are not adequate for monitoring or for a production system. When the data or log files are growing, the process may consume a very large amount of server resources and slow down the interactive users or perturb the monitoring performed on the system. As a result, we recommend that you set the size of the files to avoid automatic growth.

**NOTE:** Set the size to the maximum anticipated size of the file. Set the growth increment to size of the available space or 85% of the capacity of the drive.

If automatic file growth occurs, re-evaluate the situation and try to set more accurate sizes or plan to add more capacity for your database.

**Determining RAID Configuration**

Use the following database activity considerations to determine the appropriate RAID configuration for optimum performance:

- **Model Database** - High level of reads and writes (select, insert, update, and delete activities).
- **Catalog Database** - Medium to Low level of reads and writes (select, insert, update, and delete activities). Activities such as bulkload and copy to catalog are write activities. Both can write a significant amount of data.
  
- **Catalog Schema** - Low level of reads and very low level of writes. Activities such as bulkload are used to write occasionally, but the amount of data is relatively small.

- **Site** - Very Low level of reads and writes. While the Site is not read-only, the write activity is limited to a maximum of several rows per week.

- **Site Schema** - Very Low level of reads with no writes.

- **Report Database and Report Schema** - Read only. They contain views that are composed of queries mainly from the Site, Catalog, and Model Databases.

**NOTE** Microsoft SQL Server tempdb has a high level of read and write.

The following table is based on a Microsoft SQL Server setup and shows some reasonable orders of magnitude for small pilots based on testing conducted by Intergraph. The most critical files for performances and monitoring are isolated on their own physical drives (the G, H, I, and J drives) while the less critical files share two drives (the E and F drives). The operating system, SQL server and paging files are installed on their own drives.

<table>
<thead>
<tr>
<th>File</th>
<th>Initial Size</th>
<th>Growth Increment</th>
<th>Drive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model data</td>
<td>10 GB</td>
<td>1 GB</td>
<td>G</td>
</tr>
<tr>
<td>Model log</td>
<td>1 GB</td>
<td>500 MB</td>
<td>H</td>
</tr>
<tr>
<td>Catalog data</td>
<td>1 GB</td>
<td>500 MB</td>
<td>I</td>
</tr>
<tr>
<td>Catalog log</td>
<td>500 MB</td>
<td>100 MB</td>
<td>J</td>
</tr>
<tr>
<td>Catalog schema data</td>
<td>Default</td>
<td>Default</td>
<td>E</td>
</tr>
<tr>
<td>Catalog schema log</td>
<td>Default</td>
<td>Default</td>
<td>F</td>
</tr>
<tr>
<td>Site data</td>
<td>50 MB</td>
<td>10 MB</td>
<td>E</td>
</tr>
<tr>
<td>Site log</td>
<td>50 MB</td>
<td>10 MB</td>
<td>F</td>
</tr>
<tr>
<td>Site schema</td>
<td>Default</td>
<td>Default</td>
<td>E</td>
</tr>
<tr>
<td>Site schema log</td>
<td>Default</td>
<td>Default</td>
<td>F</td>
</tr>
<tr>
<td>Report data</td>
<td>Default</td>
<td>Default</td>
<td>E</td>
</tr>
<tr>
<td>Report log</td>
<td>N/A</td>
<td>N/A</td>
<td>F</td>
</tr>
<tr>
<td>Temp DB data</td>
<td>50 MB</td>
<td>50 MB</td>
<td>E</td>
</tr>
<tr>
<td>Temp DB log</td>
<td>50 MB</td>
<td>50 MB</td>
<td>F</td>
</tr>
</tbody>
</table>
Recommendation for Database Monitoring

NOTES

- The size of your Model database log file depends on your backup strategy. For more information about backing up your Smart 3D data, see the Project Management User's Guide, available from Help > Printable Guides.

- Tempdb size is reset to the default every time the server is re-started.

See Also

Smart 3D Database Server Recommendations (on page 18)
Recommendation for Database Monitoring (on page 209)
Monitoring the Databases (on page 209)
Assign System Administrator Privileges for SQL Server 2008 (on page 46)

Server Monitoring

The details on how to monitor system counters and log the results to a file can be found in the operating system documentation. Intergraph PPM assumes that the reader is already familiar with that topic.

While doing the monitoring at Intergraph PPM, we started from a very broad selection of counters. The analysis of these system parameters with the number of users on the system conducted us to focus on a subset of counter found the most relevant for the scalability and dimensioning analysis. The list of highlighted counters is not a definitive list of what should be monitored, but the list of counters that should be watched with the closest attention. We recommend starting from a wide selection of counters and discard later what is found not to be pertinent.

NOTES

- Testing has demonstrated that these counters can be monitored every second to analyze a specific workflow or every 10 seconds if you plan on monitoring the system for longer times.

- A log file of the user activity should be kept in order to relate the server activity to the actions of the user.

- You can also use the System and Configuration Analyzer tool (SCA) to monitor these parameters. This tool can be downloaded from eCustomer.

Processor

Processor average usage should be kept under 80% for each processor. Isolated spikes over 80% are acceptable.

We recommend monitoring the following counters:

- % Processor time
- % Privileged time
- % User time
- % Interrupt time
- Interrupts per second
- Processor queue length
- Context switches per second
Any significant discrepancy between the % Processor time and the % User time indicates that the CPU is not available for SQL server and needs to be investigated. This problem did not occur during testing.

**Logical Disk and Physical Disks**

The recommendation is to monitor the following counters for each physical drive:

- % Disk read time
- % Disk write time
- % Disk time
- % Idle time
- % Average disk queue length
- % Average disk read queue length
- % Average disk write queue length
- Disk second per read
- Disk second per write
- Disk second per transfer
- Disk read per second
- Disk write per second
- Disk transfer per second
- Disk write bytes per second
- Disk read bytes per second

**Memory**

- Available Mbytes
- Page fault per second
- Page read per second
- Page write per second
- Pages per second

**Network**

- Byte received per second
- Byte sent per second
- Current bandwidth
- Output queue length

Record PING times between client and server to verify that the software is not being affected by other network traffic.
Database (Microsoft SQL Server)

Buffer Manager Object

Counter to monitor:
- Buffer cache hit ratio
- Procedure cache pages
- Free pages
- Page read per second
- Stolen pages
- Page writes per second
- Free List Stalls per second
- Total pages
- Page Life expectancy
- Page reads/sec Number
- Page writes/sec Number

**IMPORTANT**: Buffer cache ratio should remain over 90%. During testing, the ratio has always been in the 95-99% range.

SQL Databases Object

We recommend monitoring the following counter at least for the Tempdb, Catalog, and Model databases. You can monitor the other Smart 3D databases as well. For performance testing, the Tempdb database should be monitored.

- Data file size
- Log file size
- % log used
- Transaction per second
- Active transaction

The transaction per second was not found very relevant for Smart 3D because the software executes very few transactions per second (one transaction per command normally). Also, note that two different commands, that is, two transactions can have a very different impact on the database. Testing has shown that the measure of how much the software "hits" the database server is best measured with the number of batch requests per second.

SQL Statistics Object

- Batch request per second
- SQL compilation per second
- SQL re-compilation per second

SQL Locks

- Average wait time (ms)
- Lock timeouts/second
Recommendation for Database Monitoring

- Lock waits/second
- Number of deadlocks per second

A certain amount of locking is to be expected because of the way SQL manages data integrity. Excessive locking, however, can lead to blocking and needs to be analyzed in order to correct the software. Any deadlock situation needs to be analyzed.

**SQL Latches**
- Average latch wait time (ms)
- Latch wait per second

**Database (ORACLE)**
Oracle performance counters can be monitored using the web-ui that installs with Oracle or by using the System and Configuration Analyst tool (SCA) available from eCustomer. Please consult Oracle documentation for details on it.

Oracle Database Counters:
- Dictionary Cache Hit Ratio – Should be > 90
- Library Cache Hit Ratio – Should be >= 99%
- DB Block Buffer Cache Hit Ratio – Should be > 90
- Log Switch Interval – Should be greater than 30 minutes

Oracle Reports:
- Automatic Database Diagnostics Monitor (ADDM) report – This report can be generated from the Oracle Database Console or using the SCA tool available on eCustomer.

**See Also**
*Recommendation for Database Monitoring* (on page 209)

**Results Analysis**
The classical way to analyze database activity is to analyze the activity generated by each command (place an order, repeat order, order status, and so on) and extrapolate the response of the system to a given load. For example, if placing an order causes one physical read on the data file disk, the maximum number of orders that can be placed in one minute can be computed.

Given the huge number of commands that exist in the software, this approach is not practical for our system. Instead, the focus is placed on measuring the typical activity per interactive user for a given environment. Getting reliable average data requires having several users working concurrently. The data generated by a single interactive user is usually too noisy to be used.

After the data is collected for a given load, the response of the system can be extrapolated to a higher load assuming a linear response up to a critical value. Refer to Microsoft SQL Server or Oracle performance tuning documentation for more details.
Example

The following graphic shows some of the system parameters while two users are routing pipes and two users are creating beams in structure:

<table>
<thead>
<tr>
<th>Color</th>
<th>Scale</th>
<th>Counter</th>
<th>Instance</th>
<th>Parent</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Disk-Read/sec</td>
<td>1E: G:</td>
<td>...</td>
<td>Physical</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Disk-Read/sec</td>
<td>2H: D:</td>
<td>...</td>
<td>Physical</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Disk-Writes/sec</td>
<td>0C: D:</td>
<td>...</td>
<td>Physical</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Disk-Writes/sec</td>
<td>1E: G:</td>
<td>...</td>
<td>Physical</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Disk-Writes/sec</td>
<td>2H:</td>
<td>...</td>
<td>Physical</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>% Privileged Time</td>
<td>Total</td>
<td>...</td>
<td>Process</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>% Processor Idle</td>
<td>Total</td>
<td>...</td>
<td>Program</td>
</tr>
<tr>
<td>1,000</td>
<td>1,000</td>
<td>Batch Requests/sec</td>
<td>Total</td>
<td>...</td>
<td>SQL/Serial</td>
</tr>
</tbody>
</table>

Average CPU usage: 15%

Reads per second ModelDB data: 0.003

Writes per second ModelDB data: 2.75

Read per second ModelDB log: 0.003

Write per second ModelDB log: 2.83

Reads per second C drive: 0.12

Writes per second C drive: 2.50

Batch per second: 290

CPU

- CPU capacity = 2 (processors) × 500 MHz = 1 GHz
- CPU usage per user = CPU capacity × (average CPU % used / number of users) = 1 GHz × .15/4 users = approximately .0375 GHz per user

Therefore, for a single 1.0 GHz processor:

- Usage capacity = 1.0 GHz × .75 (critical usage percentage or usable capacity)
- Number of users = Usable capacity / CPU usage per user

The system should support (0.75/0.0375) GHz per user = 20 users per GHz.
Model Data File

- Total physical I/O per second = 2.75 (Model DB writes) + 0.003 (Model DB reads) = 2.75 physical I/O per second for 4 users = approximately 0.69 physical I/O per second per user

- Ignoring RAID factor and taking a standard Max I/O = 70 \times 75\% = 52

Therefore using the same disk characteristics, can support 59/0.68 = 75 users per disk.

Model Log File

- Total physical I/O per second = 2.83 (ModelDB writes) + 0.003 (ModelDB reads) = 2.83 physical I/O per second for 4 users

- Ignoring RAID factor and taking a standard Max I/O = 70 \times 75\% = 52.

Therefore using the same disk characteristics, can support 52/0.71 = 73 users per disk.

NOTES

- Testing has determined that the main hardware parameters driving the scalability of the system are the CPU and the I/Os.

- A system different than the one used for testing purposes can lead to completely different results. For example, if the memory is scarce, more loads are placed on the I/O system.

- Because the log file I/Os are mostly sequential, the system can achieve about 150 sequential I/Os per second per physical disk, compared with only 50 random I/Os per second per physical disk.

Other Considerations

Interference Checking (IFC)

IFC imposes a very significant load on the database server (equivalent to several simultaneous interactive users). We recommend turning off IFC to measure the database activity generated by the interactive users using the design applications (piping, structure, and so on).

Reports

Some reports can put a heavy burden on the server. Intergraph PPM advises monitoring the reports activity separately from the database activity generated by the interactive users using design applications (piping, structure, and so on).

See Also

Recommendation for Database Monitoring (on page 209)
SECTION 16

Troubleshooting the Software

To troubleshoot the software, several of the software components provide log files that can provide pertinent information about the software. Additionally, the software delivers a variety of utilities as troubleshooting tools. You can locate the various log files by searching the hard drive on your computer with *.log. You can open log files and view their contents using a text editor such as Notepad. Log and error files are saved to your system Temp folder unless you specify another folder.

Log Files

To enable the error log file, use Windows Explorer to navigate to [Product Folder]\Core\Tools\Administrator\Bin and execute ErrorLogEnable.exe. This utility allows you to configure the delivery location of the log file, the file name, and four levels of logged information.

**Log run time error** - Check this box to enable error logging. Clear this box to stop error logging.

**Select the severity of the errors to be reported** - Select the error reporting level. The higher the level that you select, the more information is written to the log file. We recommend that you use level 1 at all times. The higher level error reporting (2 - Detailed, 3 - Complete, and 4 - Exhaustive) slows the software performance, and is only necessary if support requests detailed log information while tracking a problem. In all normal cases, this option should be set to 1 - Normal.
**Troubleshooting the Software**

**Error log full file name** - Specify the path and name of the log file. We recommend that you specify a location where all users have write access; otherwise, problems associated with updating the error log file may prevent users from receiving a desired response. For example, if you set the log to write to UserA’s Temp folder, then UserA is the only one who can create or update the log file. Other users (with the exception of an administrator) will not have access to UserA’s Temp folder. Likewise, if you configure the software to generate the log file in a folder under the Program Files path, only those users who belong to the Power Users or the Administrator groups will have write access to the log file. Keep disk access privileges in mind when you are configuring the log file.

**Generate time-based log file name at each new start of SP3D task host** - Depending on how you configure it, Smart 3D overwrites the log file each time you start the software. If you need to save an existing copy of the log file, rename the file before starting the software or check this option.

**Preserve User Settings** - Check this option to save severity level setting and the error log file name for just the active user. Clear this option to save the severity level setting and error log file name for all users on this computer.

**Add OS stats to every record** - Check this option to add your operating system status (such as CPU percentage and memory usage) to each log message. Please note that selecting this option slows down the software performance and likely your entire system’s performance. You only need to check this option at the request of support. It is important to notice that if Smart 3D uses more than 2 GB of memory during execution, the OS stats logged for each error take more than half a second to calculate. We recommend that this option be checked only temporarily as requested by support while tracking an issue.

**Add Stack Traces to Error records** - Check this option to add the stack of the function registering the error. Please note that this option slows down software performance and likely your entire system’s performance.

**Start memory monitor automatically when SP3D starts** - Check this option to start the Memory Monitor automatically every time Smart 3D starts. You can also click **Start Memory Monitor** to manually start the Memory Monitor. For more information, see Appendix: S3DMemoryMonitor in the Smart 3D Common User's Guide.

An error log is always created. If there is not a location specified, the default location is your Temp folder, or %TEMP%, for the process being executed. If the Log run time error option is not checked, this automatically generated error log is deleted with the software completes processing. In case the software crashes or completes in another abnormal way, the error log is left on disk to help support diagnose the problem that occurred. In addition, it is possible that two more files are created: WER_SP3DErrors_<timestamp>.log and S3DHost_<timestamp>.dmp. When contacting support, please also make these files available as part of your Service Request.

**Troubleshooting Tools**

You can use tools delivered with the Core to troubleshoot the software. These tools are located in [Product Folder]\Core\Tools\Administrator\Bin.

- **CrashSP3D.exe** - Allows you to forcefully crash Smart 3D. This is useful when you want to log a hang, either in a command that never completes or a command that takes a long time to process. It can also be useful when an unexpected error dialog displays and you want to log a Service Request for the issue. In Smart 3D, crash events are recorded in a .dmp file and stored in the specified Temp folder. Along with the .dmp file, copies of the Errorlog and WER_SP3DErrors.log file are also stored in the specified Temp folder, which are all useful in...
determining the reason for certain problems that occur in the product. CrashSP3D.exe allows you to crash Smart 3D to obtain a copy of the .dmp, Errorlog, and WER_SP3DErrors file for troubleshooting purposes. When activated, CrashSP3D.exe allows you to select which instance of Smart 3D you want to forcefully crash. Contact support for more information about the options available in this utility and when to use them.

- **ErrorLogEnable.exe** - Specifies the severity of logged runtime errors. The default setting is 1, which means only critical errors are logged. Setting 4 will log many more errors, including warnings, and could impact performance. You can also specify the name and location of the log file.

- **IMSRenderFlag.exe** - Allows you to troubleshoot video card issues. Contact support for more information about the options available in this utility and when to use them.

- **VersionCheck.exe** - Displays the version for each task component in the software.

In addition, a tool named **AppCheck.exe** is available to help troubleshoot. This tool displays the installed version of each component in the software.

For more detailed information about troubleshooting tools delivered with the software, see the Troubleshooting Reference Guide. The guide is available from **Help > Printable Guides** in the software.

### User Assistance

Smart 3D user assistance makes command information available as you perform tasks. You can access different kinds of information any time that you are running the software. This information could include reference topics, narrative descriptions, or step-by-step instructional material.

#### Printable Guides

User's Guides in PDF format are accessible, flexible, and fully searchable alternative to Help. The information found in the User's Guides is also available from Help. The User's Guides delivered with the software are located in C:\Program Files (x86)\Common Files\Intergraph\Smart3D\Help. Copies of the user's guides can also be found in the Help folder on the Intergraph Product DVD. To view these PDF documents, you will need Adobe Acrobat Reader with Search version 3.0 or higher. You can download the latest version of the Acrobat Reader from the Adobe web site. After you have installed the Acrobat Reader, you can open files individually by using the **File > Open** command in the Acrobat Reader.

#### Help

Smart 3D offers a variety of ways for you to receive help on how to use the software.

A structured table of contents, an index, and full-text search capabilities provide easy access to Help topics. You can access the table of contents by clicking **Smart 3D** on the **Help** menu.

Smart 3D Help is a complete reference tool accessible at any time the application is in use. Help provides complete command descriptions for each toolbar button, menu command, and ribbon in the software. It also gives step-by-step procedures for common tasks; for example, if you need to perform a certain task, search and display the topic. You can move or resize your application and Help windows so that they are next to each other. As such, you can follow the procedures without having to search for the pages in the documentation.
Smart 3D Help is task-specific. For example, to view Common Help, enter the Common task, and click Help > Smart 3D Help. To see more specific information, select one of the major topics or perform a search on a specific topic.

Show/Hide

Show or hide the left pane of the dialog box, including the Contents, Index, and Search.

Back

Returns you to the last Help topic you viewed. This button is disabled when you reach the first topic in the series.

Forward

Displays the next topic in a series of related topics. This button is disabled when you reach the last topic in the series.

Options

Displays a list of functions available for the Help viewer.

Contents

Displays a hierarchical listing of the topics in the Help file.

Index

Displays an index for the Help file.

Search

Performs a full-text search on a word or phrase that you entered in the Search box.

For more information, refer to the Common User’s Guide available from Help > Printable Guides within the software.
Customer Assistance

For the latest Support Services information for this product, use a World Wide Web browser to connect to http://support.intergraph.com.

Common Acronyms

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>2D</td>
<td>Two-Dimensional</td>
</tr>
<tr>
<td>3D</td>
<td>Three-Dimensional</td>
</tr>
<tr>
<td>CD</td>
<td>Compact Disc</td>
</tr>
<tr>
<td>COM+</td>
<td>Component Object Model - Plus</td>
</tr>
<tr>
<td>DCOM</td>
<td>Distributed Component Object Model</td>
</tr>
<tr>
<td>DTC</td>
<td>Distributed Transaction Coordinator</td>
</tr>
<tr>
<td>DuSS</td>
<td>Duplication Synchronization Service</td>
</tr>
<tr>
<td>EPC</td>
<td>Engineering Procurement Construction</td>
</tr>
<tr>
<td>ERP</td>
<td>Enterprise Resource Planning</td>
</tr>
<tr>
<td>FAT</td>
<td>File Allocation Table</td>
</tr>
<tr>
<td>FEED</td>
<td>Front-End Engineering and Design</td>
</tr>
<tr>
<td>GB</td>
<td>Gigabyte</td>
</tr>
<tr>
<td>GHz</td>
<td>Gigahertz</td>
</tr>
<tr>
<td>GWC</td>
<td>Global Workshare Configuration</td>
</tr>
<tr>
<td>IFC</td>
<td>Interference Checking</td>
</tr>
<tr>
<td>I/O</td>
<td>Input/Output</td>
</tr>
<tr>
<td>MB</td>
<td>Megabyte</td>
</tr>
<tr>
<td>MHZ</td>
<td>Megahertz</td>
</tr>
<tr>
<td>MDAC</td>
<td>Microsoft Data Access Components</td>
</tr>
<tr>
<td>Abbreviation</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>MMC</td>
<td>Microsoft Management Console</td>
</tr>
<tr>
<td>MSDTC</td>
<td>Microsoft Distributed Transaction Coordinator</td>
</tr>
<tr>
<td>NTFS</td>
<td>NT File System</td>
</tr>
<tr>
<td>O&amp;M</td>
<td>Operations and Maintenance</td>
</tr>
<tr>
<td>P&amp;ID</td>
<td>Piping and Instrumentation Diagram</td>
</tr>
<tr>
<td>PPM</td>
<td>Process, Power &amp; Marine</td>
</tr>
<tr>
<td>RAM</td>
<td>Random-Access Memory</td>
</tr>
<tr>
<td>ROM</td>
<td>Read-Only Memory</td>
</tr>
<tr>
<td>RPC</td>
<td>Remote Procedure Call</td>
</tr>
<tr>
<td>SQL</td>
<td>Structural Query Language</td>
</tr>
<tr>
<td>SP</td>
<td>Service Pack</td>
</tr>
<tr>
<td>SM3D</td>
<td>SmartMarine 3D</td>
</tr>
<tr>
<td>SP3D</td>
<td>SmartPlant 3D</td>
</tr>
<tr>
<td>TIP</td>
<td>Transaction Internet Protocol</td>
</tr>
<tr>
<td>VB</td>
<td>Visual Basic</td>
</tr>
<tr>
<td>XML</td>
<td>Extensible Markup Language</td>
</tr>
</tbody>
</table>
If you are using SmartPlant License Manager 2010, SmartPlant License Manager 2012, or a later version, an administrator can create environment variables to customize license tracking. These variables match the columns in the SmartPlant License Manager logging file (and journal report).

The environment variables can be added and changed using automated scripts, custom product launching utilities, or manually (as shown in the below example). The environment variables can be defined at the system level or user level. If the environment variable(s) is added at both the system and user levels, the user level takes precedence over the system level.

Any of the following variables can be defined as needed.

**ProjectName**
Defines the project name. There is a maximum of 50 characters.

**NodeName**
Defines the node name. There is a maximum of 30 characters.

*NOTE* If you are using a product published on a Citrix server, the node name recorded in SmartPlant License Manager logging will be the node name of the thin client, unless the NodeName environment variable is defined with the Citrix login.

**UserNameEx**
Defines the user name. There is a maximum of 50 characters.

### Adding Environment Variables

The following steps are an example of how to manually add new environment variables.

1. Open **Control Panel**.
2. Click **System**.
3. Click **Advanced system settings**.
4. Click **Environment Variables**.
5. Click **New...** under **User Variables**.
6. Define the new variable name and value.

7. Click **OK** to add the variable.
Appendix B
Core Display Settings

You can modify settings in the coredisplaysettings.ini file to affect the display performance and quality of Smart 3D. The coredisplaysettings.ini file is located in your [Product Folder]\SmartPlant3D\Core\Tools\Administrator\Bin. This section describes the available .ini settings, which are grouped according to their purpose and functionality.

**NOTES**

- If you are not familiar with OpenGL and Vertex Buffer Object (VBO) graphics display techniques, please contact Intergraph before modifying this file.
- Before you edit, make a backup of the file so that you can return to the default settings.
- When you modify core display settings, be aware that there can be a trade-off between performance (such as display speed) and the quality (such as the number of triangles that are rendered). The quality and performance is dependent on your graphics card and corresponding hardware.

**Motion Settings**

Motion settings in coredisplaysettings.ini determine the object display performance in the current view. The object display is based on drawing the biggest elements first, and then working down, depending on the amount of time that is set. There can be up to four updates or loopcounts that can be done where the system goes through the object sizes to determine the display. For a faster display rate performance, you can set a lower loopcount and object size.
**Core Display Settings**

**TimeSlice** – Defines how long the system waits (in milliseconds) before it begins displaying the objects on screen as the loopcount is performed. *TimeSlice* values range from 10 – 300. The default value is 30.

**TimeBeforeInterrupt** – Acts as a timer that runs during each loopcount that tells the system to move on to the next update or *Pass[#]Size*. The default value is 1.5 x *TimeSlice*.

**LoopCount** – Works in conjunction with the *Pass[#]Size* setting to define the number of times the system goes through objects in the current view in determining what objects are displayed. This setting can have one of the following 0 - 4 possible values:

0: No interruptible display. The performance is slow, but all objects are displayed.

1: The system updates the display just once and all objects display. The performance is slowest at this setting.

2: The system runs through the *Pass1Size* setting, which results in objects within the size set in *Pass1Size* displaying first and then all other objects displaying.

3: The system runs through the *Pass1Size* and *Pass2Size* settings, which results in objects within the size range of *Pass1Size* and *Pass2Size* displaying. Smaller objects display if enough time is available.

4: The system runs through the *Pass1Size*, *Pass2Size*, and *Pass3Size* settings. Smaller objects might not display, but the performance is at the maximum rate. The default value is 4.

**Pass[#]Size** – Sets the pixel size for objects to be displayed at each pass. The default values for each pass are: *Pass1Size* = 120; *Pass2Size* = 60; *Pass3Size* = 30.

**TimePerBuffer** - We do not recommend changing this setting.

**MaxPointSize** -

**DisplayEdgeOnGraphics** -

**MaxTessellatorCount** -

**BlendedTransparency** -

**BlendedTransparencyCullBackfaceAspectMask** - Allows backface culling for the transparent aspect geometry when using blended transparency. This can help visually simplify the rendering of overlapping transparent geometry.

**BlendedTransparencyCullEndCapAspectMask** - Allows endcap culling for the transparent aspect geometry of the specified aspect when using blended transparency. This can help visually simplify the rendering of overlapping transparent geometry.

**EnablePolyMeshSmoothing** -

**View Settings**

The **View Settings** section provides more detailed control of graphics display settings.

**MaxModelSizeforPointCulling** – Handles Gpoints. Defines the maximum available view size (in meters) to set the resulting point size display. The default value is 30.

**MaxModelSizeforPoint** | View Port Size in | Point

---

Intergraph Smart 3D Installation Guide 227
Core Display Settings

<table>
<thead>
<tr>
<th>Culling</th>
<th>meters</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>30</td>
<td>Less than or equal to 3 (10%)</td>
<td>4</td>
</tr>
<tr>
<td>30</td>
<td>Less than or equal to 12 (40%)</td>
<td>3</td>
</tr>
<tr>
<td>30</td>
<td>Less than or equal 21 (70%)</td>
<td>2</td>
</tr>
<tr>
<td>30</td>
<td>Less than or equal 30 (100%)</td>
<td>1</td>
</tr>
<tr>
<td>30</td>
<td>Greater than 30. If the viewport in meters is greater than MaxModelSizeForPoint Culling, then no points are drawn</td>
<td>0</td>
</tr>
</tbody>
</table>

DoNotUseHardware – Enables (0) or disables (1) graphic hardware optimization. The default value is 0 and hardware optimization is enabled.

DisableHardwareOptimization – Enables (0) or disables (1) graphic hardware optimization. The default value is 0 and hardware optimization is enabled.

UseTextBackingStore - Turns on (1) or off (0) graphics card memory to do a backing store instead of the system memory. By default, it is turned on (1) to better accommodate low-end graphics cards where copying data to system memory is very slow.

UseVBOs – Turns on (1) or off (0) caching vertex data on the graphics card (OpenGL Vertex Buffer Object (VBO)). This setting consumes resources on the graphics card and system page file. It can be disabled when the page file (disk space) is limited. By default, UseVBOs is turned on. Turning off UseVBOs can degrade performance significantly.

UseVBO[Surface type] – Allows you to turn on and off OpenGL Vertex Buffer Object (VBO) support for specific object types. The following default settings are provided.

- UseVBOBssSurface = 1
- UseVBOPlane = 1
- UseVBOSphere = 0 (Disabled by default because of the large memory footprint)
- UseVBOCone = 1
- UseVBOTorus = 1
- UseVBOProjection = 1
- UseVBORevolution = 1
- UseVBORuled = 1
- UseVBORuledNormal = 1
- UseVBOShape = 1
Core Display Settings

- **UseVBOOptimized** – Only applies to SmartPlant Review for objects such as Gpipses and Gelbows.

**VBODynamicThresholdCount** – Affects the amount of graphics that are dropped when displaying VBOs during dynamic display operations such as (zoom, pan, and fly-to). The default value is 8000 and can be increased if there is not enough data displayed during dynamic operations. You can set the value to -1 to disable the dropping of any VBOs during dynamic operations.

**Vendor-Specific Settings**

The vendor section provides settings to disable features by graphics card vendor on a per card type basis. The graphics card settings that Intergraph has worked with are listed.

[**Vendor-specific Graphics Card**] – Provides a bit field that enables you to manipulate display and performance characteristics. The value is the sum of the display property values (listed below) that your card supports.

- Textures = 1
- VBOs = 2
- Shaders = 4
- Texture Framebuffer = 8

For example, if your card supports VBOs and Shaders, then the resulting value for your card is 6 (2 + 4). You can then see if this value helps you to achieve the desired display performance. To enter a value for your card, type in: [Graphics Card Display Property Name] = [value]. You must type in the name of your graphics card as it appears in the error log “OpenGL Driver Information” info entry “GL_RENDERER” field.
A
Add Firewall Exceptions on the Oracle Database Server • 78
Add Principle Particular Properties for Structural Manufacturing • 132
Adding Environment Variables • 224
Application Maintenance • 206
Assign Access Permissions for SQL • 138
Assign System Administrator Privileges for SQL Server 2008 • 46
Assign System Administrator Privileges for SQL Server 2012 • 39

B
Batch Server Sizing • 30
Batch Services • 176
Block Assignment • 192
Block Assignment Dialog Box • 195
Block Assignment Service • 190
Board Management Service • 187
Bulkload SmartPlant Layout Reference Data • 148

C
Change Database Collation • 51
Change marine databases to material handling • 151
Change plant databases to marine • 150
Change plant databases to material handling • 150
Check Database Interferences • 170
Citrix Installations • 106
Civil Task Installation • 96
Client/Workstation Setup • 81
Common Acronyms • 222
Concurrent Users • 26
Configuration Tab (Block Assignment Dialog Box) • 196
Configure Account Mappings • 182
Configure for an Integrated Environment • 154
Configure Interference Service Properties • 167
Configure Microsoft Distributed Transaction Coordinator • 114
Configure Network Shares • 117
Configure Oracle Net Services • 63, 72
Configure Oracle Networking Components • 76
Configure Queues for Jobs • 184
Configure the Firewall to Allow DCOM Communication in Windows 2008 Server • 115
Configure the Name Generator Service • 109
Configure the Oracle Client • 92
Configure the Piping Specification Remote Access Server Service • 159
Configure Windows Firewall for the Oracle Client • 93
Configure Your Tasks • 200
Configuring the Batch Services Server for Drawings Tasks • 186
Convert Database Mode • 149
Core Display Settings • 226
Create a SQL Server Database Alert • 40, 47
Create Batch Services Queues • 183
Create Databases • 125
Create IFC Permission Group Folder and Permission Group • 169
Create the Model and Reports Databases for Oracle • 141
Create the Model and Reports Databases for SQL • 135
Create the Site, Catalog, and Schema Databases for Oracle • 138
Create the Site, Catalog, and Schema Databases for SQL • 128
Create the Smart 3D Oracle 11g Database • 58, 67
Customer Assistance • 222

D
Database Detect Tab (Interference Server Settings Dialog Box) • 172
Database Server Setup • 32
Database Server Sizing • 29
Define roles • 202
Define Workspace Dialog Box • 201
Define Your Workspace • 201
Defining your Workspace • 205
Delete the Default Oracle Database • 57, 66
Disk I/O • 209
Index

Disk Partitioning Guidelines • 25
Disk Usage • 210

E
Enable Network Access in Windows Server 2008 • 114, 158

F
File Server Sizing • 31

G
General Tab (Block Assignment Dialog Box) • 195
Getting Started • 198
Global Workshare Configuration Distribution Server Sizing • 30
Granting Batch Service Privileges • 181
GSCADFoulCheckCmds.cSetIFCForRestart • 175

I
Initialize the Oracle Database • 74
Install and Configure Oracle Server Software • 54
Install any Required SQL Server 2008 Upgrades • 45
Install any Required SQL Server 2012 Upgrades • 37
Install Database Interference Detection Service • 167
Install Microsoft .NET Framework (Database Server) • 33
Install Microsoft Office • 82
Install Microsoft SQL Server 2008 • 43
Install Microsoft SQL Server 2008 Client • 85
Install Microsoft SQL Server 2012 • 34
Install Microsoft SQL Server 2012 Client • 82
Install Oracle Database 11g Release 2 Server Software (11.2.0.2) • 64
Install Oracle Database 11g Release 2 Server Software (11.2.0.4) • 54
Install PDS Data Access • 156
Install PDS Export Tools • 155
Install Smart 3D Client Software • 94
Install Smart 3D PDS Model & Data Translators • 157
Install SmartPlant Schema Component • 155
Install the SmartPlant 3D Command Wizard • 122
Install the SmartPlant 3D Symbol/Part Definition Wizard • 122
Installation Checklist • 13
Installation Overview • 10
Installing and Configuring Microsoft SQL Server 2008 • 42
Installing and Configuring Microsoft SQL Server 2012 • 34
Installing and Configuring Oracle Client Software • 87
Installing and Configuring Oracle Server Software • 52
Installing Intergraph Batch Services • 178
Integrating with PDS • 155
Integrating with SmartPlant P&ID • 158
Integrating with SmartPlant Reference Data • 164
Interference Checking (IFC) Server Sizing • 30
Interference Checking Setup • 165
Interference Server Settings Dialog Box • 172
Internationalization • 14

L
License Server • 31
License Server and Name Generator Server Sizing • 31
Linking Servers • 137
Loading Prerequisite Software on the Client • 82
Loading Prerequisite Software on the Database Server • 33

M
Making Other Batch Servers Available • 186
Minimum Reference Data • 143
Modeling (Detail Design) Workstation Sizing • 27
Modify or Repair Intergraph Smart 3D Software • 207
Monitoring the Databases • 209
Motion Settings • 226
Move Custom DLLs to SharedContent Folder • 118

N
Name Generator Service Setup • 108
Index

Open Smart 3D • 200
Oracle 11g Release 2 32-bit Client Installation • 87
Oracle 11g Release 2 64-bit Client Installation • 90
Oracle Database Port Assignments • 79
Oracle Post-Installation Requirements • 77
Oracle Server Configuration • 53

Password Verification in Oracle • 77
Post Installation Instructions • 73
Preface • 8
Programming Resources Setup • 120
Project Size Estimates • 26

Recommendation for Database Monitoring • 209
Reference Data Setup • 117
Register Solid Edge .DLL File • 107
Register the Microsoft SQL Server • 38, 46
Register the Site Database for P&ID Access • 163
Remove Smart 3D Software • 208
Results Analysis • 215
Run the board management service • 189

Save Session Files • 205
Server Monitoring • 212
Set IFC Permission Requirements • 168
Set IFC Permissions • 170
Silent Installation • 103
Smart 3D Database Server Recommendations • 18
Smart 3D Hardware and Software Recommendations • 17
Smart 3D Project Hardware Sizing Recommendations • 25
Smart 3D Tribon Interface Setup • 123
Smart 3D Workstation Recommendations • 19
SmartPlant License Manager Environment Variables • 224
Software Loading Order • 22
SQL Server Collation Utility • 50
SQL Server Collation Utility Dialog Box • 50
SQL Server Port Assignments • 42, 49

Start the block assignment process • 194
Start the Database Interference Detection Service • 168
Starting and Stopping Batch Services • 180
Status Tab (Interference Server Settings Dialog Box) • 174
Stop the block assignment process • 194
System Administrator Workstation Sizing • 28

Third-Party Integration • 12
Troubleshooting the Software • 218

Update Site Database Name and Path • 198
Upgrade Database Version • 152
User Assistance • 220

Vendor-Specific Settings • 229
Verify Automatic Startup of Microsoft SQL Server 2008 Services • 45
Verify Automatic Startup of Microsoft SQL Server 2012 Services • 38
Verify Automatic Startup of Oracle Database Services • 76
Verify Oracle Registry Settings • 57, 67
View Settings • 227
Viewing 3D Model Data • 155

What's New in the Installation Guide • 8
Working in an Integrated Environment • 153